Autor Thema: alter aber gut ausgestatter PC friert häufig aktions-unabhängig ein  (Gelesen 181 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Offline perchlorat

  • Vollwertiges Mitglied
  • ***
  • Beiträge: 125
  • Dankeschön: 1 mal
  • Karma: +0/-0
    • Lebenslust jetzt! – Praxis für Psychotherapie
  • Desktop: XFCE
  • Grafikkarte: nVidia GeForce GTX 1650
  • Grafikkartentreiber: nonfree
  • Kernel: 5.10.2
  • Prozessor: i5-7400
  • Skill: Anfänger
  • Zweig: stable
Hab hier einen alten aber gut ausgestatteten PC mit i7-2600K, 16 GB RAM, SSD usw., der bisher auf Win 7 lief und nun auf Manjaro umgerüstet werden sollte. Der PC hatte unter Win 7 zuletzt häufige BlueScreens, die aufgrund nicht nachvollziehbarer Fehlermeldungen (Windows!!!) nicht behoben werden konnten.

Manjaro ließ sich reibungslos installieren und einrichten mit weiteren Programmen. Dann begannen wieder die Probleme, jetzt aber nicht durch "Abstürze" sondern durch häufiges Einfrieren des PC.

Ich führte dann Belastungstests mit entsprechenden Programmen aus, die schwerpunktmäßig mal die CPU ans Kochen brachten, mal das RAM usw. Bei keinem der Belastungstests ist der PC eingefroren! Das hat mich sehr gewundert!

Nachdem der PC mal wieder eingefroren ist, fand ich über dmesg etliche Fehlermeldungen. Aus denen kann ich aber leider bisher keine Schlussfolgerungen ableiten, was ich evtl. am BIOS oder sonstigen Einstellungen ändern müsste.

Da dmesg sehr umfangreiche Meldungen liefert, habe ich die relevanten heraus kopiert und in zwei Textdateien hier angehängt. Zwei Dateien deshalb, weil es zwei Ereignisse des Einfrierens waren, nach denen ich jeweils dmesg bemüht habe.

Es scheint mit dem ACPI des BIOS zu tun zu haben. Und nebenbei scheint das automatische Trimmen der SSD auch nicht zu funktionieren.
Im BIOS finde ich keine aussagekräftige Einstellung zu ACPI, die ich ändern könnte / sollte.

Das BIOS hatte ich bereits mit dem neuesten BIOS geflasht, als der PC noch unter Windows lief. Vor diesem Flashen war die Kiste auch schon instabil, sodass es am BIOS-Flash eher nicht liegt.

Was nun?

Offline perchlorat

  • Vollwertiges Mitglied
  • ***
  • Beiträge: 125
  • Dankeschön: 1 mal
  • Karma: +0/-0
    • Lebenslust jetzt! – Praxis für Psychotherapie
  • Desktop: XFCE
  • Grafikkarte: nVidia GeForce GTX 1650
  • Grafikkartentreiber: nonfree
  • Kernel: 5.10.2
  • Prozessor: i5-7400
  • Skill: Anfänger
  • Zweig: stable
Hab durch Recherche grad selbst die Lösung gefunden:

Das BIOS des recht alten ASUS P8H67 EVO hat offensichtlich (auch mit dem neuesten BIOS von 2013) einen Bug im ACPI. Man muss also die Stromspar- und Ruhezustands-Funktionen des ACPI deaktivieren.

Ich hab diese Funktionen im BIOS deaktiviert. Das reichte aber nicht aus, um den Fehler zu beheben. Ich musste im GRUB Bootloader unter /etc/default/grub in der Datei grub die Zeile:
GRUB_CMDLINE_LINUX_DEFAULT="quiet......."
gefunden werden und diese ergänzt werden durch:
GRUB_CMDLINE_LINUX_DEFAULT="quiet.......acpi=off"

Der Fehler war weg und bisher ist der PC nicht wieder eingefroren.