Autor Thema: KDE startet nicht mehr  (Gelesen 223 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Offline Fragensteller

  • Neuling
  • *
  • Beiträge: 14
  • Karma: +0/-0
  • Desktop: KDE
  • Grafikkarte: Intel 83Q963/Q965
  • Grafikkartentreiber: video-intel (free)
  • Kernel: 5.10
  • Prozessor: Intel Core2 6420
  • Skill: Anfänger
  • Zweig: stable
KDE startet nicht mehr
« am: 31. Mai 2021, 12:19:44 »
Hallo Zusammen,

meine GUI KDE Plasma startet nicht mehr. Zur Anmeldung komme ich noch und auch die Eingabe von User / PW funktioniert. Nach dem Klick auf "Anmelden" friert das Bild ein.
Was noch funktioniert ist eine Shell über Strg+Alt+F2.

Testweise habe ich XFCE installiert und das funktioniert.

Zur Historie:
Es fing damit an, dass ich auf die Idee kam, die Unterstützung für AUR-Pakete abzuschalten. Daraufhin wurden einige Pakete (Mit Warnung...) deinstalliert und nach dem Neustart hatte ich dann das oben beschriebe Elend.

Was habe ich schon versucht:

Erste Idee war, KDE neu installieren nach Anleitung (https://opensofty.com/de/2020/1/24/so-installieren-sie-kde-unter-manjaro-linux/). Ob das weiteren Schaden angerichtet hat, kann ich nicht sagen, aber geholfen hat es nicht.

Den Display-Manager SDDM habe ich auch schon versucht erneut zu installieren (https://wiki.manjaro.org/index.php/Install_Display_Managers). Ohne sichtbare Veränderung.

Wenn ich in der Shell "Startx" absetze, sehe ich verschiedene Meldungen:
(...)
Logfile: /home/ich/.local/share/X11/xorg.conf.d
Using config directory: /etc/X11/xorg.conf.d
Using System config directorx:/usr/shareX11/xorg.conf.d

xf86EnableIOPorts: failed to set IOPL for I/O (Operation not permitted)
(II) modeset(0): Initializing kms color map for depth 24, 8 pbc.Couldn't exec startkde: no such file or directory
xinit: connection to xserver lost
(...)

Da sowohl XFCE als auch andere Dienste (ProFTP) funktionieren, scheint es eher ein Konfigurations-Problem zu sein. Über den Befehl cat kann ich eine Kopie der Log-Datei in /home/ich/.local/share/X11/xorg.conf.d ansehen, was mir aber nicht weiterhilft.

Es wäre schön, wenn ich zu diesem Thema Hilfe bekommen könnte.

Vielen Dank!

Der Fragensteller



Offline Manfrago

  • Jr. Mitglied
  • **
  • Beiträge: 66
  • Dankeschön: 8 mal
  • Karma: +0/-0
  • Desktop: XFCE
  • Grafikkarte: Intel, Nvidia-Optimus
  • Grafikkartentreiber: nonfree
  • Kernel: 4.19
  • Prozessor: Diverse i5 & i7
  • Skill: Fortgeschritten
  • Zweig: stable
Re: KDE startet nicht mehr
« Antwort #1 am: 03. Juni 2021, 17:36:53 »
....Es fing damit an, dass ich auf die Idee kam, die Unterstützung für AUR-Pakete abzuschalten. Daraufhin wurden einige Pakete (Mit Warnung...) deinstalliert...
Du sagst, das damit alles anfing. Wo und wie hast du die AUR Unterstützung *abgeschaltet*, so das etwas deinstalliert wurde. In Pamac ganz sicherlich nicht.
Um überhaupt einen Hilfeansatz zu haben, müsste man bitte genauer wissen, was da bei dir abgelaufen ist.
« Letzte Änderung: 03. Juni 2021, 17:41:24 von Manfrago »
Ungesicherte Daten sind unwichtige Daten

Offline Fragensteller

  • Neuling
  • *
  • Beiträge: 14
  • Karma: +0/-0
  • Desktop: KDE
  • Grafikkarte: Intel 83Q963/Q965
  • Grafikkartentreiber: video-intel (free)
  • Kernel: 5.10
  • Prozessor: Intel Core2 6420
  • Skill: Anfänger
  • Zweig: stable
Re: KDE startet nicht mehr
« Antwort #2 am: 03. Juni 2021, 19:03:12 »
Hallo und erstmal vielen Dank für die Nachricht.
Wenn ich das noch richtig zusammenbekomme war das war in der GUI in der Anwendung "Programme Hinzufügen / Entfernen" Ich starte morgen mal ein Life-Linux vom Stick ind schaue die Option nach. Dann berichte ich.

Gruß

Fragensteller

Offline kisun

  • Vollwertiges Mitglied
  • ***
  • Beiträge: 184
  • Dankeschön: 29 mal
  • Karma: +0/-0
  • Desktop: XFCE
  • Grafikkarte: nVidia GeForce GTX 1660 Ti
  • Grafikkartentreiber: nonfree
  • Kernel: 5.11.16-2-MANJARO
  • Prozessor: i5-4690K
  • Skill: Anfänger
  • Zweig: stable
Re: KDE startet nicht mehr
« Antwort #3 am: 03. Juni 2021, 20:53:39 »
Hallo Fragesteller,

wenn der Paketmanager nach dem deaktivieren von AUR Pakete deinstalliert hat sollte das auch im 'pacman.log' stehen.

Mit folgenden Befehl kannst du dir anzeigen lassen was deinstalliert wurde.
grep removed /var/log/pacman.log
Somit kannst du erst mal nachschauen welche Pakete verloren gegangen sind. Wenn du das vom Live System aus machst müsstest du halt vorher 'chroot'en.  ;)

Offline Fragensteller

  • Neuling
  • *
  • Beiträge: 14
  • Karma: +0/-0
  • Desktop: KDE
  • Grafikkarte: Intel 83Q963/Q965
  • Grafikkartentreiber: video-intel (free)
  • Kernel: 5.10
  • Prozessor: Intel Core2 6420
  • Skill: Anfänger
  • Zweig: stable
Re: KDE startet nicht mehr
« Antwort #4 am: 04. Juni 2021, 07:22:44 »
Guten Morgen Durcheinander  ;) ,

@Manfrago: im Life-Linux habe ich nachgesehen und beschreibe das mal:
Die Anwendung heißt ""Software hizufügen/entfernen". Dort bin ich auf die Einstellungern gegangen und habe auf dem Reiter "AUR" den Schalter bei "AUR-Unterstützung einschalten" rausgenommen. -> Jaa, keine gute Idee... ::)


@Kisun: Nach "Manjaro-chroot -a" habe ich mit "grep removed /var/log/pacman.log" eine längere Liste erhalten. Ich habe den Output in "2021-05-24 removed pacman.log.txt" gespeichert und die Datei angehängt.

Vielen Dank für eure Unterstützung!

Gruß

Fragensteller


Offline Manfrago

  • Jr. Mitglied
  • **
  • Beiträge: 66
  • Dankeschön: 8 mal
  • Karma: +0/-0
  • Desktop: XFCE
  • Grafikkarte: Intel, Nvidia-Optimus
  • Grafikkartentreiber: nonfree
  • Kernel: 4.19
  • Prozessor: Diverse i5 & i7
  • Skill: Fortgeschritten
  • Zweig: stable
Re: KDE startet nicht mehr
« Antwort #5 am: 04. Juni 2021, 08:58:45 »
....Die Anwendung heißt ""Software hizufügen/entfernen". Dort bin ich auf die Einstellungern gegangen und habe auf dem Reiter "AUR" den Schalter bei "AUR-Unterstützung einschalten" rausgenommen....
Software hizufügen/entfernen, das ist das Programm Pamac, welches ich im meiner ersten Antwort bereits ansprach. Wenn du bei Pamac den Schalter für die AUR Unterstützung ausschaltest, werden keinerlei Pakete deinstalliert. Deine Deinstallations-Ausgabe aus der Pacman.log zeigt, das du jede Menge Basis Pakete von KDE deinstalliert hast, Das hat mit der AUR Abschaltung absolut nichts zu tun. Bevor wir jetzt überlegen, wie man das wieder hinbekommt sollten wir klären, wie das überhaupt passieren konnte, um das künftig zu vermeiden.
« Letzte Änderung: 04. Juni 2021, 09:02:43 von Manfrago »
Ungesicherte Daten sind unwichtige Daten

Offline Fragensteller

  • Neuling
  • *
  • Beiträge: 14
  • Karma: +0/-0
  • Desktop: KDE
  • Grafikkarte: Intel 83Q963/Q965
  • Grafikkartentreiber: video-intel (free)
  • Kernel: 5.10
  • Prozessor: Intel Core2 6420
  • Skill: Anfänger
  • Zweig: stable
Re: KDE startet nicht mehr
« Antwort #6 am: 04. Juni 2021, 14:39:01 »
Hallo Manfrago,
ich binsehr dafür, das wir soweit möglich die Ursache klären. Da ich den Tag (24.05.) eingrenzen kann, stecken vielleicht noch Infos in weiteren Log-Files.
Wo kann ich ggf. noch nach weiteren Infos suchen?

Ansonsten habe ich mir sagen lassen, dass das Problem meistens vor dem Rechner sitzt.  ;)

Gruß

Fragensteller