Autor Thema: VM (kvm) startet nicht mit 4.5er Kernel  (Gelesen 833 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Offline bluelupo

  • Neuling
  • *
  • Beiträge: 38
  • Dankeschön: 3 mal
  • Desktop: KDE
  • Grafikkarte: Intel
  • Prozessor: i7-3770S
  • Skill: Fortgeschritten
  • Zweig: stable/testing/unstable
VM (kvm) startet nicht mit 4.5er Kernel
« am: 01. Mai 2016, 19:49:23 »
Hallo Community,

eine virtuelle Manjaro Installation (KDE) startet nicht in den graphical.target mit dem aktuellsten 4.5er Kernel (4.5.2-1). Das heißt KDE kommt nicht hoch und es blinkt der Cursor oben links. Wenn ich im Grub den multi-user.target angebe, also nur in die Textkonsole boote funktioniert dies mit dem 4.5er Kernel.

Mit einem 4.4.8-1 Kernel bootet die VM problemlos und startet auch den KDE-Desktop. Woran könnte es liegen das dies mit dem 4.5er Kernel nicht klappt?

Im Xorg-Log sind Fehler:
# grep EE Xorg.0.log.old
[    73.977] Current Operating System: Linux jarodev 4.5.2-1-MANJARO #1 SMP PREEMPT Thu Apr 21 01:07:48 UTC 2016 x86_64
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[    73.979] (EE) systemd-logind: failed to get session: PID 843 does not belong to any known session
[    74.129] (EE) vmware(0): Failed to open drm.
[    74.157] (EE) vmware(0): Unable to map frame buffer BAR. Invalid argument (22)
[    74.158] (EE)
[    74.158] (EE) Backtrace:
[    74.158] (EE) 0: /usr/lib/xorg-server/Xorg (OsLookupColor+0x139) [0x596d09]
[    74.158] (EE) 1: /usr/lib/libc.so.6 (__restore_rt+0x0) [0x7f13dc86d32f]
[    74.158] (EE) 2: /usr/lib/libc.so.6 (__memset_sse2+0x54) [0x7f13dc8bc074]
[    74.159] (EE) 3: /usr/lib/xorg/modules/drivers/vmware_drv.so (_init+0x4a1c) [0x7f13d754e68c]
[    74.159] (EE) 4: /usr/lib/xorg-server/Xorg (AddScreen+0x101) [0x4392d1]
[    74.159] (EE) 5: /usr/lib/xorg-server/Xorg (InitOutput+0x43a) [0x47bcea]
[    74.159] (EE) 6: /usr/lib/xorg-server/Xorg (remove_fs_handlers+0x22a) [0x43ceaa]
[    74.159] (EE) 7: /usr/lib/libc.so.6 (__libc_start_main+0xf0) [0x7f13dc85a710]
[    74.159] (EE) 8: /usr/lib/xorg-server/Xorg (_start+0x29) [0x427489]
[    74.160] (EE) 9: ? (?+0x29) [0x29]
[    74.160] (EE)
[    74.160] (EE) Segmentation fault at address 0x0
[    74.160] (EE)
[    74.160] (EE) Caught signal 11 (Segmentation fault). Server aborting
[    74.160] (EE)
[    74.160] (EE)
[    74.160] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[    74.160] (EE)
[    74.181] (EE) Server terminated with error (1). Closing log file.
« Letzte Änderung: 01. Mai 2016, 19:58:17 von bluelupo »
Viele Grüße
bluelupo

Offline Verändert

  • Support Team
  • *****
  • Beiträge: 1131
  • Dankeschön: 60 mal
  • Ni Dieu ni maître
  • Desktop: Gnome. LXQt. i3.
  • Grafikkarte: Intel & Radeon & NVidia
  • Grafikkartentreiber: frei natürlich
  • Kernel: Immer der aktuelle.
  • Prozessor: Intel Celeron und andere.
  • Skill: Anfänger
  • Zweig: unstable
Re: VM (kvm) startet nicht mit 4.5er Kernel
« Antwort #1 am: 02. Mai 2016, 07:14:06 »
Bei mir startet gar kein DE mit 4.5. Ich glaube, der ist noch nicht hundertprozentig ausgereift. Soll es bei neuen Kerneln ja mal geben  ;)
Folgende Mitglieder bedankten sich: bluelupo

Offline bluelupo

  • Neuling
  • *
  • Beiträge: 38
  • Dankeschön: 3 mal
  • Desktop: KDE
  • Grafikkarte: Intel
  • Prozessor: i7-3770S
  • Skill: Fortgeschritten
  • Zweig: stable/testing/unstable
Re: VM (kvm) startet nicht mit 4.5er Kernel
« Antwort #2 am: 02. Mai 2016, 10:21:02 »
Hi Verändert,

das Fehlerbild spricht gerade nicht für ein direktes Kernelproblem ;-)

Das Zusammenspiel Xorg mit dem Kernel sollte das Problem sein, weil sich die VM in Textmodus ja booten lässt. Kann/sollte ich das Problem mit einem Bugreport melden und wo?
Viele Grüße
bluelupo

Offline Verändert

  • Support Team
  • *****
  • Beiträge: 1131
  • Dankeschön: 60 mal
  • Ni Dieu ni maître
  • Desktop: Gnome. LXQt. i3.
  • Grafikkarte: Intel & Radeon & NVidia
  • Grafikkartentreiber: frei natürlich
  • Kernel: Immer der aktuelle.
  • Prozessor: Intel Celeron und andere.
  • Skill: Anfänger
  • Zweig: unstable
Re: VM (kvm) startet nicht mit 4.5er Kernel
« Antwort #3 am: 02. Mai 2016, 13:02:02 »
Hast Du mal a) einen anderen Manjaro-Kernel b) einen 4.5er einer anderen Distri probiert ? Ich glaube nämlich schon, dass es am Kernel liegt und kernel.org hier der richtige Ansprechpartner ist.

Offline bluelupo

  • Neuling
  • *
  • Beiträge: 38
  • Dankeschön: 3 mal
  • Desktop: KDE
  • Grafikkarte: Intel
  • Prozessor: i7-3770S
  • Skill: Fortgeschritten
  • Zweig: stable/testing/unstable
Re: VM (kvm) startet nicht mit 4.5er Kernel
« Antwort #4 am: 02. Mai 2016, 13:23:19 »
Hi Verändert,

a) klar mit einem 4.4 Manjarokernel gibt's keine Probleme ;-)

b) mit der debianbasierten Distribution siduction (mit 4.5er Kernel) habe ich diese Probleme nicht, d.h. ich kann mit einer (kvm) VM bis in den Desktop booten ;-)

Ist den der Manjaro-4.5-Kernel wirklich eine 1:1-Kopie des 4.5 von kernel.org? Keine Anpassungen, keine Patches?
Viele Grüße
bluelupo

Offline Verändert

  • Support Team
  • *****
  • Beiträge: 1131
  • Dankeschön: 60 mal
  • Ni Dieu ni maître
  • Desktop: Gnome. LXQt. i3.
  • Grafikkarte: Intel & Radeon & NVidia
  • Grafikkartentreiber: frei natürlich
  • Kernel: Immer der aktuelle.
  • Prozessor: Intel Celeron und andere.
  • Skill: Anfänger
  • Zweig: unstable
Re: VM (kvm) startet nicht mit 4.5er Kernel
« Antwort #5 am: 02. Mai 2016, 13:31:34 »
Meines Wissens ist das der Arch-Kernel. Und der ist ja weitgehend Vanilla.
Folgende Mitglieder bedankten sich: bluelupo

Offline Verändert

  • Support Team
  • *****
  • Beiträge: 1131
  • Dankeschön: 60 mal
  • Ni Dieu ni maître
  • Desktop: Gnome. LXQt. i3.
  • Grafikkarte: Intel & Radeon & NVidia
  • Grafikkartentreiber: frei natürlich
  • Kernel: Immer der aktuelle.
  • Prozessor: Intel Celeron und andere.
  • Skill: Anfänger
  • Zweig: unstable
Re: VM (kvm) startet nicht mit 4.5er Kernel
« Antwort #6 am: 02. Mai 2016, 13:39:25 »
Cgroup. Da war was.
Vielleicht einfach mal Rob anmailen aus dem englischen Forum. Der müsste es wissen. Und der antwortet auch recht schnell.

Offline bluelupo

  • Neuling
  • *
  • Beiträge: 38
  • Dankeschön: 3 mal
  • Desktop: KDE
  • Grafikkarte: Intel
  • Prozessor: i7-3770S
  • Skill: Fortgeschritten
  • Zweig: stable/testing/unstable
Re: VM (kvm) startet nicht mit 4.5er Kernel
« Antwort #7 am: 02. Mai 2016, 14:29:31 »
Dann bleibe doch bei Kernel 4.4lts, der hat viele Jahre support. Wozu unnötig
stressen? Oder hat der 4.5 was besonderes drin, was du unbedingt brauchst?

Hi virtual-dev,

nein ich hab' jetzt keinen Stress damit ;-) Ich würde halt gerne Feedback geben das im 4.5er Manjarokernel noch ne kleine Macke ist ;-)

Ich mail mal "Rob" an wie von Verändert vorgeschlagen.
Viele Grüße
bluelupo