Autor Thema: ...und wieder Bluetooth  (Gelesen 2143 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Offline haciendero

  • Neuling
  • *
  • Beiträge: 24
  • Dankeschön: 1 mal
  • Karma: +0/-0
  • Manjaro xfce als Hauptbetriebsystem ...
  • Desktop: xfce
  • Kernel: 3.18
  • Prozessor: AMD
  • Skill: Anfänger
  • Zweig: stable
...und wieder Bluetooth
« am: 04. Februar 2015, 15:28:03 »
Hallo Zusammen,

mein Manjaro funktioniert schon fast perfekt, ich bin glücklich damit. Ich konnte noch das Bluetooth nicht aufwecken. Blueman habe ich darauf von Local, zeigt allerdings keine Bluetooth Aktivität an. Laptop ist nicht sichtbar, er sieht auch keine BTGeräte.

Folgende habe schon probiert:

[kakuk@HP455 ~]$ systemctl status bluetooth
● bluetooth.service - Bluetooth service
   Loaded: loaded (/usr/lib/systemd/system/bluetooth.service; enabled; vendor preset: disabled)
   Active: active (running) since sze 2015-02-04 14:48:19 CET; 12min ago
     Docs: man:bluetoothd(8)
 Main PID: 932 (bluetoothd)
   Status: "Running"
   CGroup: /system.slice/bluetooth.service
           └─932 /usr/lib/bluetooth/bluetoothd
[kakuk@HP455 ~]$ rfkill list
0: phy0: Wireless LAN
Soft blocked: no
Hard blocked: no


und auch diese

sudo systemctl enable bluetooth
sudo systemctl start bluetooth

dann ab-, und angemeldet...

Im Panel ist auch kein BT Zeichen zu sehen.

Was könnte ich noch versuchen?
Herzlichen Dank!
« Letzte Änderung: 04. Februar 2015, 18:57:32 von klesk »

Offline klesk

  • Held Mitglied
  • *****
  • Beiträge: 1194
  • Dankeschön: 142 mal
  • Karma: +0/-0
  • Desktop: herbstluftwm
  • Grafikkartentreiber: nvidia 3.40xx
  • Kernel: 4.2
  • Prozessor: Intel Core2 Quad Q9550 (-MCP-)
  • Skill: Durchschnitt
  • Zweig: unstable
Re: ...und wieder Bluetooth
« Antwort #1 am: 04. Februar 2015, 18:59:33 »
Ist das Module btusb geladen ?

modprobe btusb
Bist du Mitglied der Gruppe lp ?

id
Falls alles ja dann mal probieren den folgenden Ordner zu löschen

rm -rf /var/lib/bluetooth
und danach ein reboot.

Du startest es mit blueman-applet ? Mit blueman-manager Kannst du ja den Einstellungsmanager öffnen.

Wenn das alles nicht klappt würde ich es mit mal der -cli Version probieren bluez.
« Letzte Änderung: 04. Februar 2015, 19:06:29 von klesk »

Offline Pig of Destiny

  • Held Mitglied
  • *****
  • Beiträge: 1383
  • Dankeschön: 125 mal
  • Karma: +0/-0
  • Desktop: Xfce
  • Grafikkarte: Intel Graphics
  • Grafikkartentreiber: free
  • Kernel: 4.16
  • Prozessor: Intel Celeron N3350
  • Skill: Durchschnitt
  • Zweig: Arch Linux
Re: ...und wieder Bluetooth
« Antwort #2 am: 04. Februar 2015, 19:11:31 »
Blöde Frage: Hast du nen Hardware-Schalter für Bluetooth?

Offline haciendero

  • Neuling
  • *
  • Beiträge: 24
  • Dankeschön: 1 mal
  • Karma: +0/-0
  • Manjaro xfce als Hauptbetriebsystem ...
  • Desktop: xfce
  • Kernel: 3.18
  • Prozessor: AMD
  • Skill: Anfänger
  • Zweig: stable
Re: ...und wieder Bluetooth
« Antwort #3 am: 04. Februar 2015, 19:54:34 »
Danke erstmal, ich habe folgendes Ergebnis:

[kakuk@HP455 ~]$ modprobe btusb
modprobe: ERROR: could not insert 'btusb': Operation not permitted
[kakuk@HP455 ~]$ id
uid=1000(kakuk) gid=100(users) csoportok=100(users),7(lp),10(wheel),90(network),91(video),92(audio),95(storage),1000(autologin)
[kakuk@HP455 ~]$

Ich habe ein internes Bluetooth im Laptop, kein USB BT-Stick oder so. Einen extra Schalter habe am Gehäuse nicht. Mit Win8 und Linux Mint hat funktioniert...

Offline Pig of Destiny

  • Held Mitglied
  • *****
  • Beiträge: 1383
  • Dankeschön: 125 mal
  • Karma: +0/-0
  • Desktop: Xfce
  • Grafikkarte: Intel Graphics
  • Grafikkartentreiber: free
  • Kernel: 4.16
  • Prozessor: Intel Celeron N3350
  • Skill: Durchschnitt
  • Zweig: Arch Linux
Re: ...und wieder Bluetooth
« Antwort #4 am: 04. Februar 2015, 20:40:58 »
Hast du auch keine "Fn + F-Taste"-Kombination um Bluetooth einzuschalten. Bei mir ist es so, dass das Bluetooth Applet in der Leiste erscheint sobald ich über Tastenkombination bzw. Extra-Schalter Bluetooth aktiviere.

Offline klesk

  • Held Mitglied
  • *****
  • Beiträge: 1194
  • Dankeschön: 142 mal
  • Karma: +0/-0
  • Desktop: herbstluftwm
  • Grafikkartentreiber: nvidia 3.40xx
  • Kernel: 4.2
  • Prozessor: Intel Core2 Quad Q9550 (-MCP-)
  • Skill: Durchschnitt
  • Zweig: unstable
Re: ...und wieder Bluetooth
« Antwort #5 am: 04. Februar 2015, 20:53:28 »
Der modprobe Befehl muss mit sudo ausgeführt werden. Und was ist mit den anderen Sachen die ich geschrieben hatte ?

Offline Pig of Destiny

  • Held Mitglied
  • *****
  • Beiträge: 1383
  • Dankeschön: 125 mal
  • Karma: +0/-0
  • Desktop: Xfce
  • Grafikkarte: Intel Graphics
  • Grafikkartentreiber: free
  • Kernel: 4.16
  • Prozessor: Intel Celeron N3350
  • Skill: Durchschnitt
  • Zweig: Arch Linux
Re: ...und wieder Bluetooth
« Antwort #6 am: 04. Februar 2015, 20:58:52 »
Achso, ja noch was zum testen:
Führe doch mal den Befehl hciconfig aus.
Sollte der Befehl keinen Ausdruck wie z.B.: hci0:  Type: BR/EDR  Bus: USB
       BD Address: 00:22:43:E1:82:E0  ACL MTU: 1021:8  SCO MTU: 64:1
       UP RUNNING PSCAN
       RX bytes:1062273 acl:62061 sco:0 events:778 errors:0
       TX bytes:1825 acl:11 sco:0 commands:39 errors:0
hervorbringen, dann würde ich sagen, dass dein Bluetooth-Adapter entweder ausgeschaltet ist oder es ein Treiber-Problem gibt.

Offline haciendero

  • Neuling
  • *
  • Beiträge: 24
  • Dankeschön: 1 mal
  • Karma: +0/-0
  • Manjaro xfce als Hauptbetriebsystem ...
  • Desktop: xfce
  • Kernel: 3.18
  • Prozessor: AMD
  • Skill: Anfänger
  • Zweig: stable
Re: ...und wieder Bluetooth
« Antwort #7 am: 05. Februar 2015, 09:30:22 »
danke für dei Tipps, ich habe alles probiert:
sudo modprobe btusb : kommt kein Ausdruck im Terminal
/var/lib/bluetooth Ordner hatte ich gar nicht, habe aber trotzdem den Löschbefehl - wie vorgeschlagen ausgeführt.
Dann reboot, ist aber nichts passiert.

Wenn ich Blueman Manager öffne, kommt folgendes:

[kakuk@HP455 ~]$ blueman-manager

(blueman-manager:1249): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:264:30: not a number

(blueman-manager:1249): Gtk-WARNING **: Theme parsing error: mate-applications.css:37:23: 'none' is not a valid color name
Loading configuration plugins
Using GConf config backend
_________
Load (/usr/lib/python2.7/site-packages/blueman/main/PluginManager.py:54)
['Services', 'PulseAudioProfile']
_________
__load_plugin (/usr/lib/python2.7/site-packages/blueman/main/PluginManager.py:127)
loading <class 'blueman.plugins.manager.Services.Services'>
_________
__load_plugin (/usr/lib/python2.7/site-packages/blueman/main/PluginManager.py:127)
loading <class 'blueman.plugins.manager.PulseAudioProfile.PulseAudioProfile'>
_________
pa_context_event (/usr/lib/python2.7/site-packages/blueman/main/PulseAudioUtils.py:306)
1

Mit hciconfig  passiert gar nichts, kommt kein Ausdruck im Terminal.
Fn+f Tastaturkombi - passiert nichts...:(

Offline haciendero

  • Neuling
  • *
  • Beiträge: 24
  • Dankeschön: 1 mal
  • Karma: +0/-0
  • Manjaro xfce als Hauptbetriebsystem ...
  • Desktop: xfce
  • Kernel: 3.18
  • Prozessor: AMD
  • Skill: Anfänger
  • Zweig: stable
Re: ...und wieder Bluetooth
« Antwort #8 am: 05. Februar 2015, 10:38:38 »
Mit dem RALINK RT3290 Bluetooth device - was ich auch habe - scheinen viele Linuxusers Probleme zu haben, hier zB bei Ubuntu:

http://askubuntu.com/questions/324115/ralink-bluetooth-not-working-in-ubuntu-13-04

.....

Offline klesk

  • Held Mitglied
  • *****
  • Beiträge: 1194
  • Dankeschön: 142 mal
  • Karma: +0/-0
  • Desktop: herbstluftwm
  • Grafikkartentreiber: nvidia 3.40xx
  • Kernel: 4.2
  • Prozessor: Intel Core2 Quad Q9550 (-MCP-)
  • Skill: Durchschnitt
  • Zweig: unstable
Re: ...und wieder Bluetooth
« Antwort #9 am: 05. Februar 2015, 12:03:40 »
Hast du dir mal testweise das Paket

aur/rtbth-dkms 3.9.3-2 (3)
    rtbth Kernel module sources for Ralink RT3290 bluetooth

aus dem AUR installiert ? Scheint auch nicht die goldene Lösung zu sein aber zumindest die aktuellste unter Arch basierten Systemen.