Autor Thema: Benutzerkonto verschwunden nachdem ich neue Benutzer ID vergeben habe  (Gelesen 195 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Offline Paulich

  • Neuling
  • *
  • Beiträge: 3
  • Karma: +0/-0
  • Skill: Fortgeschritten
Moin Leute,

bis jetzt hat immer alles gut geklappt bzw. konnte ich mir immer selbst helfen. Jetzt steh ich leider in einer Sackgasse und weiss nicht mehr weiter.

Hab mein NAS per fstab eingebunden und festgestellt das mit der Rechtevergabe etwas nicht stimmt. Fehler gefunden. Also Benutzer IDs angepasst

-> https://de.manjaro.org/index.php?topic=3438.msg28418#msg28418

Und die Rechtevergabe passt jetzt. Mein NAS wird automatisch eingebunden und alles ist genau so wie es sein soll.

Nur, jetzt ist mein User Account verschwunden. In der Anmeldemaske ist nichts mehr und im System unter Accounts wird auch nichts mehr angezeigt.

Anmelden funktioniert aber trotzdem.

Was zur Hölle hab ich falsch gemacht???

LG Frank


Offline Paulich

  • Neuling
  • *
  • Beiträge: 3
  • Karma: +0/-0
  • Skill: Fortgeschritten
So, Problem gefunden...

UIDs unter 1000 scheinen wohl nicht zu funktionieren...

Nunja, es läuft alles und ich danke mir selber für das recherchieren der Lösung.

Falls es noch jemanden interessiert wie man mit Manjaro auf OMV mit funktionierender Rechtevergabe zugreifen kann der muss im oben verlinkten Weg unbedingt das SMBv1 Protokoll erzwingen!

Zitat
Besitz- und Zugriffsrechte¶
Für die Besitz- und Zugriffsrechte zeigt CIFS-VFS ein unterschiedliches Verhalten, je nachdem, ob die cifs-UNIX-Erweiterungen aktiv sind oder nicht.

Die UNIX-Erweiterungen sind standardmäßig aktiv, wenn die Freigaben sich auf einem Samba-Server befinden und das verwendete SMB-Protokoll sie unterstützt, aber nicht, wenn die Freigaben sich auf einem Windows-Server befinden.

Hinweis:
Die ursprünglich für das Protokoll SMBv1 entwickelten UNIX Erweiterungen unterstützen die POSIX-ACLs nicht und haben sich zudem als unsicher erwiesen. Deshalb wurden sie für das Nachfolge-Protokoll SMBv2 nicht mehr übernommen. Im Protokoll SMB-3.1.1 ist nun unter der Bezeichnung POSIX Extensions eine erweiterte, völlige Neubearbeitung integriert, die auch die POSIX-ACLs unterstützen soll. In Samba und damit in Ubuntu ist diese bis jetzt leider noch nicht verfügbar (Stand Juni 2020, Ubuntu 20.04 LTS, Samba 4.11.6). Deshalb sind die folgenden Ausführungen derzeit nur für das veraltete Protokoll SMBv1 gültig.

Der Eintrag in der fstab sieht dann so aus:

//192.168.2.110/user /home/user/NAS cifs noauto,x-systemd.automount,vers=1.0,credentials=/home/user/.smbcredentials,workgroup=workgroup,ip=192.168.2.110 0 0

LG Frank