Autor Thema: Snapd - Ausführen von Snaps wegen fehledem core nicht möglich  (Gelesen 615 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Offline Scytale

  • Neuling
  • *
  • Beiträge: 8
  • Desktop: KDE
  • Grafikkarte: AMD Radeon RX460
  • Grafikkartentreiber: free
  • Kernel: 4.15
  • Prozessor: AMD FX6300+
  • Skill: Durchschnitt
  • Zweig: stable
Hallo Manjaristen,

da Manjaro endlich auf meiner Hardware eincurrent symlink missingwandfrei läuft, bin ich von KDE Neon zu Manjaro KDE gewechselt und würde gerne lieb gewonnene Snaps mitnehmen (nahmentlich u.a. die offizielle Spotify Snap und Brave).

Ich habe mich dabei exakt an den Wiki-Eintrag gehalten https://wiki.manjaro.org/index.php?title=Spotify#Installing_as_snap , snapd.socket Dienst gestartet, rebootet und neue Snaps installiert.

Es kommt aber immer beim Ausführen des Snaps folgende Meldung:

cannot locate the core or legacy core snap (current symlink missing?): No such file or directory
Hab dann genau nach dem Arch-Wiki aufgeräumt, neuinstalliert und gleiches Ergebnis erhalten.

Das gleiche habe ich bei einem anderen PC auch mit up-to-date Manjaro KDE reproduzieren können. Beides sind frische Installationen ohne config-Ballast alter Ubuntu-Installationen.

Aus der Meldung nehme ich an, dass ich irgendeinen Symlink setzen muss. Aber wie und was?

€: Habe gerade auf Snapcraft.io gefunden: https://forum.snapcraft.io/t/manjaro-snapd-trying-to-install-ubuntu-core/2080
« Letzte Änderung: 10. Januar 2018, 21:18:02 von Scytale »

Offline Scytale

  • Neuling
  • *
  • Beiträge: 8
  • Desktop: KDE
  • Grafikkarte: AMD Radeon RX460
  • Grafikkartentreiber: free
  • Kernel: 4.15
  • Prozessor: AMD FX6300+
  • Skill: Durchschnitt
  • Zweig: stable
Re: Snapd - Ausführen von Snaps wegen fehledem core nicht möglich
« Antwort #1 am: 11. Januar 2018, 21:49:21 »
Da ich den Post nicht mehr editieren kann, warum auch immer:

Ich habe den exakt gleichen Fehler an anderen Stellen im den diversen Manjaro/Snapd Foren gefunden:

https://forum.manjaro.org/t/snap-run-hello-gives-me-cannot-locate-the-core-snap/25171
https://forum.snapcraft.io/t/manjaro-snapd-trying-to-install-ubuntu-core/2080

In der AUR ist zwar eine neuere snapd Version, aber an die wage ich mich als Arch Neuling noch nicht dran