Autor Thema: Fehler beim Update  (Gelesen 652 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Offline quantix

  • Sr. Mitglied
  • ****
  • Beiträge: 331
  • Dankeschön: 31 mal
  • Desktop: Xfce/Openbox
  • Grafikkarte: Ati RS880M / GeForce GT 730
  • Grafikkartentreiber: free / nonfree
  • Kernel: 4.13 / 4.13
  • Prozessor: AMD Phenom II P920 / i5-4460
  • Skill: Anfänger
  • Zweig: stable
Re: Fehler beim Update
« Antwort #15 am: 27. November 2017, 13:51:37 »
Hallo, KunSepp,

anscheinend hast du ein Paket an der Paketverwaltung vorbei oder aus dem AUR installiert, welches icu-59 benötigt.
Das kannst du mit
pacman -Qmherausfinden.

Als allerletzte Möglichkeit, welche mir einfällt, wäre
sudo pacman -Syu --forcewas aber mit Vorsicht zu genießen ist, da es das System beschädigen könnte.

Grüße
Josef
« Letzte Änderung: 27. November 2017, 13:53:40 von quantix »
Alles sollte so einfach wie möglich sein - aber nicht einfacher.
Albert Einstein

PGV ecogold, HP Pavilion dv7, Raspberry Pi B + 2
Manjaro, Artix, Arch

Offline Ahnungsloser

  • Held Mitglied
  • *****
  • Beiträge: 882
  • Dankeschön: 38 mal
  • Desktop: KDE Plasma 5.10.4 - OpenRC
  • Grafikkarte: Intel 3rd Gen Core processor Graphics Controller | NVIDIA GK208M [GeForce GT 720M]
  • Grafikkartentreiber: free
  • Kernel: 4.10.17-2
  • Prozessor: Intel Core i3-3217U
  • Skill: Anfänger
  • Zweig: unstable
Re: Fehler beim Update
« Antwort #16 am: 27. November 2017, 14:22:01 »
Dieses Problem existiert auch in Artix, das habe ich eben in deren Forum gelesen:

https://forum.artixlinux.org/index.php/topic,239.0.html

Zitat von: madjo  -  Vor 23 Stunden

3) There is a newer version of ICU (libicuuc.so.60) and some packages (like gconftool-2) are already built to that, but the system-repo only knows icu 59.1-1, thus pacman will report errors when trying to install mate and/or xfce4.
I solved this on my end by uncommenting the lines for the core-repository of Arch in /etc/pacman.conf refreshing pacman and installing core/icu myself. and then comment those two lines again and refreshing pacman.


% yaourt icu
1 system/icu 60.1-1 [installed]

Die Rückfrage des Entwicklers lautet, ob die mirrorlist and die package database up to date sind.

Der Lösungsansatz ist natürlich der für Artix und nicht für Manjaro, aber es scheint so zu sein, dass die aktuelle icu Version bei 60.1-1 angekommen ist, aber es leider noch Pakete gibt, die die Version 59.1-1 erwarten.
Ich habe nur leider Ahnung, welches die betroffenen Pakete sind und wie man das heraus finden kann >:D

Viele Grüße
Ahnungsloser
Im neuen Forum unter dem Nick "Roberto" :)

Offline virtual-dev

  • Global Moderator
  • *****
  • Beiträge: 274
  • Dankeschön: 610 mal
  • Desktop: Xfce4
  • Grafikkarte: Intel
  • Grafikkartentreiber: free
  • Kernel: 4.14 lts
  • Prozessor: various appliances
  • Skill: Fortgeschritten
  • Zweig: *
Re: Fehler beim Update
« Antwort #17 am: 27. November 2017, 14:43:50 »
Das Tool heisst hier und unter Archlinux:
extra/gconf 3.2.6-5 [Installiert]
    A configuration database system

Unter Artix wird so einiges anders genannt.

Für Archlinux die Liste der Pakete die mit diesem Paket hier zu tun haben:
https://www.archlinux.org/packages/extra/x86_64/gconf/
« Letzte Änderung: 27. November 2017, 14:50:17 von virtual-dev »
Folgende Mitglieder bedankten sich: Ahnungsloser

Offline Ahnungsloser

  • Held Mitglied
  • *****
  • Beiträge: 882
  • Dankeschön: 38 mal
  • Desktop: KDE Plasma 5.10.4 - OpenRC
  • Grafikkarte: Intel 3rd Gen Core processor Graphics Controller | NVIDIA GK208M [GeForce GT 720M]
  • Grafikkartentreiber: free
  • Kernel: 4.10.17-2
  • Prozessor: Intel Core i3-3217U
  • Skill: Anfänger
  • Zweig: unstable
Re: Fehler beim Update
« Antwort #18 am: 27. November 2017, 14:47:10 »
Das Tool heisst hier und unter Archlinux:
extra/gconf 3.2.6-5 [Installiert]
    A configuration database system

Unter Artix wird so einiges anders genannt.

Für Archlinux die Liste der Pakete die mit diesem Paket hier zu tun haben:
https://www.archlinux.org/packages/extra/x86_64/gconf/

Hallo virtual-dev,

vielen Dank für die Information.

Viele Grüße
Ahnungsloser
« Letzte Änderung: 02. Dezember 2017, 04:37:28 von virtual-dev »
Im neuen Forum unter dem Nick "Roberto" :)

Offline quantix

  • Sr. Mitglied
  • ****
  • Beiträge: 331
  • Dankeschön: 31 mal
  • Desktop: Xfce/Openbox
  • Grafikkarte: Ati RS880M / GeForce GT 730
  • Grafikkartentreiber: free / nonfree
  • Kernel: 4.13 / 4.13
  • Prozessor: AMD Phenom II P920 / i5-4460
  • Skill: Anfänger
  • Zweig: stable
Re: Fehler beim Update
« Antwort #19 am: 27. November 2017, 17:27:04 »
Die Rückfrage des Entwicklers lautet, ob die mirrorlist and die package database up to date sind.

Das könnte auch eine Ursache sein. Generiere mal eine neue Mirrorliste mit
sudo pacman-mirrors -foder
sudo pacman-mirrors -f --geoipund danach
sudo pacman -Syyu
Grüße
Josef
Alles sollte so einfach wie möglich sein - aber nicht einfacher.
Albert Einstein

PGV ecogold, HP Pavilion dv7, Raspberry Pi B + 2
Manjaro, Artix, Arch

Offline KunSepp

  • Neuling
  • *
  • Beiträge: 18
  • Desktop: Gnome
  • Grafikkarte: NVIDIA GF108GLM [Quadro 1000M]
  • Grafikkartentreiber: nonfree
  • Kernel: 4.13
  • Prozessor: Intel® Core™ i5-2540M CPU @ 2.60GHz × 4
  • Skill: Anfänger
  • Zweig: stable
Re: Fehler beim Update
« Antwort #20 am: 27. November 2017, 17:34:35 »
Hallo

Ich werde mit den neuen Ansätzen nochmal rangehn.
Es kann allerdings ein paar Tage dauern, da ich nicht genau weiß wann ich die Zeit habe.

Gruß
Kunsepp

Offline KunSepp

  • Neuling
  • *
  • Beiträge: 18
  • Desktop: Gnome
  • Grafikkarte: NVIDIA GF108GLM [Quadro 1000M]
  • Grafikkartentreiber: nonfree
  • Kernel: 4.13
  • Prozessor: Intel® Core™ i5-2540M CPU @ 2.60GHz × 4
  • Skill: Anfänger
  • Zweig: stable
Re: Fehler beim Update
« Antwort #21 am: 30. November 2017, 05:37:44 »
Guten Morgen :)

Ich habe nochmal alles durchprobiert. Leider hat sich nichts verändert. Die Fehlermeldung bleibt immer die selbe...

sudo pacman -Syyu --force
pacman: error while loading shared libraries: libicuuc.so.59: cannot open shared object file: No such file or directory

Danke für die Hilfe :)

Gruß Kunsepp

Offline vetzki

  • Sr. Mitglied
  • ****
  • Beiträge: 308
  • Dankeschön: 42 mal
  • Desktop: kde,lxqt,i3
  • Grafikkarte: gt 630m
  • Grafikkartentreiber: mal so, mal so
  • Kernel: 44,48,412
  • Prozessor: i5-2450
  • Skill: Durchschnitt
  • Zweig: stable
Re: Fehler beim Update
« Antwort #22 am: 30. November 2017, 16:45:59 »
was zeigt denn pacman -Ql icu an ?

edit:
nach lesen von anfang an, kommst du jetzt in eine login shell oder nicht? (kannst du wenn der bildschirm schwarz ist mit strg+alt+f2 in ein anderes tty wechseln? )
kannst du in der livecd deine partitionen mounten ?
« Letzte Änderung: 30. November 2017, 16:55:41 von vetzki »

Offline KunSepp

  • Neuling
  • *
  • Beiträge: 18
  • Desktop: Gnome
  • Grafikkarte: NVIDIA GF108GLM [Quadro 1000M]
  • Grafikkartentreiber: nonfree
  • Kernel: 4.13
  • Prozessor: Intel® Core™ i5-2540M CPU @ 2.60GHz × 4
  • Skill: Anfänger
  • Zweig: stable
Re: Fehler beim Update
« Antwort #23 am: 30. November 2017, 17:51:23 »
Hallo Vetzki

pacman -Ql zeigt die auch die Fehlermeldung: "pacman: error while loading shared libraries: libicuuc.so.59: cannot open shared object file: No such file or directory"
Eigentlich alles, außer "pacman-mirros", was mit "pacman" zu tun hat, zeigt diese Fehlermeldung an.

Die login shell kommt nicht, aber mit strg+alt+f2 in ein anderes tty wechseln funktioniert. Wenn ich dort starx eingebe kommt eine Meldung dass X-server schon läuft und dann bleibt es hängen.

Meine hoffnung war, dass wenn das Update durchläuft, alles wieder läuft.

Gruß
Kunsepp 

Offline vetzki

  • Sr. Mitglied
  • ****
  • Beiträge: 308
  • Dankeschön: 42 mal
  • Desktop: kde,lxqt,i3
  • Grafikkarte: gt 630m
  • Grafikkartentreiber: mal so, mal so
  • Kernel: 44,48,412
  • Prozessor: i5-2450
  • Skill: Durchschnitt
  • Zweig: stable
Re: Fehler beim Update
« Antwort #24 am: 30. November 2017, 19:57:01 »
das letztere klingt wie xconf problem (oder die falschen module werden geladen), steht denn in /var/log/Xorg.0.log was brauchbares?

das erstere ist komisch da du ja  icu [Installiert: 59.1-1 ] in der version 59 installiert hast, dann müsste eigentlich auch die lib vorhanden sein, deshalb die frage ob alles korrekt gemountet werden kann (was vmtl der fall ist da ja "nur" der display manager nicht startet). Wie sieht denn bei dir ls -l /usr/lib/libicuu* aus? Ist da eine .59 ?

Offline KunSepp

  • Neuling
  • *
  • Beiträge: 18
  • Desktop: Gnome
  • Grafikkarte: NVIDIA GF108GLM [Quadro 1000M]
  • Grafikkartentreiber: nonfree
  • Kernel: 4.13
  • Prozessor: Intel® Core™ i5-2540M CPU @ 2.60GHz × 4
  • Skill: Anfänger
  • Zweig: stable
Re: Fehler beim Update
« Antwort #25 am: 30. November 2017, 20:34:15 »
Hallo Vetzki

Mounten vom usb-stick funktioniert, das habe ich vorher vergessen zu schreiben.

In der Xorg.0.log steht folgendes:
[    56.819] _XSERVTransSocketUNIXCreateListener: ...SocketCreateListener() fai$
[    56.821] _XSERVTransMakeAllCOTSServerListeners: server already running
[    56.821] (EE)
Fatal server error:
[    56.822] (EE) Cannot establish any listening sockets - Make sure an X serve$
[    56.823] (EE)
Please consult the The X.Org Foundation support
         at http://wiki.x.org
 for help.
[    56.825] (EE) Please also check the log file at "/var/log/Xorg.0.log" for a$
[    56.826] (EE)
[    56.826] (EE) Server terminated with error (1). Closing log file.

Ich kann damit leider nicht wirklich etwas anfangen... :-\ Bin noch mehr oder weniger Anfänger

 ls -l /usr/lib/libicuu* bringt:

lrwxrwxrwx 1 root root      16 12. Nov 10:33 /usr/lib/libicuuc.so -> libicuuc.so.60.1
lrwxrwxrwx 1 root root      16 12. Nov 10:33 /usr/lib/libicuuc.so.60 -> libicuuc.so.60.1
-rwxr-xr-x 1 root root 1799952 12. Nov 10:33 /usr/lib/libicuuc.so.60.1

eine .59 ist nirgends zu finden







Offline Ahnungsloser

  • Held Mitglied
  • *****
  • Beiträge: 882
  • Dankeschön: 38 mal
  • Desktop: KDE Plasma 5.10.4 - OpenRC
  • Grafikkarte: Intel 3rd Gen Core processor Graphics Controller | NVIDIA GK208M [GeForce GT 720M]
  • Grafikkartentreiber: free
  • Kernel: 4.10.17-2
  • Prozessor: Intel Core i3-3217U
  • Skill: Anfänger
  • Zweig: unstable
Re: Fehler beim Update
« Antwort #26 am: 02. Dezember 2017, 09:42:15 »
ls -l /usr/lib/libicuu* bringt:

lrwxrwxrwx 1 root root      16 12. Nov 10:33 /usr/lib/libicuuc.so -> libicuuc.so.60.1
lrwxrwxrwx 1 root root      16 12. Nov 10:33 /usr/lib/libicuuc.so.60 -> libicuuc.so.60.1
-rwxr-xr-x 1 root root 1799952 12. Nov 10:33 /usr/lib/libicuuc.so.60.1

eine .59 ist nirgends zu finden

Das ist genau das Problem, weil es anscheinend Pakete gibt, im noch die libicuuc.so.59 erwarten.
Da sie nur die ibicuuc.so.60 finden, erscheint die Fehlermeldung: no such file or directory.

Ich habe im offiziellen Manjaro Forum diesen Tipp gefunden:

So you have to downgrade icu manually for pacman to work then fully update your system for others to work as well

In your command prompt, do the following :

    Go to your root directory

cd /

    Extract the oudated version of icu into your system :

sudo tar -Jxvf /var/cache/pacman/pkg/icu-59.1-2-x86_64.pkg.tar.xz

(If that package above does not exist, then you may need to grab it first)

wget https://archive.archlinux.org/packages/i/icu/icu-59.1-2-x86_64.pkg.tar.xz -O /var/cache/pacman/pkg/icu-59.1-2-x86_64.pkg.tar.xz

    the pacman should work now on, but we need to force downgrade icu or we will mess up the icu package:

sudo pacman -U --force /var/cache/pacman/pkg/icu-59.1-2-x86_64.pkg.tar.xz

    After this, check if your /etc/pacman.d/mirrorlist was properly configured to use latest mirror by using pacman-mirrors2 , Then fully update your system :

sudo pacman -Syyu

https://forum.manjaro.org/t/manjaro-failing-to-start-after-most-recent-upgrade/35425/11

Vielleicht löst das dein Problem.

Viele Grüße
Ahnungsloser
Im neuen Forum unter dem Nick "Roberto" :)

Offline vetzki

  • Sr. Mitglied
  • ****
  • Beiträge: 308
  • Dankeschön: 42 mal
  • Desktop: kde,lxqt,i3
  • Grafikkarte: gt 630m
  • Grafikkartentreiber: mal so, mal so
  • Kernel: 44,48,412
  • Prozessor: i5-2450
  • Skill: Durchschnitt
  • Zweig: stable
Re: Fehler beim Update
« Antwort #27 am: 02. Dezember 2017, 10:43:05 »
Du kannst bei pacman auch root= angeben (siehe "arch forum link" am anfang des themas),
d,h, es sollte auch gehen:
- live-cd booten
- / einhängen (z.b. nach /mnt)
- dann das paket runterladen und mit pacman -U --root=/mnt ... installieren
(oder gleich pacman -Syu --root=/mnt ein komplettes update drüberbügeln )

- oder /home sichern und komplett neu installieren (leider)

was bei dem update genau schief gelaufen ist wäre auch interessant, kannst du evtl. mal /var/log/pacman.log posten?
« Letzte Änderung: 02. Dezember 2017, 10:44:49 von vetzki »

Offline KunSepp

  • Neuling
  • *
  • Beiträge: 18
  • Desktop: Gnome
  • Grafikkarte: NVIDIA GF108GLM [Quadro 1000M]
  • Grafikkartentreiber: nonfree
  • Kernel: 4.13
  • Prozessor: Intel® Core™ i5-2540M CPU @ 2.60GHz × 4
  • Skill: Anfänger
  • Zweig: stable
Re: Fehler beim Update
« Antwort #28 am: 05. Dezember 2017, 04:16:24 »
Guten Morgen :)

pacman root angeben hat leider nichts gebracht. Die selbe Meldung.

Hier noch ein beiden letzten Tage der pacman.log

[2017-11-23 17:14] [PACMAN] Running 'pacman -Rs palemoon'
[2017-11-23 17:14] [PACMAN] Running 'pacman -Rs pale moon'
[2017-11-23 17:15] [PACMAN] Running 'pacman -Rs palemoon'
[2017-11-23 17:16] [PACMAN] Running 'pacman -Rs palemoon-bin'
[2017-11-23 17:17] [PACMAN] Running 'pacman -Rs palemoon-bin palemoon-i18n-de'
[2017-11-23 17:17] [ALPM] transaction started
[2017-11-23 17:17] [ALPM] removed palemoon-i18n-de (27.6.0-1)
[2017-11-23 17:17] [ALPM] removed palemoon-bin (27.6.1-1)
[2017-11-23 17:17] [ALPM] transaction completed
[2017-11-23 17:17] [ALPM] removed palemoon-i18n-de (27.6.0-1)
[2017-11-23 17:17] [ALPM] removed palemoon-bin (27.6.1-1)
[2017-11-23 17:17] [ALPM] transaction completed
[2017-11-23 17:17] [ALPM] running 'gtk-update-icon-cache.hook'...
[2017-11-23 17:17] [ALPM] running 'systemd-update.hook'...
[2017-11-23 17:17] [ALPM] running 'update-desktop-database.hook'...
[2017-11-25 08:42] [PACMAN] Running 'pacman -S gnome-musik'
[2017-11-25 08:43] [PACMAN] Running 'pacman -S gnomemusik'
[2017-11-25 08:46] [PACMAN] Running 'pacman -S gnome-musik'
[2017-11-25 08:47] [PACMAN] Running 'pacman -Syu'
[2017-11-25 08:47] [PACMAN] synchronizing package lists
[2017-11-25 08:47] [PACMAN] starting full system upgrade
[2017-11-25 08:47] [PACMAN] Running 'pacman -S gnome-musik'
[2017-11-25 08:43] [PACMAN] Running 'pacman -S gnomemusik'
[2017-11-25 08:46] [PACMAN] Running 'pacman -S gnome-musik'
[2017-11-25 08:47] [PACMAN] Running 'pacman -Syu'
[2017-11-25 08:47] [PACMAN] synchronizing package lists
[2017-11-25 08:47] [PACMAN] starting full system upgrade
[2017-11-25 08:47] [PACMAN] Running 'pacman -S gnome-musik'
[2017-11-25 08:48] [PACMAN] Running 'pacman -S gnome-music'
[2017-11-25 08:48] [ALPM] transaction started
[2017-11-25 08:48] [ALPM] installed tracker-miners (2.0.2-1)
[2017-11-25 08:48] [ALPM] installed gnome-music (3.26.1-1)
[2017-11-25 08:48] [ALPM] transaction completed
[2017-11-25 08:48] [ALPM] running 'glib-compile-schemas.hook'...
[2017-11-25 08:48] [ALPM] running 'gtk-update-icon-cache.hook'...
[2017-11-25 08:48] [ALPM] running 'systemd-update.hook'...
[2017-11-25 08:48] [ALPM] running 'update-desktop-database.hook'...
[2017-11-25 08:49] [PACMAN] Running 'pacman -Rs gnome-music'
[2017-11-25 08:49] [ALPM] transaction started
[2017-11-25 08:49] [ALPM] removed gnome-music (3.26.1-1)
[2017-11-25 08:49] [ALPM] removed tracker-miners (2.0.2-1)
[2017-11-25 08:49] [ALPM] removed libosinfo (1.1.0-1)
[2017-11-25 08:49] [ALPM] removed osinfo-db (20170423-1)
[2017-11-25 08:49] [ALPM] removed libiptcdata (1.0.4-3)
[2017-11-25 08:49] [ALPM] removed libgsf (1.14.41+3+gc7b4b53-1)
[2017-11-25 08:49] [ALPM] removed libgrss (0.7.0+16+g971c421-1)
[2017-11-25 08:49] [ALPM] transaction completed
[2017-11-25 08:49] [ALPM] running 'glib-compile-schemas.hook'...
[2017-11-25 12:24] [PACMAN] Running 'pacman -Syyu'
[2017-11-25 12:24] [PACMAN] synchronizing package lists
[2017-11-25 12:24] [PACMAN] starting full system upgrade
[2017-11-25 12:28] [ALPM] transaction started
[2017-11-25 12:28] [ALPM] upgraded adapta-maia-theme (3.92.1.90-2 -> 3.92.1.108$
[2017-11-25 12:28] [ALPM] upgraded filesystem (2017.06-4.3 -> 2017.06-4.4)
[2017-11-25 12:28] [ALPM] upgraded alsa-plugins (1.1.4-1 -> 1.1.5-1)
[2017-11-25 12:28] [ALPM] upgraded libogg (1.3.3-1 -> 1.3.3-2)
[2017-11-25 12:28] [ALPM] upgraded alsa-utils (1.1.4-1 -> 1.1.5-2)
[2017-11-25 12:28] [ALPM] upgraded icu (59.1-2 -> 60.1-1)
[2017-11-25 12:28] [ALPM] upgraded boost-libs (1.65.1-1 -> 1.65.1-2)
[2017-11-25 12:28] [ALPM] upgraded ca-certificates-mozilla (3.33-2 -> 3.34-1)
[2017-11-25 12:28] [ALPM] upgraded libxml2 (2.9.7+4+g72182550-1 -> 2.9.7+4+g721$
[2017-11-25 12:28] [ALPM] upgraded harfbuzz (1.6.3-1 -> 1.7.1-1)
[2017-11-25 12:28] [ALPM] upgraded libtiff (4.0.8-2 -> 4.0.9-1)
[2017-11-25 12:28] [ALPM] upgraded nettle (3.3-1 -> 3.4-1)
[2017-11-25 12:28] [ALPM] upgraded dbus (1.12.0-1 -> 1.12.2-1)
[2017-11-25 12:28] [ALPM] upgraded cherrytree (0.38.2-1 -> 0.38.3-1)
[2017-11-25 12:28] [ALPM] upgraded libconfig (1.6-2 -> 1.7.1-1)
[2017-11-25 12:28] [ALPM] upgraded mpfr (3.1.5.p2-1 -> 3.1.6.p1-1)
[2017-11-25 12:28] [ALPM] upgraded linux414 (4.14.0-0.1 -> 4.14.2-1)
[2017-11-25 12:28] [ALPM] upgraded linux49 (4.9.63-1 -> 4.9.65-1)
[2017-11-25 12:28] [ALPM-SCRIPTLET] >>> Updating module dependencies. Please wa$
[2017-11-25 12:29] [ALPM] transaction interrupted

Gruß
Kunsepp