Autor Thema: ahhh... pacman will nicht  (Gelesen 877 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Offline isralipp

  • Jr. Mitglied
  • **
  • Beiträge: 70
  • Desktop: Gnome 3.16
  • Grafikkarte: Card-1: Intel 4th Gen Core Processor Integrated Graphics Controller Card-2: NVIDIA GK107M [GeForce GT 755M]
  • Grafikkartentreiber: nonfree
  • Kernel: linux43
  • Prozessor: Intel Core i7-4700MQ
  • Skill: Fortgeschritten
  • Zweig: stable
ahhh... pacman will nicht
« am: 26. Januar 2015, 13:06:13 »
was ist da lost .. mach ich
sudo pacman -Syyu
bekomme ich folgende meldungen:
[israuor@ideapady510p ~]$ sudo pacman -Syy
[sudo] password for israuor:
error: GPGME error: No data
error: GPGME error: No data
error: GPGME error: No data
error: GPGME error: No data
:: Synchronizing package databases...
error: failed to update core (unable to lock database)
error: failed to update extra (unable to lock database)
error: failed to update community (unable to lock database)
error: failed to update multilib (unable to lock database)
error: failed to synchronize any databases
error: failed to init transaction (unable to lock database)
error: could not lock database: File exists
  if you're sure a package manager is not already
  running, you can remove /var/lib/pacman/db.lck
[israuor@ideapady510p ~]$ sudo pacman -Syyu
error: GPGME error: No data
error: GPGME error: No data
error: GPGME error: No data
error: GPGME error: No data
:: Synchronizing package databases...
error: failed to update core (unable to lock database)
error: failed to update extra (unable to lock database)
error: failed to update community (unable to lock database)
error: failed to update multilib (unable to lock database)
error: failed to synchronize any databases
error: failed to init transaction (unable to lock database)
error: could not lock database: File exists
  if you're sure a package manager is not already
  running, you can remove /var/lib/pacman/db.lck
[israuor@ideapady510p ~]$

Offline isralipp

  • Jr. Mitglied
  • **
  • Beiträge: 70
  • Desktop: Gnome 3.16
  • Grafikkarte: Card-1: Intel 4th Gen Core Processor Integrated Graphics Controller Card-2: NVIDIA GK107M [GeForce GT 755M]
  • Grafikkartentreiber: nonfree
  • Kernel: linux43
  • Prozessor: Intel Core i7-4700MQ
  • Skill: Fortgeschritten
  • Zweig: stable
Re: ahhh... pacman will nicht
« Antwort #1 am: 26. Januar 2015, 13:10:25 »
okay.. steht ja unten eh dabei... einfach die datei loeschen.. tschuldigung fuer den voreiligen Beitrag.

Offline sdoubleyou

  • Held Mitglied
  • *****
  • Beiträge: 1051
  • Dankeschön: 148 mal
  • Desktop: Gentoo + spectrwm
  • Grafikkarte: intel
  • Kernel: Longterm 4.4
  • Skill: Durchschnitt
  • Zweig: unstable
Re: ahhh... pacman will nicht
« Antwort #2 am: 26. Januar 2015, 13:12:44 »
Hallo isralipp,

das Thema wird aktuell hier an vielen Stellen besprochen und auch schon Lösungsansätze gegeben:
https://de.manjaro.org/index.php?topic=2426.msg20025#msg20025
https://de.manjaro.org/index.php?topic=2445.msg20120#msg20120

aktuell scheint es ein Bug zu sein und wird bearbeitet

sudo rm /var/lib/pacman/db.lcksudo pacman-mirrors -gsudo pacman -Syy