Autor Thema: VirtualBox Fehler  (Gelesen 1545 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Offline Hanisch

  • Held Mitglied
  • *****
  • Beiträge: 588
  • Dankeschön: 2 mal
  • Desktop: Xfce4, KDE-Plasma - 32 Bit/64Bit
  • Grafikkarte: VGA compatible controller: InnoTek Systemberatung GmbH VirtualBox Graphics Adapter, bzw. NVIDIA Optimus
  • Grafikkartentreiber: free, bzw. nonfree
  • Kernel: 4.1.32-1-MANJARO/4.4.55-1-MANJARO/4.9.20-1-MANJARO
  • Prozessor: VirtualBox bzw. Intel Core i7-2630QM
  • Skill: Durchschnitt
  • Zweig: stable
VirtualBox Fehler
« am: 10. Juni 2017, 16:14:03 »
Hallo,

plötzlich kann ich keine VM in meinem Manjaro 32Bit Host mehr starten.
Es kommt immer ein VirtualBox Fehler - siehe Anhang.

Woran kann das liegen?

Gruß
Ch. Hanisch
Je mehr man schon weiß, je mehr hat man noch zu lernen. Mit dem Wissen nimmt das Nichtwissen in gleichem Grade zu, oder vielmehr das Wissen des Nichtwissens.(Friedrich Schlegel)

Offline quantix

  • Sr. Mitglied
  • ****
  • Beiträge: 306
  • Dankeschön: 30 mal
  • Desktop: Xfce/Openbox
  • Grafikkarte: Ati RS880M / GeForce GT 730
  • Grafikkartentreiber: free / nonfree
  • Kernel: 4.11 / 4.11
  • Prozessor: AMD Phenom II P920 / i5-4460
  • Skill: Anfänger
  • Zweig: stable
Re: VirtualBox Fehler
« Antwort #1 am: 10. Juni 2017, 17:43:58 »
Hallo Hanisch,


Vielleicht hilft dir das weiter.


Grüße
Josef
Alles sollte so einfach wie möglich sein - aber nicht einfacher.
Albert Einstein

PGV ecogold, HP Pavilion dv7, Raspberry Pi B + 2
Manjaro, Artix, Arch

Offline Hanisch

  • Held Mitglied
  • *****
  • Beiträge: 588
  • Dankeschön: 2 mal
  • Desktop: Xfce4, KDE-Plasma - 32 Bit/64Bit
  • Grafikkarte: VGA compatible controller: InnoTek Systemberatung GmbH VirtualBox Graphics Adapter, bzw. NVIDIA Optimus
  • Grafikkartentreiber: free, bzw. nonfree
  • Kernel: 4.1.32-1-MANJARO/4.4.55-1-MANJARO/4.9.20-1-MANJARO
  • Prozessor: VirtualBox bzw. Intel Core i7-2630QM
  • Skill: Durchschnitt
  • Zweig: stable
Re: VirtualBox Fehler
« Antwort #2 am: 11. Juni 2017, 10:32:38 »
Vielleicht hilft dir das weiter.
Nein, leider komme ich damit nicht weiter.
Ich sehe auch keinen vernünftigen Grund, weshalb die VM's nicht mehr starten.
"Für die virtuelle Maschine Test Manjaro konnte keine neue Sitzung eröffnet werden."ist auch keine aussagekräftige Meldung.

Was kann ich noch probieren?

Gruß
Ch. Hanisch
Je mehr man schon weiß, je mehr hat man noch zu lernen. Mit dem Wissen nimmt das Nichtwissen in gleichem Grade zu, oder vielmehr das Wissen des Nichtwissens.(Friedrich Schlegel)

Offline Hanisch

  • Held Mitglied
  • *****
  • Beiträge: 588
  • Dankeschön: 2 mal
  • Desktop: Xfce4, KDE-Plasma - 32 Bit/64Bit
  • Grafikkarte: VGA compatible controller: InnoTek Systemberatung GmbH VirtualBox Graphics Adapter, bzw. NVIDIA Optimus
  • Grafikkartentreiber: free, bzw. nonfree
  • Kernel: 4.1.32-1-MANJARO/4.4.55-1-MANJARO/4.9.20-1-MANJARO
  • Prozessor: VirtualBox bzw. Intel Core i7-2630QM
  • Skill: Durchschnitt
  • Zweig: stable
Re: VirtualBox Fehler
« Antwort #3 am: 11. Juni 2017, 13:24:44 »
Hallo,

jetzt habe ich versucht, an den IDE-Port die 'systemrescuecd-x86-4.9.2.iso' anzuschließen.
Da erhalte ich:
Das optische Laufwerk /home/opa/Downloads/systemrescuecd-x86-4.9.2.iso konnte nicht an den Slot Primärer Master der VM  angeschlossen werden.

No storage device attached to device slot 0 on port 0 of controller 'IDE'.

Callee RC:NS_ERROR_ABORT (0x80004004)
bzw.
Die Einstellungen der virtuellen Maschine  konnten nicht in  gespeichert werden.

No storage device attached to device slot 0 on port 0 of controller 'IDE'.

Callee RC:NS_ERROR_ABORT (0x80004004)
und dann noch:
Der globale Extradata-Schlüssel GUI/Statusbar konnte nicht auf den Wert {} gesetzt werden.

Callee RC:NS_ERROR_CALL_FAILED (0x800706BE)


Was ist denn da los?

Gruß
Ch. Hanisch
 

« Letzte Änderung: 11. Juni 2017, 13:38:40 von Hanisch »
Je mehr man schon weiß, je mehr hat man noch zu lernen. Mit dem Wissen nimmt das Nichtwissen in gleichem Grade zu, oder vielmehr das Wissen des Nichtwissens.(Friedrich Schlegel)

Offline suska

  • Sr. Mitglied
  • ****
  • Beiträge: 371
  • Dankeschön: 31 mal
  • Desktop: openbox
  • Grafikkarte: Intel
  • Grafikkartentreiber: free
  • Kernel: 4.9
  • Prozessor: i5
  • Skill: Durchschnitt
  • Zweig: #
Re: VirtualBox Fehler
« Antwort #4 am: 11. Juni 2017, 16:52:35 »
"Für die virtuelle Maschine Test Manjaro konnte keine neue Sitzung eröffnet werden."ist auch keine aussagekräftige Meldung.

Das ist ja nicht die ganze Fehlermeldung und wenn ich eine Suchmaschine mit "ns_error_failure 0x80004005" füttere, fällt da so einiges raus, das sich testen lässt.
.:. Artix Linux .:. FreeBSD .:. Salix OS .:.

Offline Hanisch

  • Held Mitglied
  • *****
  • Beiträge: 588
  • Dankeschön: 2 mal
  • Desktop: Xfce4, KDE-Plasma - 32 Bit/64Bit
  • Grafikkarte: VGA compatible controller: InnoTek Systemberatung GmbH VirtualBox Graphics Adapter, bzw. NVIDIA Optimus
  • Grafikkartentreiber: free, bzw. nonfree
  • Kernel: 4.1.32-1-MANJARO/4.4.55-1-MANJARO/4.9.20-1-MANJARO
  • Prozessor: VirtualBox bzw. Intel Core i7-2630QM
  • Skill: Durchschnitt
  • Zweig: stable
Re: VirtualBox Fehler
« Antwort #5 am: 11. Juni 2017, 21:40:48 »
Suchmaschine mit "ns_error_failure 0x80004005" füttere, fällt da so einiges raus, das sich testen lässt.
Sorry, da finde ich nichts Zielführendes.
Evtl. hängt das mit dem Bug in der 32Bit Version von Manjaro, siehe
https://de.manjaro.org/index.php?topic=7754.new;topicseen
zusammen?

Gruß
Ch. Hanisch
Je mehr man schon weiß, je mehr hat man noch zu lernen. Mit dem Wissen nimmt das Nichtwissen in gleichem Grade zu, oder vielmehr das Wissen des Nichtwissens.(Friedrich Schlegel)

Offline Hanisch

  • Held Mitglied
  • *****
  • Beiträge: 588
  • Dankeschön: 2 mal
  • Desktop: Xfce4, KDE-Plasma - 32 Bit/64Bit
  • Grafikkarte: VGA compatible controller: InnoTek Systemberatung GmbH VirtualBox Graphics Adapter, bzw. NVIDIA Optimus
  • Grafikkartentreiber: free, bzw. nonfree
  • Kernel: 4.1.32-1-MANJARO/4.4.55-1-MANJARO/4.9.20-1-MANJARO
  • Prozessor: VirtualBox bzw. Intel Core i7-2630QM
  • Skill: Durchschnitt
  • Zweig: stable
Re: VirtualBox Fehler
« Antwort #6 am: 01. Juli 2017, 19:38:39 »
Evtl. hängt das mit dem Bug in der 32Bit Version von Manjaro, siehe
https://de.manjaro.org/index.php?topic=7754.new;topicseen
zusammen?
Offensichtlich nicht, denn inzwischen scheint der Bug des Betriebssystems soweit behoben zu sein, daß wieder Updates möglich sind.

Bleibt also dieses mysteriöse Verhalten der VirtualBox.
The VM session was aborted.
Fehlercode:
NS_ERROR_FAILURE (0x80004005)
Komponente:
SessionMachine
Interface:
ISession {7844aa05-b02e-4cdd-a04f-ade4a762e6b7}
Deinstallieren von 'virtualbox' und erneute Installation löst das Problem nicht.

Auffällig ist, daß die Datei /usr/bin/virtualbox 4 B vom 09.05.17 21:40 (verweist auf /usr/bin/VBox) gleich zweimal vorhanden ist:
#!/bin/sh
## @file
# Oracle VM VirtualBox startup script, Linux hosts.
#

#
# Copyright (C) 2006-2015 Oracle Corporation
#
# This file is part of VirtualBox Open Source Edition (OSE), as
# available from http://www.virtualbox.org. This file is free software;
# you can redistribute it and/or modify it under the terms of the GNU
# General Public License (GPL) as published by the Free Software
# Foundation, in version 2 as it comes in the "COPYING" file of the
# VirtualBox OSE distribution. VirtualBox OSE is distributed in the
# hope that it will be useful, but WITHOUT ANY WARRANTY of any kind.
#

PATH="/usr/bin:/bin:/usr/sbin:/sbin"

# The below is GNU-specific.  See slightly further down for a version which
# works on Solaris and OS X.
TARGET=`readlink -e -- "${0}"` || exit 1
MY_DIR="${TARGET%/[!/]*}"

# (
#     path="${0}"
#     while test -n "${path}"; do
#         # Make sure we have at least one slash and no leading dash.
#         expr "${path}" : / > /dev/null || path="./${path}"
#         # Filter out bad characters in the path name.
#         expr "${path}" : ".*[*?<>\\]" > /dev/null && exit 1
#         # Catch embedded new-lines and non-existing (or path-relative) files.
#         # $0 should always be absolute when scripts are invoked through "#!".
#         test "`ls -l -d "${path}" 2> /dev/null | wc -l`" -eq 1 || exit 1
#         # Change to the folder containing the file to resolve relative links.
#         folder=`expr "${path}" : "\(.*/\)[^/][^/]*/*$"` || exit 1
#         path=`expr "x\`ls -l -d "${path}"\`" : "[^>]* -> \(.*\)"`
#         cd "${folder}"
#         # If the last path was not a link then we are in the target folder.
#         test -n "${path}" || pwd
#     done
# )

if test -f /usr/lib/virtualbox/VirtualBox &&
    test -x /usr/lib/virtualbox/VirtualBox; then
    INSTALL_DIR=/usr/lib/virtualbox
elif test -f "${MY_DIR}/VirtualBox" && test -x "${MY_DIR}/VirtualBox"; then
    INSTALL_DIR="${MY_DIR}"
else
    echo "Could not find VirtualBox installation. Please reinstall."
    exit 1
fi

# Note: This script must not fail if the module was not successfully installed
#       because the user might not want to run a VM but only change VM params!

if [ "$1" = "shutdown" ]; then
    SHUTDOWN="true"
elif ! lsmod|grep -q vboxdrv; then
    cat << EOF
WARNING: The vboxdrv kernel module is not loaded. Either there is no module
         available for the current kernel (`uname -r`) or it failed to
         load. Please recompile the kernel module and install it by

           sudo /sbin/vboxconfig

         You will not be able to start VMs until this problem is fixed.
EOF
elif [ ! -c /dev/vboxdrv ]; then
    cat << EOF
WARNING: The character device /dev/vboxdrv does not exist. Try

           sudo /sbin/vboxconfig

         and if that is not successful, try to re-install the package.

         You will not be able to start VMs until this problem is fixed.
EOF
fi

if [ -f /etc/vbox/module_not_compiled ]; then
    cat << EOF
WARNING: The compilation of the vboxdrv.ko kernel module failed during the
         installation for some reason. Starting a VM will not be possible.
         Please consult the User Manual for build instructions.
EOF
fi

SERVER_PID=`ps -U \`whoami\` | grep VBoxSVC | awk '{ print $1 }'`
if [ -z "$SERVER_PID" ]; then
    # Server not running yet/anymore, cleanup socket path.
    # See IPC_GetDefaultSocketPath()!
    if [ -n "$LOGNAME" ]; then
        rm -rf /tmp/.vbox-$LOGNAME-ipc > /dev/null 2>&1
    else
        rm -rf /tmp/.vbox-$USER-ipc > /dev/null 2>&1
    fi
fi

if [ "$SHUTDOWN" = "true" ]; then
    if [ -n "$SERVER_PID" ]; then
        kill -TERM $SERVER_PID
        sleep 2
    fi
    exit 0
fi

APP=`basename $0`
case "$APP" in
    VirtualBox|virtualbox)
        exec "$INSTALL_DIR/VirtualBox" "$@"
        ;;
    VBoxManage|vboxmanage)
        exec "$INSTALL_DIR/VBoxManage" "$@"
        ;;
    VBoxSDL|vboxsdl)
        exec "$INSTALL_DIR/VBoxSDL" "$@"
        ;;
    VBoxVRDP|VBoxHeadless|vboxheadless)
        exec "$INSTALL_DIR/VBoxHeadless" "$@"
        ;;
    VBoxAutostart|vboxautostart)
        exec "$INSTALL_DIR/VBoxAutostart" "$@"
        ;;
    VBoxBalloonCtrl|vboxballoonctrl)
        exec "$INSTALL_DIR/VBoxBalloonCtrl" "$@"
        ;;
    VBoxBugReport|vboxbugreport)
        exec "$INSTALL_DIR/VBoxBugReport" "$@"
        ;;
    VBoxDTrace|vboxdtrace)
        exec "$INSTALL_DIR/VBoxDTrace" "$@"
        ;;
    vboxwebsrv)
        exec "$INSTALL_DIR/vboxwebsrv" "$@"
        ;;
    *)
        echo "Unknown application - $APP"
        exit 1
        ;;
esac
exit 0


Gruß
Ch. Hanisch
« Letzte Änderung: 01. Juli 2017, 19:51:46 von Hanisch »
Je mehr man schon weiß, je mehr hat man noch zu lernen. Mit dem Wissen nimmt das Nichtwissen in gleichem Grade zu, oder vielmehr das Wissen des Nichtwissens.(Friedrich Schlegel)

Offline Hanisch

  • Held Mitglied
  • *****
  • Beiträge: 588
  • Dankeschön: 2 mal
  • Desktop: Xfce4, KDE-Plasma - 32 Bit/64Bit
  • Grafikkarte: VGA compatible controller: InnoTek Systemberatung GmbH VirtualBox Graphics Adapter, bzw. NVIDIA Optimus
  • Grafikkartentreiber: free, bzw. nonfree
  • Kernel: 4.1.32-1-MANJARO/4.4.55-1-MANJARO/4.9.20-1-MANJARO
  • Prozessor: VirtualBox bzw. Intel Core i7-2630QM
  • Skill: Durchschnitt
  • Zweig: stable
Re: VirtualBox Fehler
« Antwort #7 am: 02. Juli 2017, 19:16:22 »
Auffällig ist, daß die Datei /usr/bin/virtualbox 4 B vom 09.05.17 21:40 (verweist auf /usr/bin/VBox) gleich zweimal vorhanden ist
Das ist übrigens auch in dem funktionierenden 64Bit System so.

Nachdem ich VirtualBox und alles Dazugehörige entfernt und VirtualBox erneut installiert hatte, erhalte ich folgende mysteriöse Meldungen beim Anschließen der erhaltenen *.vdi:
....vdi konnte nicht an den Slot SATA-Port 0 der VM gebunden werden.

Das optische Laufwerk konnte nicht an den Slot der VM angeschlossen werden.

Sehr seltsame Meldungen. Da scheint etwas mit VirtualBox im 32Bit System nicht zu stimmen.

Gruß
Ch. Hanisch


Je mehr man schon weiß, je mehr hat man noch zu lernen. Mit dem Wissen nimmt das Nichtwissen in gleichem Grade zu, oder vielmehr das Wissen des Nichtwissens.(Friedrich Schlegel)

Offline Hanisch

  • Held Mitglied
  • *****
  • Beiträge: 588
  • Dankeschön: 2 mal
  • Desktop: Xfce4, KDE-Plasma - 32 Bit/64Bit
  • Grafikkarte: VGA compatible controller: InnoTek Systemberatung GmbH VirtualBox Graphics Adapter, bzw. NVIDIA Optimus
  • Grafikkartentreiber: free, bzw. nonfree
  • Kernel: 4.1.32-1-MANJARO/4.4.55-1-MANJARO/4.9.20-1-MANJARO
  • Prozessor: VirtualBox bzw. Intel Core i7-2630QM
  • Skill: Durchschnitt
  • Zweig: stable
Re: VirtualBox Fehler
« Antwort #8 am: 06. Juli 2017, 10:27:59 »
Hallo,

jetzt habe ich mir von der Seite    https://www.virtualbox.org/wiki/Testbuilds   das TestBuild   
VirtualBox-5.1.23-116680-Linux_x86.run   runtergeladen und installiert.
Damit läuft des aber auch nicht.
Siehe im Anhang.
# /sbin/vboxconfig
Created symlink /etc/systemd/system/multi-user.target.wants/vboxdrv.service → /usr/lib/systemd/system/vboxdrv.service.
Created symlink /etc/systemd/system/multi-user.target.wants/vboxballoonctrl-service.service → /usr/lib/systemd/system/vboxballoonctrl-service.service.
Created symlink /etc/systemd/system/multi-user.target.wants/vboxautostart-service.service → /usr/lib/systemd/system/vboxautostart-service.service.
Created symlink /etc/systemd/system/multi-user.target.wants/vboxweb-service.service → /usr/lib/systemd/system/vboxweb-service.service.
vboxdrv.sh: Stopping VirtualBox services.
vboxdrv.sh: Building VirtualBox kernel modules.
Linux distribution base type not recognised.
vboxdrv.sh: failed: Look at /var/log/vbox-install.log to find out what went wrong.
Linux distribution base type not recognised.

There were problems setting up VirtualBox.  To re-start the set-up process, run
  /sbin/vboxconfig
as root.
Habe
$ sudo pacman -S linux44-virtualbox-host-modulesauch schon gemacht.
 
Was bedeutet das:
Linux distribution base type not recognised.Hier der Inhalt von /var/log/vbox-install.log
Testing system setup...
Installing VirtualBox to /opt/VirtualBox

vboxdrv.sh: Stopping VirtualBox services.
vboxdrv.sh: Building VirtualBox kernel modules.
Makefile:205: *** Error: unable to find the include directory for your current Linux kernel. Specify KERN_INCL=<directory> and run Make again.  Schluss.
Linux distribution base type not recognised.
Makefile:205: *** Error: unable to find the include directory for your current Linux kernel. Specify KERN_INCL=<directory> and run Make again.  Schluss.
Makefile:205: *** Error: unable to find the include directory for your current Linux kernel. Specify KERN_INCL=<directory> and run Make again.  Schluss.
Makefile:205: *** Error: unable to find the include directory for your current Linux kernel. Specify KERN_INCL=<directory> and run Make again.  Schluss.
Makefile:205: *** Error: unable to find the include directory for your current Linux kernel. Specify KERN_INCL=<directory> and run Make again.  Schluss.
Makefile:205: *** Error: unable to find the include directory for your current Linux kernel. Specify KERN_INCL=<directory> and run Make again.  Schluss.
Makefile:205: *** Error: unable to find the include directory for your current Linux kernel. Specify KERN_INCL=<directory> and run Make again.  Schluss.
Makefile:205: *** Error: unable to find the include directory for your current Linux kernel. Specify KERN_INCL=<directory> and run Make again.  Schluss.
Makefile:205: *** Error: unable to find the include directory for your current Linux kernel. Specify KERN_INCL=<directory> and run Make again.  Schluss.

Was geht da schief?

Gruß
Ch. Hanisch
Je mehr man schon weiß, je mehr hat man noch zu lernen. Mit dem Wissen nimmt das Nichtwissen in gleichem Grade zu, oder vielmehr das Wissen des Nichtwissens.(Friedrich Schlegel)

Offline Hanisch

  • Held Mitglied
  • *****
  • Beiträge: 588
  • Dankeschön: 2 mal
  • Desktop: Xfce4, KDE-Plasma - 32 Bit/64Bit
  • Grafikkarte: VGA compatible controller: InnoTek Systemberatung GmbH VirtualBox Graphics Adapter, bzw. NVIDIA Optimus
  • Grafikkartentreiber: free, bzw. nonfree
  • Kernel: 4.1.32-1-MANJARO/4.4.55-1-MANJARO/4.9.20-1-MANJARO
  • Prozessor: VirtualBox bzw. Intel Core i7-2630QM
  • Skill: Durchschnitt
  • Zweig: stable
Re: VirtualBox Fehler
« Antwort #9 am: 06. Juli 2017, 16:42:53 »
Hallo,

die Frage nach dem <directory> für den Kernel bewegt mich, was trage ich da ein?
Specify KERN_INCL=<directory> and run Make again.KERN_INCL ist doch eine Environment-Variable. Wie setze ich die?

$ virtualbox
WARNING: The vboxdrv kernel module is not loaded. Either there is no module
         available for the current kernel (4.4.75-1-MANJARO) or it failed to
         load. Please recompile the kernel module and install it by

           sudo /sbin/vboxconfig

         You will not be able to start VMs until this problem is fixed.
^C

 $ sudo /sbin/vboxconfig
Created symlink /etc/systemd/system/multi-user.target.wants/vboxdrv.service → /usr/lib/systemd/system/vboxdrv.service.
Created symlink /etc/systemd/system/multi-user.target.wants/vboxballoonctrl-service.service → /usr/lib/systemd/system/vboxballoonctrl-service.service.
Created symlink /etc/systemd/system/multi-user.target.wants/vboxautostart-service.service → /usr/lib/systemd/system/vboxautostart-service.service.
Created symlink /etc/systemd/system/multi-user.target.wants/vboxweb-service.service → /usr/lib/systemd/system/vboxweb-service.service.
vboxdrv.sh: Stopping VirtualBox services.
vboxdrv.sh: Building VirtualBox kernel modules.
Linux distribution base type not recognised.
vboxdrv.sh: failed: Look at /var/log/vbox-install.log to find out what went wrong.
Linux distribution base type not recognised.

There were problems setting up VirtualBox.  To re-start the set-up process, run
  /sbin/vboxconfig
as root.
Damit vboxdrv automatisch geladen wird, muß in   /etc/modules-load.d/modules.conf    noch eingetragen sein:
vboxdrv
vboxnetadp
vboxnetflt
vboxpci

Vielleicht würde es mit der Environment-Variablen KERN_INCL= ...  laufen.


Gruß
Ch. Hanisch
 
« Letzte Änderung: 06. Juli 2017, 17:02:10 von Hanisch »
Je mehr man schon weiß, je mehr hat man noch zu lernen. Mit dem Wissen nimmt das Nichtwissen in gleichem Grade zu, oder vielmehr das Wissen des Nichtwissens.(Friedrich Schlegel)

Offline Hanisch

  • Held Mitglied
  • *****
  • Beiträge: 588
  • Dankeschön: 2 mal
  • Desktop: Xfce4, KDE-Plasma - 32 Bit/64Bit
  • Grafikkarte: VGA compatible controller: InnoTek Systemberatung GmbH VirtualBox Graphics Adapter, bzw. NVIDIA Optimus
  • Grafikkartentreiber: free, bzw. nonfree
  • Kernel: 4.1.32-1-MANJARO/4.4.55-1-MANJARO/4.9.20-1-MANJARO
  • Prozessor: VirtualBox bzw. Intel Core i7-2630QM
  • Skill: Durchschnitt
  • Zweig: stable
Re: VirtualBox Fehler
« Antwort #10 am: 06. Juli 2017, 18:43:46 »
Hallo,

nach
$ uname -r
4.4.75-1-MANJARO
$ sudo pacman -S linux44-headers
und
$ sudo /sbin/vboxconfig
Created symlink /etc/systemd/system/multi-user.target.wants/vboxdrv.service → /usr/lib/systemd/system/vboxdrv.service.
Created symlink /etc/systemd/system/multi-user.target.wants/vboxballoonctrl-service.service → /usr/lib/systemd/system/vboxballoonctrl-service.service.
Created symlink /etc/systemd/system/multi-user.target.wants/vboxautostart-service.service → /usr/lib/systemd/system/vboxautostart-service.service.
Created symlink /etc/systemd/system/multi-user.target.wants/vboxweb-service.service → /usr/lib/systemd/system/vboxweb-service.service.
vboxdrv.sh: Stopping VirtualBox services.
vboxdrv.sh: Building VirtualBox kernel modules.
vboxdrv.sh: Starting VirtualBox services.
funktioniert es immer noch nicht.

Woran liegt das?

Gruß
Ch. Hanisch


Je mehr man schon weiß, je mehr hat man noch zu lernen. Mit dem Wissen nimmt das Nichtwissen in gleichem Grade zu, oder vielmehr das Wissen des Nichtwissens.(Friedrich Schlegel)

Offline gosia

  • Held Mitglied
  • *****
  • Beiträge: 992
  • Dankeschön: 168 mal
  • Desktop: Openbox + xfce
  • Grafikkarte: Intel HD 4000
  • Grafikkartentreiber: i915 (free)
  • Kernel: 4.9 Artix
  • Prozessor: Intel Core i5-3210M
  • Skill: Durchschnitt
  • Zweig: stable
Re: VirtualBox Fehler
« Antwort #11 am: 07. Juli 2017, 19:07:02 »
Hallo Ch. Hanisch,
jetzt habe ich mir von der Seite    https://www.virtualbox.org/wiki/Testbuilds   das TestBuild   
VirtualBox-5.1.23-116680-Linux_x86.run   runtergeladen und installiert.
was für eine Idee...
Was bedeutet das:
Linux distribution base type not recognised.
Das bedeutet, daß das Installationsskript versucht herauszufinden, auf welcher Distri es arbeitet. Da es aber nicht alle gefühlt 250 Distris abtesten kann, sucht es nach den wichtigsten Familien ("distribution base type"):
SUSE, Mandriva/Mageia, Red Hat, Ubuntu, Debian, Gentoo, Slackware, Arch (ich hoffe, ich habe keine übersehen)
Wie Du siehst ist Manjaro nicht dabei, was aber wahrscheinlich ohne Bedeutung ist.
Makefile:205: *** Error: unable to find the include directory for your current Linux kernel. Specify KERN_INCL=<directory> and run Make again.
 
Was geht da schief?
Das, was da steht. Die Variable KERN_INCL ist nicht deklariert und es kann die Header nicht finden. Du kannst also den Ort deklarieren, aber ich vermute mal, Du hast die Header gar nicht installiert. Normalerweise findet es die ja von selbst, wenn sie nicht gerade an einem exotischen Ort liegen.
Nachtrag Ich hatte die Antwort schon gestern nachmittag begonnen und sehe jetzt, daß Du das mit den Headern selbst gemerkt hast. Ist aber schwierig was zu sagen, weil
funktioniert es immer noch nicht.
eine verdammt aussagekräftige Fehlermeldung ist  ::) Zumindest in dem Code-Ausschnitt gibt es keine Fehler.
Ansonsten bin ich bei dem ganzen systemd-Gedöns eh raus und kann nichts zur Wahrheitsfindung beitragen.

Aber, wenn Du sozusagen "Fremdsoftware" am Paketmanager vorbei installierst, solltest Du schon wissen, was Du tust. Der Support hier im Forum kann da nur gering sein, weil die meisten (oder wahrscheinlich fast alle) dafür pacman benutzen, zumal ja virtualbox in den Repos existiert.
Da wäre also das VirtualBox-Forum die bessere Anlaufstelle
https://forums.virtualbox.org/

Viele Grüße gosia

Offline Hanisch

  • Held Mitglied
  • *****
  • Beiträge: 588
  • Dankeschön: 2 mal
  • Desktop: Xfce4, KDE-Plasma - 32 Bit/64Bit
  • Grafikkarte: VGA compatible controller: InnoTek Systemberatung GmbH VirtualBox Graphics Adapter, bzw. NVIDIA Optimus
  • Grafikkartentreiber: free, bzw. nonfree
  • Kernel: 4.1.32-1-MANJARO/4.4.55-1-MANJARO/4.9.20-1-MANJARO
  • Prozessor: VirtualBox bzw. Intel Core i7-2630QM
  • Skill: Durchschnitt
  • Zweig: stable
Re: VirtualBox Fehler
« Antwort #12 am: 07. Juli 2017, 20:28:41 »
Hallo,
...Zumindest in dem Code-Ausschnitt gibt es keine Fehler.
Dieses Test-Build von VirtualBox 5.1.23 scheint also ordnungsgemäß installiert zu sein.
Was allerdings irritiert ist die Fehlermeldung beim Versuch, eine VM zu starten:
Make sure that you do not mix the OSE version and the PUEL version of VirtualBox.Siehe im Anhang von Posting #8.
Offensichtlich gibt es da noch eine Mischung, aber welche?
Was muß ich nun von der VirtualBox-Installation (OSE version) aus dem Manjaro-Repo alles auf meinem System löschen?

Zitat
Aber, wenn Du sozusagen "Fremdsoftware" am Paketmanager vorbei installierst, solltest Du schon wissen, was Du tust.
... zumal ja virtualbox in den Repos existiert.
Genau das ist mein Problem. Die VirtualBox aus den Repos für das 32Bit System scheint total buggy zu sein, deshalb habe ich mir das Test-Build installiert.
Ich würde gern wieder auf virtualbox aus dem Manjaro-Repo zurückgreifen, sobald das wieder funktioniert.

Gruß
Ch. Hanisch

Je mehr man schon weiß, je mehr hat man noch zu lernen. Mit dem Wissen nimmt das Nichtwissen in gleichem Grade zu, oder vielmehr das Wissen des Nichtwissens.(Friedrich Schlegel)

Offline gosia

  • Held Mitglied
  • *****
  • Beiträge: 992
  • Dankeschön: 168 mal
  • Desktop: Openbox + xfce
  • Grafikkarte: Intel HD 4000
  • Grafikkartentreiber: i915 (free)
  • Kernel: 4.9 Artix
  • Prozessor: Intel Core i5-3210M
  • Skill: Durchschnitt
  • Zweig: stable
Re: VirtualBox Fehler
« Antwort #13 am: 07. Juli 2017, 23:55:22 »
Hallo Ch. Hanisch,
Was muß ich nun von der VirtualBox-Installation (OSE version) aus dem Manjaro-Repo alles auf meinem System löschen?
Deinstalliere das ganze Virtualbox-Zeugs und lösche noch das Directory ~/.config/VirtualBox/
Dann ist alles weg.
Die VirtualBox aus den Repos für das 32Bit System scheint total buggy zu sein
Vielleicht verstehe ich dich jetzt falsch, aber wo in den 32-bit-Repos (multilib) gibt es eine Virtualbox? Oder habe ich da was übersehen? Und warum überhaupt 32-bit?

Viele Grüße gosia

Offline Hanisch

  • Held Mitglied
  • *****
  • Beiträge: 588
  • Dankeschön: 2 mal
  • Desktop: Xfce4, KDE-Plasma - 32 Bit/64Bit
  • Grafikkarte: VGA compatible controller: InnoTek Systemberatung GmbH VirtualBox Graphics Adapter, bzw. NVIDIA Optimus
  • Grafikkartentreiber: free, bzw. nonfree
  • Kernel: 4.1.32-1-MANJARO/4.4.55-1-MANJARO/4.9.20-1-MANJARO
  • Prozessor: VirtualBox bzw. Intel Core i7-2630QM
  • Skill: Durchschnitt
  • Zweig: stable
Re: VirtualBox Fehler
« Antwort #14 am: 08. Juli 2017, 10:22:42 »
Deinstalliere das ganze Virtualbox-Zeugs und lösche noch das Directory ~/.config/VirtualBox/
Dann ist alles weg.
Nachdem ich auch noch
virtualbox-host-dkms
linux44-virtualbox-host-modules
gelöscht, aber
~/VirtualBox\ VMs  und  ~/.config/VirtualBox  behalten hatte, startete das Test-Build 5.1.23 erst einmal ohne Fehlermeldungen.

Dann aber beim Versuch, eine VM zu starten kam auch hier die Fehlermeldung wie bei der VirtualBox-OSE aus dem Manjaro-Repo.
Siehe Anhang.
Allerdings konnte ich mir eine zusätzliche Test-VM anlegen, was unter der VirtualBox-OSE (siehe Posting vom 11.06.2017) nicht ging.

Somit stelle ich fest, daß das Test-Build 5.1.23 zwar läuft, aber sich auch keine VM's starten lassen.
Also muß es am 32Bit Betriebssystem liegen.
Was hat sich da nach den letzten Updates verändert, was VirtualBox nicht verträgt?

Gruß
Ch. Hanisch










Vielleicht verstehe ich dich jetzt falsch, aber wo in den 32-bit-Repos (multilib) gibt es eine Virtualbox? Oder habe ich da was übersehen? Und warum überhaupt 32-bit?

Viele Grüße gosia
[/quote]
Je mehr man schon weiß, je mehr hat man noch zu lernen. Mit dem Wissen nimmt das Nichtwissen in gleichem Grade zu, oder vielmehr das Wissen des Nichtwissens.(Friedrich Schlegel)