Manjaro Linux Forum

Manjaro Editionen => Support für die XFCE Edition => Thema gestartet von: Eric Zettler am 14. Juli 2013, 20:10:23

Titel: Fehler nach Installation verhindert Update und Installation anderer Pakete
Beitrag von: Eric Zettler am 14. Juli 2013, 20:10:23
Hallo,

habe mir eben die x86_64 ISO geladen und installiert.
Würde nun gerne weiter machen, erhalte aber nach dem Start des ersten Updates folgende Popup-Box:

transaction failed, pm_errno 47 (conflicting files), [('harfbuzz-icu', '/usr/include/harfbuzz/hb-icu.h', None)]

was alles Weitere verhindert.


Was ist zu tun?
Titel: Re: Fehler nach Installation verhindert Update und Installation anderer Pakete
Beitrag von: Eric Zettler am 14. Juli 2013, 20:19:51
Nachtrag: Lese gerade in einem Blog, dass genau der gleiche Fehler bei einem anderen User Mitte Juni aufgetreten ist, was diesen bewogen hat, die Finger von dem "verdammt schnellen System" zu lassen.
Gleiches habe ich nicht vor, bin darum an einer kurzfristigen Hilfe sehr interessiert.
Titel: Re: Fehler nach Installation verhindert Update und Installation anderer Pakete
Beitrag von: eskaini am 14. Juli 2013, 20:26:19
Wie machst du denn das Update?
Titel: Re: Fehler nach Installation verhindert Update und Installation anderer Pakete
Beitrag von: Eric Zettler am 14. Juli 2013, 20:29:05
Oben rechts erscheint diese "orange Sonne", Rechtsklick, Klick auf "Starte pamac-Manager",

also, ich denke, ich mache das Übliche... ;)
Titel: Re: Fehler nach Installation verhindert Update und Installation anderer Pakete
Beitrag von: Eric Zettler am 14. Juli 2013, 20:34:25
Übrigens mache ich jetzt Folgendes (gerade hier gelesen)

sudo pacman-mirrors -g
sudo pacman -Syyu

Vielleicht hilft das.
Titel: Re: Fehler nach Installation verhindert Update und Installation anderer Pakete
Beitrag von: eskaini am 14. Juli 2013, 20:46:43
Ja, normalerweise kann man das so machen, aber bitte bei diesem Update nicht pamac benutzen sondern pacman im Terminal, also genau so wie du es bereits geschrieben hast.

Also erst sudo pacman -Syyuu und dann noch mal sudo pacman -Su.
Titel: Re: Fehler nach Installation verhindert Update und Installation anderer Pakete
Beitrag von: Eric Zettler am 14. Juli 2013, 21:19:05
Hallo, und Danke.

Das Problem ist für mich(!) gelöst. Interessierte finden die drei benötigten Kommandos in diesem Thread.

Nach dem Download von ca. 500 MByte und Installation war alles OK, oben rechts lacht die grüne Sonne.
Jetzt hab ich auch meinen geliebten KRUSADER installieren können. Läuft!

Fazit: Meines Erachtens nach muss die ISO im Downloadbereich aktualisiert werden, damit nicht weitere Willige, die mal etwas Neues ausprobieren wollen,
in die Falle laufen.

Ich freue mich auf Manjaro, los geht's... :D
Titel: Re: Fehler nach Installation verhindert Update und Installation anderer Pakete
Beitrag von: pin guin am 14. Juli 2013, 23:19:35
@Eric Zettler @ Parmaster

War in der gleichen Situation,  also: Danke für die Fragestellung und die Lösung!
Titel: Re: Fehler nach Installation verhindert Update und Installation anderer Pakete
Beitrag von: Joke am 15. Juli 2013, 12:09:44
Schliesse mich Eric Zettler mal an!

Ich habe auch das Problem, das man nach der Installation von Manjaro die Updates nur über das Terminal machen kann!

Das schreckt neue User natürlich ab.

Gruss
Joke
Titel: Re: Fehler nach Installation verhindert Update und Installation anderer Pakete
Beitrag von: eskaini am 15. Juli 2013, 18:29:19
Es ist nur das eine Update wenn man 0.8.6 installiert, ansonsten geht es natürlich auch mit pamac.