Manjaro Linux Forum

Manjaro Editionen => Support für die XFCE Edition => Thema gestartet von: HuRRiCaNe am 31. Mai 2019, 15:47:38

Titel: OpenVPN verschleiert die IP nicht
Beitrag von: HuRRiCaNe am 31. Mai 2019, 15:47:38
Guten Tag,

woran könnte es liegen, dass OpenVPN die IP-Adresse nicht versteckt? Weder über die Shell noch über den Netzwerkmanager funktioniert es.

Ich bekomme nicht mal Fehler angezeigt.

.....
Fri May 31 15:45:34 2019 Initialization Sequence Completed


Sollte eigentlich alles funktionieren. Ich habe mir vom Anbieter testweise ein chrome- bzw. firefox-addon geladen und siehe da: Es funktioniert!

Allerdings möchte ich natürlich, dass der komplette Traffic über den VPN geht und nicht nur die Browser.

Hat jemand ne Idee, woran es liegen könnte?


uname -r
5.1.4-1-MANJARO

Desk:
XFCE
Titel: Re: OpenVPN verschleiert die IP nicht
Beitrag von: HuRRiCaNe am 01. Juni 2019, 13:55:58
Also ich habe den "Fehler" gefunden!

Einstellungen des (Funk)netzwerks öffnen, IPv4 Einstellung anklicken (Methode=Automatisch, nur Adressen), DNS-Server 127.0.0.1 setzen, IPv6 Methode auf ignorieren setzen.


sodann

https://ipleak.net
https://www.dnsleaktest.com/

testen und gucken, ob es funktioniert hat :)


Zusätzlich im ovpn file einfügen:

script-security 2
up /etc/openvpn/update-resolv-conf
down /etc/openvpn/update-resolv-conf


run:

sudo openvpn --config name_of_your_file.ovpn





Ich hoffe, ich konnte damit auch anderen helfen!

Cheers
Titel: Re: OpenVPN verschleiert die IP nicht
Beitrag von: HuRRiCaNe am 08. Juni 2019, 21:27:51
Leider kann ich nichts editieren! Oder ich bin zu doof 8) .

Jedenfalls habe ich noch zusätzlich WEBRT im Browser deaktivieren müssen und als Ipv4-Einstellungen den DNS-Server vom VPN-Provider eingetragen!

Mit 127.0.0.1 lief es nur mit VPN und ohne nicht mehr.

Naja wie auch immer, hoffe, ich kann damit noch anderen helfen...