Manjaro Linux Forum

Technische Fragen und Hilfe => Installation und Konfiguration => Thema gestartet von: charly700 am 09. Juni 2019, 19:19:55

Titel: Boot Problem mit zwei SSD's (1xNVME und 1xSATA) und Grub2 auf der SATA SSD
Beitrag von: charly700 am 09. Juni 2019, 19:19:55
Hallo

Habe auch ein komisches Problem mit UEFI und Dualboot. Es geht um den neuen PC meines Vaters und deshalb habe ich nicht immer alle Infos schnell zur Verfügung.

Auf der ersten SSD (NVME) befindet sich Win 10 und auf der SATA SSD Manjaro. Es gibt zwei UEFI Partitionen eine auf der Windows SSD und eine auf der Manjaro SSD.
Getrennt Booten beide Systeme einwandfrei (also wen im UEFI einmal die eine und dann wieder die andere als erstes Laufwerk eingestellt wird).

Wenn ich die zweite SSD als Bootlaufwerk im UEFI auswähle kommt auch der Grub und ich kann Manjaro ganz normal booten, wenn ich aber Windows im Grub auswähle kommt folgende Fehlermeldung:

error: no such device: 4ACD-77D9.
error: file `/efi/Microsoft/Boot/bootmgfw.efi' not found.

Press any key to continue..._

Wo könnte ich da ansetzen das ich mit Grub auch Windows booten kann? Da er ja mit "sudo update-grub" Windows auch findet, frage ich mich warum er es dann nicht booten kann?

Falls ihr noch Infos braucht bitte nur sagen, dauert aber dann ein Weilchen da ich erst zu meinem Vater fahren muss um die Infos zu besorgen.

Oder ist die zweite UEFI Partition der Grund dafür das ich Windows nicht über Grub booten kann? Habe im Internet irgendwo gelesen dass man auch pro SSD eine UEFI Partition verwenden kann. Wenn nicht dann installiere ich Manjaro einfach nochmals und verwende die UEFI Partition von Windows.

Aber eine Neuinstallation würde ich mir gerne ersparen.

Der Grund warum ich Grub und die UEFI Partition auf der zweiten SSD habe ist der, das Windows immer wieder nach einem Update Einstellungen im UEFI geändert hat und somit Manjaro nicht gebootet werden konnte. Da mein Vater das nicht selbst bereinigen kann, dachte ich wäre das jetzt die Lösung. Wäre es ja auch wenn Windows aus Grub booten würde.

Danke schon mal für eure Antworten
LG Charly
Titel: Re: Boot Problem mit zwei SSD's (1xNVME und 1xSATA) und Grub2 auf der SATA SSD
Beitrag von: charly700 am 16. Juni 2019, 16:51:09
Hat wirklich keiner eine Antwort für mich?
Titel: Re: Boot Problem mit zwei SSD's (1xNVME und 1xSATA) und Grub2 auf der SATA SSD
Beitrag von: gosia am 16. Juni 2019, 19:10:06
Hallo Charly,
fühle mich eigentlich gar nicht kompetent, weil ich zum Glück weder was mit Windows oder UEFI zu tun habe. Aber weil Du so verzweifelt klingst, wenigstens meine unmassgebliche Meinung:
Zwei UEFI halte ich für eine schlechte Idee, ich habe bisher immer nur von einer UEFI-Partition gelesen, wundert mich also nicht besonders, wenn da Grub ins Schleudern kommt.
Wenn ich die zweite SSD als Bootlaufwerk im UEFI auswähle kommt auch der Grub
Das klingt so, als ob Du den Grub auf die zweite FP/SSD gepackt hast. Ist IMHO auch eine schlechte Idee, weil der Grub wohl in den MBR der ersten FP soll, also in die, von der Du ohne was umzustellen bootest (1. SSD)
Wo könnte ich da ansetzen das ich mit Grub auch Windows booten kann?
Ich würde da den üblichen Weg gehen, also chroot und den Grub nach dieser Anleitung auf der ersten FP reparieren
https://wiki.manjaro.org/index.php/Restore_the_GRUB_Bootloader
dabei dort auf den UEFI-Punkt achten.
Ob die zweite UEFI-Partition vorher weg muss, weiss ich nicht. Vom Gefühl her sage ich, weg mit dem Ding (aber wenn, dann vorher)
Der Grund warum ich Grub und die UEFI Partition auf der zweiten SSD habe ist der, das Windows immer wieder nach einem Update Einstellungen im UEFI geändert hat
Hm, lese ich zum ersten Mal. Bei Neuinstallation von Windows ja, da ist immer alles wichtige weg. Aber bei einem blossen Update? Da müssten sich ja jede Woche sämtliche Dualbooter hier drängeln und um Rat fragen. Aber wie gesagt, von Windows 10 weiss ich nur, daß es sowas auch gibt...

viele Grüße gosia
Titel: Re: Boot Problem mit zwei SSD's (1xNVME und 1xSATA) und Grub2 auf der SATA SSD
Beitrag von: charly700 am 18. Juni 2019, 23:06:27
Danke für deine Antwort. Natürlich ist das nicht immer nach jedem Update, aber nach den zwei Großen Updates die jedes Jahr kommen.

Windows ändert da schon mal was im UEFI oder der Grub ist einfach weg. Ich weiß nicht warum Microsoft so damit umgeht.
Bei diesem PC funktioniert auch das Windows Update auf die letzte Version nicht und ich weiß nicht ob ich Windows auch neu Aufsetzen soll. Habe mit den PC's oder Notebooks meines Vaters immer wieder mal Probleme mit Windows 10 und dadurch auch schon mal mit Manjaro (mein Vater hat einen PC und drei Notebooks jeweils im Dualboot Win10 und Manjaro).
Viel Arbeit ab und zu für mich.  :(

Ich werde deine Tipps demnächst mal versuchen, und wenn es nicht so geht werde ich wohl Manjaro nochmals neu Installieren und die UEFI Partition der Windows Platte verwenden und den Grub auch wieder dort installieren. Ist aber auch nicht gerade einfach da es sich um eine NVME SSD handelt (wo Win10 drauf ist) und dieses bei der Installation von Manjaro auch nicht immer ansprechbar war. Mal sehen.

Danke
Charly
Titel: Re: Boot Problem mit zwei SSD's (1xNVME und 1xSATA) und Grub2 auf der SATA SSD
Beitrag von: charly700 am 21. Juni 2019, 20:30:13
Hi

Habe Manjaro neu installiert und die zweite UEFI Partition gelöscht und den Grub bei Manjaro Architekt Automatisch installieren lassen (kann jetzt aber nicht sagen wo er denn hin Installiert hat) und was soll ich sagen, es läuft jetzt mal. Hoffe das bleibt auch so.

Danke
Gruß Charly