Manjaro Linux Forum

Technische Fragen und Hilfe => Installation und Konfiguration => Thema gestartet von: Lip am 18. Oktober 2019, 13:56:22

Titel: Nvidia 430xx Treiber lässt sich nicht entfernen
Beitrag von: Lip am 18. Oktober 2019, 13:56:22
Hallo!

Ich stell mich gerade bestimmt super blöd an, aber ich komme einfach nicht weiter.
Vielleicht könnt ihr mir kurz helfen.

Ich habe den nvidia-430xx Treiber am laufen und möchte zum testen den nvidia-435xx installieren.
Dazu muss ich zuerst den 430xx entfernen. Wenn ich es versuche bringt er mir immer folgendes:

Starting
> Removing video-nvidia-430xx...
Using default
Has lib32 support: true
Sourcing /var/lib/mhwd/local/pci/video-nvidia-430xx/MHWDCONFIG
Processing classid: 0300
Sourcing /var/lib/mhwd/scripts/include/0300
Processing classid: 0302
checking dependencies...
error: failed to prepare transaction (could not satisfy dependencies)
:: linux-latest-nvidia-430xx: removing linux53-nvidia-430xx breaks dependency 'linux53-nvidia-430xx'
Error: pacman failed!
Error: script failed!

Wie bekomme ich den 430xx entfernt um den 435xx installieren zu können ?

Vorab vielen Dank und liebe Grüße

Lip
Titel: Re: Nvidia 430xx Treiber lässt sich nicht entfernen
Beitrag von: SpiritOfTux am 18. Oktober 2019, 14:18:01
Sehe Dir mal die Doku an "Removing Installed Drivers " https://wiki.manjaro.org/index.php/Configure_Graphics_Cards (https://wiki.manjaro.org/index.php/Configure_Graphics_Cards)
Wie der neue Treiber installiert wird steht hier auch beschrieben

Viel Erfolg


Titel: Re: Nvidia 430xx Treiber lässt sich nicht entfernen
Beitrag von: Lip am 18. Oktober 2019, 17:14:17

Im Wiki habe ich natürlich bereits nachgeschaut.

Wenn ich im Terminal:
Zitat
sudo mhwd -r pci video-nvidia-430xx
eingebe, erhalte ich folgendes:
Zitat
Removing video-nvidia-430xx...
Using default
Has lib32 support: true
Sourcing /var/lib/mhwd/local/pci/video-nvidia-430xx/MHWDCONFIG
Processing classid: 0300
Sourcing /var/lib/mhwd/scripts/include/0300
Processing classid: 0302
Prüfe Abhängigkeiten...
Fehler: Konnte den Vorgang nicht vorbereiten (Kann Abhängigkeiten nicht erfüllen)
:: linux-latest-nvidia-430xx: das Entfernen von linux53-nvidia-430xx verletzt Abhängigkeit von 'linux53-nvidia-430xx'
Error: pacman failed!
Error: script failed!

Also das gleiche Ergebnis, nur diesmal auf Deutsch  ;)
Titel: Re: Nvidia 430xx Treiber lässt sich nicht entfernen
Beitrag von: Lip am 25. Oktober 2019, 15:49:20
Hallo!

Die Lösung ist: "linux-latest-nvidia-430xx" muss entfernt werden.

sudo pacman -R linux-latest-nvidia-430xx
Das ist ein metapackage von linux-latest-extramodules.