Autor Thema: Thunar - eingehängte Laufwerke verschwinden in der Geräteliste  (Gelesen 399 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Offline perchlorat

  • Jr. Mitglied
  • **
  • Beiträge: 93
  • Karma: +0/-0
    • Lebenslust jetzt! – Praxis für Psychotherapie
  • Desktop: XFCE
  • Grafikkarte: nVidia GeForce GTX 1650
  • Grafikkartentreiber: nonfree
  • Kernel: 5.10.2
  • Prozessor: i5-7400
  • Skill: Anfänger
  • Zweig: stable
Wieder ein lästiges Problem, das ich aber noch nie zuvor hatte:
Starte ich meinen PC, so wird die zusätzlich zur System-SSD vorhandene HDD nicht automatisch eingehängt, aber korrekt angezeigt. Nachdem ich durch Draufklicken das Einhängen bewirkt habe und auch darauf gearbeitet hatte, wollte ich wieder in Thunar Dateien auf der HDD verschieben und stellte fest, dass die HDD nicht mehr unter "Geräte" angezeigt wurde.
Ich startete eine neue Instanz von Thunar und die Platte fehlte wieder! Daraufhin hangelte ich mich über Dateisystem /run/media/USER/HDD wieder hinein und hatte problemlos Zugriff. Auch danach wurde die HDD  in Thunar nicht unter "Geräte"angezeigt. Die HDD ist übrigens mit ext4 formatiert und nur eine Partition. SMART meldet, dass sie völlig OK ist.

Das Gleiche erlebe ich mit verschiedenen mobilen HDDs, die ich über USB-3 anstecke. DIese sind meist in FAT32 oder xFAT formatiert und eine in NTSF.

Geprüft habe ich, dass die Datenträgerverwaltung von Thunar aktiviert ist. Und unter Einstellungen / Wechseldatenträger- und Medieneinstellungen habe ich versuchsweise aktiviert: "HotPlug-Wechsellaufwerke automatisch einhängen" und außerdem "Wechselmedien beim Einlegen einhängen".

Nach einem Reboot hat sich das Verhalten anscheinend nicht geändert: Die o.g. HDD wird nicht, wie ich erwartet hätte, nun automatisch eingehängt und der oben beschriebene Fehler bleibt auch bestehen.

Am liebsten wäre mir ja, dass eine HDD, die ich neu einstecke, automatisch gemountet wird und in diesem Zustand verbleibt, bis ich sie manuell auswerfe oder den PC herunter fahre.

Was sollte ich tun, um den Ärger zu beheben?

Offline Manfrago

  • Jr. Mitglied
  • **
  • Beiträge: 58
  • Dankeschön: 5 mal
  • Karma: +0/-0
  • Desktop: XFCE
  • Grafikkarte: Intel, Nvidia-Optimus
  • Grafikkartentreiber: nonfree
  • Kernel: 4.19
  • Prozessor: Diverse i5 & i7
  • Skill: Fortgeschritten
  • Zweig: stable
Re: Thunar - eingehängte Laufwerke verschwinden in der Geräteliste
« Antwort #1 am: 17. Dezember 2020, 15:26:24 »
Warum eingehängte Laufwerke angeblich wieder verschwinden, darum können wir uns später noch kümmern.
Nun erst mal das Einhängen der internen HDD beim Start:
Soweit nicht bereits geschehen, Gnome-Disk aus den Repos installieren.
Jetzt unter -> Zubehör -> Laufwerke aufrufen, dort die entsprechende Partition markieren und auf das Zahnradsymbol gehen um die Einhängeoptionen der Partition zu bearbeiten. Normalerweise reicht es, hier den Haken bei "Vorgabe der Benutzersteuerung" rauszunehmen, damit die Platte beim Systemstart automatisch eingehängt wird.
Jetzt zu den externen Laufwerken: In der Einstellungsverwaltung auf -> "Wechseldatenträger und Medieneinstellungen" gehen, "Hotplug" und "Wechselmedien beim Einlegen einhängen" ankreuzen.
Jetzt ist erst mal die Basis dafür geschaffen, unter der es eigentlich funktionieren müsste. Du wirst über den Zwischenstand berichten?


Ungesicherte Daten sind unwichtige Daten

Offline quantix

  • Held Mitglied
  • *****
  • Beiträge: 580
  • Dankeschön: 90 mal
  • Karma: +0/-0
  • Desktop: Xfce + fish
  • Grafikkarte: Ati RS880M / GeForce GT 730
  • Grafikkartentreiber: nonfree
  • Kernel: 5.9
  • Prozessor: AMD Phenom II P920 / i5-4460
  • Skill: Anfänger
  • Zweig: stable
Re: Thunar - eingehängte Laufwerke verschwinden in der Geräteliste
« Antwort #2 am: 17. Dezember 2020, 16:42:23 »
Hallo perchlorat,

hast du das Paket udiskie installiert?

Grüße
Josef
Alles sollte so einfach wie möglich sein - aber nicht einfacher.
Albert Einstein

PGV ecogold, HP Pavilion dv7, Acer Spin 1, Raspberry Pi 2

Offline perchlorat

  • Jr. Mitglied
  • **
  • Beiträge: 93
  • Karma: +0/-0
    • Lebenslust jetzt! – Praxis für Psychotherapie
  • Desktop: XFCE
  • Grafikkarte: nVidia GeForce GTX 1650
  • Grafikkartentreiber: nonfree
  • Kernel: 5.10.2
  • Prozessor: i5-7400
  • Skill: Anfänger
  • Zweig: stable
Re: Thunar - eingehängte Laufwerke verschwinden in der Geräteliste
« Antwort #3 am: 17. Dezember 2020, 22:53:20 »
@Manfrago
Herzlichen Dank für deinen Tipp. Da wär ich nicht drauf gekommen. Ich hab es also genau so umgesetzt, wie du geraten hast. Resultat:
Die HDD im PC wurde mit dem Systemstart automatisch gemountet.

Ich steckte gerade eine USB-HDD ein. Sie erschien für ca. 10 Sekunden unter "Geräte" im unmounted-Zustand und verschwand dann von selbst wieder von dort, ohne dass ich in dieser Zeit irgend eine Aktion am PC vorgenommen habe. – Starte ich eine neue Instanz von Thunar, bleibt die HDD unsichtbar.

Bisher war der Fehler so, dass die neu angesteckte HDD in der Geräteliste stand, ich sie durch Anklicken auch mounten konnte, aber beim ersten Zugriff auf Dateien dort, flog sie aus der Geräteliste raus, blieb aber gemountet.

Ich muss mich also allen Ernstes über /run/media/user/HDD in die HDD hinein bringen, um auf die HDD per Thunar zugreifen zu können. Echt krass!


@quantix:
udiskie hab ich nicht installiert, aber auf Nachprüfung in Pamac finde ich, dass es installiert ist.

Offline Manfrago

  • Jr. Mitglied
  • **
  • Beiträge: 58
  • Dankeschön: 5 mal
  • Karma: +0/-0
  • Desktop: XFCE
  • Grafikkarte: Intel, Nvidia-Optimus
  • Grafikkartentreiber: nonfree
  • Kernel: 4.19
  • Prozessor: Diverse i5 & i7
  • Skill: Fortgeschritten
  • Zweig: stable
Re: Thunar - eingehängte Laufwerke verschwinden in der Geräteliste
« Antwort #4 am: 18. Dezember 2020, 00:55:11 »
Udiskie scheint ein Bestandteil der Manjaro Grundinstallation zu sein. Bei mir ist Manjaro Minimal installiert und auch hier wurde es von Anbeginn an mit installiert. Die alleinige Installation von Udiskie kann folglich ohne Änderungen an dessen Konfiguration nicht die Ursache für dein unmount Problem sein. Mir fällt dazu gerade kein Lösungsansatz ein. Eventuell meldet sich zu dem Thema ja noch jemand.
« Letzte Änderung: 18. Dezember 2020, 01:00:10 von Manfrago »
Ungesicherte Daten sind unwichtige Daten

Offline SpiritOfTux

  • Held Mitglied
  • *****
  • Beiträge: 1560
  • Dankeschön: 237 mal
  • Karma: +0/-0
    • https://twitter.com/SpiritOfTux
  • Desktop: KDE Plasma
  • Grafikkarte: NVIDIA [GeForce RTX 2070] [GeForce GTX 1060] [GeForce GTX 560 Ti] [GeForce GT 635M]
  • Grafikkartentreiber: On: NB Nvidia, HTPC Nvidia, PowerWorkStation Nvidia
  • Kernel: LTS, 5.4.y; 4.19.y; 4.14.y,
  • Prozessor: Notebook: Tuxedo Computers XA1510 AMD Ryzen 9 3900X; WorkStation Intel Xeon
  • Skill: Fortgeschritten
  • Zweig: Stable Version: on PowerWorkStation, NB, HTPC, Desktop:s: Testing/Unstable only VM
Re: Thunar - eingehängte Laufwerke verschwinden in der Geräteliste
« Antwort #5 am: 18. Dezember 2020, 10:09:52 »
Was ich hier vermisse, wurde das Filesystem der USB-Disk geprüft?

Wie sieht das einbinden des Filesystem aus:

Bsp.

Das Filesystem des Rechner legt das Inhaltsverzeichnis mit Kapitel 1 bis 6 fest,
jetzt wird die USB-Disk angeschlossen diese bildet dann Kapitel 7 bis 9 fest.

Wird nun die USB-Disk einfach vom USB-Anschluß entfernt, ohne die Funktion
sicher entfernen zu benutzen , verhält sich dies wie das rausreißen der Seiten im
Kapitel 7 bis 9, der Cache des Rechners könnte also noch Daten enthalten die auf
die USB-Disk hätten geschrieben werden müssen.
Hier durch wird ein inkonsistentes Filesystem entstehen, stellt der Kernel nun dies
fest wird die USB-Disk terminiert, was zu deiner Beschreibung passen würde.

Überprüfe die USB-Disk (alle Partitionen) mit GParted https://gparted.org/display-doc.php%3Fname%3Dhelp-manual
Vielen Dank, dass du diesen Artikel bei uns gelesen hast!  Wir würden uns sehr freuen, wenn du diesen ebenfalls im folgenden Abschnitt bewerten würdest.(Sag Danke) 
Nach hilfreichen Antworten suchen: Manjaro Forum | Manjaro Wiki | Arch Wiki | Arch WiKi on NB/PC : sudo pacman -S arch-wiki-man https://github.com/greg-js/arch-wiki-man#readme

Offline Manfrago

  • Jr. Mitglied
  • **
  • Beiträge: 58
  • Dankeschön: 5 mal
  • Karma: +0/-0
  • Desktop: XFCE
  • Grafikkarte: Intel, Nvidia-Optimus
  • Grafikkartentreiber: nonfree
  • Kernel: 4.19
  • Prozessor: Diverse i5 & i7
  • Skill: Fortgeschritten
  • Zweig: stable
Re: Thunar - eingehängte Laufwerke verschwinden in der Geräteliste
« Antwort #6 am: 18. Dezember 2020, 13:25:50 »
Ich stelle zwischenzeitlich mal ein paar Fragen:
1. Wurde eine der externen HDD mal zum clonen einer noch im System bestehenden Partition verwendet?
2. Verwendest du einen Hub oder USB-C Adapter an USB?
Zeige doch bitte mal
sudo lsblk -o NAME,UUID,FSTYPE,SIZE,LABEL,MOUNTPOINT
im Codeblock
In dem Moment, wo es dir gelingt, ein externes Laufwerk zu mounten, zeige zusätzlich
grep "^device /dev/" /proc/self/mountstats
im Codeblock
Ungesicherte Daten sind unwichtige Daten

Offline perchlorat

  • Jr. Mitglied
  • **
  • Beiträge: 93
  • Karma: +0/-0
    • Lebenslust jetzt! – Praxis für Psychotherapie
  • Desktop: XFCE
  • Grafikkarte: nVidia GeForce GTX 1650
  • Grafikkartentreiber: nonfree
  • Kernel: 5.10.2
  • Prozessor: i5-7400
  • Skill: Anfänger
  • Zweig: stable
Re: Thunar - eingehängte Laufwerke verschwinden in der Geräteliste
« Antwort #7 am: 22. Dezember 2020, 15:41:11 »
Hab jetzt beide mobilen HDDs, eine Transcend und eine dicke mobile 3,5"-HDD eingestöpselt. Dabei verwende ich eine USB-3-PCIe-Karte, die fünf USB3.0-Anschlüsse bereit stellt. Direkt an USB-3-Anschlüsse, die das MoBo bereit stellt (ASRock 170P) stecke ich inzwischen nichts mehr ein, weil sich schon früher gezeigt hatte, dass solch angeschlossene HDDs ab und zu mitten im Betrieb ausgeworfen werden. Hab nur immer Glück gehabt, dass dabei keine Daten verloren gegangen sind, besonders an meiner Veracrypt-Platte.

HDDs, die ich über die 5-fach-Karte anstecke, haben nie solche Probleme gemacht.

Die o.g. HDDs habe ich mit Gparted untersucht und keine Probleme feststellen können. Sie sind auch alle nie dazu genutzt worden, als Systempartition bzw. Bootdevices zu dienen.

Jetzt gerade habe ich eine brandneue Transcend 2TB 2,5" eingesteckt. Sie erschien kurz unter "Geräte" in nicht eingehängtem Zustand und flog nach ca.10 Sekunden dort wieder raus.

Zu dieser Zeit hatte ich das Terminal offen und konnte folgendes feststellen nachdem sie aus "Geräte" rausgeflogen war:
$ sudo lsblk -o NAME,UUID,FSTYPE,SIZE,LABEL,MOUNTPOINT
NAME   UUID                                 FSTYPE   SIZE LABEL     MOUNTPOINT
sda                                                476,9G           
├─sda1 7B33-FB7D                            vfat     300M           /boot/efi
├─sda2 8add473e-8e1e-49ef-a3dc-f743bc94f479 ext4   467,8G           /
└─sda3 ee747fc6-f391-4536-be4d-657d7f408bbf swap     8,8G           [SWAP]
sdb                                                931,5G           
└─sdb1 68207901-49e7-4f68-856a-1ae4888126c8 ext4   931,5G Daten     /mnt/6820790
sdc                                                931,5G           
└─sdc1                                             931,5G           
  └─veracrypt1_0
                                                   931,5G           
    └─veracrypt1
       C294136694135BEB                     ntfs   931,5G LL-Crypt  /mnt/veracry
sdi                                                  1,8T           
└─sdi1 9C8AB7468AB71BA8                     ntfs     1,8T Transcend /run/media/c
sr0                                                 1024M           

Dies bestätigt, dass die HDD zwar nicht mehr in Thunar unter "Geräte" angezeigt wird, wohl aber offensichtlich als sdi1 gemounted ist. Sie kann so auch in Thunar unter /run/media/USR/... gefunden werden.

Mich stört also, dass die HDD nur umständlich über das Hinein-Navigieren in dieses Verzeichnis zugänglich ist statt über "Geräte". Und ferner, dass ich sie nicht über Thunar ordnungsgemäß auswerfen kann, bevor ich sie abstöpsele. Streng genommen darf ich sie erst dann trennen, wenn ich den PC runterfahre.

dmesg habe ich noch bemüht und dies ergibt für den fraglichen Vorgnag:
[ 3122.704829] usb 4-3.3: new SuperSpeed Gen 1 USB device number 4 using xhci_hcd
[ 3122.749992] usb 4-3.3: New USB device found, idVendor=8564, idProduct=7000, bcdDevice=80.00
[ 3122.749997] usb 4-3.3: New USB device strings: Mfr=2, Product=3, SerialNumber=1
[ 3122.750001] usb 4-3.3: Product: StoreJet Transcend
[ 3122.750004] usb 4-3.3: Manufacturer: StoreJet Transcend
[ 3122.750007] usb 4-3.3: SerialNumber:             WDZS02EX
[ 3122.751896] usb-storage 4-3.3:1.0: USB Mass Storage device detected
[ 3122.752138] scsi host9: usb-storage 4-3.3:1.0
[ 3123.789608] scsi 9:0:0:0: Direct-Access     StoreJet Transcend        0    PQ: 0 ANSI: 6
[ 3123.791832] sd 9:0:0:0: [sdi] 3907029168 512-byte logical blocks: (2.00 TB/1.82 TiB)
[ 3123.792106] sd 9:0:0:0: [sdi] Write Protect is off
[ 3123.792112] sd 9:0:0:0: [sdi] Mode Sense: 43 00 00 00
[ 3123.792381] sd 9:0:0:0: [sdi] Write cache: enabled, read cache: enabled, doesn't support DPO or FUA
[ 3123.845201]  sdi: sdi1
[ 3123.846535] sd 9:0:0:0: [sdi] Attached SCSI disk


GREP liefert:
$ grep "^device /dev/" /proc/self/mountstats
device /dev/sda2 mounted on / with fstype ext4
device /dev/sdb1 mounted on /mnt/68207901-49e7-4f68-856a-1ae4888126c8 with fstype ext4
device /dev/sda1 mounted on /boot/efi with fstype vfat
device /dev/mapper/veracrypt1 mounted on /mnt/veracrypt1 with fstype fuseblk
device /dev/sdi1 mounted on /run/media/clemens/Transcend with fstype fuseblk

Es ist übrigens Zufall, dass die Transcend und die zusätzlich hier aufgeführte Veracrypt-HDD beide in NTFS formatiert sind. Der Bug tritt auch bei xFAT32 und bei ext4 formatierten mobilen HDDs auf.

Der Bug tritt erstaunlicher Weise nicht auf, wenn ich SD-Speicherkarten in einen Cardreader-Slot oder USB-Sticks einstöpsele. Die bleiben immer unter "Geräte" sichtbar.

Offline Manfrago

  • Jr. Mitglied
  • **
  • Beiträge: 58
  • Dankeschön: 5 mal
  • Karma: +0/-0
  • Desktop: XFCE
  • Grafikkarte: Intel, Nvidia-Optimus
  • Grafikkartentreiber: nonfree
  • Kernel: 4.19
  • Prozessor: Diverse i5 & i7
  • Skill: Fortgeschritten
  • Zweig: stable
Re: Thunar - eingehängte Laufwerke verschwinden in der Geräteliste
« Antwort #8 am: 22. Dezember 2020, 17:51:37 »
Laut deinen Terminalausgaben scheint mir das alles in Ordnung zu sein.
Was ich jetzt machen würde: Mit einem Live-Medium den PC starten und schauen, ob die Sache anders oder gleich abläuft.
Du schriebst, an den PC Standard USB Anschlüssen werden deine Festplatten ab und an im laufenden Betrieb ausgeworfen und du musst auf eine USB-3-PCIe-Karte zurückgreifen. Mein Verdacht geht daher eher in Richtung Hardware als in Richtung Thunar.
Ungesicherte Daten sind unwichtige Daten

Offline perchlorat

  • Jr. Mitglied
  • **
  • Beiträge: 93
  • Karma: +0/-0
    • Lebenslust jetzt! – Praxis für Psychotherapie
  • Desktop: XFCE
  • Grafikkarte: nVidia GeForce GTX 1650
  • Grafikkartentreiber: nonfree
  • Kernel: 5.10.2
  • Prozessor: i5-7400
  • Skill: Anfänger
  • Zweig: stable
Re: Thunar - eingehängte Laufwerke verschwinden in der Geräteliste
« Antwort #9 am: 22. Dezember 2020, 18:20:09 »
Wenn es an der Harwdare läge, wäre der Fehler betr. der USB-Anschlüsse die vom MoBo kommen, schon viel früher aufgefallen. Auf dieser Kiste hatte ich bereits 2018 mit Ubuntu angefangen und bin dann seit 2019 auf Manjaro umgestiegen. Das Auswerfen der Veracrypt-HDD mitten im Betrieb begann nach irgend einem Kernel-Update. Das Thema hatte ich hier versucht, im Forum zu diskutieren.
Dann hatte jemand geschrieben, es handele sich um einen mit dem Kernel in Verbindung stehenden Bug im USB-Bereich. Vermutlich würde es um einen Timing-Fehler gehen, der aber schwer auffindbar sei, weil er nur sporadisch auftreten würde.
Bald daruf erkannte ich, dass der Fehler aufhörte, wenn ich die Platte über einen Hub mit dem PC verband.

Und weil mir der Hub lästig schien, habe ich vor rund 8 Monaten eine PCIe-Karte mit den 5 USB-3-Anschlüssen gekauft. Und damit laufen alle Platten einwandfrei ohne dass sie ausgeworfen werden.

Dann tauchte der hier besprochen Fehler nach einem der letzten Updates neu und zum ersten Mal auf. Immerhin wird die Platte nicht einfach ausgeworfen, sondern nur ihr Eintrag unter "Geräte" verschwindet und zieht dann einen ärgerlichen Handling-Aufwand nach sich.
umount im Terminal ist auch keine Lösung, denn seitdem ich die Gnome-Diskverwaltung installiert habe, wird nicht mehr der Name, den ich dem Laufwerk gegeben habe angezeigt, sondern die UUID. Ich verspüre äußerste Unlust, im Terminal die UUID der HDD anzugeben, bloß um sie unmounten zu können!!!

Offline Manfrago

  • Jr. Mitglied
  • **
  • Beiträge: 58
  • Dankeschön: 5 mal
  • Karma: +0/-0
  • Desktop: XFCE
  • Grafikkarte: Intel, Nvidia-Optimus
  • Grafikkartentreiber: nonfree
  • Kernel: 4.19
  • Prozessor: Diverse i5 & i7
  • Skill: Fortgeschritten
  • Zweig: stable
Re: Thunar - eingehängte Laufwerke verschwinden in der Geräteliste
« Antwort #10 am: 22. Dezember 2020, 18:42:39 »
....denn seitdem ich die Gnome-Diskverwaltung installiert habe, wird nicht mehr der Name, den ich dem Laufwerk gegeben habe angezeigt, sondern die UUID...
Das lässt sich in der Gnome-Diskverwaltung unter "Einhängeoptionen" ->"Identifizieren als" ändern, sollte dann aber mit Bedacht gemacht werden.
Ich würde dennoch dazu raten, per Live-Medium zu starten. Nur so können wir im Ausschlussverfahren bereits einige, mögliche Fehlerquellen abhaken.
Ungesicherte Daten sind unwichtige Daten

Offline SpiritOfTux

  • Held Mitglied
  • *****
  • Beiträge: 1560
  • Dankeschön: 237 mal
  • Karma: +0/-0
    • https://twitter.com/SpiritOfTux
  • Desktop: KDE Plasma
  • Grafikkarte: NVIDIA [GeForce RTX 2070] [GeForce GTX 1060] [GeForce GTX 560 Ti] [GeForce GT 635M]
  • Grafikkartentreiber: On: NB Nvidia, HTPC Nvidia, PowerWorkStation Nvidia
  • Kernel: LTS, 5.4.y; 4.19.y; 4.14.y,
  • Prozessor: Notebook: Tuxedo Computers XA1510 AMD Ryzen 9 3900X; WorkStation Intel Xeon
  • Skill: Fortgeschritten
  • Zweig: Stable Version: on PowerWorkStation, NB, HTPC, Desktop:s: Testing/Unstable only VM
Re: Thunar - eingehängte Laufwerke verschwinden in der Geräteliste
« Antwort #11 am: 22. Dezember 2020, 19:32:51 »
Kleine Empfehlung:

Installiere den 5.4 LTS Kernel der Kernel 5.9 hat den Status EOL
starte den 5.4 Kernel und deinstalliere den 5.9 Kernel (kein Service mehr)

Es wird in den nächsten Tagen sicherlich noch ein großes Update geben,
hier nach würde ich dann den 5.10.2 LTS Kernel installieren, nicht vorher.
Vielen Dank, dass du diesen Artikel bei uns gelesen hast!  Wir würden uns sehr freuen, wenn du diesen ebenfalls im folgenden Abschnitt bewerten würdest.(Sag Danke) 
Nach hilfreichen Antworten suchen: Manjaro Forum | Manjaro Wiki | Arch Wiki | Arch WiKi on NB/PC : sudo pacman -S arch-wiki-man https://github.com/greg-js/arch-wiki-man#readme

Offline Manfrago

  • Jr. Mitglied
  • **
  • Beiträge: 58
  • Dankeschön: 5 mal
  • Karma: +0/-0
  • Desktop: XFCE
  • Grafikkarte: Intel, Nvidia-Optimus
  • Grafikkartentreiber: nonfree
  • Kernel: 4.19
  • Prozessor: Diverse i5 & i7
  • Skill: Fortgeschritten
  • Zweig: stable
Re: Thunar - eingehängte Laufwerke verschwinden in der Geräteliste
« Antwort #12 am: 22. Dezember 2020, 19:54:40 »
....Installiere den 5.4 LTS Kernel der Kernel 5.9 hat den Status EOL
starte den 5.4 Kernel und deinstalliere den 5.9 Kernel (kein Service mehr)...
Das ist generell ein guter Ratschlag, wird aber höchstwahrscheinlich nicht das Problem des TE lösen.
Ein Kernel, unter dem man verschiedentliche externe Festplatten nicht mounten kann und die Laufwerke dann auch noch vom Desktop fliegen lässt, hätte sicherlich für einige Aufregung gesorgt.
Ungesicherte Daten sind unwichtige Daten

Offline perchlorat

  • Jr. Mitglied
  • **
  • Beiträge: 93
  • Karma: +0/-0
    • Lebenslust jetzt! – Praxis für Psychotherapie
  • Desktop: XFCE
  • Grafikkarte: nVidia GeForce GTX 1650
  • Grafikkartentreiber: nonfree
  • Kernel: 5.10.2
  • Prozessor: i5-7400
  • Skill: Anfänger
  • Zweig: stable
Re: Thunar - eingehängte Laufwerke verschwinden in der Geräteliste
« Antwort #13 am: 22. Dezember 2020, 22:24:05 »
Also für das bisschen Zeit, bis der 5.10 Kernel als LTS erscheint, wird mir der 5.9.11 noch gut genug sein. Und dann werde ich erst mal auf 5.10 bleiben.

Es war auch nicht meine Idee, dass das Problem im Kernel liegen könnte, sondern wurde im developer-Forum verschiedentlich vermutet.

Wenn ich ein Manjaro-Live starte, habe ich den Fehler nicht und Thunar macht, was es soll.

Offline Manfrago

  • Jr. Mitglied
  • **
  • Beiträge: 58
  • Dankeschön: 5 mal
  • Karma: +0/-0
  • Desktop: XFCE
  • Grafikkarte: Intel, Nvidia-Optimus
  • Grafikkartentreiber: nonfree
  • Kernel: 4.19
  • Prozessor: Diverse i5 & i7
  • Skill: Fortgeschritten
  • Zweig: stable
Re: Thunar - eingehängte Laufwerke verschwinden in der Geräteliste
« Antwort #14 am: 22. Dezember 2020, 23:07:50 »
Wenn ich ein Manjaro-Live starte, habe ich den Fehler nicht und Thunar macht, was es soll.
Das habe ich mal hervorgehoben, weil damit diverse Denkansätze ad acta gelegt werden können.
1. Den Verdacht, es könne an dem Datenträger liegen, können wir nun endgültig begraben.
2. An Thunar an sich liegt es offenbar auch nicht.
3. Hardwaredefekte scheiden jetzt eigentlich auch aus.
4. Ob es doch am Kernel liegt? Das würde ich ganz hinten an stellen.
5. Mit dem Live-Medium werden nicht zwingend alle Treiber geladen, die bei einer Installation noch nachgereicht werden könnten. Das sollte man sich eventuell genauer anschauen.
Der TE ist im Besitz einer nagelneuen Transcend. Ich würde darauf parallel ein neues Manjaro installieren, die Sache neu angehen und ggfls auf die interne FP clonen.. In der Zeit, die wir hier bereits mit Forschungsarbeit beschäftigt sind, hätte ich bereits mindestens 5 neue Systeme identisch aufgesetzt. Hart - aber fair.
Ungesicherte Daten sind unwichtige Daten