Autor Thema: Grafiktreiber NVIDIA GK106GLM [Quadro K2100M]  (Gelesen 493 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Offline GKMRico

  • Neuling
  • *
  • Beiträge: 17
  • Karma: +0/-0
  • Desktop: XFCE
  • Grafikkarte: NVIDIA GK106GLM [Quadro K2100M]
  • Grafikkartentreiber: nonfree ???
  • Kernel: aktuell + LTS
  • Prozessor: Intel(R) Core(TM) i7-4900MQ CPU @ 2.80GHz
  • Skill: Anfänger
  • Zweig: stable
Re: Grafiktreiber NVIDIA GK106GLM [Quadro K2100M]
« Antwort #15 am: 17. Januar 2021, 10:23:02 »
Ich werde es nochmal versuchen nach https://wiki.manjaro.org/index.php/Configure_NVIDIA_(non-free)_settings_and_load_them_on_Startup den Bumblebee Treiber zu installieren wenn ich Nerven dafür habe. Ich habe allerdings die Befürchtung das es wiedermal schiefgeht.

Offline GKMRico

  • Neuling
  • *
  • Beiträge: 17
  • Karma: +0/-0
  • Desktop: XFCE
  • Grafikkarte: NVIDIA GK106GLM [Quadro K2100M]
  • Grafikkartentreiber: nonfree ???
  • Kernel: aktuell + LTS
  • Prozessor: Intel(R) Core(TM) i7-4900MQ CPU @ 2.80GHz
  • Skill: Anfänger
  • Zweig: stable
Re: Grafiktreiber NVIDIA GK106GLM [Quadro K2100M]
« Antwort #16 am: 17. Januar 2021, 22:57:02 »
Ich habe nun mit linux54 und video-nvidia-390xx nochmal versucht Bumblebee nach https://wiki.archlinux.org/index.php/Bumblebee zum laufen zu bekommen.
Aber leider gibt es noch Schwierigkeiten den Dienst zu starten:
$ optirun glxgears -info
[   71.747797] [ERROR]The Bumblebee daemon has not been started yet or the socket path /var/run/bumblebee.socket was incorrect.
[   71.747882] [ERROR]Could not connect to bumblebee daemon - is it running?

$ sudo systemctl status bumlebeed.service
Unit bumlebeed.service could not be found.

Ich bin mir nicht sicher ob die lib32 Sachen nötig sind? :
$ pacman -Ss bumblebee
community/bumblebee 3.2.1-22 [Installiert]
    NVIDIA Optimus support for Linux through Primus/VirtualGL
community/primus 20151110-9 [Installiert]
    Faster OpenGL offloading for Bumblebee
community/primus_vk 1.5-1
    Nvidia Vulkan offloading for Bumblebee
multilib/lib32-primus 20151110-4
    Faster OpenGL offloading for Bumblebee (32-bit)
multilib/lib32-primus_vk 1.5-1
    Nvidia Vulkan offloading for Bumblebee

Offline GKMRico

  • Neuling
  • *
  • Beiträge: 17
  • Karma: +0/-0
  • Desktop: XFCE
  • Grafikkarte: NVIDIA GK106GLM [Quadro K2100M]
  • Grafikkartentreiber: nonfree ???
  • Kernel: aktuell + LTS
  • Prozessor: Intel(R) Core(TM) i7-4900MQ CPU @ 2.80GHz
  • Skill: Anfänger
  • Zweig: stable
Re: Grafiktreiber NVIDIA GK106GLM [Quadro K2100M]
« Antwort #17 am: 18. Januar 2021, 09:41:02 »
 Wenigstens bootet mein Rechner noch    :)   
/etc/X11/xorg.conf.d/      enthält 2 Dateien    90-mhwd.conf     und    00-keyboard.conf
Fehlt da nicht was?

Wieso kann es nicht so einfach sein wie früher mal :  https://i.redd.it/dbfgci2vt9y31.png
Wobei damals auch nur einer der bumblebee Treiber funktionierte.
Ich komme nicht wirklich weiter und bin dankbar für jeden Hinweis.

Offline GKMRico

  • Neuling
  • *
  • Beiträge: 17
  • Karma: +0/-0
  • Desktop: XFCE
  • Grafikkarte: NVIDIA GK106GLM [Quadro K2100M]
  • Grafikkartentreiber: nonfree ???
  • Kernel: aktuell + LTS
  • Prozessor: Intel(R) Core(TM) i7-4900MQ CPU @ 2.80GHz
  • Skill: Anfänger
  • Zweig: stable
Re: Grafiktreiber NVIDIA GK106GLM [Quadro K2100M]
« Antwort #18 am: 18. Januar 2021, 17:44:24 »
Ok, ich habe im Bios unter "Hybridgrafik" 3 Optionen  "aus", "an", "auto"  ich hatte bis jetzt immer "auto" eingestellt.
Nun habe ich auf "an" gestellt und bootete wo natürlich keine Grafik kam. Ich loggte mich in die Konsole und :

$ sudo mhwd -l
> 0000:01:00.0 (0300:10de:11fc) Display controller nVidia Corporation:
--------------------------------------------------------------------------------
                  NAME               VERSION          FREEDRIVER           TYPE
--------------------------------------------------------------------------------
video-hybrid-intel-nvidia-390xx-bumblebee            2020.11.30               false            PCI
    video-nvidia-390xx            2020.11.30               false            PCI
           video-linux            2018.05.04                true            PCI
     video-modesetting            2020.01.13                true            PCI
            video-vesa            2017.03.12                true            PCI


> 0000:00:02.0 (0300:8086:0416) Display controller Intel Corporation:
--------------------------------------------------------------------------------
                  NAME               VERSION          FREEDRIVER           TYPE
--------------------------------------------------------------------------------
video-hybrid-intel-nvidia-390xx-bumblebee            2020.11.30               false            PCI
           video-linux            2018.05.04                true            PCI
     video-modesetting            2020.01.13                true            PCI
            video-vesa            2017.03.12                true            PCI

Jo das suchte ich die ganze Zeit. Also :

sudo mhwd -f -i pci video-hybrid-intel-nvidia-390xx-bumblebee
Neustart und siehe da Manjaro zeigt alles wie gewohnt sauber an und läuft sehr ruhig.
Schlecht nur das mein Windows7 nun keine Grafik mehr booten kann, also Bios nochmal auf "auto" und den Intel Grafik Treiber unter Windows mit Legacy installiert... läuft.

Nun ist doch noch ein wenig unklar, NVIDIA X Server Setting schreibt beim Start:
 "You do not appear to be using the NVIDIA X driver. Pease edit your X configuration file (just run 'nvidia-xconfig' as root), and restart the X server."
Was ist zu tun? Ich will es ja nicht wieder kaputt machen.

Desweiteren funktioniert "Bereitschaft" nicht und über die fn Helligkeitssteuerung schaltet sich das Display nur ab und an. 

Der "bumlebeed.service" läuft noch immer nicht, wobei ich mir nicht sicher bin ob das so muss.

optirun glxgears -info funktioniert.
Soweit so gut. Tipps sind mir weiterhin willkommen.

Offline GKMRico

  • Neuling
  • *
  • Beiträge: 17
  • Karma: +0/-0
  • Desktop: XFCE
  • Grafikkarte: NVIDIA GK106GLM [Quadro K2100M]
  • Grafikkartentreiber: nonfree ???
  • Kernel: aktuell + LTS
  • Prozessor: Intel(R) Core(TM) i7-4900MQ CPU @ 2.80GHz
  • Skill: Anfänger
  • Zweig: stable
Re: Grafiktreiber NVIDIA GK106GLM [Quadro K2100M]
« Antwort #19 am: 20. Januar 2021, 10:01:26 »
Nun endlich, mit LTS Kernel linux54 funktioniert alles wieder wie gewohnt.