Autor Thema: Nach heutigem Update funktioniert Dual-Boot nicht mehr.  (Gelesen 305 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Offline Medds

  • Neuling
  • *
  • Beiträge: 14
  • Dankeschön: 1 mal
  • Karma: +0/-0
  • Desktop: KDE Plasma
  • Grafikkarte: Nvidia GTX 2080 TI
  • Prozessor: AMD 3800x
  • Skill: Anfänger
Nach heutigem Update funktioniert Dual-Boot nicht mehr.
« am: 09. März 2021, 17:01:28 »
Hallo.
Hab gerade eben die vielen Aktualisierungen von Manjaro über sudo pacman -Syyu gemacht.
Seitdem wird mir in grub mein Windows nicht mehr angezeigt.
Hat jemand eine Idee was hierbei das Problem sein könnte? Weil bis gerade eben hat es noch funktioniert.
Zur Info
Ich benutze Uefi
Windows ist auf einer NVME
Linux auf einer extrigen SSD auf der auch Grub ist.
Wenn ich im BIOS von der SSD starte kommt Grub und hat mir leider nur bis gerade eben auch Windows angezeigt.
Bitte gebt bescheid wenn weitere Informationen erforderlich sind, da ich Linux und Manjaro Neuling bin.

Vielen Dank im Voraus

Ergänzung:

Anzeige wenn ich den os-prober starte:

[dns@dns-rechner ~]$ sudo os-prober
[sudo] Passwort für dns:
/dev/nvme0n1p1@/efi/Microsoft/Boot/bootmgfw.efi:Windows Boot Manager:Windows:efi

Inhalt von Grub:

  GNU nano 5.6                                                                                                                     /etc/default/grub                                                                                                                               
GRUB_DEFAULT=2
GRUB_TIMEOUT=10
GRUB_TIMEOUT_STYLE=menu
GRUB_DISTRIBUTOR="Manjaro"
GRUB_CMDLINE_LINUX_DEFAULT="quiet apparmor=1 security=apparmor udev.log_priority=3"
GRUB_CMDLINE_LINUX=""

# If you want to enable the save default function, uncomment the following
# line, and set GRUB_DEFAULT to saved.
GRUB_SAVEDEFAULT=true

# Preload both GPT and MBR modules so that they are not missed
GRUB_PRELOAD_MODULES="part_gpt part_msdos"

# Uncomment to enable booting from LUKS encrypted devices
#GRUB_ENABLE_CRYPTODISK=y

# Uncomment to use basic console
GRUB_TERMINAL_INPUT=console

# Uncomment to disable graphical terminal
#GRUB_TERMINAL_OUTPUT=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command 'videoinfo'
GRUB_GFXMODE=1440x900x32

# Uncomment to allow the kernel use the same resolution used by grub
GRUB_GFXPAYLOAD_LINUX=keep

# Uncomment if you want GRUB to pass to the Linux kernel the old parameter
# format "root=/dev/xxx" instead of "root=/dev/disk/by-uuid/xxx"
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
GRUB_DISABLE_RECOVERY=true

# Uncomment and set to the desired menu colors.  Used by normal and wallpaper
# modes only.  Entries specified as foreground/background.
GRUB_COLOR_NORMAL="light-gray/black"
GRUB_COLOR_HIGHLIGHT="green/black"

# Uncomment one of them for the gfx desired, a image background or a gfxtheme
#GRUB_BACKGROUND="/usr/share/grub/background.png"
GRUB_THEME="/usr/share/grub/themes/manjaro/theme.txt"

# Uncomment to get a beep at GRUB start
#GRUB_INIT_TUNE="480 440 1"

# Uncomment to ensure that the root filesystem is mounted read-only so that
# systemd-fsck can run the check automatically
GRUB_ROOT_FS_RO=true

« Letzte Änderung: 09. März 2021, 17:03:38 von Medds »

Offline Medds

  • Neuling
  • *
  • Beiträge: 14
  • Dankeschön: 1 mal
  • Karma: +0/-0
  • Desktop: KDE Plasma
  • Grafikkarte: Nvidia GTX 2080 TI
  • Prozessor: AMD 3800x
  • Skill: Anfänger
Re: Nach heutigem Update funktioniert Dual-Boot nicht mehr.
« Antwort #1 am: 09. März 2021, 18:41:24 »
Nochmalige Ergänzung:

bei
sudo update-grubkommt folgendes:
[dns@dns-rechner ~]$ sudo os-prober
/dev/nvme0n1p1@/efi/Microsoft/Boot/bootmgfw.efi:Windows Boot Manager:Windows:efi
[dns@dns-rechner ~]$ sudo update-grub
Generating grub configuration file ...
Found theme: /usr/share/grub/themes/manjaro/theme.txt
Found linux image: /boot/vmlinuz-5.9-x86_64
Found initrd image: /boot/amd-ucode.img /boot/initramfs-5.9-x86_64.img
Found initrd fallback image: /boot/initramfs-5.9-x86_64-fallback.img
Adding boot menu entry for UEFI Firmware Settings ...
Found memtest86+ image: /boot/memtest86+/memtest.bin
done
Glaube da fehlt irgendwie sowas wie    found windows    oder so. Obwohl der os-prober, wenn ich es richtig deute, das Windows erkennt.


Offline gosia

  • Held Mitglied
  • *****
  • Beiträge: 2065
  • Dankeschön: 414 mal
  • Karma: +0/-0
  • Desktop: Openbox + xfce
  • Grafikkarte: Intel HD 4000
  • Grafikkartentreiber: i915 (free)
  • Kernel: 4.19 Artix
  • Prozessor: Intel Core i5-3210M
  • Skill: Durchschnitt
  • Zweig: stable
Re: Nach heutigem Update funktioniert Dual-Boot nicht mehr.
« Antwort #2 am: 09. März 2021, 20:49:42 »
Hallo Medds,
Obwohl der os-prober, wenn ich es richtig deute, das Windows erkennt.
Ja, aber der os-prober ist abgeschaltet.
"Note that os-prober is now disabled"
https://forum.manjaro.org/t/stable-update-2021-03-08-kernels-plasma-5-21-2-haskell-kodi-grub-kde-dev/56877
Zur Lösung s. diesen Thread
https://manjaro-forum.de/viewtopic.php?f=3&t=3226

viele Grüße gosia
"funktioniert nicht" ist keine brauchbare Fehlermeldung
Folgende Mitglieder bedankten sich: Rallebiker, Paulich, Medds

Offline Medds

  • Neuling
  • *
  • Beiträge: 14
  • Dankeschön: 1 mal
  • Karma: +0/-0
  • Desktop: KDE Plasma
  • Grafikkarte: Nvidia GTX 2080 TI
  • Prozessor: AMD 3800x
  • Skill: Anfänger
Re: Nach heutigem Update funktioniert Dual-Boot nicht mehr.
« Antwort #3 am: 10. März 2021, 16:08:20 »
Vielen Dank. Hab so das Problem lösen können
Folgende Mitglieder bedankten sich: Paulich

Offline Rallebiker

  • Sr. Mitglied
  • ****
  • Beiträge: 297
  • Dankeschön: 1 mal
  • Karma: +0/-0
  • Desktop: Xfce 4.16.0
  • Grafikkarte: NVIDIA G96 [GeForce 9500 GT] / Intel Mobile 4 Series Integrated Graphics
  • Grafikkartentreiber: nouveau / i915
  • Kernel: 5.11.2-1-MANJARO x86_64
  • Prozessor: Intel Core2 6400 (-MCP-) / Intel Core2 Duo P8400
  • Skill: Anfänger
  • Zweig: Manjaro Linux 20.2
Re: Nach heutigem Update funktioniert Dual-Boot nicht mehr.
« Antwort #4 am: 10. März 2021, 17:58:13 »
Hallo!
Bei mir nach dem Update der gleiche Effekt,
aber mit dem Tipp hier konnte man es beheben.
Hatte in der /etc/default nicht nur grub,
sondern auch grub.pacnew stehen.
Dort stand dieser zusätzliche Eintrag auskommentiert drin.
wie schon geschrieben, das sudo update-grub sollte man in keinem Fall vergessen  ;)
Gruss Rallebiker
___________________
Ich bin wie ich bin.
Die einen kennen mich - die anderen können mich. (Adenauer)