Autor Thema: Nach installation Bildschrim schwarz  (Gelesen 287 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Offline Speedreini93

  • Neuling
  • *
  • Beiträge: 7
  • Karma: +0/-0
  • Skill: Anfänger
Nach installation Bildschrim schwarz
« am: 15. März 2021, 20:38:35 »
Hallo,
ich hab mir Manjaro auf der zweiten Platte neben Windows installiert.
Die Installation lief sauber durch. Nur nach dem neustart erhalte ich leider ein schwarzes bild mit der Meldung: "Failed to start Light Display Manager".
Nach etwas suche bin ich auf einem Post gestoßen und habe mit ALT + F3 den Befehl "sudo chown root:lightdm /var/lib/lightdm-data" und "sudo systemctl restart lightdm" eingegeben.
Dies hat auch funktioniert und ich dachte ich mache mal ein Update vom Kernel 5.9 auf 5.11 mit der Hoffnung es geht weg.
Leider nicht. Jedes mal nach dem booten muss ich immer erst "sudo systemctl restart lightdm" eingeben, damit ich ins Desktop komme.
Wenn ich zusätzliche Infos braucht sagt Bescheid. Bin da noch etwas unerfahren.

Code: XML
  1. System:
  2.   Kernel: 5.11.2-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.1
  3.   Desktop: Xfce 4.16.0 Distro: Manjaro Linux
  4. Machine:
  5.   Type: Desktop System: ASUS product: N/A v: N/A serial: <filter>
  6.   Mobo: ASUSTeK model: ROG CROSSHAIR VIII FORMULA v: Rev X.0x
  7.   serial: <filter> UEFI: American Megatrends v: 3302 date: 03/05/2021
  8. CPU:
  9.   Info: 16-Core model: AMD Ryzen 9 5950X bits: 64 type: MT MCP arch: Zen 3
  10.   rev: 0 L2 cache: 8 MiB
  11.   flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  12.   bogomips: 217727
  13.   Speed: 3598 MHz min/max: 2200/7228 MHz boost: enabled Core speeds (MHz):
  14.   1: 3598 2: 2879 3: 2197 4: 2196 5: 2196 6: 2197 7: 2249 8: 2198 9: 3598
  15.   10: 2879 11: 2876 12: 2876 13: 2879 14: 2879 15: 2875 16: 2879 17: 2874
  16.   18: 2198 19: 2197 20: 2197 21: 2197 22: 2196 23: 2196 24: 2879 25: 2195
  17.   26: 2199 27: 2876 28: 2879 29: 2877 30: 2877 31: 2199 32: 2198
  18. Graphics:
  19.   Device-1: AMD Navi 21 [Radeon RX 6800/6800 XT / 6900 XT] driver: amdgpu
  20.   v: kernel bus ID: 0f:00.0
  21.   Display: x11 server: X.Org 1.20.10 driver: loaded: amdgpu,ati
  22.   unloaded: modesetting,radeon resolution: 3840x2160~60Hz
  23.   OpenGL:
  24.   renderer: AMD SIENNA_CICHLID (DRM 3.40.0 5.11.2-1-MANJARO LLVM 11.1.0)
  25.   v: 4.6 Mesa 20.3.4 direct render: Yes
  26. Audio:
  27.   Device-1: Creative Labs driver: snd_hda_intel v: kernel bus ID: 07:00.0
  28.   Device-2: AMD driver: snd_hda_intel v: kernel bus ID: 0f:00.1
  29.   Device-3: AMD Starship/Matisse HD Audio vendor: ASUSTeK
  30.   driver: snd_hda_intel v: kernel bus ID: 11:00.4
  31.   Sound Server: ALSA v: k5.11.2-1-MANJARO
  32. Network:
  33.   Device-1: Aquantia AQC111 NBase-T/IEEE 802.3bz Ethernet [AQtion]
  34.   vendor: ASUSTeK driver: atlantic v: kernel port: N/A bus ID: 05:00.0
  35.   IF: enp5s0 state: down mac: <filter>
  36.   Device-2: Intel I211 Gigabit Network vendor: ASUSTeK driver: igb v: kernel
  37.   port: f000 bus ID: 08:00.0
  38.   IF: enp8s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
  39.   Device-3: Intel Wi-Fi 6 AX200 driver: iwlwifi v: kernel port: f000
  40.   bus ID: 09:00.0
  41.   IF: wlp9s0 state: down mac: <filter>
  42. Drives:
  43.   Local Storage: total: 5.46 TiB used: 8.8 GiB (0.2%)
  44.   ID-1: /dev/nvme0n1 vendor: Samsung model: SSD 970 EVO 1TB size: 931.51 GiB
  45.   temp: 41.9 C
  46.   ID-2: /dev/nvme1n1 vendor: Corsair model: Force MP600 size: 931.51 GiB
  47.   temp: 42.9 C
  48.   ID-3: /dev/sda vendor: Western Digital model: WD40EFRX-68N32N0
  49.   size: 3.64 TiB
  50. Partition:
  51.   ID-1: / size: 881.65 GiB used: 8.8 GiB (1.0%) fs: ext4 dev: /dev/nvme0n1p2
  52.   ID-2: /boot/efi size: 299.4 MiB used: 312 KiB (0.1%) fs: vfat
  53.   dev: /dev/nvme0n1p1
  54. Swap:
  55.   ID-1: swap-1 type: partition size: 34.46 GiB used: 0 KiB (0.0%)
  56.   dev: /dev/nvme0n1p3
  57. USB:
  58.   Hub-1: 1-0:1 info: Full speed (or root) Hub ports: 6 rev: 2.0
  59.   Device-1: 1-1:2 info: MCT Elektronikladen VISION type: HID,Keyboard
  60.   driver: hid-generic,usbhid rev: 2.0
  61.   Device-2: 1-2:3 info: Logitech G910 Orion Spectrum Mechanical Keyboard
  62.   type: Keyboard,HID driver: hid-generic,usbhid rev: 2.0
  63.   Hub-2: 1-5:4 info: Genesys Logic Hub ports: 4 rev: 2.0
  64.   Device-1: 1-5.1:5 info: MCT Elektronikladen aquaero type: Keyboard,HID
  65.   driver: hid-generic,usbhid rev: 2.0
  66.   Device-2: 1-5.2:6 info: MCT Elektronikladen D5 NEXT type: HID
  67.   driver: hid-generic,usbhid rev: 2.1
  68.   Device-3: 1-5.3:7 info: ASUSTek AURA LED Controller type: HID
  69.   driver: hid-generic,usbhid rev: 2.0
  70.   Device-4: 1-5.4:8 info: ASUSTek AURA LED Controller type: HID
  71.   driver: hid-generic,usbhid rev: 2.0
  72.   Hub-3: 2-0:1 info: Full speed (or root) Hub ports: 4 rev: 3.1
  73.   Hub-4: 3-0:1 info: Full speed (or root) Hub ports: 6 rev: 2.0
  74.   Hub-5: 3-2:2 info: ASMedia ASM1074 High-Speed hub ports: 4 rev: 2.1
  75.   Hub-6: 3-3:3 info: ASMedia ASM1074 High-Speed hub ports: 4 rev: 2.1
  76.   Device-1: 3-5:5 info: MCT Elektronikladen MPS type: HID
  77.   driver: hid-generic,usbhid rev: 1.1
  78.   Hub-7: 3-6:6 info: Terminus FE 2.1 7-port Hub ports: 7 rev: 2.0
  79.   Device-1: 3-6.1:7 info: Corsair Lighting Node Pro type: HID
  80.   driver: hid-generic,usbhid rev: 2.0
  81.   Device-2: 3-6.4:8 info: Corsair Lighting Node Pro type: HID
  82.   driver: hid-generic,usbhid rev: 2.0
  83.   Hub-8: 4-0:1 info: Full speed (or root) Hub ports: 4 rev: 3.1
  84.   Hub-9: 4-2:2 info: ASMedia ASM1074 SuperSpeed hub ports: 4 rev: 3.0
  85.   Hub-10: 4-3:3 info: ASMedia ASM1074 SuperSpeed hub ports: 4 rev: 3.0
  86.   Hub-11: 5-0:1 info: Full speed (or root) Hub ports: 2 rev: 2.0
  87.   Hub-12: 6-0:1 info: Full speed (or root) Hub ports: 1 rev: 3.1
  88.   Hub-13: 7-0:1 info: Full speed (or root) Hub ports: 4 rev: 2.0
  89.   Device-1: 7-4:2 info: Logitech G502 Proteus Spectrum Optical Mouse
  90.   type: Mouse,HID driver: hid-generic,usbhid rev: 2.0
  91.   Hub-14: 8-0:1 info: Full speed (or root) Hub ports: 4 rev: 3.1
  92. Sensors:
  93.   System Temperatures: cpu: 46.6 C mobo: N/A gpu: amdgpu temp: 36.0 C
  94.   Fan Speeds (RPM): N/A gpu: amdgpu fan: 0
  95. Info:
  96.   Processes: 509 Uptime: N/A Memory: 31.33 GiB used: 2 GiB (6.4%)
  97.   Init: systemd Compilers: gcc: N/A Packages: 1162 Shell: Bash v: 5.1.0
  98.   inxi: 3.3.01
  99.  

Offline gosia

  • Held Mitglied
  • *****
  • Beiträge: 2065
  • Dankeschön: 414 mal
  • Karma: +0/-0
  • Desktop: Openbox + xfce
  • Grafikkarte: Intel HD 4000
  • Grafikkartentreiber: i915 (free)
  • Kernel: 4.19 Artix
  • Prozessor: Intel Core i5-3210M
  • Skill: Durchschnitt
  • Zweig: stable
Re: Nach installation Bildschrim schwarz
« Antwort #1 am: 15. März 2021, 21:31:04 »
Hallo Speedreini93,
Jedes mal nach dem booten muss ich immer erst "sudo systemctl restart lightdm" eingeben, damit ich ins Desktop komme.
Du musst lightdm dauerhaft "einschalten":
sudo systemctl enable lightdm.service --forcehttps://wiki.manjaro.org/index.php/Install_Desktop_Environments#Optional:_Install_and_use_LightDM.2C_the_recommended_display_manager_for_XFCE

viele Grüße gosia
"funktioniert nicht" ist keine brauchbare Fehlermeldung
Folgende Mitglieder bedankten sich: Speedreini93

Offline Speedreini93

  • Neuling
  • *
  • Beiträge: 7
  • Karma: +0/-0
  • Skill: Anfänger
Re: Nach installation Bildschrim schwarz
« Antwort #2 am: 15. März 2021, 21:43:14 »
Hat leider nicht geklappt. Hab es eingegeben und neugestartet und es blieb so. Gab keine Fehlermeldung bei der Eingabe des Befehls.
Hier sind die beiden Config Datein. Vielleicht ist da etwas falsch eingestellt.

ightdm.conf
Code: XML
  1. [Seat:*]
  2. #
  3. # General configuration
  4. #
  5. # start-default-seat = True to always start one seat if none are defined in the configuration
  6. # greeter-user = User to run greeter as
  7. # minimum-display-number = Minimum display number to use for X servers
  8. # minimum-vt = First VT to run displays on
  9. # lock-memory = True to prevent memory from being paged to disk
  10. # user-authority-in-system-dir = True if session authority should be in the system location
  11. # guest-account-script = Script to be run to setup guest account
  12. # logind-check-graphical = True to on start seats that are marked as graphical by logind
  13. # log-directory = Directory to log information to
  14. # run-directory = Directory to put running state in
  15. # cache-directory = Directory to cache to
  16. # sessions-directory = Directory to find sessions
  17. # remote-sessions-directory = Directory to find remote sessions
  18. # greeters-directory = Directory to find greeters
  19. # backup-logs = True to move add a .old suffix to old log files when opening new ones
  20. # dbus-service = True if LightDM provides a D-Bus service to control it
  21. #
  22. [LightDM]
  23. #start-default-seat=true
  24. #greeter-user=lightdm
  25. #minimum-display-number=0
  26. #minimum-vt=7 # Setting this to a value < 7 implies security issues, see FS#46799
  27. #lock-memory=true
  28. #user-authority-in-system-dir=false
  29. #guest-account-script=guest-account
  30. #logind-check-graphical=false
  31. #log-directory=/var/log/lightdm
  32. run-directory=/run/lightdm
  33. #cache-directory=/var/cache/lightdm
  34. #sessions-directory=/usr/share/lightdm/sessions:/usr/share/xsessions:/usr/share/wayland-sessions
  35. #remote-sessions-directory=/usr/share/lightdm/remote-sessions
  36. #greeters-directory=$XDG_DATA_DIRS/lightdm/greeters:$XDG_DATA_DIRS/xgreeters
  37. #backup-logs=true
  38. #dbus-service=true
  39.  
  40. #
  41. # Seat configuration
  42. #
  43. # Seat configuration is matched against the seat name glob in the section, for example:
  44. # [Seat:*] matches all seats and is applied first.
  45. # [Seat:seat0] matches the seat named "seat0".
  46. # [Seat:seat-thin-client*] matches all seats that have names that start with "seat-thin-client".
  47. #
  48. # type = Seat type (local, xremote)
  49. # pam-service = PAM service to use for login
  50. # pam-autologin-service = PAM service to use for autologin
  51. # pam-greeter-service = PAM service to use for greeters
  52. # xserver-command = X server command to run (can also contain arguments e.g. X -special-option)
  53. # xmir-command = Xmir server command to run (can also contain arguments e.g. Xmir -special-option)
  54. # xserver-config = Config file to pass to X server
  55. # xserver-layout = Layout to pass to X server
  56. # xserver-allow-tcp = True if TCP/IP connections are allowed to this X server
  57. # xserver-share = True if the X server is shared for both greeter and session
  58. # xserver-hostname = Hostname of X server (only for type=xremote)
  59. # xserver-display-number = Display number of X server (only for type=xremote)
  60. # xdmcp-manager = XDMCP manager to connect to (implies xserver-allow-tcp=true)
  61. # xdmcp-port = XDMCP UDP/IP port to communicate on
  62. # xdmcp-key = Authentication key to use for XDM-AUTHENTICATION-1 (stored in keys.conf)
  63. # greeter-session = Session to load for greeter
  64. # greeter-hide-users = True to hide the user list
  65. # greeter-allow-guest = True if the greeter should show a guest login option
  66. # greeter-show-manual-login = True if the greeter should offer a manual login option
  67. # greeter-show-remote-login = True if the greeter should offer a remote login option
  68. # user-session = Session to load for users
  69. # allow-user-switching = True if allowed to switch users
  70. # allow-guest = True if guest login is allowed
  71. # guest-session = Session to load for guests (overrides user-session)
  72. # session-wrapper = Wrapper script to run session with
  73. # greeter-wrapper = Wrapper script to run greeter with
  74. # guest-wrapper = Wrapper script to run guest sessions with
  75. # display-setup-script = Script to run when starting a greeter session (runs as root)
  76. # display-stopped-script = Script to run after stopping the display server (runs as root)
  77. # greeter-setup-script = Script to run when starting a greeter (runs as root)
  78. # session-setup-script = Script to run when starting a user session (runs as root)
  79. # session-cleanup-script = Script to run when quitting a user session (runs as root)
  80. # autologin-guest = True to log in as guest by default
  81. # autologin-user = User to log in with by default (overrides autologin-guest)
  82. # autologin-user-timeout = Number of seconds to wait before loading default user
  83. # autologin-session = Session to load for automatic login (overrides user-session)
  84. # autologin-in-background = True if autologin session should not be immediately activated
  85. # exit-on-failure = True if the daemon should exit if this seat fails
  86. #
  87. [Seat:*]
  88. #type=local
  89. #pam-service=lightdm
  90. #pam-autologin-service=lightdm-autologin
  91. #pam-greeter-service=lightdm-greeter
  92. #xserver-command=X
  93. #xmir-command=Xmir
  94. #xserver-config=
  95. #xserver-layout=
  96. #xserver-allow-tcp=false
  97. #xserver-share=true
  98. #xserver-hostname=
  99. #xserver-display-number=
  100. #xdmcp-manager=
  101. #xdmcp-port=177
  102. #xdmcp-key=
  103. greeter-session=lightdm-gtk-greeter
  104. #greeter-hide-users=false
  105. #greeter-allow-guest=true
  106. #greeter-show-manual-login=false
  107. #greeter-show-remote-login=true
  108. user-session=xfce
  109. #allow-user-switching=true
  110. #allow-guest=true
  111. #guest-session=
  112. session-wrapper=/etc/lightdm/Xsession
  113. #greeter-wrapper=
  114. #guest-wrapper=
  115. #display-setup-script=
  116. #display-stopped-script=
  117. #greeter-setup-script=
  118. #session-setup-script=
  119. #session-cleanup-script=
  120. #autologin-guest=false
  121. autologin-user=reinhold
  122. #autologin-user-timeout=0
  123. #autologin-in-background=false
  124. #autologin-session=
  125. #exit-on-failure=false
  126.  
  127. #
  128. # XDMCP Server configuration
  129. #
  130. # enabled = True if XDMCP connections should be allowed
  131. # port = UDP/IP port to listen for connections on
  132. # listen-address = Host/address to listen for XDMCP connections (use all addresses if not present)
  133. # key = Authentication key to use for XDM-AUTHENTICATION-1 or blank to not use authentication (stored in keys.conf)
  134. # hostname = Hostname to report to XDMCP clients (defaults to system hostname if unset)
  135. #
  136. # The authentication key is a 56 bit DES key specified in hex as 0xnnnnnnnnnnnnnn.  Alternatively
  137. # it can be a word and the first 7 characters are used as the key.
  138. #
  139. [XDMCPServer]
  140. #enabled=false
  141. #port=177
  142. #listen-address=
  143. #key=
  144. #hostname=
  145.  
  146. #
  147. # VNC Server configuration
  148. #
  149. # enabled = True if VNC connections should be allowed
  150. # command = Command to run Xvnc server with
  151. # port = TCP/IP port to listen for connections on
  152. # listen-address = Host/address to listen for VNC connections (use all addresses if not present)
  153. # width = Width of display to use
  154. # height = Height of display to use
  155. # depth = Color depth of display to use
  156. #
  157. [VNCServer]
  158. #enabled=false
  159. #command=Xvnc
  160. #port=5900
  161. #listen-address=
  162. #width=1024
  163. #height=768
  164. #depth=8
  165.  

lightdm-gtk-greeter.conf
Code: XML
  1. [greeter]
  2. background = /usr/share/backgrounds/illyria-default-lockscreen.jpg
  3. user-background = false
  4. font-name = Cantarell Bold 12
  5. xft-antialias = true
  6. icon-theme-name = Adapta-Papirus-Maia
  7. screensaver-timeout = 60
  8. theme-name = Matcha-sea
  9. cursor-theme-name = xcursor-breeze
  10. show-clock = false
  11. default-user-image = #manjaro
  12. xft-hintstyle = hintfull
  13. position = 50%,center 57%,center
  14. clock-format =
  15. panel-position = bottom
  16. indicators = ~host;~spacer;~clock;~spacer;~language;~session;~a11y;~power
  17.  

Gruß
Speedreini93

Offline gosia

  • Held Mitglied
  • *****
  • Beiträge: 2065
  • Dankeschön: 414 mal
  • Karma: +0/-0
  • Desktop: Openbox + xfce
  • Grafikkarte: Intel HD 4000
  • Grafikkartentreiber: i915 (free)
  • Kernel: 4.19 Artix
  • Prozessor: Intel Core i5-3210M
  • Skill: Durchschnitt
  • Zweig: stable
Re: Nach installation Bildschrim schwarz
« Antwort #3 am: 15. März 2021, 22:55:09 »
Hallo Speedreini,
Hier sind die beiden Config Datein. Vielleicht ist da etwas falsch eingestellt.
Naja möglich, aber so auf die schnelle kann ich nichts entdecken.
Glaube auch nicht so sehr, dass es daran liegt. Denn wenn Du mit
sudo systemctl restart lightdmden Dienst von Hand startest liest er ja auch nur die gleiche Konfiguration ein, und da funktioniert es. Wüsste also nicht, warum es beim automatischen Start nicht funktionieren sollte.
Da fällt mir im Moment nichts ein, aber vielleicht hat ja jemand anderes eine gute Idee.

viele Grüße gosia
"funktioniert nicht" ist keine brauchbare Fehlermeldung
Folgende Mitglieder bedankten sich: Speedreini93

Offline Speedreini93

  • Neuling
  • *
  • Beiträge: 7
  • Karma: +0/-0
  • Skill: Anfänger
Re: Nach installation Bildschrim schwarz
« Antwort #4 am: 15. März 2021, 23:30:58 »
Trotzdem danke für deine Hilfe. :)
Dann warten wir etwas. :)

Hier ist noch eine Log von der lighdm
Code: XML
  1. [+0.00s] DEBUG: Logging to /var/log/lightdm/lightdm.log
  2. [+0.00s] DEBUG: Starting Light Display Manager 1.30.0, UID=0 PID=1711
  3. [+0.00s] DEBUG: Loading configuration dirs from /usr/share/lightdm/lightdm.conf.d
  4. [+0.00s] DEBUG: Loading configuration dirs from /usr/local/share/lightdm/lightdm.conf.d
  5. [+0.00s] DEBUG: Loading configuration dirs from /var/lib/flatpak/exports/share/lightdm/lightdm.conf.d
  6. [+0.00s] DEBUG: Loading configuration dirs from /etc/xdg/lightdm/lightdm.conf.d
  7. [+0.00s] DEBUG: Loading configuration from /etc/lightdm/lightdm.conf
  8. [+0.00s] DEBUG: Registered seat module local
  9. [+0.00s] DEBUG: Registered seat module xremote
  10. [+0.00s] DEBUG: Using D-Bus name org.freedesktop.DisplayManager
  11. [+0.00s] DEBUG: _g_io_module_get_default: Found default implementation local (GLocalVfs) for ‘gio-vfs’
  12. [+0.00s] DEBUG: Monitoring logind for seats
  13. [+0.00s] DEBUG: New seat added from logind: seat0
  14. [+0.00s] DEBUG: Seat seat0: Loading properties from config section Seat:*
  15. [+0.00s] DEBUG: Seat seat0 has property CanMultiSession=no
  16. [+0.00s] DEBUG: Seat seat0: Starting
  17. [+0.00s] DEBUG: Seat seat0: Creating user session
  18. [+0.00s] DEBUG: Loading users from org.freedesktop.Accounts
  19. [+0.00s] DEBUG: User /org/freedesktop/Accounts/User1000 added
  20. [+0.00s] DEBUG: Seat seat0: Creating display server of type x
  21. [+0.00s] DEBUG: Could not run plymouth --ping: Failed to execute child process “plymouth” (No such file or directory)
  22. [+0.00s] DEBUG: Using VT 7
  23. [+0.00s] DEBUG: Seat seat0: Starting local X display on VT 7
  24. [+0.00s] DEBUG: XServer 0: Logging to /var/log/lightdm/x-0.log
  25. [+0.00s] DEBUG: XServer 0: Writing X server authority to /run/lightdm/root/:0
  26. [+0.00s] DEBUG: XServer 0: Launching X Server
  27. [+0.00s] DEBUG: Launching process 1717: /usr/bin/X :0 -seat seat0 -auth /run/lightdm/root/:0 -nolisten tcp vt7 -novtswitch
  28. [+0.00s] DEBUG: XServer 0: Waiting for ready signal from X server :0
  29. [+0.00s] DEBUG: Acquired bus name org.freedesktop.DisplayManager
  30. [+0.00s] DEBUG: Registering seat with bus path /org/freedesktop/DisplayManager/Seat0
  31. [+0.05s] DEBUG: Seat seat0 changes active session to
  32. [+1.28s] DEBUG: Got signal 10 from process 1717
  33. [+1.28s] DEBUG: XServer 0: Got signal from X server :0
  34. [+1.28s] DEBUG: XServer 0: Connecting to XServer :0
  35. [+1.28s] DEBUG: Seat seat0: Display server ready, starting session authentication
  36. [+1.28s] DEBUG: Session pid=1761: Started with service 'lightdm-autologin', username 'reinhold'
  37. [+1.30s] DEBUG: Session pid=1761: Authentication complete with return value 0: Success
  38. [+1.31s] DEBUG: Seat seat0: Session authenticated, running command
  39. [+1.31s] DEBUG: Registering session with bus path /org/freedesktop/DisplayManager/Session0
  40. [+1.31s] DEBUG: Session pid=1761: Running command /etc/lightdm/Xsession startxfce4
  41. [+1.31s] DEBUG: Creating shared data directory /var/lib/lightdm-data/reinhold
  42. [+1.31s] DEBUG: Session pid=1761: Logging to .xsession-errors
  43. [+1.32s] DEBUG: Activating VT 7
  44. [+1.32s] DEBUG: Activating login1 session 3
  45. [+1.32s] DEBUG: Seat seat0 changes active session to 3
  46. [+1.32s] DEBUG: Session 3 is already active
  47.  

Offline gosia

  • Held Mitglied
  • *****
  • Beiträge: 2065
  • Dankeschön: 414 mal
  • Karma: +0/-0
  • Desktop: Openbox + xfce
  • Grafikkarte: Intel HD 4000
  • Grafikkartentreiber: i915 (free)
  • Kernel: 4.19 Artix
  • Prozessor: Intel Core i5-3210M
  • Skill: Durchschnitt
  • Zweig: stable
Re: Nach installation Bildschrim schwarz
« Antwort #5 am: 16. März 2021, 15:32:08 »
Hallo Speedreini,
frisch ausgeruht habe ich mir deine Logdateien nochmals genauer angesehen. Zwar immer noch keine Lösung, aber ein paar Anmerkungen, in welche Richtung man suchen könnte.
1. Der einzig echte Fehler den ich sehe, ist der, dass Plymouth nicht startet
[+0.00s] DEBUG: Could not run plymouth --ping: Failed to execute child process “plymouth” (No such file or directory)
Das scheint mir nicht weiter tragisch, da Plymouth eh nur dekorative Funktion hat. Trotzdem könntest du versuchen, Plymouth abzuschalten und zu deinstallieren, um das als Fehlerquelle auszuschliessen.
https://wiki.manjaro.org/index.php?title=Plymouth#Removal
Dann habe ich den starken Verdacht, dass es nicht an LightDM sondern an der XFCE-Sitzung liegt, weil LightDM erfolgreich dein Autologin durchführt
[+1.28s] DEBUG: Seat seat0: Display server ready, starting session authentication
[+1.28s] DEBUG: Session pid=1761: Started with service 'lightdm-autologin', username 'reinhold'
[+1.30s] DEBUG: Session pid=1761: Authentication complete with return value 0: Success
und sogar bis zum Start von xfce kommt
[+1.31s] DEBUG: Session pid=1761: Running command /etc/lightdm/Xsession startxfce4
[+1.31s] DEBUG: Creating shared data directory /var/lib/lightdm-data/reinhold
[+1.31s] DEBUG: Session pid=1761: Logging to .xsession-errors
da wäre also der Inhalt der Datei ~/.xsession-errors interessant und eventuell auch die Datei /var/log/Xorg.0.log
Da letztere meist umfangreich ist würde die Ausgabe von
grep -e "EE|WW" /var/log/Xorg.0.loggenügen.

viele Grüße gosia
"funktioniert nicht" ist keine brauchbare Fehlermeldung
Folgende Mitglieder bedankten sich: Speedreini93

Offline Speedreini93

  • Neuling
  • *
  • Beiträge: 7
  • Karma: +0/-0
  • Skill: Anfänger
Re: Nach installation Bildschrim schwarz
« Antwort #6 am: 16. März 2021, 15:49:29 »
Code: XML
  1. [+0.00s] DEBUG: Could not run plymouth --ping: Failed to execute child process “plymouth” (No such file or directory)
Diesen Fehler hab ich wegbekommen, indem ich plymouth installliert habe.

Die ganzen 4 Logs sind in einer Datei. mit dem .old dabei.
« Letzte Änderung: 16. März 2021, 15:53:36 von Speedreini93 »

Offline gosia

  • Held Mitglied
  • *****
  • Beiträge: 2065
  • Dankeschön: 414 mal
  • Karma: +0/-0
  • Desktop: Openbox + xfce
  • Grafikkarte: Intel HD 4000
  • Grafikkartentreiber: i915 (free)
  • Kernel: 4.19 Artix
  • Prozessor: Intel Core i5-3210M
  • Skill: Durchschnitt
  • Zweig: stable
Re: Nach installation Bildschrim schwarz
« Antwort #7 am: 16. März 2021, 16:55:49 »
Hallo Speedreini,
Du schreibst ja schneller als ich antworten kann ;)
Ist leider ein unklares Bild, deine ~/.xsession-errors steckt so voller Warnungen und Fehler, dass man gar nicht so recht weiss, wo man anfangen soll, zumal es sich ja um eine ganz frische Installation handelt. Welche ISO hast Du da benutzt und auch gleich ein Update gemacht?
sudo pacman -SyuÜbrigens sind die *.old-Dateien immer die vom vorherigen Lauf, die braucht man in der Regel eigentlich nicht. Hier ist es aber zufällig gut, weil in der Xorg.0.log.old ein Fehler gemeldet wird:
[     4.727] (II) modesetting: Driver for Modesetting Kernel Drivers: kms
[     4.727] (II) VESA: driver for VESA chipsets: vesa
[     4.727] (EE) open /dev/dri/card0: No such file or directory
[     4.727] (WW) Falling back to old probe method for modesetting
[     4.727] (EE) open /dev/dri/card0: No such file or directory
[     4.727] vesa: Refusing to run on UEFI
[     4.727] (EE) Screen 0 deleted because of no matching config section.
[     4.727] (II) UnloadModule: "modesetting"
[     4.727] (EE) Device(s) detected, but none match those in the config file.
[     4.727] (EE) Fatal server error:
[     4.727] (EE) no screens found(EE)
[     4.727] (EE) Please consult the The X.Org Foundation support at http://wiki.x.org for help.
[     4.727] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[     4.727] (EE) Server terminated with error (1). Closing log file.
in der aktuellen Xorg.0.log sehe ich den nicht, die bricht irgendwie unvermittelt ab. Übertragungsfehler?
Aber bitte für die Zukunft, dampfe die Xorg.0.log wie angegeben mit diesem Kommando etwas ein
grep -E "EE|WW" /var/log/Xorg.0.logman wird sonst geradezu erschlagen von der Fülle. Eventuelle Infos kannst Du dann immer noch auf Verlangen nachliefern.
Außerdem denke ich, dass es an der Zeit ist, etwas über deine Hardware, ganz speziell die verwendete Grafikkarte zu posten, z.B. die Ausgabe von
inxi -F
viele Grüße gosia

PS. in der vorigen Antwort von mir war ein Fehler drin. Es muss tatsächlich
grep -E "EE|WW" /var/log/Xorg.0.logmit grossem -E sein.
« Letzte Änderung: 16. März 2021, 17:00:39 von gosia »
"funktioniert nicht" ist keine brauchbare Fehlermeldung
Folgende Mitglieder bedankten sich: Speedreini93

Offline Speedreini93

  • Neuling
  • *
  • Beiträge: 7
  • Karma: +0/-0
  • Skill: Anfänger
Re: Nach installation Bildschrim schwarz
« Antwort #8 am: 16. März 2021, 17:09:10 »
Hallo,
bekomme immer eine Meldung, wenn einer im Thread etwas postet. :)
Mhh, verstehe nicht. Das so ein frisches System. Soviele Fehler hat.
Hab es von https://manjaro.org/download/ geladen. Die XFCE 20.2.1.

Alles klar. Werde es mit dem Befehl: "grep -E "EE|WW" /var/log/Xorg.0.log" machen.
Code: XML
  1. [    30.086] Current Operating System: Linux reinhold 5.11.2-1-MANJARO #1 SMP PREEMPT Fri Feb 26 12:17:53 UTC 2021 x86_64
  2.         (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
  3. [    30.086] (WW) The directory "/usr/share/fonts/OTF" does not exist.
  4. [    30.086] (WW) The directory "/usr/share/fonts/Type1" does not exist.
  5. [    30.103] (WW) Open ACPI failed (/var/run/acpid.socket) (No such file or directory)
  6. [    30.117] (WW) Warning, couldn't open module fbdev
  7. [    30.117] (EE) Failed to load module "fbdev" (module does not exist, 0)
  8. [    30.147] (WW) Falling back to old probe method for modesetting
  9. [    30.302] (II) Initializing extension MIT-SCREEN-SAVER
  10. [   152.656] (EE) event25 - Logitech Gaming Keyboard G910: client bug: event processing lagging behind by 18ms, your system is too slow
  11.  

inxi -F
Code: XML
  1. System:
  2.   Host: reinhold Kernel: 5.11.2-1-MANJARO x86_64 bits: 64
  3.   Desktop: Xfce 4.16.0 Distro: Manjaro Linux
  4. Machine:
  5.   Type: Desktop System: ASUS product: N/A v: N/A
  6.   serial: <superuser required>
  7.   Mobo: ASUSTeK model: ROG CROSSHAIR VIII FORMULA v: Rev X.0x
  8.   serial: <superuser required> UEFI: American Megatrends v: 3302
  9.   date: 03/05/2021
  10. CPU:
  11.   Info: 16-Core model: AMD Ryzen 9 5950X bits: 64 type: MT MCP
  12.   L2 cache: 8 MiB
  13.   Speed: 3743 MHz min/max: 2200/7228 MHz Core speeds (MHz): 1: 3743 2: 2837
  14.   3: 2197 4: 2147 5: 2117 6: 2172 7: 2198 8: 2199 9: 3160 10: 2823 11: 2836
  15.   12: 2995 13: 2874 14: 2876 15: 2876 16: 2872 17: 3594 18: 2197 19: 2196
  16.   20: 2196 21: 2197 22: 2196 23: 2198 24: 2878 25: 2198 26: 2197 27: 2875
  17.   28: 2877 29: 2874 30: 3596 31: 2198 32: 2196
  18. Graphics:
  19.   Device-1: AMD Navi 21 [Radeon RX 6800/6800 XT / 6900 XT] driver: amdgpu
  20.   v: kernel
  21.   Display: x11 server: X.Org 1.20.10 driver: loaded: amdgpu,ati
  22.   unloaded: modesetting,radeon,vesa resolution: 3840x2160
  23.   OpenGL:
  24.   renderer: AMD SIENNA_CICHLID (DRM 3.40.0 5.11.2-1-MANJARO LLVM 11.1.0)
  25.   v: 4.6 Mesa 20.3.4
  26. Audio:
  27.   Device-1: Creative Labs driver: snd_hda_intel
  28.   Device-2: AMD driver: snd_hda_intel
  29.   Device-3: AMD Starship/Matisse HD Audio driver: snd_hda_intel
  30.   Sound Server: ALSA v: k5.11.2-1-MANJARO
  31. Network:
  32.   Device-1: Aquantia AQC111 NBase-T/IEEE 802.3bz Ethernet [AQtion]
  33.   driver: atlantic
  34.   IF: enp5s0 state: down mac: 04:d9:f5:c9:03:28
  35.   Device-2: Intel I211 Gigabit Network driver: igb
  36.   IF: enp8s0 state: up speed: 1000 Mbps duplex: full mac: 04:d9:f5:c9:03:27
  37. Drives:
  38.   Local Storage: total: 5.46 TiB used: 15.45 GiB (0.3%)
  39.   ID-1: /dev/nvme0n1 vendor: Samsung model: SSD 970 EVO 1TB size: 931.51 GiB
  40.   ID-2: /dev/nvme1n1 vendor: Corsair model: Force MP600 size: 931.51 GiB
  41.   ID-3: /dev/sda vendor: Western Digital model: WD40EFRX-68N32N0
  42.   size: 3.64 TiB
  43. Partition:
  44.   ID-1: / size: 881.65 GiB used: 15.45 GiB (1.8%) fs: ext4
  45.   dev: /dev/nvme0n1p2
  46.   ID-2: /boot/efi size: 299.4 MiB used: 312 KiB (0.1%) fs: vfat
  47.   dev: /dev/nvme0n1p1
  48. Swap:
  49.   ID-1: swap-1 type: partition size: 34.46 GiB used: 0 KiB (0.0%)
  50.   dev: /dev/nvme0n1p3
  51. Sensors:
  52.   System Temperatures: cpu: 40.0 C mobo: N/A gpu: amdgpu temp: 37.0 C
  53.   Fan Speeds (RPM): N/A gpu: amdgpu fan: 0
  54. Info:
  55.   Processes: 494 Uptime: 4m Memory: 31.33 GiB used: 1.62 GiB (5.2%)
  56.   Shell: Bash inxi: 3.3.01
  57.  

Ach, deswegen kam kein Ergebnis, wo ich den falschen Befehl eingegeben haben. Nja, nicht schlimm. :)

Gruß
Speedreini93

//edit
Habe sudo pacman -Syu als erstes nach der Installation durchgeführt. System ist aktuell.
« Letzte Änderung: 16. März 2021, 17:13:53 von Speedreini93 »

Offline gosia

  • Held Mitglied
  • *****
  • Beiträge: 2065
  • Dankeschön: 414 mal
  • Karma: +0/-0
  • Desktop: Openbox + xfce
  • Grafikkarte: Intel HD 4000
  • Grafikkartentreiber: i915 (free)
  • Kernel: 4.19 Artix
  • Prozessor: Intel Core i5-3210M
  • Skill: Durchschnitt
  • Zweig: stable
Re: Nach installation Bildschrim schwarz
« Antwort #9 am: 16. März 2021, 20:36:29 »
Hallo Speedreini,
danke für die Infos. Leider kann ich nichts entdecken, was mich irgendwie weiterbringt. Könnte mit dem Grafiktreiber zusammenhängen, aber das ist reine Spekulation.
Also ich muss das Handtuch werfen und hoffe, dass jemand anderes eine hilfreiche Idee hat. Tut mir leid.

viele Grüße gosia
"funktioniert nicht" ist keine brauchbare Fehlermeldung
Folgende Mitglieder bedankten sich: Speedreini93

Offline Speedreini93

  • Neuling
  • *
  • Beiträge: 7
  • Karma: +0/-0
  • Skill: Anfänger
Re: Nach installation Bildschrim schwarz
« Antwort #10 am: 16. März 2021, 20:41:53 »
Schade, nja kann man nichts machen. Trotzdem danke für deine Bemühungen. :)

Offline Holle

  • Neuling
  • *
  • Beiträge: 3
  • Dankeschön: 3 mal
  • Karma: +0/-0
  • Desktop: KDE Plasma
  • Grafikkartentreiber: free
  • Prozessor: AMD® Ryzen™ 7 PRO 4750G
  • Skill: Fortgeschritten
Re: Nach installation Bildschrim schwarz
« Antwort #11 am: 16. März 2021, 21:07:16 »
Ich würde mal noch versuchen den lightdm manager zu deinstallieren und den Service auch deaktivieren.
Dann landest Du beim Reboot in der Konsole.
Meldest Dich dann an mit User und Password und startest die Xfce-Session manuell.
Damit umgehst Du sämtliche Probleme mit lightdm. Der machte bei mir auch schon manchmal Probleme bei Arch.
Und bei fehlerhaften Updates von lightdm ist man dann auch nicht mehr betroffen.
Ich glaube das Starten war dann:
startxfce4
« Letzte Änderung: 16. März 2021, 21:15:12 von Holle »
Folgende Mitglieder bedankten sich: Speedreini93

Offline Speedreini93

  • Neuling
  • *
  • Beiträge: 7
  • Karma: +0/-0
  • Skill: Anfänger
Re: Nach installation Bildschrim schwarz
« Antwort #12 am: 16. März 2021, 22:13:11 »
So, ich habe jetzt mal Manjaro neu installiert und siehe da es geht.
Keine Ahnung, was jetzt anders ist. Muss wohl beim ersten mal etwas schief gelaufen sein.
Trotzdem danke für die Hilfe. :)