Autor Thema: ssh connection übers Internet ohne Router Zugriff  (Gelesen 107 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Offline Josh_Aus_Hessen

  • Neuling
  • *
  • Beiträge: 2
  • Desktop: KDE
  • Skill: Anfänger
ssh connection übers Internet ohne Router Zugriff
« am: 09. Februar 2019, 19:22:36 »
Hey,
also mein Problem ist, dass ich eine ssh Verbindung übers Internet zu einem Gerät aufbauen möchte, ohne dass ich zugriff auf den Router habe.
Wenn ich im lokalen Netzwerk bin funktioniert es mit v4 und v6 und sogar mit der dynamischen DNS Adresse, die ich eingerichtet habe.
Aber außerhalb des Netzwerkes bekomme ich die Nachricht:

ssh: connect to host xxxxxx.ddnss.de port 443: Network is unreachable
bzw
ssh: connect to host [ipv6] port 443: Network is unreachable

gibt es eine Möglichkeit das Problem zu lösen? Wenn nein, weiß jemand woran das Problem liegt.

Danke im Voraus, Gruß
Joshua

Offline gosia

  • Held Mitglied
  • *****
  • Beiträge: 1532
  • Dankeschön: 294 mal
  • Desktop: Openbox + xfce
  • Grafikkarte: Intel HD 4000
  • Grafikkartentreiber: i915 (free)
  • Kernel: 4.19 Artix
  • Prozessor: Intel Core i5-3210M
  • Skill: Durchschnitt
  • Zweig: stable
Re: ssh connection übers Internet ohne Router Zugriff
« Antwort #1 am: 09. Februar 2019, 20:56:24 »
Hallo Joshua,
gibt es einen Grund, daß du Port 443 (HTTPS) für ssh benutzt?
Aber probiere mal die Option -v um mehr Debug-Infos zu erhalten
ssh -v ...
viele Grüße gosia
"funktioniert nicht" ist keine brauchbare Fehlermeldung

Offline Josh_Aus_Hessen

  • Neuling
  • *
  • Beiträge: 2
  • Desktop: KDE
  • Skill: Anfänger
Re: ssh connection übers Internet ohne Router Zugriff
« Antwort #2 am: 10. Februar 2019, 00:47:48 »
Ich hatte mal eine Empfehlung gelesen, dass der Port für ssh teilweise in öffentlichen Netzen gesperrt ist und hab es daher auf dem Zielrechner umgestellt.


Von außen:

> ssh -v Lenovo
OpenSSH_7.9p1, OpenSSL 1.1.1a  20 Nov 2018
debug1: Reading configuration data /home/joshua/.ssh/config
debug1: /home/joshua/.ssh/config line 17: Applying options for Lenovo
debug1: Reading configuration data /etc/ssh/ssh_config
debug1: Connecting to [URL] [Ipv6 Adresse] port 443.
debug1: connect to address [IPv6 Adresse] port 443: Network is unreachable
ssh: connect to host [URL] port 443: Network is unreachable

Aus dem lokalen Netzwerk:

> ssh -v Lenovo
OpenSSH_7.9p1, OpenSSL 1.1.1a  20 Nov 2018
debug1: Reading configuration data /home/joshua/.ssh/config
debug1: /home/joshua/.ssh/config line 17: Applying options for Lenovo
debug1: Reading configuration data /etc/ssh/ssh_config
debug1: Connecting to [URL] [Ipv6 Adresse] port 443.
debug1: Connection established.
debug1: identity file /home/joshua/.ssh/id_rsa type 0
debug1: identity file /home/joshua/.ssh/id_rsa-cert type -1
debug1: Local version string SSH-2.0-OpenSSH_7.9
debug1: Remote protocol version 2.0, remote software version OpenSSH_7.9
debug1: match: OpenSSH_7.9 pat OpenSSH* compat 0x04000000
debug1: Authenticating to [URL]:443 as 'joshua'
debug1: SSH2_MSG_KEXINIT sent
debug1: SSH2_MSG_KEXINIT received
debug1: kex: algorithm: curve25519-sha256
debug1: kex: host key algorithm: ecdsa-sha2-nistp256
debug1: kex: server->client cipher: chacha20-poly1305@openssh.com MAC: <implicit> compression: none
debug1: kex: client->server cipher: chacha20-poly1305@openssh.com MAC: <implicit> compression: none
debug1: expecting SSH2_MSG_KEX_ECDH_REPLY
debug1: Server host key: ecdsa-sha2-nistp256 SHA256: [...]
debug1: Host '[URL]:443' is known and matches the ECDSA host key.
debug1: Found key in /home/joshua/.ssh/known_hosts:4                                    //Ziel Rechner
debug1: rekey after 134217728 blocks
debug1: SSH2_MSG_NEWKEYS sent
debug1: expecting SSH2_MSG_NEWKEYS
debug1: SSH2_MSG_NEWKEYS received
debug1: rekey after 134217728 blocks
debug1: Will attempt key: /home/joshua/.ssh/id_rsa RSA SHA256: [...] explicit
debug1: SSH2_MSG_EXT_INFO received
debug1: kex_input_ext_info: server-sig-algs=<ssh-ed25519,ssh-rsa,rsa-sha2-256,rsa-sha2-512,ssh-dss,ecdsa-sha2-nistp256,ecdsa-sha2-nistp384,ecdsa-sha2-nistp521>
debug1: SSH2_MSG_SERVICE_ACCEPT received
debug1: Authentications that can continue: publickey
debug1: Next authentication method: publickey
debug1: Offering public key: /home/joshua/.ssh/id_rsa RSA SHA256: [...] explicit
debug1: Server accepts key: /home/joshua/.ssh/id_rsa RSA SHA256: [...] explicit
Enter passphrase for key '/home/joshua/.ssh/id_rsa':
debug1: Authentication succeeded (publickey).
Authenticated to [URL] ([Ipv6 Adresse]:443).
debug1: channel 0: new [client-session]
debug1: Requesting no-more-sessions@openssh.com
debug1: Entering interactive session.
debug1: pledge: network
debug1: client_input_global_request: rtype hostkeys-00@openssh.com want_reply 0
debug1: Remote: /home/joshua/.ssh/authorized_keys:1: key options: agent-forwarding port-forwarding pty user-rc x11-forwarding
debug1: Remote: /home/joshua/.ssh/authorized_keys:1: key options: agent-forwarding port-forwarding pty user-rc x11-forwarding
Last login: Sat Feb  9 19:13:38 2019 from [Ipv6 Adresse]
« Letzte Änderung: 10. Februar 2019, 08:42:23 von Linu74 »

Offline gosia

  • Held Mitglied
  • *****
  • Beiträge: 1532
  • Dankeschön: 294 mal
  • Desktop: Openbox + xfce
  • Grafikkarte: Intel HD 4000
  • Grafikkartentreiber: i915 (free)
  • Kernel: 4.19 Artix
  • Prozessor: Intel Core i5-3210M
  • Skill: Durchschnitt
  • Zweig: stable
Re: ssh connection übers Internet ohne Router Zugriff
« Antwort #3 am: 10. Februar 2019, 20:58:25 »
Hallo Joshua,
Ich hatte mal eine Empfehlung gelesen, dass der Port für ssh teilweise in öffentlichen Netzen gesperrt ist und hab es daher auf dem Zielrechner umgestellt.
Naja, da kann man geteilter Meinung sein. Da mir aber sonst nichts einfällt, würde ich es doch mal mit dem handelsüblichen ssh-Port 22 versuchen.
Und da die Debug-Infos auch nur sagen, daß das Netz nicht erreichbar ist, kannst du ja mal mit tracepath nachsehen, wo es hängenbleibt.

viele Grüße gosia
"funktioniert nicht" ist keine brauchbare Fehlermeldung