Autor Thema: KDE braucht nach update 100% CPU (inkl. Lösung)  (Gelesen 2124 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Offline struppi

  • Vollwertiges Mitglied
  • ***
  • Beiträge: 130
  • Dankeschön: 2 mal
  • Desktop: XFCE
  • Skill: Durchschnitt
  • Zweig: stable
KDE braucht nach update 100% CPU (inkl. Lösung)
« am: 20. Mai 2014, 16:54:19 »
Was eine Wurst :(

Ich versuche seit Jahren Windows Usern Linux nahe zu bringen und hatte gerade wieder eine Umsteigerin auf Manjaroo gebracht (sehr schöne Distri, werde ich auch für mich persönlich in's Auge fassen :) ).

Da ich persönlich mittlerweile voll auf XFCE umgestiegen bin (von Gnome), hatte ich ihr das installiert. Aber um auch die Möglichkeiten die sei nun hat zu demonstrieren, zusätzlich noch KDE. Da (Ex) Windows User gerne sinnlose Desktop Anwendungen benutzen, lag das nahe ;).Zumal ich gelesen habe, KDE würde Windows Usern gefallen.

Das nur als, vorgeplänkel.

Gestern war ja "update Time", dass der update nur in der Konsole läuft war ein überwindbares Hindernis und hat auch geklappt (ob sie das selbst rausgefunden hätte, bezweifle ich, die Meldungen im updater waren nicht hilfreich). Aber heute rief sie mich an, "nichts läuft mehr, kein Programm startet".

Also hin und mir die Sache mal angeschaut. Tatsächlich startete keine Anwendung mehr. Vermeintlich!
Das Problem liess sich in einem Terminal - mit top - schnell lokalisieren: baloo!

Mal ein paar (verzweifelte) Meinungen:
http://askubuntu.com/questions/437635/how-to-turn-off-baloo-in-kde-4-13

https://bbs.archlinux.org/viewtopic.php?id=180313
(sehr erheiternd)

Keine Ahnung warum balloo da so in die Kacke greift, aber das schönste ist dann das:
http://vhanda.in/blog/2014/04/desktop-search-configuration/
Zitat
There is no explicit “Enable/Disable” button any more. We would like to promote the use of searching and feel that Baloo should never get in the users way.

Das gibt's doch nicht (erinnert mich an die "Diskussionen" bei Gnome). Ich fand diese Autoindizierung schon unter Windows furchtbar überflüssig. Kaum jemand durchsucht seine eigenen Dokumente und wenn dann installiert man sich etwas passendes. Darüber hinaus braucht das Platz, nicht jeder hat eine 2 TB Platte in seinem Rechner. Und wenn ich durch sowas meinen Rechner für Tage unbrauchbar mache, dann ist das dich alles andere als "smart". Das ist dumm.

Auch für mich.

Nach der anfänglichen Freunde über Linux, muss ich immer mehr Bedenken beseitigen und es bringt ja leider nichts, wenn man dann erklärt woran es liegt. Der Fakt bleibt, dass der Anwender in zwei Tagen zweimal schwer vor eine Probe gestellt wurde.

Sie ist wieder bei XFCE.

Für alle anderen gibt es die Möglichkeiten Baloo aus dem home Verzeichnis zu sperren:
Zitat
However, we are smart about it and IF you add your HOME directory to the list of “excluded folders”, Baloo will switch itself off since it no longer has anything to index.
Das hält aber natürlich Baloo erstmal nicht von der Arbeit ab und ich werd mich auf die  suche nach dem Index machen müssen, wenn da schon zwei Tage gerödelt wurde können da ein paar Gigabyte Datenmüll zusammen kommen.
Vielleicht hilft das: http://4nakama.net/2014/04/19/how-to-disable-baloo-in-latest-kde-and-kubuntu-14-04/

Offline pycrk

  • Jr. Mitglied
  • **
  • Beiträge: 69
  • Desktop: xfce i3
  • Grafikkarte: Intel HD Graphics 520
  • Grafikkartentreiber: nonfree
  • Kernel: 4.8.12-1
  • Prozessor: Intel Core i5-6200U
  • Skill: Durchschnitt
  • Zweig: stable
Re: KDE braucht nach update 100% CPU (inkl. Lösung)
« Antwort #1 am: 20. Mai 2014, 18:43:25 »
Hi struppi,

Ich hatte das gleiche Problem, außer das bei mir die Programme liefen, aber das System hin und wieder hängen blieb. Hab es zwar durch Hilfe aus dem Forum hier hingebogen das mein Sys wieder normal läuft, aber das Booten dauerte mir leider mit 5 Minuten viel zu lange. Im Endeffekt hab ich das OS wieder neu installiert und geupdatet, seit dem läuft es Problemlos.

Gruß Pycrk

Offline bero

  • Sr. Mitglied
  • ****
  • Beiträge: 309
  • Dankeschön: 5 mal
  • Desktop: KDE
  • Grafikkarte: Intel
  • Skill: Durchschnitt
  • Zweig: stable
Re: KDE braucht nach update 100% CPU (inkl. Lösung)
« Antwort #2 am: 20. Mai 2014, 20:34:44 »
Hi,

kann eure Probleme nicht bestätigen.
Update lief sauber durch, die Bootzeit hat sich geringfügig verkürzt.
Die Systemlast ist ok, top sagt mir allerdings auch, dass baloo nicht läuft (warum auch immer).
Welche Kernel-Version verwendet ihr denn?

Offline pycrk

  • Jr. Mitglied
  • **
  • Beiträge: 69
  • Desktop: xfce i3
  • Grafikkarte: Intel HD Graphics 520
  • Grafikkartentreiber: nonfree
  • Kernel: 4.8.12-1
  • Prozessor: Intel Core i5-6200U
  • Skill: Durchschnitt
  • Zweig: stable
Re: KDE braucht nach update 100% CPU (inkl. Lösung)
« Antwort #3 am: 20. Mai 2014, 21:07:03 »
schau mal in diesem Thread, im dritten Codeblock stehen meine Daten.

https://de.manjaro.org/index.php?topic=1267.msg10346#msg10346

Offline bero

  • Sr. Mitglied
  • ****
  • Beiträge: 309
  • Dankeschön: 5 mal
  • Desktop: KDE
  • Grafikkarte: Intel
  • Skill: Durchschnitt
  • Zweig: stable
Re: KDE braucht nach update 100% CPU (inkl. Lösung)
« Antwort #4 am: 20. Mai 2014, 21:37:02 »
sehr spannend.
Ich verwende eigentlich nur noch den 3.14er Kernel.

Jetzt habe ich mal spaßeshalber mit dem 3.10 gestartet und was soll ich nach einem kurzen Test sagen:
LAN geht gar nicht, WLAN Verbindungsabbrüche
aber Systemstart ok, CPU Last ok

na hätte ja sein können :-\

Offline fabdo

  • Sr. Mitglied
  • ****
  • Beiträge: 380
  • Dankeschön: 1 mal
    • fabdo.net
  • Desktop: Xfce
  • Grafikkarte: NVIDIA GTX 750
  • Grafikkartentreiber: nonfree
  • Kernel: 4.4.8
  • Prozessor: Dual core AMD Phenom II X2 550
  • Skill: Durchschnitt
  • Zweig: stable
Re: KDE braucht nach update 100% CPU (inkl. Lösung)
« Antwort #5 am: 20. Mai 2014, 21:40:22 »
kann ich auch nicht bestätigen. an beiden pcs kein problem mit updates- lief super durch, auch kein problem mit systemlast. bei mir laufen drei dinger: baloo_file , akonadi_baloo_indexer , baloo_file_extractor
Desktop: Xfce, 64bit, NVIDIA, nonfree, linux448 (stable)
Laptop: Xfce, 64bit, ATI, free, linux448 (stable)

http://fabdo.net

Offline struppi

  • Vollwertiges Mitglied
  • ***
  • Beiträge: 130
  • Dankeschön: 2 mal
  • Desktop: XFCE
  • Skill: Durchschnitt
  • Zweig: stable
Re: KDE braucht nach update 100% CPU (inkl. Lösung)
« Antwort #6 am: 20. Mai 2014, 22:25:59 »
Ich bin ja noch nicht so lange mit Manjaro unterwegs, hat man da die Wahl des Kernels?
Ich mache ein update wenn mir das System sagt, es liegen updates vor, also dürfte der Kernel aktuell sein, der angeboten wird.

Natürlich braucht man auch Daten um diesen Indexer auszulasten. Wie gesagt, das System war ein Windows XP Umzug mit einigen GB Bilder und vielen GB Musik (keine Ahnung ob Baloo da auch die Finger drauf hat, es ist ja eine "semantische Suche"). Ich nehme an, dass die Menge der Daten eine entscheidene Rolle spielt. Und vielleicht auch, ob es vorher einen Indexer gab.

Der Rechner ist auch nicht der allerneuste, nur ein Zweikern Rechner mit 1 GB Speicher. Da lief nach dem update gar nichts mehr unter KDE.

Das die updates bei anderen durchlaufen ist aber merkwürdig. Ich hatte das Problem jetzt an zwei Rechner, dass der update über den Updater der Oberfläche nicht durchlief, erst in der Konsole ging es. Auf diesen Weg: https://de.manjaro.org/index.php?topic=1267.0

Offline bero

  • Sr. Mitglied
  • ****
  • Beiträge: 309
  • Dankeschön: 5 mal
  • Desktop: KDE
  • Grafikkarte: Intel
  • Skill: Durchschnitt
  • Zweig: stable
Re: KDE braucht nach update 100% CPU (inkl. Lösung)
« Antwort #7 am: 21. Mai 2014, 08:17:25 »
Bei mir lief das Update auch nur über Konsole, dort aber eben problemlos.

Zum Thema Kernel schau mal hier:
https://wiki.manjaro.org/index.php?title=Der_Manjaro_Kernel

Offline Matthias19281

  • Held Mitglied
  • *****
  • Beiträge: 748
  • Dankeschön: 22 mal
  • Desktop: OpenBox
  • Grafikkarte: Intel (Laptop) / Nvidia (PC)
  • Grafikkartentreiber: free
  • Kernel: Kernel 3.17
  • Prozessor: Pentium B940 (Laptop) / Intel Core 2 Duo 8400 (PC)
  • Skill: Fortgeschritten
  • Zweig: unstable/stable
Re: KDE braucht nach update 100% CPU (inkl. Lösung)
« Antwort #8 am: 22. Mai 2014, 09:16:18 »
Also bei einem älteren Rechner würde ich zu XFCE, Openbox oder LXDE greifen - für die Suche auch unter KDE würde ich Synapse verwenden, tolles Werkzeug und wenn du in den genannten DEs etwas Eyecandy haben möchtest kann ich dir das Cairo-Dock empfehlen...

Openbox ist anfänglich sehr fummlig, aber wenn man sich dran gewöhnt hat will man nix mehr anderes. Bei XFCE kannst du alles klicken... LXDE ist eine Art Zwischending.
A mind is like a parachute, it doesn't work unless it's open
Frank Zappa

Offline minidiegi

  • Jr. Mitglied
  • **
  • Beiträge: 52
  • Desktop: KDE
  • Grafikkarte: NVIDIA Corporation GT218 [GeForce 210]
  • Grafikkartentreiber: 340
  • Kernel: 4.14.10-2-MANJARO
  • Skill: Anfänger
  • Zweig: stable
Re: KDE braucht nach update 100% CPU (inkl. Lösung)
« Antwort #9 am: 22. Mai 2014, 13:01:30 »
Irgendwie herrscht hier großes durcheinander...zumindest blicke ich nicht mehr durch, ich suche hier die oben angekündigte Lösung des Problems baloo.

Die verlinkte Lösung von Kubuntu passt nicht ganz. 

Die drittletzte Zeile muss lauten: echo ‘Indexing-Enabled=false’ >> $HOME/.kde4/share/config/baloofilerc
"Wer andauernd begreift, was er tut, bleibt unter seinem Niveau." Martin Walser, deutscher Schriftsteller.

Offline struppi

  • Vollwertiges Mitglied
  • ***
  • Beiträge: 130
  • Dankeschön: 2 mal
  • Desktop: XFCE
  • Skill: Durchschnitt
  • Zweig: stable
Re: KDE braucht nach update 100% CPU (inkl. Lösung)
« Antwort #10 am: 23. Mai 2014, 09:27:16 »
Zuerst: Ich wollte jetzt keine grosse Diskussion über KDE usw. führen, wie gesagt ich hab einer ehemaligen Windows Nutzerin Manjaro empfohlen und KDE war ihre Wahl als sie es sah. Das aufgetauchte Problem ist eines in den Standardeinstellungen, d.h. irgendwelche Tipps bringen da wenig. Da der User in dem Moment schon reingefallen ist.

Grundsätzlich lief aber das KDE vor dem update (der über die Konsole auch ohne Probleme klappte) einwandfrei.

Und ich kenne mich auch aus, nutze Linux jetzt seit 7 Jahren intensiv mit etlichen Desktop. Insofern weiss ich auch wie die Kernel Version finde, ich hatte mich nur gefragt ob man bei automatischen updates unterschiedliche Kernelversionen hat?

Ich habe hier nur versucht zu beschreiben, wohin manche "Verschlimmbesserungen" führen. Wie so oft: Gut gemeint ist das Gegenteil von gut!

Irgendwie herrscht hier großes durcheinander...zumindest blicke ich nicht mehr durch, ich suche hier die oben angekündigte Lösung des Problems baloo.

Die verlinkte Lösung von Kubuntu passt nicht ganz. 

Die drittletzte Zeile muss lauten: echo ‘Indexing-Enabled=false’ >> $HOME/.kde4/share/config/baloofilerc
Da ich im konkreten Fall einfach von KDE zu XFCE gewechselt bin hatte ich das nicht ausprobiert.  Aber Danke für den Hinweis.

Wobei das aber "der harte Weg" ist, laut den Programmierern reicht aber schon etwas anderes:
http://4nakama.net/2014/04/19/how-to-disable-baloo-in-latest-kde-and-kubuntu-14-04/

Offline hutlos

  • Vollwertiges Mitglied
  • ***
  • Beiträge: 144
  • Dankeschön: 4 mal
  • Desktop: KDE/Plasma
  • Kernel: 4.9
  • Prozessor: intel core i5
  • Skill: Anfänger
  • Zweig: stable
Re: KDE braucht nach update 100% CPU (inkl. Lösung)
« Antwort #11 am: 23. Mai 2014, 12:55:24 »
oder man läßt den rechner mal die nacht durchlaufen, dann ist das problem auch erledigt.

Offline struppi

  • Vollwertiges Mitglied
  • ***
  • Beiträge: 130
  • Dankeschön: 2 mal
  • Desktop: XFCE
  • Skill: Durchschnitt
  • Zweig: stable
Re: KDE braucht nach update 100% CPU (inkl. Lösung)
« Antwort #12 am: 23. Mai 2014, 13:08:17 »
oder man läßt den rechner mal die nacht durchlaufen, dann ist das problem auch erledigt.
Naja, wenn man weiss warum der Rechner nicht mehr funktioniert und wenn man den Rechner üblicherweise durchlaufen läßt und wenn man so was nutzt, mag das stimmen. Alle drei Punkte treffen hier aber nicht zu.
Ein absoluter Neuling steigt um - kaum ein 08/15 Anwender läßt seinen Rechner einfach mal so die Nacht durchlaufen (ich mach das aber auch nicht) - und nach Dateien sucht so ein Anwender auch nicht.

Das Problem ist das solche Dinge immer häufiger aufgrund der Entscheidung von "Hipster" getroffen werden, die eigentlich lieber Apple benutzen. Ich finde das auch nicht schlimm, aber ich finde es sollten sich nicht alle davon beeinderucken lassen und es muss auch Software für Anwender geben, die Selbstverantwortlich mit ihrem Werkzeug arbeiten wollen.
In dem Fall war es natürlich mein Fehler KDE zu empfehlen. Das lag aber daran, dass ich persönlich noch nie damit gearbeitet habe, weil es mir nicht gefällt.

Ich habe das ganze aufgeschrieben, weil ich nachdem ich zu Hilfe gerufen wurde, in vielen Foren genau zu diesem Thema Threads gefunden habe und vermutete, dass es dem einen oder anderen helfen würde falls man danach sucht, warum urplötzlich der Rechner blockiert ist.