Autor Thema: Windows nicht eingehängt?  (Gelesen 1070 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Offline crankbunnyhopp

  • Neuling
  • *
  • Beiträge: 9
  • Skill: Anfänger
Windows nicht eingehängt?
« am: 02. Dezember 2014, 11:52:58 »
Hallo,

heute melde ich mich mit meinem letzten problem unter manjaro xfce (sorry aber bin noch anfänger also hab kA)

Auf meinem Desktop gibt es zwei Verknüpfungen, die warsch. meine Windows Partition anzeigen. diese sollen da vom desktop weg. wenn ich die verknüpfungen anklicke spuckt es jeweils diese Fehlermeldungen aus.

1. Error mounting /dev/sda2 at /run/media/daniel/988A55EB8A55C682: Command-line `mount -t "ntfs" -o "uhelper=udisks2,nodev,nosuid,uid=1000,gid=100,dmask=0077,fmask=0177" "/dev/sda2" "/run/media/daniel/988A55EB8A55C682"' exited with non-zero exit status 14: The disk contains an unclean file system (0, 0).
Metadata kept in Windows cache, refused to mount.
Failed to mount '/dev/sda2': Die Operation ist nicht erlaubt
The NTFS partition is in an unsafe state. Please resume and shutdown
Windows fully (no hibernation or fast restarting), or mount the volume
read-only with the 'ro' mount option.

2. Error mounting /dev/sda1 at /run/media/daniel/System-reserviert: Command-line `mount -t "ntfs" -o "uhelper=udisks2,nodev,nosuid,uid=1000,gid=100,dmask=0077,fmask=0177" "/dev/sda1" "/run/media/daniel/System-reserviert"' exited with non-zero exit status 14: The disk contains an unclean file system (0, 0).
Metadata kept in Windows cache, refused to mount.
Failed to mount '/dev/sda1': Die Operation ist nicht erlaubt
The NTFS partition is in an unsafe state. Please resume and shutdown
Windows fully (no hibernation or fast restarting), or mount the volume
read-only with the 'ro' mount option.


Der eine Datenträger hat 505 gb und der andere ist windows system reserviert.

Danke schonmal für die schnelle und freundliche Hilfe hier

Offline klesk

  • Held Mitglied
  • *****
  • Beiträge: 1194
  • Dankeschön: 142 mal
  • Desktop: herbstluftwm
  • Grafikkartentreiber: nvidia 3.40xx
  • Kernel: 4.2
  • Prozessor: Intel Core2 Quad Q9550 (-MCP-)
  • Skill: Durchschnitt
  • Zweig: unstable
Re: Windows nicht eingehängt?
« Antwort #1 am: 02. Dezember 2014, 14:32:08 »
Hab jetzt hier leider nur die Englischen Bezeichnungen, hoffe du verstehst trotzdem was ich meine. Du hast hier natürlich mehrere Möglichkeiten wie du vorgehst.
Die erste wäre sie einfach nur zu verstecken über einen rechts klick auf den Desktop --> Desktop Einstellungen ( Desktop Settings) --> Icons --> Default Icons und dort den bisschen mit den Haken bei Removable Drives rumspielen (Disk and Drives müsste es sein).

Eine weitere Möglichkeit wäre, zu der ich raten würde, die 505 GB Partition über die /etc/fstab automatisch zu mounten. Datenspeicher braucht man immer :)
Dafür wäre ein Eintrag in der Fstab nötig der z.b so aussieht -->

UUID=D288ECCC88ECB061           /media/Windows    ntfs-3g         defaults,noatime,uid=1000       0 0

Die UUID bekommst du über die ausgabe von

blkid

Sind natürlich nur Exemplarische Optionen, wie ich sie z.b für NTFS nutze. Kannst natürlich z.b auch

noauto,rw

anstatt default. Gibt da verschiedenste Möglichkeiten. Die System-Reserviert kannst du dann über z.b

sudo mousepad /etc/udev/rules.d/10-local.rules

KERNEL=="sda1",ENV{UDISKS_IGNORE}="1"

verstecken. Dann wird sie gar nicht mehr unter Linux beachtet.
Hab leider selber kein XFCE. Eventuell hat einer noch bessere Vorschläge dafür.

Offline crankbunnyhopp

  • Neuling
  • *
  • Beiträge: 9
  • Skill: Anfänger
Re: Windows nicht eingehängt?
« Antwort #2 am: 02. Dezember 2014, 17:39:42 »
vielen Dank für die Hilfe :) aber jetzt muss ich erstmal wieder manjaro zum starten bringen. hat plötzlich nicht mehr gestartet aber das dürfte ich dann selbst wieder hinbekommen.