Autor Thema: Programm ohne Sudo Passwort starten  (Gelesen 4061 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Offline joerg1702

  • Neuling
  • *
  • Beiträge: 45
  • Desktop: XFCE
  • Grafikkarte: Gainwaard 210
  • Grafikkartentreiber: free
  • Kernel: 3.16
  • Prozessor: AMD Athlon(tm) II X2 240 Processor
  • Skill: Anfänger
  • Zweig: stable
Programm ohne Sudo Passwort starten
« am: 17. Dezember 2014, 09:34:47 »
Diesen Befehl sudo java -jar /home/joerg/Shutdown_3.0.1.jar hide möchte ich im Autostart stecken,in rc local geht es nicht.
Dann habe ich diesen Eintrag joerg ALL = NOPASSWD: /usr/bin/java -jar /home/joerg/Shutdown_3.0.1.jar hidein Sudoers gemacht funktioniert komischerweise auch nicht oder hab ich noch was vergessen?

Offline sam

  • Held Mitglied
  • *****
  • Beiträge: 598
  • Dankeschön: 27 mal
  • Desktop: MATE, KDE, Xfce, Openbox, Fluxbox
  • Grafikkarte: Intel Corporation 4 Series Chipset Integrated Graphics Controller (rev 03)
  • Grafikkartentreiber: free
  • Prozessor: Intel® Core™2 Quad CPU @ 4× 2.666GHz
  • Skill: Fortgeschritten
  • Zweig: stable
Re: Programm ohne Sudo Passwort starten
« Antwort #1 am: 17. Dezember 2014, 10:29:20 »
Die /etc/rc.local wird von Systemd von Haus aus ignoriert.
Wie es trotzdem klappt, kannst Du z.B. hier lesen: https://raymii.org/s/tutorials/rc.local_support_on_Arch_Linux_and_systemd.html

Offline klesk

  • Held Mitglied
  • *****
  • Beiträge: 1194
  • Dankeschön: 142 mal
  • Desktop: herbstluftwm
  • Grafikkartentreiber: nvidia 3.40xx
  • Kernel: 4.2
  • Prozessor: Intel Core2 Quad Q9550 (-MCP-)
  • Skill: Durchschnitt
  • Zweig: unstable
Re: Programm ohne Sudo Passwort starten
« Antwort #2 am: 17. Dezember 2014, 10:33:46 »
Für den Sudoers Eintrag, probiere mal ein Befehlsalias zu erstellen

Cmnd_Alias JSHUTDOWN = /usr/bin/java -jar /home/joerg/Shutdown_3.0.1.jar hide
joerg ALL = NOPASSWD: JSHUTDOWN

Offline joerg1702

  • Neuling
  • *
  • Beiträge: 45
  • Desktop: XFCE
  • Grafikkarte: Gainwaard 210
  • Grafikkartentreiber: free
  • Kernel: 3.16
  • Prozessor: AMD Athlon(tm) II X2 240 Processor
  • Skill: Anfänger
  • Zweig: stable
Re: Programm ohne Sudo Passwort starten
« Antwort #3 am: 17. Dezember 2014, 10:41:18 »
rc-local.service diesen Eintrag gibts auch nicht mehr deswegen kann ich ihn auch nicht bearbeiten.

Offline sam

  • Held Mitglied
  • *****
  • Beiträge: 598
  • Dankeschön: 27 mal
  • Desktop: MATE, KDE, Xfce, Openbox, Fluxbox
  • Grafikkarte: Intel Corporation 4 Series Chipset Integrated Graphics Controller (rev 03)
  • Grafikkartentreiber: free
  • Prozessor: Intel® Core™2 Quad CPU @ 4× 2.666GHz
  • Skill: Fortgeschritten
  • Zweig: stable
Re: Programm ohne Sudo Passwort starten
« Antwort #4 am: 17. Dezember 2014, 10:50:24 »
Richtig, den gibt es nicht. Deswegen musst Du selbst einen erstellen.

Edit:
Und den Befehl in der rc.local dann ohne "sudo" eintragen.
« Letzte Änderung: 17. Dezember 2014, 10:52:36 von sam »

Offline joerg1702

  • Neuling
  • *
  • Beiträge: 45
  • Desktop: XFCE
  • Grafikkarte: Gainwaard 210
  • Grafikkartentreiber: free
  • Kernel: 3.16
  • Prozessor: AMD Athlon(tm) II X2 240 Processor
  • Skill: Anfänger
  • Zweig: stable
Re: Programm ohne Sudo Passwort starten
« Antwort #5 am: 17. Dezember 2014, 22:00:20 »
Mit Sudoers komm ich schon mal nicht weiter er reagiert da drauf nicht frage mich nur warum.

Offline sam

  • Held Mitglied
  • *****
  • Beiträge: 598
  • Dankeschön: 27 mal
  • Desktop: MATE, KDE, Xfce, Openbox, Fluxbox
  • Grafikkarte: Intel Corporation 4 Series Chipset Integrated Graphics Controller (rev 03)
  • Grafikkartentreiber: free
  • Prozessor: Intel® Core™2 Quad CPU @ 4× 2.666GHz
  • Skill: Fortgeschritten
  • Zweig: stable
Re: Programm ohne Sudo Passwort starten
« Antwort #6 am: 17. Dezember 2014, 22:21:33 »
Um es dir etwas einfacher zu machen, hier die Befehle, die Du brauchst, damit die rc.local funktioniert:
1.cat << EOF | sudo tee /etc/systemd/system/rc-local.service
[Unit]
Description=/etc/rc.local compatibility

[Service]
Type=oneshot
ExecStart=/etc/rc.local
RemainAfterExit=yes

[Install]
WantedBy=multi-user.target
EOF
(per Copy&Paste ins Terminal-Fenster kopieren)
Erstellt die Service-Datei

2. sudo systemctl enable rc-localAktiviert den Service

3.
In die /etc/rc.local trägst Du dann den Befehl ein:/usr/bin/java -jar /home/joerg/Shutdown_3.0.1.jar hideund startest das System neu.

Offline joerg1702

  • Neuling
  • *
  • Beiträge: 45
  • Desktop: XFCE
  • Grafikkarte: Gainwaard 210
  • Grafikkartentreiber: free
  • Kernel: 3.16
  • Prozessor: AMD Athlon(tm) II X2 240 Processor
  • Skill: Anfänger
  • Zweig: stable
Re: Programm ohne Sudo Passwort starten
« Antwort #7 am: 18. Dezember 2014, 09:51:50 »
Trotz dieses schönen Scripts kommt am ende das raus.
[joerg@manjaro-xfce ~]$ sudo systemctl enable rc-local
[sudo] password for joerg:
Failed to execute operation: File exists
[joerg@manjaro-xfce ~]$

Offline sam

  • Held Mitglied
  • *****
  • Beiträge: 598
  • Dankeschön: 27 mal
  • Desktop: MATE, KDE, Xfce, Openbox, Fluxbox
  • Grafikkarte: Intel Corporation 4 Series Chipset Integrated Graphics Controller (rev 03)
  • Grafikkartentreiber: free
  • Prozessor: Intel® Core™2 Quad CPU @ 4× 2.666GHz
  • Skill: Fortgeschritten
  • Zweig: stable
Re: Programm ohne Sudo Passwort starten
« Antwort #8 am: 18. Dezember 2014, 10:13:29 »
Trotz dieses schönen Scripts kommt am ende das raus.
[joerg@manjaro-xfce ~]$ sudo systemctl enable rc-local
[sudo] password for joerg:
Failed to execute operation: File exists
Probier:sudo systemctl disable rc-localund danach wiedersudo systemctl enable rc-local

Offline joerg1702

  • Neuling
  • *
  • Beiträge: 45
  • Desktop: XFCE
  • Grafikkarte: Gainwaard 210
  • Grafikkartentreiber: free
  • Kernel: 3.16
  • Prozessor: AMD Athlon(tm) II X2 240 Processor
  • Skill: Anfänger
  • Zweig: stable
Re: Programm ohne Sudo Passwort starten
« Antwort #9 am: 18. Dezember 2014, 11:05:06 »
Keine Chance mit der rc local habe gerade mal mit Sudoers probiert Manjaro reagiert nicht das gleiche nochmal mit Sudoers am Linux Mint 17 XFCE getestet und da war es ein voller Erfolg das verstehe ich absolut nicht.

Offline sam

  • Held Mitglied
  • *****
  • Beiträge: 598
  • Dankeschön: 27 mal
  • Desktop: MATE, KDE, Xfce, Openbox, Fluxbox
  • Grafikkarte: Intel Corporation 4 Series Chipset Integrated Graphics Controller (rev 03)
  • Grafikkartentreiber: free
  • Prozessor: Intel® Core™2 Quad CPU @ 4× 2.666GHz
  • Skill: Fortgeschritten
  • Zweig: stable
Re: Programm ohne Sudo Passwort starten
« Antwort #10 am: 18. Dezember 2014, 12:44:01 »
Probier
sudo systemctl -f enable rc-local
Falls das wieder nicht funktioniert, beschreibe bitte was Du davor gemacht hast (also jetzt nicht mit sudoers, sondern nur mit rc.local).  Den Fehler kann ich bei mir nicht reproduzieren.

Poste bitte auch die Ausgabe von ls -l `find / -name "rc-local*" 2>/dev/null`
« Letzte Änderung: 18. Dezember 2014, 12:45:46 von sam »

Offline joerg1702

  • Neuling
  • *
  • Beiträge: 45
  • Desktop: XFCE
  • Grafikkarte: Gainwaard 210
  • Grafikkartentreiber: free
  • Kernel: 3.16
  • Prozessor: AMD Athlon(tm) II X2 240 Processor
  • Skill: Anfänger
  • Zweig: stable
Re: Programm ohne Sudo Passwort starten
« Antwort #11 am: 18. Dezember 2014, 14:17:27 »
Mit Clonezilla die Kiste wieder im Urzustand gebracht und dannwieder ganz von vorn angefangen,diese Fehlermeldung war nicht mehr aber das Programm kommt auch nicht. Hier das Ergebnis

[joerg@manjaro-xfce ~]$ sudo systemctl -f enable rc-local
[sudo] password for joerg:
[joerg@manjaro-xfce ~]$ ls -l `find / -name "rc-local*" 2>/dev/null`
lrwxrwxrwx 1 root root  36 18.12.2014 13:56 /etc/systemd/system/multi-user.target.wants/rc-local.service -> /etc/systemd/system/rc-local.service
-rw-r--r-- 1 root root 153 18.12.2014 13:55 /etc/systemd/system/rc-local.service

/sys/fs/cgroup/devices/system.slice/rc-local.service:
insgesamt 0
-rw-r--r-- 1 root root 0 18.12.2014 14:02 cgroup.clone_children
-rw-r--r-- 1 root root 0 18.12.2014 14:02 cgroup.procs
--w------- 1 root root 0 18.12.2014 13:59 devices.allow
--w------- 1 root root 0 18.12.2014 14:02 devices.deny
-r--r--r-- 1 root root 0 18.12.2014 14:02 devices.list
-rw-r--r-- 1 root root 0 18.12.2014 14:02 notify_on_release
-rw-r--r-- 1 root root 0 18.12.2014 14:02 tasks

/sys/fs/cgroup/systemd/system.slice/rc-local.service:
insgesamt 0
-rw-r--r-- 1 root root 0 18.12.2014 14:02 cgroup.clone_children
-rw-r--r-- 1 root root 0 18.12.2014 13:59 cgroup.procs
-rw-r--r-- 1 root root 0 18.12.2014 14:02 notify_on_release
-rw-r--r-- 1 root root 0 18.12.2014 14:02 tasks
[joerg@manjaro-xfce ~]$
« Letzte Änderung: 18. Dezember 2014, 14:20:52 von joerg1702 »

Offline sam

  • Held Mitglied
  • *****
  • Beiträge: 598
  • Dankeschön: 27 mal
  • Desktop: MATE, KDE, Xfce, Openbox, Fluxbox
  • Grafikkarte: Intel Corporation 4 Series Chipset Integrated Graphics Controller (rev 03)
  • Grafikkartentreiber: free
  • Prozessor: Intel® Core™2 Quad CPU @ 4× 2.666GHz
  • Skill: Fortgeschritten
  • Zweig: stable
Re: Programm ohne Sudo Passwort starten
« Antwort #12 am: 18. Dezember 2014, 14:42:39 »
Sieht okay aus und sollte funktionieren.

Testen kannst Du das, indem Du das hier in die rc.local einträgstecho "Test" > /home/joerg/test.txtwenn nach einem Systemneustart die Datei test.txt in Deinem Homeverzeichnis liegt, funktioniert rc.local.

Wenn Dein Java-Programm nicht startet, dann liegt es vermutlich entweder daran, dass es gar nicht funktioniert oder dass es nur unter X funktioniert.
Welche Funktion soll das Programm haben?

Offline joerg1702

  • Neuling
  • *
  • Beiträge: 45
  • Desktop: XFCE
  • Grafikkarte: Gainwaard 210
  • Grafikkartentreiber: free
  • Kernel: 3.16
  • Prozessor: AMD Athlon(tm) II X2 240 Processor
  • Skill: Anfänger
  • Zweig: stable
Re: Programm ohne Sudo Passwort starten
« Antwort #13 am: 18. Dezember 2014, 15:04:00 »
Der Test funktioniert die rc.local istok,das Programm startet immer noch nicht aber es funktioniert per Terminal und bei Mint steckt es in Sudoers da funktioniert es auch.
Was das Ding macht guckst du hier http://www.android-powerpoint.com/shutdown/

Offline sam

  • Held Mitglied
  • *****
  • Beiträge: 598
  • Dankeschön: 27 mal
  • Desktop: MATE, KDE, Xfce, Openbox, Fluxbox
  • Grafikkarte: Intel Corporation 4 Series Chipset Integrated Graphics Controller (rev 03)
  • Grafikkartentreiber: free
  • Prozessor: Intel® Core™2 Quad CPU @ 4× 2.666GHz
  • Skill: Fortgeschritten
  • Zweig: stable
Re: Programm ohne Sudo Passwort starten
« Antwort #14 am: 18. Dezember 2014, 15:13:54 »
Also zum ferngesteuerten Ausschalten Deines Rechners? Brauchst Du dafür Root-Rechte?
Das geht doch auch ohne Root-Rechte:systemctl haltodersystemctl poweroff