Autor Thema: Updateproblem pacman-Version  (Gelesen 1076 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Offline oehajo

  • Neuling
  • *
  • Beiträge: 3
  • Skill: Anfänger
Updateproblem pacman-Version
« am: 04. Januar 2015, 20:31:08 »
Vielleicht das falsche Forum, wenn ja bitte verschieben. Nutze seit ca. zwei Wochen die 0.90-Testversion der XFCE-Ausgabe. Lief bisher sehr rund. Aber heute plötzlich kein Update mehr möglich. Folgende Meldung erscheint:
::
Die folgenden Pakete sollten zuerst aktualisiert werden :
    pacman
:: Möchten Sie den laufenden Prozess abbrechen
:: und diese Pakete nun aktualisieren? [J/n] j

Löse Abhängigkeiten auf...
Suche nach Zwischenkonflikten...
Fehler: Konnte den Vorgang nicht vorbereiten (Kann Abhängigkeiten nicht erfüllen)
:: package-query: benötigt pacman<4.2

Der Aktualisierungsmanager funktioniert deshalb ebenfalls nicht.
Gibt es eine Problemlösung?

Danke und Gutes Neues!

Offline klesk

  • Held Mitglied
  • *****
  • Beiträge: 1194
  • Dankeschön: 142 mal
  • Desktop: herbstluftwm
  • Grafikkartentreiber: nvidia 3.40xx
  • Kernel: 4.2
  • Prozessor: Intel Core2 Quad Q9550 (-MCP-)
  • Skill: Durchschnitt
  • Zweig: unstable
Re: Updateproblem pacman-Version
« Antwort #1 am: 04. Januar 2015, 20:33:58 »
Schau dir den Beitrag an, sollte dein Problem lösen

[Update] 2015-01-03 - Pacman 4.2, Pamac 2.1, pyalpm 0.7, Kodi 14.0

Hier findest du im allgemeinen meistens eine Lösung für Probleme bei Unstable Updates

Unstable Updates
« Letzte Änderung: 04. Januar 2015, 20:36:32 von klesk »

Offline oehajo

  • Neuling
  • *
  • Beiträge: 3
  • Skill: Anfänger
Re: Updateproblem pacman-Version
« Antwort #2 am: 04. Januar 2015, 21:16:34 »
Danke für die schnelle Antwort.
Ging im englischen Forum genauso schnell.
Tolle Benutzergemeinschaft!
Die rettende Lösung war:

ok I have fixed by pressing NO during the upgrade...

I had some error doing the XBMC
error: failed to commit transaction (conflicting files)
kodi: /usr/include/xbmc exists in filesystem
kodi: /usr/lib/xbmc exists in filesystem
kodi: /usr/share/xbmc exists in filesystem
Errors occurred, no packages were upgraded.

Then I did it again by not selecting the XBMC

Did the pacman installation and after that I did the

[root@W wolf]# sudo pacman-db-upgrade
==> Pre-4.2 database format detected - upgrading...

Then everything worked

Frage nach dem pacman-update mit n beantworten.
Update durchlaufen lassen.
Danach sudo pacman-db-upgrade.
Alles wieder in Ordnung.