Autor Thema: "black screen" nach dem Booten  (Gelesen 3878 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Offline Croyd

  • Neuling
  • *
  • Beiträge: 4
  • Desktop: xfce
  • Skill: Anfänger
  • Zweig: stable
"black screen" nach dem Booten
« am: 17. September 2013, 12:16:52 »
Hallo allerseits,

ich habe mir kürzlich Manjaro 3.7.1 Xfce neu installiert. Leider erhalte ich aber ab dem Booten des Kernels (nach GRUB) nurnoch einen schwarzen Bildschirm. Das Problem ist mir prinzipiell nicht unbekannt und tritt bei allen Linuxdistributionen ab einer bestimmten Kernel-Version bei mir auf. Ein gut funktionierender Workaround wird hier geschildert:

Zitat
Comment 24 for bug #744187
I got this working with the following workarounds that have been previously mentioned:
1. Hold down shift to bring up the grub menu at startup - add "nomodeset" to the kernel options. System boots up although the correct resolution is not detected, this is just temporary to make the following changes...
2. Add "setpci -s 00:02.0 F4.B=00" to /etc/rc.local
3. On reboot after step 2 the brightness was stuck at maximum, so I added "acpi_osi=Linux acpi_backlight=legacy" to the kernel parameters in /boot/grub/grub.cfg
4. On reboot, screen is the correct resolution and the brightness keys work (although the on-screen brightness bar no longer appears but I can live with that).

Mein Problem ist nun, dass ich trotz Allem nach dem Booten einen schwarzen Bildschirm kriege. Es ist dann zwar möglich "blind" in eine Text-Terminal zu wechseln, sich als root anzumelden und den Befehl manuell zu starten (dannach lässt sich Manjaro einwandfrei verwenden), jedoch kann dass ja nicht das Ende meiner Möglichkeiten sein.

Hat jemand eine Idee, wieso rc.local nicht ordnungsgemäß ausgeführt wird?

Danke schonmal an alle, die sich mit dem Problem beschäftigen.

Offline Verändert

  • Support Team
  • *****
  • Beiträge: 1154
  • Dankeschön: 63 mal
  • Ni Dieu ni maître
  • Desktop: Gnome. LXQt. i3.
  • Grafikkarte: Intel & Radeon & NVidia
  • Grafikkartentreiber: frei natürlich
  • Kernel: Immer der aktuelle.
  • Prozessor: Intel Celeron und andere.
  • Skill: Anfänger
  • Zweig: unstable
Re: "black screen" nach dem Booten
« Antwort #1 am: 18. September 2013, 07:03:20 »
Es würde helfen, wenn wir wüssten, was für eine Hardware Du nutzt und welche Treiber.

Offline Croyd

  • Neuling
  • *
  • Beiträge: 4
  • Desktop: xfce
  • Skill: Anfänger
  • Zweig: stable
Re: "black screen" nach dem Booten
« Antwort #2 am: 18. September 2013, 09:47:54 »
Hallo,

meine Hardware ist die folgende:
# lspci -nnk
00:00.0 Host bridge [0600]: Intel Corporation Mobile 4 Series Chipset Memory Controller Hub [8086:2a40] (rev 07)
Subsystem: Acer Incorporated [ALI] Device [1025:048a]
Kernel driver in use: agpgart-intel
Kernel modules: intel_agp
00:02.0 VGA compatible controller [0300]: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller [8086:2a42] (rev 07)
Subsystem: Acer Incorporated [ALI] Device [1025:048a]
Kernel driver in use: i915
Kernel modules: i915
00:02.1 Display controller [0380]: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller [8086:2a43] (rev 07)
Subsystem: Acer Incorporated [ALI] Device [1025:048a]
00:1a.0 USB controller [0c03]: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #4 [8086:2937] (rev 03)
Subsystem: Acer Incorporated [ALI] Device [1025:048a]
Kernel driver in use: uhci_hcd
Kernel modules: uhci_hcd
00:1a.1 USB controller [0c03]: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #5 [8086:2938] (rev 03)
Subsystem: Acer Incorporated [ALI] Device [1025:048a]
Kernel driver in use: uhci_hcd
Kernel modules: uhci_hcd
00:1a.7 USB controller [0c03]: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #2 [8086:293c] (rev 03)
Subsystem: Acer Incorporated [ALI] Device [1025:048a]
Kernel driver in use: ehci-pci
Kernel modules: ehci_pci
00:1b.0 Audio device [0403]: Intel Corporation 82801I (ICH9 Family) HD Audio Controller [8086:293e] (rev 03)
Subsystem: Acer Incorporated [ALI] Device [1025:048a]
Kernel driver in use: snd_hda_intel
Kernel modules: snd_hda_intel
00:1c.0 PCI bridge [0604]: Intel Corporation 82801I (ICH9 Family) PCI Express Port 1 [8086:2940] (rev 03)
Kernel driver in use: pcieport
Kernel modules: shpchp
00:1c.1 PCI bridge [0604]: Intel Corporation 82801I (ICH9 Family) PCI Express Port 2 [8086:2942] (rev 03)
Kernel driver in use: pcieport
Kernel modules: shpchp
00:1c.2 PCI bridge [0604]: Intel Corporation 82801I (ICH9 Family) PCI Express Port 3 [8086:2944] (rev 03)
Kernel driver in use: pcieport
Kernel modules: shpchp
00:1d.0 USB controller [0c03]: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #1 [8086:2934] (rev 03)
Subsystem: Acer Incorporated [ALI] Device [1025:048a]
Kernel driver in use: uhci_hcd
Kernel modules: uhci_hcd
00:1d.1 USB controller [0c03]: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #2 [8086:2935] (rev 03)
Subsystem: Acer Incorporated [ALI] Device [1025:048a]
Kernel driver in use: uhci_hcd
Kernel modules: uhci_hcd
00:1d.2 USB controller [0c03]: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #3 [8086:2936] (rev 03)
Subsystem: Acer Incorporated [ALI] Device [1025:048a]
Kernel driver in use: uhci_hcd
Kernel modules: uhci_hcd
00:1d.3 USB controller [0c03]: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #6 [8086:2939] (rev 03)
Subsystem: Acer Incorporated [ALI] Device [1025:048a]
Kernel driver in use: uhci_hcd
Kernel modules: uhci_hcd
00:1d.7 USB controller [0c03]: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #1 [8086:293a] (rev 03)
Subsystem: Acer Incorporated [ALI] Device [1025:048a]
Kernel driver in use: ehci-pci
Kernel modules: ehci_pci
00:1e.0 PCI bridge [0604]: Intel Corporation 82801 Mobile PCI Bridge [8086:2448] (rev 93)
00:1f.0 ISA bridge [0601]: Intel Corporation ICH9M LPC Interface Controller [8086:2919] (rev 03)
Subsystem: Acer Incorporated [ALI] Device [1025:048a]
Kernel driver in use: lpc_ich
Kernel modules: lpc_ich
00:1f.2 SATA controller [0106]: Intel Corporation 82801IBM/IEM (ICH9M/ICH9M-E) 4 port SATA Controller [AHCI mode] [8086:2929] (rev 03)
Subsystem: Acer Incorporated [ALI] Device [1025:048a]
Kernel driver in use: ahci
Kernel modules: ahci
00:1f.3 SMBus [0c05]: Intel Corporation 82801I (ICH9 Family) SMBus Controller [8086:2930] (rev 03)
Subsystem: Acer Incorporated [ALI] Device [1025:048a]
Kernel driver in use: i801_smbus
Kernel modules: i2c_i801
04:00.0 Network controller [0280]: Broadcom Corporation BCM43225 802.11b/g/n [14e4:4357] (rev 01)
Subsystem: Foxconn International, Inc. T77H103.00 Wireless Half-size Mini PCIe Card [105b:e021]
Kernel driver in use: bcma-pci-bridge
Kernel modules: bcma
05:00.0 Ethernet controller [0200]: Broadcom Corporation NetLink BCM57780 Gigabit Ethernet PCIe [14e4:1692] (rev 01)
Subsystem: Acer Incorporated [ALI] Device [1025:048a]
Kernel driver in use: tg3
Kernel modules: tg3

Falls Ihr noch etwas benötigt fragt einfach.
Danke!

Gruß, Croyd

Offline Verändert

  • Support Team
  • *****
  • Beiträge: 1154
  • Dankeschön: 63 mal
  • Ni Dieu ni maître
  • Desktop: Gnome. LXQt. i3.
  • Grafikkarte: Intel & Radeon & NVidia
  • Grafikkartentreiber: frei natürlich
  • Kernel: Immer der aktuelle.
  • Prozessor: Intel Celeron und andere.
  • Skill: Anfänger
  • Zweig: unstable
Re: "black screen" nach dem Booten
« Antwort #3 am: 18. September 2013, 10:56:55 »
Hui, ein schon etwas älteres Schätzchen. Sei's drum, prinzipiell funktioniert es ja. Als root kannst Du Dich anmelden. Siehst Du schon beim booten nichts ? Dann ist vermutlich Plymouth schuld. Oder erst beim Anmelden ? Dann müssen wir wohl MDM durch was anderes ersetzen.

Offline Croyd

  • Neuling
  • *
  • Beiträge: 4
  • Desktop: xfce
  • Skill: Anfänger
  • Zweig: stable
Re: "black screen" nach dem Booten
« Antwort #4 am: 18. September 2013, 14:53:21 »
Der Bildschirm steigt während des Bootens aus. Ich kriege noch die Meldung
     /dev/sda4 ...irgendwas... clean blocks
dannach wird er schwarz.

Da die Bootoption nomodeset Abhilfe schafft vermute ich, dass das Problem beim KMS liegt. Nur kann ich ohne Modesetting keine GUI betreiben.
Es stört mich allerdings nicht sonderlich, dass mein Bildschirm beim Hochfahren schwarz bleibt. Bisher hat es immer geklappt, dass ich den oben beschriebenen Befehl in /etc/rc.local eingtragen habe. Dieser wurde dann mit Laden des Display Managers ausgeführt und hat meinen Bildschirm wieder "angeknipst".

Da auch ich anfangs das Problem bei MDM (zumindest, warum rc.local nicht startet) gesucht habe, habe ich diesen mittlerweile durch lxdm erstetzt. Den gewünschten Effekt hat das aber auch nicht gebracht.

Danke für Deine Überlegungen. Ich hoffe ich konnte noch einige nützliche Infos geben.

Offline Pig of Destiny

  • Held Mitglied
  • *****
  • Beiträge: 1383
  • Dankeschön: 125 mal
  • Desktop: Xfce
  • Grafikkarte: Intel Graphics
  • Grafikkartentreiber: free
  • Kernel: 4.16
  • Prozessor: Intel Celeron N3350
  • Skill: Durchschnitt
  • Zweig: Arch Linux
Re: "black screen" nach dem Booten
« Antwort #5 am: 18. September 2013, 19:43:34 »
Mit nem Eintrag in die rc.local wirst du wohl Pech haben. Die wird seit systemd nicht mehr genutzt.
Hier in dem Thread aus dem Arch-Forum geht es auch um nen quasi-rc.local-Ersatz mit systemd:
https://bbs.archlinux.de/viewtopic.php?id=21655
Vll. hilft er dir ja weiter.

Offline Croyd

  • Neuling
  • *
  • Beiträge: 4
  • Desktop: xfce
  • Skill: Anfänger
  • Zweig: stable
Re: "black screen" nach dem Booten
« Antwort #6 am: 18. September 2013, 23:40:03 »
Es funktioniert!  ;D

Ich habe jetzt ohne rechtes Verständnis mit der Vorlage in dem Forum und dem Archlinux-Wiki einen eigenen Service /etc/systemd/system/fix-blackscreen.service erstellt:

[Unit]
Description=Fixing black screen

[Service]
Type=oneshot
ExecStart=/usr/local/bin/fix-blackscreen.sh

[Install]
WantedBy=multi-user.target


Die Datei fix-blackscreen.sh enthält dabei:

#!/bin/bash
setpci -s 00:02.0 F4.B=0


Anschließend habe ich den Service gestartet...
# sudo systemctl enable fix-blackscreen.service
Der Bildschirm wird zu Beginn des Bootvorgangs zwar immernoch schwarz, reaktiviert sich aber noch vor dem Laden des Display Managers wieder.
Für mich ist das Problem damit gelöst.  ;D

Danke für die hilfreichen Posts und die letztendlich zielführenden Hinweise.

Gruß, Croyd

Offline Pig of Destiny

  • Held Mitglied
  • *****
  • Beiträge: 1383
  • Dankeschön: 125 mal
  • Desktop: Xfce
  • Grafikkarte: Intel Graphics
  • Grafikkartentreiber: free
  • Kernel: 4.16
  • Prozessor: Intel Celeron N3350
  • Skill: Durchschnitt
  • Zweig: Arch Linux
Re: "black screen" nach dem Booten
« Antwort #7 am: 19. September 2013, 06:41:23 »
Schön, dass es geklappt hat  ;D