Autor Thema: Nach Update Keyboard-Layout geändert  (Gelesen 2040 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Offline digitus

  • Held Mitglied
  • *****
  • Beiträge: 744
  • Dankeschön: 12 mal
  • Life is too short for defective software.
    • Diaspora-Profil
  • Desktop: XFCE
  • Grafikkarte: Intel HD 4600
  • Grafikkartentreiber: intel
  • Kernel: 4.6
  • Prozessor: Intel Core i5-4590
  • Skill: Durchschnitt
  • Zweig: stable
Nach Update Keyboard-Layout geändert
« am: 15. März 2015, 23:45:46 »
Liebe Leute,

nachdem mich systemd am Desktop-PC zunehmend ärgert (siehe Bootzeit-Thread), teste ich gerade die OpenRC-Edition in der VM.

Beim Update erzählte mir Pacman irgendwann, dass das Keyboard-Layout nun anderweitig verwaltet werde und ich beim nächsten Start die Einstellungen anpassen solle. Ich komme (da auch die automatische Anmeldung deaktiviert wurde) garnicht mehr über den Anmeldebildschirm hinaus, weil mein PW nicht akzeptiert wird, obwohl ich es so eingetippt habe, wie es nach dem gemutmaßten US-Layout passen sollte.

Was mache ich nun? Kann ich über die Konsole gehen?

Ratlose Grüße,
Andreas
MANJARO - not just a rolling release but also a rocking distribution!

GypsyWolve

  • Gast
Re: Nach Update Keyboard-Layout geändert
« Antwort #1 am: 16. März 2015, 01:54:48 »
Wenn du auf Konsole kommst

yaourt xfce4-session-consolekit
und

yaourt xfce4-power-manager-upower
installieren. Darauf achten das du die AUR Pakete waehlst.

reboot.


Viel Glueck


GW

Offline digitus

  • Held Mitglied
  • *****
  • Beiträge: 744
  • Dankeschön: 12 mal
  • Life is too short for defective software.
    • Diaspora-Profil
  • Desktop: XFCE
  • Grafikkarte: Intel HD 4600
  • Grafikkartentreiber: intel
  • Kernel: 4.6
  • Prozessor: Intel Core i5-4590
  • Skill: Durchschnitt
  • Zweig: stable
Re: Nach Update Keyboard-Layout geändert
« Antwort #2 am: 16. März 2015, 07:44:41 »
Ich schaffe es garnicht in die Konsole ... mit Strg - Alt - Fx komme ich lediglich in die Konsolen des Host-Systems ...

Ich setze jetzt mal die VM neu auf und installiere die von Dir genannten Pakete vor dem Neustart. Komme ich dann um das Problem herum?

Versuch macht kluch :)

CU,
Andreas
MANJARO - not just a rolling release but also a rocking distribution!

Offline digitus

  • Held Mitglied
  • *****
  • Beiträge: 744
  • Dankeschön: 12 mal
  • Life is too short for defective software.
    • Diaspora-Profil
  • Desktop: XFCE
  • Grafikkarte: Intel HD 4600
  • Grafikkartentreiber: intel
  • Kernel: 4.6
  • Prozessor: Intel Core i5-4590
  • Skill: Durchschnitt
  • Zweig: stable
Re: Nach Update Keyboard-Layout geändert
« Antwort #3 am: 16. März 2015, 08:33:04 »
==> Installiere oder erstelle Abhängigkeiten von xfce4-session-consolekit:
Fehler: Ziel nicht gefunden: libxfce4ui>=4.12.1

libxfce4ui 4.12.1 finde ich garnicht :(

4.12.0-1 ist instaliert ...

Grüße,
Andreas
MANJARO - not just a rolling release but also a rocking distribution!

GypsyWolve

  • Gast
Re: Nach Update Keyboard-Layout geändert
« Antwort #4 am: 16. März 2015, 09:30:16 »
Sitze derzeit mit Arch in Aktion fest. Kann z.Zt.<nicht zu Manjaro wechseln.

Unter Arch sagt er mir

==> xfce4-session-consolekit dependencies:
 - libxfce4ui>=4.12.1 (already installed)
 - libwnck (already installed)
 - libsm (already installed)
 - polkit-consolekit (already installed)
 - xorg-iceauth (already installed)
 - xorg-xinit (already installed)
 - xorg-xrdb (already installed)
 - hicolor-icon-theme (already installed)
 - consolekit (already installed)
 - upower=0.9.23 (already installed)
 - intltool (already installed)
 - xfce4-dev-tools>=4.12 (already installed)

Unter Manjaro ist OpenRC Bestandteil der Repos, unter Arch habe ich ergaenzend

[openrc-eudev]
SigLevel = PackageOptional
Server = http://downloads.sourceforge.net/project/archopenrc/$repo/$arch

eingebunden.

Vermute mal das Manjaro hinterherhinkt, resp. nach dem update vllt eine neue iso zusammen gestellt werden sollte. Umsteiger koennte sowas abschrecken.

Ist ja dumm


Vermute warten oder artoo mal anschreiben mit deiner Fehlermeldung



GW

Offline klesk

  • Held Mitglied
  • *****
  • Beiträge: 1194
  • Dankeschön: 142 mal
  • Desktop: herbstluftwm
  • Grafikkartentreiber: nvidia 3.40xx
  • Kernel: 4.2
  • Prozessor: Intel Core2 Quad Q9550 (-MCP-)
  • Skill: Durchschnitt
  • Zweig: unstable
Re: Nach Update Keyboard-Layout geändert
« Antwort #5 am: 16. März 2015, 11:04:06 »
Um in der VM auf die Konsole zu kommen musst du glaube ich Alt Gr. + F1 - F6, soweit ich mich richtig erinnere. Eventuell auch Alt Gr.+ Strg + F1.

Soweit ich mich richtig erinnere kann man das Keyboard-Layout nicht mehr mit keyboardctl einstellen. Üblicherweise wird es unter OpenRC über die /etc/conf.d/keymaps eingestellt. Aber wenn du bei der Installation ein deutsches Layout gewählt hast müsstest du es ja weiterhin haben. Ggf. muss man die keymaps noch zum boot Runlevel hinzufügen

rc-update add keymaps boot
Sollte aber schon automatisch sein.

Ich werde später an meinem Laptop mal nachschauen da dort auch die XFCE OPENRC von 20.02 installiert ist.
« Letzte Änderung: 16. März 2015, 11:17:34 von klesk »

Offline digitus

  • Held Mitglied
  • *****
  • Beiträge: 744
  • Dankeschön: 12 mal
  • Life is too short for defective software.
    • Diaspora-Profil
  • Desktop: XFCE
  • Grafikkarte: Intel HD 4600
  • Grafikkartentreiber: intel
  • Kernel: 4.6
  • Prozessor: Intel Core i5-4590
  • Skill: Durchschnitt
  • Zweig: stable
Re: Nach Update Keyboard-Layout geändert
« Antwort #6 am: 16. März 2015, 11:10:55 »
Aber wenn du bei der Installation ein deutsches Layout gewählt hast müsstest du es ja weiterhin haben.

Das hätte ich auch erwartet, deswegen hat es mich ja irritiert, dass ich plötzlich mein PW nicht mehr eingeben konnte.

Zitat
Ich werde später an meinem Laptop mal nachschauen da dort auch die XFCE OPENRC von 20.02 installiert ist.

Lass Dir Zeit, ich komme heute sowieso nicht mehr zum "Basteln" :)

Grüße,
Andreas
MANJARO - not just a rolling release but also a rocking distribution!

Offline digitus

  • Held Mitglied
  • *****
  • Beiträge: 744
  • Dankeschön: 12 mal
  • Life is too short for defective software.
    • Diaspora-Profil
  • Desktop: XFCE
  • Grafikkarte: Intel HD 4600
  • Grafikkartentreiber: intel
  • Kernel: 4.6
  • Prozessor: Intel Core i5-4590
  • Skill: Durchschnitt
  • Zweig: stable
Re: Nach Update Keyboard-Layout geändert
« Antwort #7 am: 17. März 2015, 00:04:31 »
Jetzt hat es mir doch keine Ruhe gelassen:

Mit der manjaro-xfce-0.8.12-openrc-x86_64.iso bin ich immer wieder in den beschriebenen Fehler reingelaufen.

Mit der manjaro-xfce-0.9.0-openrc-pre1-i686.iso klappt es in der VM wunderbar ... bloß ist es keine XFCE sondern eine Openbox-Oberfläche - auch mal interessant.

Jetzt geht es aber ins Bett.

Gute N8,
Andreas
MANJARO - not just a rolling release but also a rocking distribution!

LuMI

  • Gast
Re: Nach Update Keyboard-Layout geändert
« Antwort #8 am: 17. März 2015, 06:13:14 »
Also am Keyboard-Layout liegt das definitiv nicht, denn wenn du die Sitzung von Openbox-Xfce auf Openbox änderst kannst dich einloggen. Hab das gerade mit manjaro-xfce-0.8.12-openrc-i686.iso getestet. Was mir aufgefallen ist. Wenn Update durch ist kann man vom Menü aus die Maschine nicht neu starten. Loginmanager ist da, Fenstermanager kann seine arbeit nimmer machen.

MfG

Offline klesk

  • Held Mitglied
  • *****
  • Beiträge: 1194
  • Dankeschön: 142 mal
  • Desktop: herbstluftwm
  • Grafikkartentreiber: nvidia 3.40xx
  • Kernel: 4.2
  • Prozessor: Intel Core2 Quad Q9550 (-MCP-)
  • Skill: Durchschnitt
  • Zweig: unstable
Re: Nach Update Keyboard-Layout geändert
« Antwort #9 am: 17. März 2015, 11:25:27 »
Macht ihr eigentlich ein Vollesvoll - Update inklusive AUR ? In der OpenRC Version liegt da zumindest auch noch 1 Paket für xfce.

Offline Saxonia

  • Sr. Mitglied
  • ****
  • Beiträge: 417
  • Dankeschön: 6 mal
    • Linuxkiste.de
  • Desktop: XFCE
  • Grafikkartentreiber: Intel free - Nvidia nonfree
  • Kernel: 3.19. x86
  • Skill: Durchschnitt
  • Zweig: unstable
Re: Nach Update Keyboard-Layout geändert
« Antwort #10 am: 17. März 2015, 13:01:57 »


Mit der manjaro-xfce-0.9.0-openrc-pre1-i686.iso klappt es in der VM wunderbar ... bloß ist es keine XFCE sondern eine Openbox-Oberfläche - auch mal interessant.



Gute N8,
Andreas
Ausloggen und im Login von default auf xfce umstellen.
Gruß, Saxonia
Ride On (AC/DC)

LuMI

  • Gast
Re: Nach Update Keyboard-Layout geändert
« Antwort #11 am: 17. März 2015, 16:05:07 »
@klesk

nur pacman -Syyu --noconfirm
MfG

Offline klesk

  • Held Mitglied
  • *****
  • Beiträge: 1194
  • Dankeschön: 142 mal
  • Desktop: herbstluftwm
  • Grafikkartentreiber: nvidia 3.40xx
  • Kernel: 4.2
  • Prozessor: Intel Core2 Quad Q9550 (-MCP-)
  • Skill: Durchschnitt
  • Zweig: unstable
Re: Nach Update Keyboard-Layout geändert
« Antwort #12 am: 17. März 2015, 16:12:26 »
Die Fehlermeldung

==> Installiere oder erstelle Abhängigkeiten von xfce4-session-consolekit:
Fehler: Ziel nicht gefunden: libxfce4ui>=4.12.1

hat im Moment jeder, da das Paket nicht im stable/testing ist. Sollte allerdings auch keine größeren Auswirkungen haben.
Wegen der Tastaturbelegung ist es, wie ich gesagt habe. Sie wird in der '/etc/conf.d/keymaps' festgelegt in der ersten Option

keymap="de-latin1-nodeadkeys"
und keymaps sollte im boot-runlevel sein

rc-update -v show
ansonsten

rc-update add keymaps boot
Ich denke das das Problem mit dem einloggen nicht daran liegt. Gib uns mal den Inhalt von deiner /etc/conf.d/xdm und /etc/lxdm/lxdm.conf. Einloggen solltest du dich über STRG + ALT + F1 - F6 können. Du kannst dort auch mal schauen ob

startx
eine Fehlermeldung bringt.
Ich hab die gleiche Version und kann den Fehler leider nicht reproduzieren. Die Mirrors sind bei euch auch up2date ?

sudo pacman-mirrors -g

LuMI

  • Gast
Re: Nach Update Keyboard-Layout geändert
« Antwort #13 am: 17. März 2015, 16:38:18 »
Ich komme mit STRG + ALT + F1 - F6 in der Virtualbox nicht in die Konsole.

/etc/lxdm/lxdm.conf

[base]
## uncomment and set autologin username to enable autologin
# autologin=dgod

## uncomment and set timeout to enable timeout autologin,
## the value should >=5
# timeout=10

## default session or desktop used when no systemwide config
session=/usr/bin/startxfce4

## uncomment and set to set numlock on your keyboard
# numlock=0

## set this if you don't want to put xauth file at ~/.Xauthority
# xauth_path=/tmp

# not ask password for users who have empty password
# skip_password=1

## greeter used to welcome the user
greeter=/usr/lib/lxdm/lxdm-greeter-gtk

[server]
## arg used to start xserver, not fully function
# arg=/usr/bin/X -background vt7
# uncomment this if you really want xserver listen to tcp
# tcp_listen=1
# uncoment this if you want reset the xserver after logou
# reset=1

[display]
## gtk theme used by greeter
gtk_theme=Greenbird

## background of the greeter
bg=/usr/share/backgrounds/LenovoFlourish.png

## if show bottom pane
bottom_pane=1

## if show language select control
lang=0

## if show keyboard layout select control
keyboard=0

## the theme of greeter
theme=Industrial

[input]

[userlist]
## if disable the user list control at greeter
disable=0

## whitelist user
white=

## blacklist user
black=

/etc/conf.d/xdm

# We always try and start X on a static VT. The various DMs normally default
# to using VT7. If you wish to use the xdm init script, then you should ensure
# that the VT checked is the same VT your DM wants to use. We do this check to
# ensure that you haven't accidentally configured something to run on the VT
# in your /etc/inittab file so that you don't get a dead keyboard.
CHECKVT=7

# What display manager do you use ?  [ xdm | gdm | kdm | gpe | entrance ]
# NOTE: If this is set in /etc/rc.conf, that setting will override this one.
DISPLAYMANAGER="lxdm"
#DISPLAYMANAGER="lightdm"

MfG

LuMI

  • Gast
Re: Nach Update Keyboard-Layout geändert
« Antwort #14 am: 17. März 2015, 16:54:12 »
ich gehe der Sache jetzt mal richtig nach. ich klone einfach die manjaro-xfce-0.8.12-openrc-i686.iso, Mit Update und ohne. Als root musste doch einloggen am lxdm klappen?

MfG
« Letzte Änderung: 17. März 2015, 16:58:58 von LuMI »