Autor Thema: Manjaro schaltet nicht ab...  (Gelesen 1868 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Offline schwedeii

  • Neuling
  • *
  • Beiträge: 11
  • Redmond- nein Danke
  • Desktop: xfce
  • Grafikkarte: D2xxx/N2xxx Integrated Graphics Controller
  • Grafikkartentreiber: Atom-netbook-edition
  • Kernel: Linux version 3.18.12-1-MANJARO _64
  • Prozessor: Intel(R) Atom(TM) CPU D2550 @ 1.86GHz
  • Skill: Anfänger
  • Zweig: stable
Manjaro schaltet nicht ab...
« am: 31. Mai 2015, 13:40:31 »
Liebe Gemeinde, ich hab da schon wieder ein kleines Problem,

der Rechner arbeitet soweit ganz gut, nur will er nach dem shutdown nicht abschalten, warum, weiss ich nicht, kann mir jemand erklären, wo ich da eine Info hierfür herbekomme?
Lieber xfce als Kacheln

Offline schwedeii

  • Neuling
  • *
  • Beiträge: 11
  • Redmond- nein Danke
  • Desktop: xfce
  • Grafikkarte: D2xxx/N2xxx Integrated Graphics Controller
  • Grafikkartentreiber: Atom-netbook-edition
  • Kernel: Linux version 3.18.12-1-MANJARO _64
  • Prozessor: Intel(R) Atom(TM) CPU D2550 @ 1.86GHz
  • Skill: Anfänger
  • Zweig: stable
Re: Manjaro schaltet nicht ab...
« Antwort #1 am: 01. Juni 2015, 16:35:56 »
sudo shutdown -h nowja, das wäre zu einfach gewesen, aber manchmal sind es ja so kleine Dinge. Nein, das funzt nicht, aber ich habe jetzt mal den splash abgeschalten und sehe da, dass der Rechner krampfhaft versucht, das NFS abzuschalten, es aber nicht hinbekommt. Da ich Debianer bin und von Systemd nicht die blasseste Ahnung habe, nun meine Frage:
Wie kann ich einen Dienst erstellen, der das NFS als letztes mountet und als erstes unmountet, um sicher zu stellen, dass es ausgehängt wird, bevor das Netzwerk heruntegefahren wird??
Lieber xfce als Kacheln

Offline klesk

  • Held Mitglied
  • *****
  • Beiträge: 1194
  • Dankeschön: 142 mal
  • Desktop: herbstluftwm
  • Grafikkartentreiber: nvidia 3.40xx
  • Kernel: 4.2
  • Prozessor: Intel Core2 Quad Q9550 (-MCP-)
  • Skill: Durchschnitt
  • Zweig: unstable
Re: Manjaro schaltet nicht ab...
« Antwort #2 am: 01. Juni 2015, 18:22:56 »
Du könntest es versuchen mit systemd zu mounten, wären folgende Optionen innerhalb des fstab Eintrags:

noauto,x-systemd.automount,x-systemd.device-timeout=10,timeo=14 0 0
Ohne systemd kannst du es mit der Option

_netdev

probieren.



Offline schwedeii

  • Neuling
  • *
  • Beiträge: 11
  • Redmond- nein Danke
  • Desktop: xfce
  • Grafikkarte: D2xxx/N2xxx Integrated Graphics Controller
  • Grafikkartentreiber: Atom-netbook-edition
  • Kernel: Linux version 3.18.12-1-MANJARO _64
  • Prozessor: Intel(R) Atom(TM) CPU D2550 @ 1.86GHz
  • Skill: Anfänger
  • Zweig: stable
Re: Manjaro schaltet nicht ab...
« Antwort #3 am: 02. Juni 2015, 17:42:37 »
Danke, aber beide Optionen funktionieren nicht. Hier mal die entsprechende Zeile:

192.168.08.15:/netz     /media/topf     nfs     rw,user,auto,nolock 0   0
die Option nolock mußte ich mit reinnehmen, sonst hätte das Laufwerk nicht gemountet.
Lieber xfce als Kacheln

Offline klesk

  • Held Mitglied
  • *****
  • Beiträge: 1194
  • Dankeschön: 142 mal
  • Desktop: herbstluftwm
  • Grafikkartentreiber: nvidia 3.40xx
  • Kernel: 4.2
  • Prozessor: Intel Core2 Quad Q9550 (-MCP-)
  • Skill: Durchschnitt
  • Zweig: unstable
Re: Manjaro schaltet nicht ab...
« Antwort #4 am: 02. Juni 2015, 19:52:48 »
Wenn die beiden Optionsvorschläge nicht funktionieren wird es schon kniffeliger. Ist es ein älterer NFS-Server ?

Testen könntest du noch die Optionen

soft,sync,no_wdelay
Mit den letzten beiden werden die Datein sofort auf übertragen und bleiben nicht im Buffer. Falls du Performanceeinbußen feststellst, nimm sie wieder raus.

Eine andere mögliche die man testen könnte wäre es die generelle Zeit zu verkürzen bis ein Dienst beendet wird

/etc/systemd/system.conf:

DefaultTimeoutStopSec=10

Offline Hubsi_Gberg

  • Held Mitglied
  • *****
  • Beiträge: 599
  • Dankeschön: 48 mal
  • Desktop: XFCE
  • Grafikkarte: NVIDIA G94GL [Quadro FX 1800]
  • Grafikkartentreiber: nouveau
  • Kernel: 4.9.31-1-MANJARO (linux49)
  • Prozessor: Intel Xeon W3680 (-HT-MCP-)
  • Skill: Durchschnitt
  • Zweig: stable
Re: Manjaro schaltet nicht ab...
« Antwort #5 am: 02. Juni 2015, 21:16:09 »
Hallo schwedeii

hast du im BIOS vielleicht die Option "Wake on lan"? Wenn ja, dann schalte sie mal bitte aus (dürfte standardmäßig aktiviert sein). Vielleicht hilft diese Maßnahme.

Offline Ocsej

  • Held Mitglied
  • *****
  • Beiträge: 580
  • Dankeschön: 2 mal
  • Ocsej
  • Desktop: Openbox /-Laptop Openbox
  • Grafikkarte: Desktoprechner nVidia Geforce 8500 GT / Laptop ATI Mobility RADEON HD 3470
  • Grafikkartentreiber: Desktop Rechner nVidia-free / Laptop ATI-free
  • Kernel: 4.1.6-1-ARCH /-64bit
  • Prozessor: Desktop Rechner (HP) AMD 5600 / Laptop Acer Aspire 5530G QL60 1,9GHz
  • Skill: Durchschnitt
  • Zweig: ARCH /-Stable
Re: Manjaro schaltet nicht ab...
« Antwort #6 am: 02. Juni 2015, 22:46:41 »
Probiere doch mal "poweroff" im Terminal
Deutscher Manjaro IRC Channel auf Freenode #manjaro-de

ARCH /-64bit installiert.

Ocsej

sdoubleyou

  • Gast
Re: Manjaro schaltet nicht ab...
« Antwort #7 am: 02. Juni 2015, 22:55:39 »
Wenn Deine Angaben zum Kernel noch aktuell sind, dann sag ich mal: "Willkommen im Club" :-)

Mit dem 3.18er hatte ich auch dieses Problem teilweise. Bei mir lag es an TLP. Das wurde nicht sauber unterstützt.

Schau einmal, ob Du TLP oder auch noch die Laptop-Mode-tools aktiv sind.

Umstellung bzw. Abstellung steht teilweise hier
https://de.manjaro.org/index.php?topic=2438.0

Seit Umstellung auf einen anderen Kernel habe ich dieses Problem nicht mehr

« Letzte Änderung: 02. Juni 2015, 23:04:28 von sdoubleyou »

Offline schwedeii

  • Neuling
  • *
  • Beiträge: 11
  • Redmond- nein Danke
  • Desktop: xfce
  • Grafikkarte: D2xxx/N2xxx Integrated Graphics Controller
  • Grafikkartentreiber: Atom-netbook-edition
  • Kernel: Linux version 3.18.12-1-MANJARO _64
  • Prozessor: Intel(R) Atom(TM) CPU D2550 @ 1.86GHz
  • Skill: Anfänger
  • Zweig: stable
Re: Manjaro schaltet nicht ab...
« Antwort #8 am: 03. Juni 2015, 17:40:47 »
Zitat
Testen könntest du noch die Optionen

Code: [Auswählen]

soft,sync,no_wdelay


Mit den letzten beiden werden die Datein sofort auf übertragen und bleiben nicht im Buffer. Falls du Performanceeinbußen feststellst, nimm sie wieder raus.

Eine andere mögliche die man testen könnte wäre es die generelle Zeit zu verkürzen bis ein Dienst beendet wird

/etc/systemd/system.conf:

Code: [Auswählen]

DefaultTimeoutStopSec=10

leider funktioniert dies alles nicht. als nfs-Server dient eine Debian 6.

zum anderen, die option wake-on-lan habe ich hier gar nicht, und tlp ist nicht installiert, weil es meinen USB-Scanner nicht eingeschalten hat. Jede Veränderung an den fstab-Einstellungen sorgt dafür, dass das Laufwerk gar nicht erst eingebunden wird.
Lieber xfce als Kacheln

Offline Xoland

  • Neuling
  • *
  • Beiträge: 13
  • Desktop: x86_64/xfce
  • Grafikkarte: Nvidia/ATI
  • Grafikkartentreiber: free
  • Kernel: 3.17
  • Prozessor: i5
  • Skill: Durchschnitt
  • Zweig: stabile/testing
Re: Manjaro schaltet nicht ab...
« Antwort #9 am: 03. Juni 2015, 18:50:56 »
Ich hatte auch immer Probleme mit dem Aushängen meiner NAS Geräte vor dem Ausschalten des PCs. Und nicht nur bei Manjaro, auch bei Arch und Debian.

Ich habe ein kleines Script davor geschaltet. Und es als Starter integriert.

#!/bin/bash
HDD=$(mount | grep -e "on /media/*" | cut -d " " -f3)
for i in $HDD; do
sudo umount -l $i
done
sudo shutdown -h now

sollte zumindest dann nicht mehr im Netzwerk hängen bleiben.

Gruß, Xoland
« Letzte Änderung: 03. Juni 2015, 18:55:31 von Xoland »
Wenn Microsoft die Lösung ist, hätte ich gerne das Problem zurück.