Autor Thema: Bereitschaft funktioniert nicht beim Schließen des Laptopbildschirms  (Gelesen 1273 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Offline FTtk

  • Jr. Mitglied
  • **
  • Beiträge: 99
  • Dankeschön: 4 mal
  • Desktop: XFCE 64-bit
  • Grafikkarte: Intel Mobile 4 Series Integrated Graphics Controller
  • Prozessor: Pentium Dual-Core CPU T4300 @ 2.10GHz,
  • Skill: Anfänger
  • Zweig: stable
Hey,
auf meinem Samsung Laptop läuft Manjaro mit XFCE in 64-bit.

In der XFCE Energieverwaltung gibt es ja den Punkt "Beim Schleißen des Laptopbildschirms".
Hier würde ich gerne Bereitschaft im Akkubetrieb auswählen. Nur leider scheint das nicht zu funktionieren. Lediglich der Bildschirm dunkelt sich ab, sobald ich den Bildschirm einklappe. Die Einstellung Ruhezustand widerum macht was sie soll.

Das Seltsame ist nur, dass sich der Laptop aber in den Bereitschaftszustand versetzen lässt, wenn ich es im "Abmeldemenü" auswähle. Der Modus an sich scheint also zu funktionieren.
« Letzte Änderung: 19. Juni 2015, 23:26:49 von oberon »

Offline oberon

  • Held Mitglied
  • *****
  • Beiträge: 675
  • Dankeschön: 75 mal
  • Desktop: i3, Cinnamon, Deepin, Xfce
  • Grafikkarte: Intel ValleyView Gen7
  • Grafikkartentreiber: free (Intel)
  • Kernel: 4.1 / 4.4
  • Prozessor: Intel Pentium N3540 Quad Core 2.6GHz
  • Skill: Durchschnitt
  • Zweig: unstable
Schau mal ob in deiner /etc/systemd/logind.conf irgendwo HandleLidSwitch=systemctl suspend steht bzw. ob die Zeile überhaupt auskommentiert ist!
« Letzte Änderung: 18. Juni 2015, 22:28:55 von oberon »

Offline FTtk

  • Jr. Mitglied
  • **
  • Beiträge: 99
  • Dankeschön: 4 mal
  • Desktop: XFCE 64-bit
  • Grafikkarte: Intel Mobile 4 Series Integrated Graphics Controller
  • Prozessor: Pentium Dual-Core CPU T4300 @ 2.10GHz,
  • Skill: Anfänger
  • Zweig: stable
#NAutoVTs=6
#ReserveVT=6
#KillUserProcesses=no
#KillOnlyUsers=
#KillExcludeUsers=root
#Controllers=
#ResetControllers=cpu
#InhibitDelayMaxSec=5
HandlePowerKey=ignore
HandleSuspendKey=ignore
HandleHibernateKey=ignore
HandleLidSwitch=ignore
#PowerKeyIgnoreInhibited=no
#SuspendKeyIgnoreInhibited=no
#HibernateKeyIgnoreInhibited=no
#LidSwitchIgnoreInhibited=yes

Das "ignore" sollte da wohl nicht stehen?
Nur zur Info, weil ich "HandlePowerKey=ignore" sehe: Beim Drücken des Powerknopfes kommt schon das Abmeldemenü, wie auch in den Energieeinstellungen gesetzt.
« Letzte Änderung: 18. Juni 2015, 22:51:14 von FTtk »

Offline oberon

  • Held Mitglied
  • *****
  • Beiträge: 675
  • Dankeschön: 75 mal
  • Desktop: i3, Cinnamon, Deepin, Xfce
  • Grafikkarte: Intel ValleyView Gen7
  • Grafikkartentreiber: free (Intel)
  • Kernel: 4.1 / 4.4
  • Prozessor: Intel Pentium N3540 Quad Core 2.6GHz
  • Skill: Durchschnitt
  • Zweig: unstable
Versuch mal die Zeile mit HandleLidSwitch zu ändern und schau ob das funktioniert... ;)

Offline FTtk

  • Jr. Mitglied
  • **
  • Beiträge: 99
  • Dankeschön: 4 mal
  • Desktop: XFCE 64-bit
  • Grafikkarte: Intel Mobile 4 Series Integrated Graphics Controller
  • Prozessor: Pentium Dual-Core CPU T4300 @ 2.10GHz,
  • Skill: Anfänger
  • Zweig: stable
Ja und nein  :-\

Nach dem Ändern der Zeile geht der Laptop zwar in Bereitschaft wenn ich den Deckel schließe, aber nicht nur im Akkubetrieb, sondern auch wenn der Strom angeschlossen ist.
Hier sollte er eigentlich nur den Bildschirm abschalten...

Hab mal Screenshots meiner Einstellungen der Energieverwaltung gemacht:
https://www.picflash.org/viewer.php?img=2015-06-22-212004_1366x768_scrotQ7BI6M.png
https://www.picflash.org/viewer.php?img=2015-06-22-212015_1366x768_scrot7PAUMR.png
https://www.picflash.org/viewer.php?img=2015-06-22-212019_1366x768_scrotLU0IRJ.png

sdoubleyou

  • Gast
Was ich noch zu dem Thema gefunden habe:

Arch Wiki xfce
Zitat
Laptop lid settings ignored

You may find that the lid close settings in Xfce4 Power Manager are ignored, meaning that the laptop will always suspend on lid close, no matter what settings are chosen in the power manager. This is because the power manager is not set to handle lid close events by default. Instead, logind handles the lid close event. To change this behavior so that the the power manager handles lid close events, execute the following command:

xfconf-query -c xfce4-power-manager -p /xfce4-power-manager/logind-handle-lid-switch -s false

Ein Versuch wäre es wert  ;)
« Letzte Änderung: 23. Juni 2015, 18:21:56 von sdoubleyou »

Offline FTtk

  • Jr. Mitglied
  • **
  • Beiträge: 99
  • Dankeschön: 4 mal
  • Desktop: XFCE 64-bit
  • Grafikkarte: Intel Mobile 4 Series Integrated Graphics Controller
  • Prozessor: Pentium Dual-Core CPU T4300 @ 2.10GHz,
  • Skill: Anfänger
  • Zweig: stable
Das wars, danke!

Hab in der /etc/systemd/logind.conf die Zeile wieder zu
HandleLidSwitch=ignoregeändert und
xfconf-query -c xfce4-power-manager -p /xfce4-power-manager/logind-handle-lid-switch -s falseausgeführt.

Schwupps schon funktioniert alles wie in der Energieverwaltung angegeben :D

Aber schon irgendwie komisch, dass es diese Einstellungsmöglichkeiten gibt, aber sie ohne "Rumgefrickel" nicht funktionieren...