Autor Thema: Fehler nach erstem Update der 64bit Installation  (Gelesen 2032 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Offline JotEs

  • Jr. Mitglied
  • **
  • Beiträge: 82
  • Dankeschön: 2 mal
  • Desktop: Xfce 4
  • Grafikkarte: Intel Haswell Integrated Graphics Controller
  • Grafikkartentreiber: free
  • Kernel: 4.4.x (x86_64) LTS
  • Prozessor: Intel Core i5-4570
  • Skill: Durchschnitt
  • Zweig: stable
Fehler nach erstem Update der 64bit Installation
« am: 22. Oktober 2013, 18:45:13 »
Ich habe nun die 64bit-Version aus den Manjaroquellen instaliert. Nach der Installation läuft alles einwandfrei. Es wird eine Aktualisierung mit 118 Updates angeboten. Danach funktionieren zwei Dinge nicht mehr. Das zuvor mit der rechten Maustaste erreichbare Menü erscheint nicht mehr, stattdessen eine Fehlermeldung. Weiterhin die bereits in meinem vorhergehen Posting erwähnte Meldung beim Start von Firefox, dass bereits eine Instanz von FF läuft und deshalb nicht gestartet werden kann.
Was läuft hier bei der Aktualisierung schief?
Manjaro XFCE x86_64bit auf Eigenbau mit Intel Desktop Board DH87RL

Offline Pig of Destiny

  • Held Mitglied
  • *****
  • Beiträge: 1383
  • Dankeschön: 125 mal
  • Desktop: Xfce
  • Grafikkarte: Intel Graphics
  • Grafikkartentreiber: free
  • Kernel: 4.16
  • Prozessor: Intel Celeron N3350
  • Skill: Durchschnitt
  • Zweig: Arch Linux
Re: Fehler nach erstem Update der 64bit Installation
« Antwort #1 am: 22. Oktober 2013, 22:20:40 »
Wie lautet denn die Fehlermeldung?

Offline JotEs

  • Jr. Mitglied
  • **
  • Beiträge: 82
  • Dankeschön: 2 mal
  • Desktop: Xfce 4
  • Grafikkarte: Intel Haswell Integrated Graphics Controller
  • Grafikkartentreiber: free
  • Kernel: 4.4.x (x86_64) LTS
  • Prozessor: Intel Core i5-4570
  • Skill: Durchschnitt
  • Zweig: stable
Re: Fehler nach erstem Update der 64bit Installation
« Antwort #2 am: 23. Oktober 2013, 09:26:49 »
Wie lautet denn die Fehlermeldung?
Es ist ein kleines Fenster mit dem Titel "Openbox" und der MitteilungUngültige Ausgabe vom Pipe-Menü "/usr/bin/obmenu-generator -i"Könnte man feststellen, welche der Aktualisierungspakete (vorher traten die Fehler ja nicht auf) das verursachen? Eigentlich müsste doch jeder, der die OpenBox-Edition (manjaro-openbox-0.8.7.1-x86_64.iso) herunterlädt und installiert, nach der ersten Aktualisierung auf diese Probleme stoßen. Das ist doch sicher nicht so vorteilhaft für die Verbreitung dieser Distribution.

JotEs
Manjaro XFCE x86_64bit auf Eigenbau mit Intel Desktop Board DH87RL

Offline Pig of Destiny

  • Held Mitglied
  • *****
  • Beiträge: 1383
  • Dankeschön: 125 mal
  • Desktop: Xfce
  • Grafikkarte: Intel Graphics
  • Grafikkartentreiber: free
  • Kernel: 4.16
  • Prozessor: Intel Celeron N3350
  • Skill: Durchschnitt
  • Zweig: Arch Linux
Re: Fehler nach erstem Update der 64bit Installation
« Antwort #3 am: 24. Oktober 2013, 06:56:28 »
Ich selbst benutze eigentlich Xfce, weshalb ich auch nicht unbedingt ein openbox-Experte bin, aber du könntest mal versuchen die menu.xml zu kopieren wie folgt:
cp /etc/xdg/openbox/menu.xml ~/.config/openbox
Ich glaube auch nicht, dass das Problem jeder Openbox-Manjaro-User hat, das hätte man sicher schon mitbekommen. War bei der letzten Aktualisierung was mit "perl" dabei?


Offline JotEs

  • Jr. Mitglied
  • **
  • Beiträge: 82
  • Dankeschön: 2 mal
  • Desktop: Xfce 4
  • Grafikkarte: Intel Haswell Integrated Graphics Controller
  • Grafikkartentreiber: free
  • Kernel: 4.4.x (x86_64) LTS
  • Prozessor: Intel Core i5-4570
  • Skill: Durchschnitt
  • Zweig: stable
Re: Fehler nach erstem Update der 64bit Installation
« Antwort #4 am: 24. Oktober 2013, 15:10:20 »
Das Kopieren gelang mit Rootrechten. Nun haben alle  drei Dateien im Ordner ~/.config/openbox den Besitzer root, was vermutlich nicht korrekt ist. Immerhin läßt sich jetzt das Menü über die rechte Maustaste aufrufen, wenn auch ohne Icons und mit vielen Programmen, die gar nicht installiert sind.
Zitat
War bei der letzten Aktualisierung was mit "perl" dabei?
Ja, mehrere Pakete

Vielen Dank für die Unterstützung. Vielleicht sollte ich es auch mit Xfce versuchen.
Manjaro XFCE x86_64bit auf Eigenbau mit Intel Desktop Board DH87RL

Offline Pig of Destiny

  • Held Mitglied
  • *****
  • Beiträge: 1383
  • Dankeschön: 125 mal
  • Desktop: Xfce
  • Grafikkarte: Intel Graphics
  • Grafikkartentreiber: free
  • Kernel: 4.16
  • Prozessor: Intel Celeron N3350
  • Skill: Durchschnitt
  • Zweig: Arch Linux
Re: Fehler nach erstem Update der 64bit Installation
« Antwort #5 am: 24. Oktober 2013, 16:11:11 »
Nun ja, wie bereits erwähnt nutze ich ja Openbox selbst nicht. Ich meine aber mal gelesen zu haben, dass es je nach Version von perl zu Problemen kommen könnte.

Auf jeden Fall wären alle weiteren Tipps die ich dir geben könnte aus irgend welchen Wikis oder Foren "geklaut". Was openbox und dessen Konfiguration bzgl Icons und so weiter angeht hab ich nen recht guten Wiki-Einteag bei Arch gefunden:
https://wiki.archlinux.de/title/Openbox

Ich hoffe er hilft dir weiter und entschuldige mich gleich mal, dass ich dir jetzt nicht so gut weiter helfen kann vermutlich.

Und was Xfce angeht: Mir gefällt's super, es ist ziemlich schnell und ich arbeite auch gerne mit nem "klassischen" Desktop. Ausprobieren kostet ja nix. Du kannst es dir wenn du willst ja auch per live-Mesium erst einmal anschauen.

Offline JotEs

  • Jr. Mitglied
  • **
  • Beiträge: 82
  • Dankeschön: 2 mal
  • Desktop: Xfce 4
  • Grafikkarte: Intel Haswell Integrated Graphics Controller
  • Grafikkartentreiber: free
  • Kernel: 4.4.x (x86_64) LTS
  • Prozessor: Intel Core i5-4570
  • Skill: Durchschnitt
  • Zweig: stable
Re: Fehler nach erstem Update der 64bit Installation
« Antwort #6 am: 25. Oktober 2013, 11:31:13 »
Viellen Dank für Deine Mühe und Hinweise. Besonders das Wiki, war so hilfreich, dass Openbox nun ganz gut läuft bei mir. Damit bin ich erstmal  zufrieden. Auch die gestrige Aktualisierung mit über 100 Paketen ist glatt durchgelaufen.
Die Xfce-Version macht auch einen ganz guten Eindruck. Mal sehen wie ich mich entscheide. Gemessen an den Reaktionen hier im Forum hat besonders Manjaro-OpenBox wohl noch nicht die ganz große Verbreitung gefunden. Schade eigentlich.
Manjaro XFCE x86_64bit auf Eigenbau mit Intel Desktop Board DH87RL

Offline Pig of Destiny

  • Held Mitglied
  • *****
  • Beiträge: 1383
  • Dankeschön: 125 mal
  • Desktop: Xfce
  • Grafikkarte: Intel Graphics
  • Grafikkartentreiber: free
  • Kernel: 4.16
  • Prozessor: Intel Celeron N3350
  • Skill: Durchschnitt
  • Zweig: Arch Linux
Re: Fehler nach erstem Update der 64bit Installation
« Antwort #7 am: 25. Oktober 2013, 15:34:10 »
Schön, dass es dir geholfen hat.

Ja, ich glaube auch, dass die meisten Xfce benutzen. Es ist halt, auch für mich, ein großer Unterschied ob ich einen reinen Window-Manager wie Openbox benutze oder eine trotzdem flott laufenden aber doch vollständige Desktopumgebung wie Xfce, die man nicht mehr so umfassend zu konfigurieren braucht.

Also ich nutze es in erster Linie aus Gewohnheits- und Bequemlichkeitsgründen.