Autor Thema: NFS Mount - brauche Hilfe  (Gelesen 1004 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Offline caho

  • Held Mitglied
  • *****
  • Beiträge: 661
  • Dankeschön: 18 mal
  • A friend of classical guitar
  • Desktop: Plasma 5.x
  • Kernel: 4.20
  • Prozessor: Intel Quad Core i7-2600
  • Skill: Durchschnitt
  • Zweig: stable
NFS Mount - brauche Hilfe
« am: 29. Juli 2015, 19:15:00 »
Hallo Freunde,

ich brauche dringend Eure Hilfe. Und zwar habe ich folgendes Problem:

Ich habe in der fstab mein NAS so eingebunden:

192.168.102.50:/volume1/caho /home/caho/NAS nfs noauto,x-systemd.automount
Das Problem ist folgendes:
Nach dem Booten beim Versuch, den Ordner "NAS" zu öffnen, lässt er das nicht zu.

ABER:
Wenn ich als Benutzer in KDE angemeldet bin und in der Konsole ein "sudo mount -a" ausführe, dann wird das NAS korrekt gemountet und der Zugriff funktioniert einwandfrei.

Könnt Ihr mir vielleicht helfen? Ich weiß nicht mehr, wo ich hier ansetzen soll.

Danke schon mal im Voraus
caho

Ein Freund klassischer Gitarre

Offline Bankman

  • Sr. Mitglied
  • ****
  • Beiträge: 354
  • Dankeschön: 22 mal
  • Desktop: XFCE
  • Grafikkarte: Intel HD graphics 620
  • Grafikkartentreiber: free
  • Kernel: Linux 4.20
  • Prozessor: Intel® Core™ i5-7200U
  • Skill: Durchschnitt
  • Zweig: stable
Re: NFS Mount - brauche Hilfe
« Antwort #1 am: 29. Juli 2015, 19:54:40 »
Hallo Caho,

So habe ich meine Synology eingebunden:
192.168.178.33:/volume1/Dirk /mnt/DiskStation/Dirk nfs noauto,x-systemd.automount nouser,relatime,rw,dev,exec,suid 0 0 Den Namen und die IP musst du natürlich anpassen  ;-)
So habe ich meine Synology eingebunden und es funzt einwandfrei.
"Mögen hätt ich schon wollen, aber dürfen hab ich mich nicht getraut."

Offline caho

  • Held Mitglied
  • *****
  • Beiträge: 661
  • Dankeschön: 18 mal
  • A friend of classical guitar
  • Desktop: Plasma 5.x
  • Kernel: 4.20
  • Prozessor: Intel Quad Core i7-2600
  • Skill: Durchschnitt
  • Zweig: stable
Re: NFS Mount - brauche Hilfe
« Antwort #2 am: 29. Juli 2015, 19:58:16 »
Hallo Bankman,

danke für die schnelle Antwort.

manchmal ist die Verzweiflung größer als die Augen, um das offensichtliche zu sehen.

So funktioniert die NAS Einbindung per NFS in meiner fstab:
192.168.102.50:/volume1/caho /home/caho/NAS nfs ,nouser,noauto,x-systemd.automount.x-systemd.device-timeout=10,timeo=14,hard,intr,noat
Die Lösung habe ich hier https://wiki.manjaro.org/index.php?title=Fstab_-_Use_SystemD_automount gefunden

Ich werde mir die Optionen mal näher anschauen, wo der Unterschied zwischen Deiner und meiner Konfiguration ist.
Aber trotzdem - war ein guter Tipp mit der Synology Disk Station.  Vielen Dank dafür.

Gruß
caho
Ein Freund klassischer Gitarre

Offline Bankman

  • Sr. Mitglied
  • ****
  • Beiträge: 354
  • Dankeschön: 22 mal
  • Desktop: XFCE
  • Grafikkarte: Intel HD graphics 620
  • Grafikkartentreiber: free
  • Kernel: Linux 4.20
  • Prozessor: Intel® Core™ i5-7200U
  • Skill: Durchschnitt
  • Zweig: stable
Re: NFS Mount - brauche Hilfe
« Antwort #3 am: 29. Juli 2015, 20:10:09 »
Prima wenn es funktioniert und du mit der Synology zufrieden bist. Das freut mich.
An der Konfiguration habe ich lange getüftelt und viele Tutorials dazu gelesen und herumexperimentiert.
Gib gerne Bescheid, wenn du zu einer anderen, besseren Lösung kommst.

Grüße
Bankman
"Mögen hätt ich schon wollen, aber dürfen hab ich mich nicht getraut."

Offline caho

  • Held Mitglied
  • *****
  • Beiträge: 661
  • Dankeschön: 18 mal
  • A friend of classical guitar
  • Desktop: Plasma 5.x
  • Kernel: 4.20
  • Prozessor: Intel Quad Core i7-2600
  • Skill: Durchschnitt
  • Zweig: stable
Re: NFS Mount - brauche Hilfe
« Antwort #4 am: 29. Juli 2015, 20:25:14 »
das werde ich gerne tun, kann aber noch dauern. Ich habe das NAS ja heute erst bekommen.

Gruß
caho
Ein Freund klassischer Gitarre