Autor Thema: KDE - kein Bluetooth-Adapter gefunden  (Gelesen 2616 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Offline Ahnungsloser

  • Held Mitglied
  • *****
  • Beiträge: 900
  • Dankeschön: 43 mal
  • Desktop: KDE Plasma 5.14.5 - OpenRC
  • Grafikkarte: Intel 3rd Gen Core processor Graphics Controller | NVIDIA GK208M [GeForce GT 720M]
  • Grafikkartentreiber: free
  • Kernel: 4.20.0-artix1-1-ARTIX
  • Prozessor: Intel Core i3-3217U
  • Skill: Anfänger
  • Zweig: stable
KDE - kein Bluetooth-Adapter gefunden
« am: 09. August 2015, 09:49:21 »
Hallo liebe Manjaroianer  :)

ich wollte mit meinem Asus Notebook R510C eine Verbindung zu einem Bluetoothgerät herstellen.

Jetzt behauptet KDE, dass keine Bluetooth-Adapter gefunden wurde.
Die Bluetooth-Integration ist in KDE aktiviert und pulseautio-bluetooth ist installiert.

Jetzt habe ich den Befehl
lspciausgeführt und folgende Ausgabe erhalten:
00:00.0 Host bridge: Intel Corporation 3rd Gen Core processor DRAM Controller (rev 09)
00:01.0 PCI bridge: Intel Corporation Xeon E3-1200 v2/3rd Gen Core processor PCI Express Root Port (rev 09)
00:02.0 VGA compatible controller: Intel Corporation 3rd Gen Core processor Graphics Controller (rev 09)
00:14.0 USB controller: Intel Corporation 7 Series/C210 Series Chipset Family USB xHCI Host Controller (rev 04)
00:16.0 Communication controller: Intel Corporation 7 Series/C210 Series Chipset Family MEI Controller #1 (rev 04)
00:1a.0 USB controller: Intel Corporation 7 Series/C210 Series Chipset Family USB Enhanced Host Controller #2 (rev 04)
00:1b.0 Audio device: Intel Corporation 7 Series/C210 Series Chipset Family High Definition Audio Controller (rev 04)
00:1c.0 PCI bridge: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 1 (rev c4)
00:1c.1 PCI bridge: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 2 (rev c4)
00:1c.3 PCI bridge: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 4 (rev c4)
00:1d.0 USB controller: Intel Corporation 7 Series/C210 Series Chipset Family USB Enhanced Host Controller #1 (rev 04)
00:1f.0 ISA bridge: Intel Corporation HM76 Express Chipset LPC Controller (rev 04)
00:1f.2 SATA controller: Intel Corporation 7 Series Chipset Family 6-port SATA Controller [AHCI mode] (rev 04)
00:1f.3 SMBus: Intel Corporation 7 Series/C210 Series Chipset Family SMBus Controller (rev 04)
01:00.0 3D controller: NVIDIA Corporation GK208M [GeForce GT 720M] (rev ff)
03:00.0 Network controller: Qualcomm Atheros AR9485 Wireless Network Adapter (rev 01)
04:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. Device 5289 (rev 01)
04:00.2 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 0a)

Interpretiere ich diese Ausgabe richtig, dass dieses Notebook gar keinen Bluetooth-Adapter besitzt?

Viele Grüße
Ahnungsloser
Im neuen Forum unter dem Nick "Roberto" :)

Offline jordan

  • Vollwertiges Mitglied
  • ***
  • Beiträge: 154
  • Dankeschön: 12 mal
  • Skill: Fortgeschritten
Re: KDE - kein Bluetooth-Adapter gefunden
« Antwort #1 am: 09. August 2015, 11:12:14 »
Hallo!
1. In einem anderen Forum - ist schon lange her - habe ich mal gelesen, daß manche Hersteller ihre Laptops bzgl. Hardware für eine ganze Gruppe von verschiedenen Geräten "gleichartig" konfigurieren, also z.B. BT-Schalter, unabhängig davon, ob in einem bestimmten Notebook BT wirklich realisiert wird.
2. BT kann im BIOS deaktiviert sein.
3. Ich vermute, die Folgerung aus "lspci" ist nicht richtig.

Edit:
Bin im Moment nicht auf Manjaro, aber auch dort sollte der Befehl "rfkill" verhanden sein:
rfkill list-> bei mir
0: hci0: Bluetooth
Soft blocked: no
Hard blocked: no
1: phy0: Wireless LAN
Soft blocked: no
Hard blocked: no
« Letzte Änderung: 09. August 2015, 11:28:25 von jordan »
Jordan @  Linux Multiboot:

Offline jordan

  • Vollwertiges Mitglied
  • ***
  • Beiträge: 154
  • Dankeschön: 12 mal
  • Skill: Fortgeschritten
Re: KDE - kein Bluetooth-Adapter gefunden
« Antwort #2 am: 09. August 2015, 11:30:49 »
Jordan @  Linux Multiboot:

sdoubleyou

  • Gast
Re: KDE - kein Bluetooth-Adapter gefunden
« Antwort #3 am: 09. August 2015, 11:53:35 »
was sagt denn Dein Handbuch zu dem Notebook? Eigentlich müsstest Du Bluetooth haben.
Leuchtet denn das Bluetooth-Signal?
hast Du schon einmal bluedevil aufgerufen und geschaut, was da steht?

Offline Ahnungsloser

  • Held Mitglied
  • *****
  • Beiträge: 900
  • Dankeschön: 43 mal
  • Desktop: KDE Plasma 5.14.5 - OpenRC
  • Grafikkarte: Intel 3rd Gen Core processor Graphics Controller | NVIDIA GK208M [GeForce GT 720M]
  • Grafikkartentreiber: free
  • Kernel: 4.20.0-artix1-1-ARTIX
  • Prozessor: Intel Core i3-3217U
  • Skill: Anfänger
  • Zweig: stable
Re: KDE - kein Bluetooth-Adapter gefunden
« Antwort #4 am: 09. August 2015, 12:56:09 »
Also im Bios kann ich Bluetooth nicht aktivieren oder deaktivieren.
Lt. allgemeinem Handbuch für diese Serie, soll das Gerät mit einem Bluetooth Adapter ausgestattet sein.
Es gibt auch keinen Hardware-Schalter, der Buetooth an bzw. ausschalten kann.

Die Ausgabe von
sudo rfkill listgibt:

0: phy0: Wireless LAN
        Soft blocked: no
        Hard blocked: no
1: asus-wlan: Wireless LAN
        Soft blocked: no
        Hard blocked: no

Es sieht also so aus, als ob das Modell kein Bluetooth hat.
Vielleicht ist dieses Modell speziell für Saturn produziert worden und hat dieses feature nicht.
Im neuen Forum unter dem Nick "Roberto" :)

Offline Ahnungsloser

  • Held Mitglied
  • *****
  • Beiträge: 900
  • Dankeschön: 43 mal
  • Desktop: KDE Plasma 5.14.5 - OpenRC
  • Grafikkarte: Intel 3rd Gen Core processor Graphics Controller | NVIDIA GK208M [GeForce GT 720M]
  • Grafikkartentreiber: free
  • Kernel: 4.20.0-artix1-1-ARTIX
  • Prozessor: Intel Core i3-3217U
  • Skill: Anfänger
  • Zweig: stable
Re: KDE - kein Bluetooth-Adapter gefunden
« Antwort #5 am: 09. August 2015, 13:18:06 »
Eines ist mir noch eingefallen.

Bei einer kompletten Neuinstallation muss ich den W-LAN Adapter einmal per Terminal
mit diesem Befehl einschalten, da sonst der Atheros AR9485 von Linux nicht erkannt wird.

echo "options asus_nb_wmi wapf=1" | sudo tee /etc/modprobe.d/asus.conf
Ist es auch möglich, sowohl W-LAN als auch Bluetooth (sofern vorhanden) einzuschalten?
Im neuen Forum unter dem Nick "Roberto" :)

Offline Ahnungsloser

  • Held Mitglied
  • *****
  • Beiträge: 900
  • Dankeschön: 43 mal
  • Desktop: KDE Plasma 5.14.5 - OpenRC
  • Grafikkarte: Intel 3rd Gen Core processor Graphics Controller | NVIDIA GK208M [GeForce GT 720M]
  • Grafikkartentreiber: free
  • Kernel: 4.20.0-artix1-1-ARTIX
  • Prozessor: Intel Core i3-3217U
  • Skill: Anfänger
  • Zweig: stable
Re: KDE - kein Bluetooth-Adapter gefunden
« Antwort #6 am: 09. August 2015, 13:57:42 »
Hier nochmal eine andere Ausgabe:

lsmod | grep blue
bluetooth             458752  5 bnep
rfkill                 24576  7 cfg80211,bluetooth,asus_wmi
crc16                  16384  2 ext4,bluetooth

So ganz nebenbei ... wie rufe ich bluedevil auf?  :-[
Im neuen Forum unter dem Nick "Roberto" :)

Offline Ahnungsloser

  • Held Mitglied
  • *****
  • Beiträge: 900
  • Dankeschön: 43 mal
  • Desktop: KDE Plasma 5.14.5 - OpenRC
  • Grafikkarte: Intel 3rd Gen Core processor Graphics Controller | NVIDIA GK208M [GeForce GT 720M]
  • Grafikkartentreiber: free
  • Kernel: 4.20.0-artix1-1-ARTIX
  • Prozessor: Intel Core i3-3217U
  • Skill: Anfänger
  • Zweig: stable
Re: KDE - kein Bluetooth-Adapter gefunden
« Antwort #7 am: 09. August 2015, 14:13:28 »
Vielleicht gibt die Ausgabe von

lsmod | grep -i asus
asus_nb_wmi            24576  0
asus_wmi               24576  1 asus_nb_wmi
sparse_keymap          16384  1 asus_wmi
led_class              16384  2 ath9k,asus_wmi
rfkill                 24576  7 cfg80211,bluetooth,asus_wmi
video                  24576  2 i915,asus_wmi
wmi                    20480  2 mxm_wmi,asus_wmi

noch mehr Aufschluss
Im neuen Forum unter dem Nick "Roberto" :)

sdoubleyou

  • Gast
Re: KDE - kein Bluetooth-Adapter gefunden
« Antwort #8 am: 09. August 2015, 18:55:21 »
bluedevil ist unter KDE die Verwaltung für bluetooth. Im Kicker gib in der Such-Leiste einfach mal bluedevil ein

Offline Ahnungsloser

  • Held Mitglied
  • *****
  • Beiträge: 900
  • Dankeschön: 43 mal
  • Desktop: KDE Plasma 5.14.5 - OpenRC
  • Grafikkarte: Intel 3rd Gen Core processor Graphics Controller | NVIDIA GK208M [GeForce GT 720M]
  • Grafikkartentreiber: free
  • Kernel: 4.20.0-artix1-1-ARTIX
  • Prozessor: Intel Core i3-3217U
  • Skill: Anfänger
  • Zweig: stable
Re: KDE - kein Bluetooth-Adapter gefunden
« Antwort #9 am: 09. August 2015, 19:32:33 »
Das war mir jetzt zu einfach  8)

Habe ich eingegeben und bluedevil wird nicht als Programm angezeigt.
Scheint also nicht installiert zu sein.

Bei dem Versuch, das Paket zu installieren, kommt allerdings der Hinweis, dass bluedevil 1:5.3.2-1 aktuell ist.
Ist der Anzeigename evtl. anders? Ich bin gerade ein wenig verwirrt.
Im neuen Forum unter dem Nick "Roberto" :)

sdoubleyou

  • Gast
Re: KDE - kein Bluetooth-Adapter gefunden
« Antwort #10 am: 09. August 2015, 19:51:46 »
Wenn du "bluedevil eingibst, dann erscheint der Menüeintrag
Adapter - Bluetooth-Adapter einrichtensiehe Anlage  ;)

Offline Ahnungsloser

  • Held Mitglied
  • *****
  • Beiträge: 900
  • Dankeschön: 43 mal
  • Desktop: KDE Plasma 5.14.5 - OpenRC
  • Grafikkarte: Intel 3rd Gen Core processor Graphics Controller | NVIDIA GK208M [GeForce GT 720M]
  • Grafikkartentreiber: free
  • Kernel: 4.20.0-artix1-1-ARTIX
  • Prozessor: Intel Core i3-3217U
  • Skill: Anfänger
  • Zweig: stable
Re: KDE - kein Bluetooth-Adapter gefunden
« Antwort #11 am: 09. August 2015, 19:57:04 »
danke ... das erscheint bei mir und dann kommt die Meldung, dass keine Adapter gefunden wurden.

Nach der Ausgabe von
lsmod | grep -i asuswar ich der Meinung, dass ein Bluetooth Adapter eingebaut ist.
Im neuen Forum unter dem Nick "Roberto" :)

sdoubleyou

  • Gast
Re: KDE - kein Bluetooth-Adapter gefunden
« Antwort #12 am: 09. August 2015, 20:12:58 »
evtl. musst Du den noch aktivieren!?. Bei den meisten Asus-Modellen geht das mit Fn+F2 (glaube ich zumindest).
Lies doch mal in deine Bedine dazu

bzw. lies einmal hier
https://wiki.archlinux.org/index.php/Bluetooth#Troubleshooting

bluetoothctl
Zitat
If bluetoothctl cannot find any controller, the bluetooth device may be blocked. Try to unblock it using rfkill:

# rfkill unblock bluetooth
« Letzte Änderung: 09. August 2015, 20:15:39 von sdoubleyou »

Offline Ahnungsloser

  • Held Mitglied
  • *****
  • Beiträge: 900
  • Dankeschön: 43 mal
  • Desktop: KDE Plasma 5.14.5 - OpenRC
  • Grafikkarte: Intel 3rd Gen Core processor Graphics Controller | NVIDIA GK208M [GeForce GT 720M]
  • Grafikkartentreiber: free
  • Kernel: 4.20.0-artix1-1-ARTIX
  • Prozessor: Intel Core i3-3217U
  • Skill: Anfänger
  • Zweig: stable
Re: KDE - kein Bluetooth-Adapter gefunden
« Antwort #13 am: 09. August 2015, 20:25:17 »
Diese Tastenkombination funktioniert leider nicht und laut www liegt das an asus_nb_wmi

lsmod | egrep '_acpi|_bluetooth|asus_laptop|_rfkill|_wmi'
asus_nb_wmi            24576  0
asus_wmi               24576  1 asus_nb_wmi
sparse_keymap          16384  1 asus_wmi
mxm_wmi                16384  0
led_class              16384  2 ath9k,asus_wmi
rfkill                 24576  7 cfg80211,bluetooth,asus_wmi
wmi                    20480  2 mxm_wmi,asus_wmi
video                  24576  2 i915,asus_wmi

Naja, es gibt schlimmeres als kein Bluetooth, kein wlan z.b.
Von daher kein Problem.
Im neuen Forum unter dem Nick "Roberto" :)

Offline Ahnungsloser

  • Held Mitglied
  • *****
  • Beiträge: 900
  • Dankeschön: 43 mal
  • Desktop: KDE Plasma 5.14.5 - OpenRC
  • Grafikkarte: Intel 3rd Gen Core processor Graphics Controller | NVIDIA GK208M [GeForce GT 720M]
  • Grafikkartentreiber: free
  • Kernel: 4.20.0-artix1-1-ARTIX
  • Prozessor: Intel Core i3-3217U
  • Skill: Anfänger
  • Zweig: stable
Re: KDE - kein Bluetooth-Adapter gefunden
« Antwort #14 am: 09. August 2015, 21:11:08 »
Bluetooth scheint gestartet:

$ systemctl status bluetooth -l
● bluetooth.service - Bluetooth service
   Loaded: loaded (/usr/lib/systemd/system/bluetooth.service; enabled; vendor preset: disabled)
   Active: active (running) since So 2015-08-09 20:47:01 CEST; 11min ago
     Docs: man:bluetoothd(8)
 Main PID: 543 (bluetoothd)
   Status: "Running"
   CGroup: /system.slice/bluetooth.service
           └─543 /usr/lib/bluetooth/bluetoothd

Aug 09 20:47:01 AsusNotebook systemd[1]: Starting Bluetooth service...
Aug 09 20:47:01 AsusNotebook bluetoothd[543]: Bluetooth daemon 5.32
Aug 09 20:47:01 AsusNotebook systemd[1]: Started Bluetooth service.
Aug 09 20:47:01 AsusNotebook bluetoothd[543]: Starting SDP server
Aug 09 20:47:01 AsusNotebook bluetoothd[543]: Bluetooth management interface 1.9 initialized

Es scheint so, dass pulseaudio nicht gestartet wird.

$ pulseaudio -D
E: [pulseaudio] main.c: Start des Daemons fehlgeschlagen.

Kann das damit zusammen hängen?

Der Bluetooth-Adapter wird unter rfkill überhaupt nicht aufgelistet:

$ rfkill list
0: phy0: Wireless LAN
        Soft blocked: no
        Hard blocked: no
1: asus-wlan: Wireless LAN
        Soft blocked: no
        Hard blocked: no
« Letzte Änderung: 09. August 2015, 21:13:30 von Ahnungsloser »
Im neuen Forum unter dem Nick "Roberto" :)