Autor Thema: Failed to set new theme (Update] 2015-08-10)  (Gelesen 1261 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Offline Hubsi_Gberg

  • Held Mitglied
  • *****
  • Beiträge: 599
  • Dankeschön: 48 mal
  • Desktop: XFCE
  • Grafikkarte: NVIDIA G94GL [Quadro FX 1800]
  • Grafikkartentreiber: nouveau
  • Kernel: 4.9.31-1-MANJARO (linux49)
  • Prozessor: Intel Xeon W3680 (-HT-MCP-)
  • Skill: Durchschnitt
  • Zweig: stable
Failed to set new theme (Update] 2015-08-10)
« am: 10. August 2015, 21:21:41 »
Hallo an alle,

nach dem heutige Update (Update] 2015-08-10) weigert sich mein XFCE beharrlich durchzustarten.

Wie hier geschildert, verhält sich der Desktop im Großen und Ganzen ähnlich. Bei mir reagiert er noch auf einige Benutzereingaben. Beispielsweise kann ich damit noch ein Bildschirmfoto erstellen und abspeichern.

Ich hatte bereits nach dem letzten Update diese "Erscheinung". Allerdings habe ich damals am Anmeldefenster gezielt die XFCE-Sitzung vorgegeben. Danach war wieder alles gut. Diesmal hilft dieser Schritt nicht weiter.

Aktuell habe ich versucht, Platz zum machen, indem ich gut 10 MB an Fotos aus dem Bilder-Ordner auf die externe Datenplatte geschaufelt habe. Auch den 318er Kernel habe ich aus dem System verbannt. Der Erfolg beider Maßnahmen war gleich Null.

Ich habe dann spontan mal meinen zweiten Desktop Cinnamon gestartet. Dieser brachte mir wenigstens ein zusätzliches Meldefenster. Ich habe es zwar nicht gezielt getestet, aber ich denke er hat sich völlig normal verhalten. Sogar der Abmelde-Knopf und die damit verbundenen Funktionen verhielten sich augenscheinlich normal, denn ich habe das System darüber nochmals neu gestartet.

Ich glaube nicht, dass die Partition komplett voll ist. Immerhin sind noch rund 800 MB frei. Daher vermute ich den Fehler wohl eher im XFCE-Zweig.

Wer kann helfen?

P.S.:
Ich habe aktuell Manjaro verlassen und schreibe diesen Text aus Mint 17.

Offline Verändert

  • Support Team
  • *****
  • Beiträge: 1149
  • Dankeschön: 62 mal
  • Ni Dieu ni maître
  • Desktop: Gnome. LXQt. i3.
  • Grafikkarte: Intel & Radeon & NVidia
  • Grafikkartentreiber: frei natürlich
  • Kernel: Immer der aktuelle.
  • Prozessor: Intel Celeron und andere.
  • Skill: Anfänger
  • Zweig: unstable
Re: Failed to set new theme (Update] 2015-08-10)
« Antwort #1 am: 10. August 2015, 22:21:29 »
800MB sind, mit Verlaub, nichts. Du hast ein grundlegendes Problem mit Deiner Partitionierung. Selbst wenn wir das unmittelbare Problem lösen- es wird wieder eines geben.

Offline klesk

  • Held Mitglied
  • *****
  • Beiträge: 1194
  • Dankeschön: 142 mal
  • Desktop: herbstluftwm
  • Grafikkartentreiber: nvidia 3.40xx
  • Kernel: 4.2
  • Prozessor: Intel Core2 Quad Q9550 (-MCP-)
  • Skill: Durchschnitt
  • Zweig: unstable
Re: Failed to set new theme (Update] 2015-08-10)
« Antwort #2 am: 10. August 2015, 22:30:36 »
Temporär könnte man zur Zeit vermutlich nur den Pacman Cache leeren

sudo pacman -Scc
und ggfs bei den Journalen aufräumen

du -h /var/log/journal
um die Größe fest zu stellen und bei Bedarf zu löschen.
Aber damit gewinnt man auch nur ein paar MB/GB, daher kann ich mich da auch nur Verändert anschließen.
Eventuell noch bisschen das Home ausmisten, das du wenigstes 2GiB frei bekommst, dann dürfte der Fehler auch nicht mehr auftauchen.

Offline Hubsi_Gberg

  • Held Mitglied
  • *****
  • Beiträge: 599
  • Dankeschön: 48 mal
  • Desktop: XFCE
  • Grafikkarte: NVIDIA G94GL [Quadro FX 1800]
  • Grafikkartentreiber: nouveau
  • Kernel: 4.9.31-1-MANJARO (linux49)
  • Prozessor: Intel Xeon W3680 (-HT-MCP-)
  • Skill: Durchschnitt
  • Zweig: stable
Re: Failed to set new theme (Update] 2015-08-10)
« Antwort #3 am: 10. August 2015, 22:36:58 »
800MB sind, mit Verlaub, nichts. Du hast ein grundlegendes Problem mit Deiner Partitionierung. Selbst wenn wir das unmittelbare Problem lösen- es wird wieder eines geben.

Ich habe mich in der Zwischenzeit sowieso mit dem Gedanken getragen, das zweite OS auf der Platte zu löschen und den Platz dann Manjaro zuzuschlagen. Es ist eh die letzte 32-bit-Version davon. Und ich habe es nur der Neugierde halber mal auf die Platte genommen.

Ich könnte nochmals folgendes probieren: Den XFCE-Session-Cache leeren mit
rm -r ~/.cache/sessions/Vielleicht bringt das noch etwas?

Und / Oder:
Ich entferne den Cinnamon-Desktop. Das dürfte nochmals Platz bringen.
« Letzte Änderung: 10. August 2015, 22:42:57 von Hubsi_Gberg »

Offline Hubsi_Gberg

  • Held Mitglied
  • *****
  • Beiträge: 599
  • Dankeschön: 48 mal
  • Desktop: XFCE
  • Grafikkarte: NVIDIA G94GL [Quadro FX 1800]
  • Grafikkartentreiber: nouveau
  • Kernel: 4.9.31-1-MANJARO (linux49)
  • Prozessor: Intel Xeon W3680 (-HT-MCP-)
  • Skill: Durchschnitt
  • Zweig: stable
Re: Failed to set new theme (Update] 2015-08-10)
« Antwort #4 am: 11. August 2015, 11:28:47 »
Ich habe jetzt das überflüssige OS von der Platte entfernt und somit Platz geschaffen. Die Fehlermeldung trat nicht mehr auf.

Allerdings hatte mein XFCE-Menü nicht mehr den "Manjaro"-Startknopf, sondern die Gnome-Maus des Whiskermenüs. Das Manjaro-Symbol musste ich wieder per Hand herstellen.

Alles in allem also alles wieder in Ordnung.

Offline Hubsi_Gberg

  • Held Mitglied
  • *****
  • Beiträge: 599
  • Dankeschön: 48 mal
  • Desktop: XFCE
  • Grafikkarte: NVIDIA G94GL [Quadro FX 1800]
  • Grafikkartentreiber: nouveau
  • Kernel: 4.9.31-1-MANJARO (linux49)
  • Prozessor: Intel Xeon W3680 (-HT-MCP-)
  • Skill: Durchschnitt
  • Zweig: stable
Re: Failed to set new theme (Update] 2015-08-10)
« Antwort #5 am: 11. August 2015, 17:59:25 »
Ich habe einfach auf die Icon-Schaltfläche geklickt und in der Suchzeile "Manjaro" eingegeben. Es kamen zwei grüne "Manjaro"-Ms zum Vorschein. Davon habe ich einfach eines gewählt.

Ist vermutlich nicht das Original, aber für mich tüt's das zunächst auch. Gut, dass du den Pfad mal geschrieben hast, in dem es zu finden ist. Hilft vielleicht auch anderen Suchenden weiter.  8)