Autor Thema: Plötzlich funktioniert Cups nicht mehr  (Gelesen 2994 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Offline kochstudio

  • Neuling
  • *
  • Beiträge: 36
  • Desktop: Xfce netbook
  • Grafikkartentreiber: free
  • Kernel: 4.4.25-1-netbook
  • Prozessor: Atom N270
  • Skill: Anfänger
Plötzlich funktioniert Cups nicht mehr
« am: 26. August 2015, 09:12:17 »
Cups, ghostscript, psfonts, cups-pdf sind fehlerfrei installiert.
der Dienst lässt sich aber nicht starten - gestern funktionierte es einwandfrei?  :o

[heinz@ideapad ~]$ sudo systemctl start cups.service
Failed to start cups.service: Unit cups.service failed to load: No such file or directory
« Letzte Änderung: 26. August 2015, 09:13:49 von Linu74 »

Online Linu74

  • Administrator
  • ******
  • Beiträge: 1986
  • Dankeschön: 143 mal
  • Desktop: XFCE/i3gaps x86_64
  • Grafikkarte: Intel/Nvidia
  • Grafikkartentreiber: free/nonfree
  • Kernel: 4.1, 4.4
  • Prozessor: Core2Duo + Intel® Core™ i5-2520M
  • Skill: Durchschnitt
  • Zweig: testing
Re: Plötzlich funktioniert Cups nicht mehr
« Antwort #1 am: 26. August 2015, 09:17:20 »
Versuch mal folgendes:

sudo systemctl status org.cups.cupsd.service
Linu74
Manjaro XFCE/i3gaps x86_64bit auf ThinkPad X200, T400, T520
Deutscher Manjaro IRC Channel auf Freenode #manjaro-de

Offline kochstudio

  • Neuling
  • *
  • Beiträge: 36
  • Desktop: Xfce netbook
  • Grafikkartentreiber: free
  • Kernel: 4.4.25-1-netbook
  • Prozessor: Atom N270
  • Skill: Anfänger
Re: Plötzlich funktioniert Cups nicht mehr
« Antwort #2 am: 26. August 2015, 09:39:10 »
Versuch mal folgendes:

sudo systemctl status org.cups.cupsd.service
Linu74

[heinz@ideapad ~]$ sudo systemctl status org.cups.cupsd.service
[sudo] Passwort für heinz:
● org.cups.cupsd.service - CUPS Scheduler
   Loaded: loaded (/usr/lib/systemd/system/org.cups.cupsd.service; disabled; vendor preset: disabled)
   Active: active (running) since Mi 2015-08-26 08:57:50 CEST; 38min ago
     Docs: man:cupsd(8)
 Main PID: 986 (cupsd)
   CGroup: /system.slice/org.cups.cupsd.service
           └─986 /usr/bin/cupsd -l

Aug 26 08:57:50 ideapad systemd[1]: Started CUPS Scheduler.

Drucker sind weiterhin unerreichbar
« Letzte Änderung: 26. August 2015, 09:42:44 von Linu74 »

Online Linu74

  • Administrator
  • ******
  • Beiträge: 1986
  • Dankeschön: 143 mal
  • Desktop: XFCE/i3gaps x86_64
  • Grafikkarte: Intel/Nvidia
  • Grafikkartentreiber: free/nonfree
  • Kernel: 4.1, 4.4
  • Prozessor: Core2Duo + Intel® Core™ i5-2520M
  • Skill: Durchschnitt
  • Zweig: testing
Re: Plötzlich funktioniert Cups nicht mehr
« Antwort #3 am: 26. August 2015, 09:46:38 »
Cups, ghostscript, psfonts, cups-pdf sind fehlerfrei installiert.
der Dienst lässt sich aber nicht starten - gestern funktionierte es einwandfrei?  :o

Ob es nun gestern funktioniert hat, kann ich aus der Ferne nicht sagen.

Was hast du denn gestern gemacht? Update's installiert oder sonstiges am System geändert?
Um was für einen Drucker handelt es sich? Anschlußvariante USB oder Netzwerkdrucker?

Linu74
Manjaro XFCE/i3gaps x86_64bit auf ThinkPad X200, T400, T520
Deutscher Manjaro IRC Channel auf Freenode #manjaro-de

Offline sdoubleyou

  • Held Mitglied
  • *****
  • Beiträge: 1049
  • Dankeschön: 148 mal
  • Desktop: Gentoo + spectrwm
  • Grafikkarte: intel
  • Kernel: Longterm 4.4
  • Skill: Durchschnitt
  • Zweig: unstable
Re: Plötzlich funktioniert Cups nicht mehr
« Antwort #4 am: 26. August 2015, 09:48:06 »
Cups, ghostscript, psfonts, cups-pdf sind fehlerfrei installiert.
der Dienst lässt sich aber nicht starten - gestern funktionierte es einwandfrei?  :o

[heinz@ideapad ~]$ sudo systemctl start cups.service
Failed to start cups.service: Unit cups.service failed to load: No such file or directory

Seit cups 2.0.0 ist der Servicename geändert worden. Du musst den alten Service disable setzen

systemctl disable cups.servicedann
systemctl enable org.cups.cupsd.service
systemctl daemon-reload
systemctl start org.cups.cupsd.service
Folgende Mitglieder bedankten sich: kochstudio

Offline kochstudio

  • Neuling
  • *
  • Beiträge: 36
  • Desktop: Xfce netbook
  • Grafikkartentreiber: free
  • Kernel: 4.4.25-1-netbook
  • Prozessor: Atom N270
  • Skill: Anfänger
Re: Plötzlich funktioniert Cups nicht mehr
« Antwort #5 am: 26. August 2015, 09:57:41 »
Ob es nun gestern funktioniert hat, kann ich aus der Ferne nicht sagen.

Was hast du denn gestern gemacht? Update's installiert oder sonstiges am System geändert?
Um was für einen Drucker handelt es sich? Anschlußvariante USB oder Netzwerkdrucker?

Linu74
Definitiv hat es gestern funktioniert - habe alle Drucker im Netz gesehen, jetzt sehe ich nur eine lokalen Drucker, der an einem MAC angeschlossen ist (inaktiv).
Nichts wissentlich geändert, nicht einmal neu angemeldet, nur Ruhezustand.

Online Linu74

  • Administrator
  • ******
  • Beiträge: 1986
  • Dankeschön: 143 mal
  • Desktop: XFCE/i3gaps x86_64
  • Grafikkarte: Intel/Nvidia
  • Grafikkartentreiber: free/nonfree
  • Kernel: 4.1, 4.4
  • Prozessor: Core2Duo + Intel® Core™ i5-2520M
  • Skill: Durchschnitt
  • Zweig: testing
Re: Plötzlich funktioniert Cups nicht mehr
« Antwort #6 am: 26. August 2015, 10:02:28 »
Dann starte mal Neu, vielleicht liegt es am Ruhezustand.

Linu74
Manjaro XFCE/i3gaps x86_64bit auf ThinkPad X200, T400, T520
Deutscher Manjaro IRC Channel auf Freenode #manjaro-de

Offline kochstudio

  • Neuling
  • *
  • Beiträge: 36
  • Desktop: Xfce netbook
  • Grafikkartentreiber: free
  • Kernel: 4.4.25-1-netbook
  • Prozessor: Atom N270
  • Skill: Anfänger
Re: Plötzlich funktioniert Cups nicht mehr
« Antwort #7 am: 26. August 2015, 10:11:19 »
Seit cups 2.0.0 ist der Servicename geändert worden. Du musst den alten Service disable setzen

systemctl disable cups.servicedann
systemctl enable org.cups.cupsd.service
systemctl daemon-reload
systemctl start org.cups.cupsd.service
Danke, das hat funktioniert, musste mich aber neu anmelden.
Nach einem Neustart wird der Dienst allerdings nicht gestartet.
Wie sage ich meinem Rechner nun, dass er dies tun soll?
Danke im Voraus ;-)

Offline kochstudio

  • Neuling
  • *
  • Beiträge: 36
  • Desktop: Xfce netbook
  • Grafikkartentreiber: free
  • Kernel: 4.4.25-1-netbook
  • Prozessor: Atom N270
  • Skill: Anfänger
Re: Plötzlich funktioniert Cups nicht mehr
« Antwort #8 am: 26. August 2015, 10:13:10 »
Dann starte mal Neu, vielleicht liegt es am Ruhezustand.

Linu74
Hatte ich versucht, ohne Erfolg...
« Letzte Änderung: 26. August 2015, 10:19:50 von kochstudio »

Offline kochstudio

  • Neuling
  • *
  • Beiträge: 36
  • Desktop: Xfce netbook
  • Grafikkartentreiber: free
  • Kernel: 4.4.25-1-netbook
  • Prozessor: Atom N270
  • Skill: Anfänger
Re: Plötzlich funktioniert Cups nicht mehr
« Antwort #9 am: 26. August 2015, 10:56:28 »
Also - der Drucker ist jetzt auch nach einem Neustart erreichbar, allerdings ist er in der Druckerverwaltung nicht sichtbar.

Offline kochstudio

  • Neuling
  • *
  • Beiträge: 36
  • Desktop: Xfce netbook
  • Grafikkartentreiber: free
  • Kernel: 4.4.25-1-netbook
  • Prozessor: Atom N270
  • Skill: Anfänger
Re: Plötzlich funktioniert Cups nicht mehr
« Antwort #10 am: 16. Oktober 2015, 11:57:02 »
Drucker ist in der Regel nicht mehr sichtbar.
In der cups Druckerverwaltung ist dafür folgender Fehlereintrag zu finden:

E [25/Aug/2015:09:24:35 +0200] [Client 23] Returning HTTP Verboten for CUPS-Get-Devices (no URI) from localhost
E [25/Aug/2015:09:24:35 +0200] [CGI] CUPS-Get-Devices request failed with status 401: Verboten