Autor Thema: heute Updates - ncurses 6.0 - Warnung  (Gelesen 2693 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

sdoubleyou

  • Gast
heute Updates - ncurses 6.0 - Warnung
« am: 18. September 2015, 16:54:37 »
Heute sind im unstable Updates gekommen. ncurses 6.0 und bash 4.3.042-2

Nach dem Update können bestimmte Pakete nicht mehr gestartet werden. Bei mir sind das newsbeuter und mutt
error while loading shared libraries: libncursesw.so.5: cannot open shared object file: No such file or directory
Ich möchte hier keine Panik verursachen, aber möchte dringend vor einem downgrade warnen.
Im Arch Forum häufen sich die Meldungen, dass ich die User durch das downgrade das gesamte System zerschossen haben.

Es wird auch bash in der Version 4.3.042-3 benötigt.

Ein Arch developer schrieb:
Zitat
We also just pushed bash 4.3.042-3 and readline 6.3.008-3 which specifically require libncursesw.so.6 in order to prevent this from happening to other users

Hier müssen wir noch warten. Also, bitte aktuell kein downgrade fahren.
Im engl. Forum wird es auch schon besprochen
« Letzte Änderung: 01. Februar 2017, 02:18:49 von virtual-dev »

Offline oberon

  • Held Mitglied
  • *****
  • Beiträge: 675
  • Dankeschön: 75 mal
  • Desktop: i3, Cinnamon, Deepin, Xfce
  • Grafikkarte: Intel ValleyView Gen7
  • Grafikkartentreiber: free (Intel)
  • Kernel: 4.1 / 4.4
  • Prozessor: Intel Pentium N3540 Quad Core 2.6GHz
  • Skill: Durchschnitt
  • Zweig: unstable
Re: heute Updates - ncurses 6.0 - Warnung
« Antwort #1 am: 19. September 2015, 01:10:24 »
Die Probleme waren v.a. für Openrc relativ schwerwiegend, inzwischen wurde das aber gelöst und mit den neuesten Paketen ist nun auch in unstable und testing wieder alles in Butter.
In stable sollte es in jedem Fall keinerlei Schwierigkeiten geben.

Offline SpiritOfTux

  • Held Mitglied
  • *****
  • Beiträge: 1223
  • Dankeschön: 183 mal
    • https://twitter.com/SpiritOfTux
  • Desktop: KDE Plasma, Deepin
  • Grafikkarte: NVIDIA [GeForce GTX 1060] [GeForce GTX 560 Ti] [GeForce GT 635M]
  • Grafikkartentreiber: On: NB intel/nvidia, HTPC nvidia, PowerWorkStation nvidia
  • Kernel: 4.14.y LTS, 4.9.y LTS,
  • Prozessor: Notebook: Intel(R) Core(TM) i5-3230M CPU @ 2.60GHz
  • Skill: Fortgeschritten
  • Zweig: stable 17.1.y on PowerWorkStation, NB, HTPC, Desktop:s: Testing or Unstable only VM
Re: heute Updates - ncurses 6.0 - Warnung
« Antwort #2 am: 19. September 2015, 15:00:55 »
So sah es heute gestern beim Update von 1509rc3 aus

upgrading ncurses
upgrading readline
/usr/bin/bash: error while loading shared libraries: libncursesw.so.5: cannot open shared object file: No such file or directory
error: command failed to execute correctly
upgrading bash
« Letzte Änderung: 19. September 2015, 15:06:10 von SpiritOfTux »
Vielen Dank, dass du diesen Artikel bei uns gelesen hast!  Wir würden uns sehr freuen, wenn du diesen ebenfalls im folgenden Abschnitt bewerten würdest.(Danke sagen) 
Nach hilfreichen Antworten suchen: Manjaro Forum | Manjaro Wiki | Arch Wiki | Arch WiKi on NB/PC : sudo pacman -S arch-wiki-man https://github.com/greg-js/arch-wiki-man#readme

Offline Ahnungsloser

  • Held Mitglied
  • *****
  • Beiträge: 915
  • Dankeschön: 46 mal
  • Desktop: KDE Plasma 5.15.0 - OpenRC
  • Grafikkarte: Intel 3rd Gen Core processor Graphics Controller | NVIDIA GK208M [GeForce GT 720M]
  • Grafikkartentreiber: free
  • Kernel: 4.20.8-artix1-1-ARTIX x86_64
  • Prozessor: Intel Core i3-3217U
  • Skill: Anfänger
  • Zweig: stable
Re: heute Updates - ncurses 6.0 - Warnung
« Antwort #3 am: 20. September 2015, 08:49:52 »
Ich erhalte beim Aktualisieren von KDE 15.09-rc3 die gleiche Meldung, allerdings nicht unmittelbar nach der Zeile der Aktualisierung von ncurses sondern nach der update Zeile von readline:

( 1/54) Aktualisiere ncurses                                                    [##############################################] 100%
( 2/54) Aktualisiere readline                                                   [##############################################] 100%
/usr/bin/bash: error while loading shared libraries: libncursesw.so.5: cannot open shared object file: No such file or directory
Fehler: Befehl konnte nicht korrekt ausgeführt werden
Im neuen Forum unter dem Nick "Roberto" :)

Offline oberon

  • Held Mitglied
  • *****
  • Beiträge: 675
  • Dankeschön: 75 mal
  • Desktop: i3, Cinnamon, Deepin, Xfce
  • Grafikkarte: Intel ValleyView Gen7
  • Grafikkartentreiber: free (Intel)
  • Kernel: 4.1 / 4.4
  • Prozessor: Intel Pentium N3540 Quad Core 2.6GHz
  • Skill: Durchschnitt
  • Zweig: unstable
Re: heute Updates - ncurses 6.0 - Warnung
« Antwort #4 am: 20. September 2015, 09:15:45 »
Wurde bash ev. erst später aktualisiert?
Ich sehe der Ausschnitt ist bei 2 von 54 updates ... ;)
Was passiert wenn du nochmal einsudo pacman -Syyumachst?

Offline Ahnungsloser

  • Held Mitglied
  • *****
  • Beiträge: 915
  • Dankeschön: 46 mal
  • Desktop: KDE Plasma 5.15.0 - OpenRC
  • Grafikkarte: Intel 3rd Gen Core processor Graphics Controller | NVIDIA GK208M [GeForce GT 720M]
  • Grafikkartentreiber: free
  • Kernel: 4.20.8-artix1-1-ARTIX x86_64
  • Prozessor: Intel Core i3-3217U
  • Skill: Anfänger
  • Zweig: stable
Re: heute Updates - ncurses 6.0 - Warnung
« Antwort #5 am: 20. September 2015, 09:19:14 »
Dann erhalte ich die Meldung, dass es nichts zu tun gibt.
Im neuen Forum unter dem Nick "Roberto" :)

Offline oberon

  • Held Mitglied
  • *****
  • Beiträge: 675
  • Dankeschön: 75 mal
  • Desktop: i3, Cinnamon, Deepin, Xfce
  • Grafikkarte: Intel ValleyView Gen7
  • Grafikkartentreiber: free (Intel)
  • Kernel: 4.1 / 4.4
  • Prozessor: Intel Pentium N3540 Quad Core 2.6GHz
  • Skill: Durchschnitt
  • Zweig: unstable
Re: heute Updates - ncurses 6.0 - Warnung
« Antwort #6 am: 20. September 2015, 11:04:43 »
Ich denke dann sollte alles gut sein :)

Offline Pig of Destiny

  • Held Mitglied
  • *****
  • Beiträge: 1383
  • Dankeschön: 125 mal
  • Desktop: Xfce
  • Grafikkarte: Intel Graphics
  • Grafikkartentreiber: free
  • Kernel: 4.16
  • Prozessor: Intel Celeron N3350
  • Skill: Durchschnitt
  • Zweig: Arch Linux
Re: heute Updates - ncurses 6.0 - Warnung
« Antwort #7 am: 20. September 2015, 17:31:07 »
Du kannst ja noch mal die installierte Version von readline prüfen mit pacman -Qs readlinees sollte herauskommen: local/readline 6.3.008-3
    GNU readline library

Offline Ahnungsloser

  • Held Mitglied
  • *****
  • Beiträge: 915
  • Dankeschön: 46 mal
  • Desktop: KDE Plasma 5.15.0 - OpenRC
  • Grafikkarte: Intel 3rd Gen Core processor Graphics Controller | NVIDIA GK208M [GeForce GT 720M]
  • Grafikkartentreiber: free
  • Kernel: 4.20.8-artix1-1-ARTIX x86_64
  • Prozessor: Intel Core i3-3217U
  • Skill: Anfänger
  • Zweig: stable
Re: heute Updates - ncurses 6.0 - Warnung
« Antwort #8 am: 20. September 2015, 18:52:24 »
bei mir kommt das raus:

local/lib32-readline 6.3.008-2
    GNU readline library (32-bit)
local/perl 5.22.0-1 (base)
    A highly capable, feature-rich programming language
local/readline 6.3.008-3
    GNU readline library
Im neuen Forum unter dem Nick "Roberto" :)

Offline Pig of Destiny

  • Held Mitglied
  • *****
  • Beiträge: 1383
  • Dankeschön: 125 mal
  • Desktop: Xfce
  • Grafikkarte: Intel Graphics
  • Grafikkartentreiber: free
  • Kernel: 4.16
  • Prozessor: Intel Celeron N3350
  • Skill: Durchschnitt
  • Zweig: Arch Linux
Re: heute Updates - ncurses 6.0 - Warnung
« Antwort #9 am: 20. September 2015, 19:07:10 »
Ja, dann wurde readline upgedated. Passt also soweit.