Autor Thema: Numlock beim Start aktivieren  (Gelesen 2551 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Offline Bankman

  • Sr. Mitglied
  • ****
  • Beiträge: 354
  • Dankeschön: 22 mal
  • Desktop: XFCE
  • Grafikkarte: Intel HD graphics 620
  • Grafikkartentreiber: free
  • Kernel: Linux 4.20
  • Prozessor: Intel® Core™ i5-7200U
  • Skill: Durchschnitt
  • Zweig: stable
Numlock beim Start aktivieren
« am: 29. September 2015, 17:35:11 »
Hallo Gemeinde,

habe mir gestern mal eine komplette Neuinstallation gegönnt und mein System wunderbar neu eingerichtet.
Leider klappt das automatische Aktivieren der Numlock-Taste beim Systemstart nicht.
Bin gemäß https://wiki.archlinux.org/index.php/LightDM vorgegangen und habe numlockx installiert und den entsprechenden Eintrag greeter-setup-script=/usr/bin/numlockx on in /etc/lightdm/lightdm.conf plaziert.

Leider funzt das nicht.
Habt ihr evtl. eine Idee?
Arbeite übrigens mit einem Lenovo Y510p

Vielen Dank!
Bankman
"Mögen hätt ich schon wollen, aber dürfen hab ich mich nicht getraut."

Offline klesk

  • Held Mitglied
  • *****
  • Beiträge: 1194
  • Dankeschön: 142 mal
  • Desktop: herbstluftwm
  • Grafikkartentreiber: nvidia 3.40xx
  • Kernel: 4.2
  • Prozessor: Intel Core2 Quad Q9550 (-MCP-)
  • Skill: Durchschnitt
  • Zweig: unstable
Re: Numlock beim Start aktivieren
« Antwort #1 am: 29. September 2015, 17:39:02 »
Haste es mal manuell ausprobiert, ob es funktioniert ?

Offline Bankman

  • Sr. Mitglied
  • ****
  • Beiträge: 354
  • Dankeschön: 22 mal
  • Desktop: XFCE
  • Grafikkarte: Intel HD graphics 620
  • Grafikkartentreiber: free
  • Kernel: Linux 4.20
  • Prozessor: Intel® Core™ i5-7200U
  • Skill: Durchschnitt
  • Zweig: stable
Re: Numlock beim Start aktivieren
« Antwort #2 am: 29. September 2015, 17:48:34 »
was meinst du mit "manuell ausprobiert"?
Falls du das Betätigen der "NumLock"-Taste meinst: klar, wenn ich die drücke, dann funzt es.
"Mögen hätt ich schon wollen, aber dürfen hab ich mich nicht getraut."

Offline klesk

  • Held Mitglied
  • *****
  • Beiträge: 1194
  • Dankeschön: 142 mal
  • Desktop: herbstluftwm
  • Grafikkartentreiber: nvidia 3.40xx
  • Kernel: 4.2
  • Prozessor: Intel Core2 Quad Q9550 (-MCP-)
  • Skill: Durchschnitt
  • Zweig: unstable
Re: Numlock beim Start aktivieren
« Antwort #3 am: 29. September 2015, 18:03:23 »
Meinte eigentlich im Terminal

numlockx on
numlockx off

Nur damit man das als Fehlerquelle ausschließen kann.

Offline Bankman

  • Sr. Mitglied
  • ****
  • Beiträge: 354
  • Dankeschön: 22 mal
  • Desktop: XFCE
  • Grafikkarte: Intel HD graphics 620
  • Grafikkartentreiber: free
  • Kernel: Linux 4.20
  • Prozessor: Intel® Core™ i5-7200U
  • Skill: Durchschnitt
  • Zweig: stable
Re: Numlock beim Start aktivieren
« Antwort #4 am: 29. September 2015, 18:09:21 »
Sorry, stand etwas auf der Leitung.
Aber klar, habe im Terminal numlockx on eingegeben.
Hat aber nichts gebracht.
"Mögen hätt ich schon wollen, aber dürfen hab ich mich nicht getraut."

Offline Linu74

  • Administrator
  • ******
  • Beiträge: 2037
  • Dankeschön: 148 mal
  • Desktop: XFCE/i3gaps x86_64
  • Grafikkarte: Intel/Nvidia
  • Grafikkartentreiber: free/nonfree
  • Kernel: 4.19
  • Prozessor: Core2Duo + Intel® Core™ i5-2520M
  • Skill: Durchschnitt
  • Zweig: testing
Re: Numlock beim Start aktivieren
« Antwort #5 am: 29. September 2015, 18:17:17 »
Schau mal was die "Suche" im Forum ergeben hat:

https://de.manjaro.org/index.php?topic=3001.msg25387#msg25387

Linu74
Manjaro XFCE/i3gaps x86_64bit auf ThinkPad X200, T400, T520
Deutscher Manjaro IRC Channel auf Freenode #manjaro-de

Offline Bankman

  • Sr. Mitglied
  • ****
  • Beiträge: 354
  • Dankeschön: 22 mal
  • Desktop: XFCE
  • Grafikkarte: Intel HD graphics 620
  • Grafikkartentreiber: free
  • Kernel: Linux 4.20
  • Prozessor: Intel® Core™ i5-7200U
  • Skill: Durchschnitt
  • Zweig: stable
Re: Numlock beim Start aktivieren
« Antwort #6 am: 29. September 2015, 18:28:48 »
Schau mal was die "Suche" im Forum ergeben hat:

https://de.manjaro.org/index.php?topic=3001.msg25387#msg25387

Linu74

Sorry, hatte ich vergessen zu erwähnen.
Das hatte ich auch probiert, leider ohne Erfolg.
Habe aber den Eintrag unter /Einstellungen/Sitzung und Startverhalten/Automatisch gestartete Anwendungen mal dringelassen.
"Mögen hätt ich schon wollen, aber dürfen hab ich mich nicht getraut."

Offline klesk

  • Held Mitglied
  • *****
  • Beiträge: 1194
  • Dankeschön: 142 mal
  • Desktop: herbstluftwm
  • Grafikkartentreiber: nvidia 3.40xx
  • Kernel: 4.2
  • Prozessor: Intel Core2 Quad Q9550 (-MCP-)
  • Skill: Durchschnitt
  • Zweig: unstable
Re: Numlock beim Start aktivieren
« Antwort #7 am: 29. September 2015, 18:50:09 »
Das Problem ist, wenn numlockx schon so nicht funktioniert z.b mit

numlockx toggle
müsste man ersteinmal herausfinden warum es nicht geht, oder sich nach alternativen umschauen falls es was gibt.
Ich werde mal schauen ob ich was dazu finde.


Offline Bankman

  • Sr. Mitglied
  • ****
  • Beiträge: 354
  • Dankeschön: 22 mal
  • Desktop: XFCE
  • Grafikkarte: Intel HD graphics 620
  • Grafikkartentreiber: free
  • Kernel: Linux 4.20
  • Prozessor: Intel® Core™ i5-7200U
  • Skill: Durchschnitt
  • Zweig: stable
Re: Numlock beim Start aktivieren
« Antwort #8 am: 29. September 2015, 20:19:34 »
Zitat
müsste man ersteinmal herausfinden warum es nicht geht, oder sich nach alternativen umschauen falls es was gibt.

Zumal es bei meiner alten Installation funktioniert hatte  ???
"Mögen hätt ich schon wollen, aber dürfen hab ich mich nicht getraut."

Offline Bankman

  • Sr. Mitglied
  • ****
  • Beiträge: 354
  • Dankeschön: 22 mal
  • Desktop: XFCE
  • Grafikkarte: Intel HD graphics 620
  • Grafikkartentreiber: free
  • Kernel: Linux 4.20
  • Prozessor: Intel® Core™ i5-7200U
  • Skill: Durchschnitt
  • Zweig: stable
Re: Numlock beim Start aktivieren
« Antwort #9 am: 30. September 2015, 18:48:04 »
Zitat
Schaue dir mal diese Seite an, liest sich interessant:

https://wiki.archlinux.org/index.php/Activating_Numlock_on_Bootup

Danke für den Link.
Habe jetzt die Punkte
1 Console
1.1 Using a separate service
1.2 Extending getty@.service
1.3 Bash alternative
2 X.org
2.1 startx
2.6 Xfce und
2.10 LightDM ausprobiert.

Leider bis dato alles ohne Erfolg.
Ich verstehe das nicht. Bei der alten Installation hatte ich das mittels LightDM aktiviert und es hat funktioniert.
Und jetzt will es einfach nicht funktionieren...

Bin ratlos  :-\
"Mögen hätt ich schon wollen, aber dürfen hab ich mich nicht getraut."

Offline klesk

  • Held Mitglied
  • *****
  • Beiträge: 1194
  • Dankeschön: 142 mal
  • Desktop: herbstluftwm
  • Grafikkartentreiber: nvidia 3.40xx
  • Kernel: 4.2
  • Prozessor: Intel Core2 Quad Q9550 (-MCP-)
  • Skill: Durchschnitt
  • Zweig: unstable
Re: Numlock beim Start aktivieren
« Antwort #10 am: 30. September 2015, 19:23:46 »
Was ist den in der

/etc/X11/xorg.conf.d/20-keyboard.conf

eingestellt ?

Offline Bankman

  • Sr. Mitglied
  • ****
  • Beiträge: 354
  • Dankeschön: 22 mal
  • Desktop: XFCE
  • Grafikkarte: Intel HD graphics 620
  • Grafikkartentreiber: free
  • Kernel: Linux 4.20
  • Prozessor: Intel® Core™ i5-7200U
  • Skill: Durchschnitt
  • Zweig: stable
Re: Numlock beim Start aktivieren
« Antwort #11 am: 30. September 2015, 20:10:15 »
Habe nur eine Datei /etc/X11/xorg.conf.d/00-keyboard.conf und die sieht so aus:
# Read and parsed by systemd-localed. It's probably wise not to edit this file
# manually too freely.
Section "InputClass"
        Identifier "system-keyboard"
        MatchIsKeyboard "on"
        Option "XkbLayout" "de"
        Option "XkbModel" "pc105"
EndSection
"Mögen hätt ich schon wollen, aber dürfen hab ich mich nicht getraut."

LuMI

  • Gast
Re: Numlock beim Start aktivieren
« Antwort #12 am: 01. Oktober 2015, 05:39:32 »
Zitat
habe mir gestern mal eine komplette Neuinstallation gegönnt und mein System wunderbar neu eingerichtet.
Leider klappt das automatische Aktivieren der Numlock-Taste beim Systemstart nicht.

 ??? ??? ??? ??? ??? ??? ??? ??? ???

Zitat
Aber klar, habe im Terminal
Code: [Auswählen]

numlockx on
eingegeben.
Hat aber nichts gebracht.

ich würde zuerst numlockx installieren ...

sudo pacman -S numlockx

https://de.manjaro.org/index.php?topic=3001.msg25387#msg25387

https://wiki.archlinux.de/title/Numlock

MfG
« Letzte Änderung: 01. Oktober 2015, 05:47:13 von LuMI »

LuMI

  • Gast
Re: Numlock beim Start aktivieren
« Antwort #13 am: 01. Oktober 2015, 06:39:48 »
Zitat
Laut help ist on sogar default

Ja, wenn man es installiert. Auf der .iso ist numlockx nicht dabei.

http://sourceforge.net/projects/manjarolinux/files/release/15.09/xfce/manjaro-xfce-15.09-x86_64-pkgs.txt/download

MfG

Offline Bankman

  • Sr. Mitglied
  • ****
  • Beiträge: 354
  • Dankeschön: 22 mal
  • Desktop: XFCE
  • Grafikkarte: Intel HD graphics 620
  • Grafikkartentreiber: free
  • Kernel: Linux 4.20
  • Prozessor: Intel® Core™ i5-7200U
  • Skill: Durchschnitt
  • Zweig: stable
Re: Numlock beim Start aktivieren
« Antwort #14 am: 01. Oktober 2015, 07:16:03 »
Ja, wenn man es installiert. Auf der .iso ist numlockx nicht dabei.

http://sourceforge.net/projects/manjarolinux/files/release/15.09/xfce/manjaro-xfce-15.09-x86_64-pkgs.txt/download

MfG

Natürlich habe ich NumLockX installiert. Das es ohne nicht geht ist doch eigentlich klar...
"Mögen hätt ich schon wollen, aber dürfen hab ich mich nicht getraut."