Autor Thema: Numlock beim Start aktivieren  (Gelesen 2539 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Offline Verändert

  • Support Team
  • *****
  • Beiträge: 1149
  • Dankeschön: 62 mal
  • Ni Dieu ni maître
  • Desktop: Gnome. LXQt. i3.
  • Grafikkarte: Intel & Radeon & NVidia
  • Grafikkartentreiber: frei natürlich
  • Kernel: Immer der aktuelle.
  • Prozessor: Intel Celeron und andere.
  • Skill: Anfänger
  • Zweig: unstable
Re: Numlock beim Start aktivieren
« Antwort #15 am: 01. Oktober 2015, 07:48:52 »
Funktioniert es denn mit einer externen Tastatur (soweit Du eine hast) ?

Offline Bankman

  • Sr. Mitglied
  • ****
  • Beiträge: 354
  • Dankeschön: 22 mal
  • Desktop: XFCE
  • Grafikkarte: Intel HD graphics 620
  • Grafikkartentreiber: free
  • Kernel: Linux 4.20
  • Prozessor: Intel® Core™ i5-7200U
  • Skill: Durchschnitt
  • Zweig: stable
Re: Numlock beim Start aktivieren
« Antwort #16 am: 01. Oktober 2015, 08:24:37 »
Sorry, aber eine externe Tastatur habe ich nicht.
Kann es evtl. sein, dass da schon bei der Installation irgendwas nicht ganz rund gelaufen ist? Könnte eine nochmalige Neuinstallation was bringen? Wie gesagt, bei der vorherigen Installation ging es.
"Mögen hätt ich schon wollen, aber dürfen hab ich mich nicht getraut."

LuMI

  • Gast
Re: Numlock beim Start aktivieren
« Antwort #17 am: 01. Oktober 2015, 10:34:09 »
Zitat
Sorry, aber eine externe Tastatur habe ich nicht.
Kann es evtl. sein, dass da schon bei der Installation irgendwas nicht ganz rund gelaufen ist? Könnte eine nochmalige Neuinstallation was bringen? Wie gesagt, bei der vorherigen Installation ging es.

Bei mir funktioniert es.
Numlockx wird mit Autostart Eintrag gestartet.
Meine 20-keyboard.conf sieht so aus.

/etc/X11/xorg.conf.d/20-keyboard.conf

Section "InputClass"
 Identifier "system-keyboard"
 MatchIsKeyboard "on"
 Option "XkbLayout" "de"
 Option "XkbModel" "pc105"
 Option "XkbVariant" "nodeadkeys"
 Option "XkbOptions" "terminate:ctrl_alt_bksp"
EndSection


MfG

Offline Bankman

  • Sr. Mitglied
  • ****
  • Beiträge: 354
  • Dankeschön: 22 mal
  • Desktop: XFCE
  • Grafikkarte: Intel HD graphics 620
  • Grafikkartentreiber: free
  • Kernel: Linux 4.20
  • Prozessor: Intel® Core™ i5-7200U
  • Skill: Durchschnitt
  • Zweig: stable
Re: Numlock beim Start aktivieren
« Antwort #18 am: 01. Oktober 2015, 19:47:34 »
Gehe doch mal die Einstellungen:
Einstellungen/Tastatur/Verhalten/Ziffernblock (Num-Taste) beim Start wieder herstellen
durch. Häkchen gesetzt?

Oder unter Tastaturbelegung mal Option "XkbVariant" "nodeadkeys" probieren.

Dann könntest du eventuell mal dort eine andere Tastatur auswählen.

Eventuell hattest du die Keybelegung auch damals von Hand verändert?

Wenn z.B. die Fn oder Num-Taste falsch belegt ist, nützt
auch das beste numlockx nichts.

Sehr guter Hinweis, vielen Dank! Das ist eine richtig gute Idee.
Das Häkchen ist gesetzt und ich hatte damals die Belegung ganz sicher nicht von Hand geändert.
Unter Einstellungen/Tastatur gibt es aber viele viele Möglichkeiten.
Wie kriege ich denn am einfachsten raus welche Tastatur ich habe?

Habe einen Lenovo y510p mit 102 Tasten.
"Mögen hätt ich schon wollen, aber dürfen hab ich mich nicht getraut."

Offline klesk

  • Held Mitglied
  • *****
  • Beiträge: 1194
  • Dankeschön: 142 mal
  • Desktop: herbstluftwm
  • Grafikkartentreiber: nvidia 3.40xx
  • Kernel: 4.2
  • Prozessor: Intel Core2 Quad Q9550 (-MCP-)
  • Skill: Durchschnitt
  • Zweig: unstable
Re: Numlock beim Start aktivieren
« Antwort #19 am: 01. Oktober 2015, 20:13:01 »
Würde glaube ich erstmal Lumis config so übernehmen und das testen. Deckt sich ja mit virtual-devs Lösungsansatz.
Ansonsten kannst du im manjaro-settings-manager deine Tastatur ändern, bzw kannst du dort auch z.b nodeadkeys auswählen.
Folgende Mitglieder bedankten sich: Bankman

Offline Bankman

  • Sr. Mitglied
  • ****
  • Beiträge: 354
  • Dankeschön: 22 mal
  • Desktop: XFCE
  • Grafikkarte: Intel HD graphics 620
  • Grafikkartentreiber: free
  • Kernel: Linux 4.20
  • Prozessor: Intel® Core™ i5-7200U
  • Skill: Durchschnitt
  • Zweig: stable
Re: Numlock beim Start aktivieren
« Antwort #20 am: 01. Oktober 2015, 20:25:04 »
Danke euch allen!
Es hat endlich funktioniert  :D :D :D

Es war die Kombination aus nicht optimaler Tastatureinstellung ("nodeadkeys" war das Stichwort) und das Einfügen der Numlock-Option in der lightdm.conf ein paar Zeilen zu weit oben (bin eher zufällig draufgekommen beim Probieren).

Danke auch für den Hinweis die Tastatureinstellungen über den manjaro-settings-manager zu ändern. Dort findet man etwas mehr Infos als unter Einstellungen/Tastatur wie z.B. die vorgenannte Option "nodeadkeys".
"Mögen hätt ich schon wollen, aber dürfen hab ich mich nicht getraut."