Autor Thema: Installation über PXE Boot  (Gelesen 958 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Offline roadrunner

  • Neuling
  • *
  • Beiträge: 1
  • Skill: Anfänger
Installation über PXE Boot
« am: 05. Oktober 2015, 23:18:41 »
Servus,

Ich hoffe Ihr könnt mir helfen. Seit einiger Zeit versuche ich verzweifelt Manjaro über mein internes Netzwerk per PXE zu installieren. Auch unzähliges Suchen im Internet brachte mich nicht weiter.

Ich sage es gleich: Ich bin ein LINUX Anfänger und habe da sicherlich viel zu wenig Wissen. Daher habe ich mal mit den DEBIAN basierten Distros begonnen. Da man nur mit der Herausforderung wächst, geht's weiter mit ARCH bzw. MANJARO... Kann ja nicht so schwer sein :) Tja denkste... da ich mir selbst nicht mehr weiterhelfen kann wende ich mich hierzu an Euch.

Ich will MANJARO über PXE Booten es kommt am Ende aber nur (Screenshot liegt bei - da sieht man ein wenig mehr):

ERROR: Couldn't mount /dev/sr0
ERROR: Couldn't mount /dev/sd[a-z][0-9]

Nachfolgend ein wenig Details über meine Installation hier:

1) Synology NAS DS214: Dieses NAS dient als Server. Ich habe die DEBIAN basierten Distributionen schon erfolgreich mittels PXE booten und installieren können (Xubuntu, MINT, SparkyLinux). Gehe als davon aus, dass der TFTP Server, sowie das PXE und die Konfiguration prinzipiell funktioniert
2) Ich versuche immer zuerst mittels VM (installiert auch meinem Haupt PC - Windows 10 - noch(?) mal schauen :) ) vom NAS zu booten - Die VM dient mir als Test für die PXE Boot Konfiguration. Wenn es dort läuft, dann versuche ich es mit meinem alten PC (AMD Athlon X2)
3) Das ISO File habe ich auf das NAS Kopiert und über den DSM (Disk Station Manager) als Ordner zugänglich gemacht.

Ergibt also in Summe 192.168.1.199:/volume1/tftpboot/isoimages/manjaro-xfce/
#) 192.168.1.199 ist die IP vom NAS
#) volume1 ist die HDD im NAS
#) tftpboot kommt vom PXE Server
#) isoimages ist ein von mir angelegter ORDNER in dem ich die ISO's reinlege
#) manjaro-xfce stellt den Inhalt vom ISO dar (Quelle: manjaro-xfce-15.09-x86_64.iso)

So sieht meine PXE Config aus:

LABEL LinuxManjaro XFCE_3
MENU LABEL LinuxManjaro XFCE x64_3
KERNEL isoimages/manjaro-xfce/manjaro/boot/x86_64/manjaro
INITRD isoimages/manjaro-xfce/manjaro/boot/x86_64/manjaro.img
APPEND archisobasedir=arch archiso_nfs_srv=192.168.1.199:/volume1/tftpboot/isoimages/manjaro-xfce/ ip=::::::dhcp

Ich habe da jetzt schon mehrere Arten probiert - aber irgendwie kommt immer das gleiche raus.  :(
Was mache ich falsch?
Wenn ich das richtig verstehe, dann sucht er das boot device, findet es aber nicht, versucht daher /dev/sr0 und Co. durch ob er was findet. Findet aber nichts... Wie teile ich denn dem Kernel mit, wo er "das" findet was er sucht?
Ich vermute auch, dass er das squashfs sucht. Aber welches nehme ich denn? Ich glaube in dem Ordner manjaro-xfce\manjaro\x86_64 das diese *.sqfs Dateien sind. Richtig? Aber derer gibt es 4 Stück... Bei XUbuntu und co gibt es nur eine Datei...

Ich bin verwirrt...  :o Könnt Ihr mir bitte helfen?

Danke - mfg roadrunner