Autor Thema: NFS Verbindung NFS-Server zu NFS-Klient...  (Gelesen 2054 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Offline Gerschon

  • Vollwertiges Mitglied
  • ***
  • Beiträge: 101
  • Desktop: Verschiedene bei Anderen Distris bei Manjaro xfce-Desktop
  • Grafikkarte: Verschiedene in den Pcs und Notebooks
  • Prozessor: 32-Bit Rechner und 64-Bit Rechner
  • Skill: Anfänger
  • Zweig: stable
NFS Verbindung NFS-Server zu NFS-Klient...
« am: 17. Oktober 2015, 19:00:49 »
Hallo will den Manjaro-Rechner auch als NFS-Server für die anderen Linuxrechner nutzen.

Das ist bereits da auf dem Rechner, also installiert:

pacman -Qs nfs
local/mkinitcpio-nfs-utils 0.3-5.3
    ipconfig and nfsmount tools for NFS root support in mkinitcpio
local/nfs-utils 1.3.2-6
    Support programs for Network File Systems
local/nfsidmap 0.26-1
    Library to help mapping IDs, mainly for NFSv4

Dann ist in /etc die Datei exports. Da ist aber alles im Moment durch # auskommentiert.

Will vom Linux Klient nfs Verbindung haben auf das jeweilige Heimverzeichnis des Benutzers.

Genügt es die Datei exports heranzunehmen um da das auskommentierte  durch löschen des # in Betrieb zu nehmen?

Diese Datei exports ist ähnlich aufgebaut wie die smb.conf unter samba...

# /etc/exports - exports(5) - directories exported to NFS clients
#
# Example for NFSv2 and NFSv3:
#  /srv/home        hostname1(rw,sync) hostname2(ro,sync)
# Example for NFSv4:
#  /srv/nfs4        hostname1(rw,sync,fsid=0)
#  /srv/nfs4/home   hostname1(rw,sync,nohide)
# Using Kerberos and integrity checking:
#  /srv/nfs4        *(rw,sync,sec=krb5i,fsid=0)
#  /srv/nfs4/home   *(rw,sync,sec=krb5i,nohide)
#
# Use `exportfs -arv` to reload.







Meine Lebenskraft ist unverkäuflich und Du kannst nur etwas freiwillig geschenkt bekommen davon, wenn ich als lebender  Mann und souveränes und mündiges, einmaliges, göttlich beseeltes Individuum respektvoll wertgeschätzt werde.

Offline gosia

  • Held Mitglied
  • *****
  • Beiträge: 1530
  • Dankeschön: 293 mal
  • Desktop: Openbox + xfce
  • Grafikkarte: Intel HD 4000
  • Grafikkartentreiber: i915 (free)
  • Kernel: 4.19 Artix
  • Prozessor: Intel Core i5-3210M
  • Skill: Durchschnitt
  • Zweig: stable
Re: NFS Verbindung NFS-Server zu NFS-Klient...
« Antwort #1 am: 18. Oktober 2015, 22:09:13 »
Hallo Gerschon
Hallo will den Manjaro-Rechner auch als NFS-Server für die anderen Linuxrechner nutzen.

Dann ist in /etc die Datei exports. Da ist aber alles im Moment durch # auskommentiert.
Will vom Linux Klient nfs Verbindung haben auf das jeweilige Heimverzeichnis des Benutzers.
Genügt es die Datei exports heranzunehmen um da das auskommentierte  durch löschen des # in Betrieb zu nehmen?
Naja, anpassen solltest Du die /etc/exports schon  ;) Eine Zeile in der Art:
/home   192.168.1.0/255.255.255.0(rw,no_subtree_check)ermöglicht allen Rechnern im Netzwerk 192.168.1.X den Zugriff auf das Homeverzeichnis
Soll nur ein Rechner zugreifen können, reicht dessen IP ohne Subnetzmaske
Wichtig: Kein Leerzeichen zwischen IP-Adresse u. Optionen!
no_subtree_check: ohne Überprüfung von Unterverzeichnissen
weitere mögliche Optionen s. https://wiki.ubuntuusers.de/NFS
Damit die Einträge in der /etc/exports wirksam werden dies ausführen:
exportfs -ravWird nur NFS Version 4 benutzt, sollte in der Datei /etc/conf.d/nfs-server.conf folgende Option eingetragen werden:
NFSD_OPTS="-N 2 -N 3"Dann kannst Du rpcbind.service u. nfs-server.service wie gewohnt auf dem Server starten, bzw. enable. Wenn ich das richtig verstanden habe, reicht bei NFS Vers. 4 der nfs-server, aber wahrscheinlich schadet es nicht, beides zu starten.
Das ist so das Grundgerüst, dann kannst Du auf den Clients NFS anwerfen u. das gewünschte Verzeichnis einhängen:
mount -t nfs <IP-Adresse des Servers>:/Verzeichnis /mountpoint/on/clientangepasst also z.B.
mount -t nfs 192.168.0.10:/home /mnt/nfsManche Nicht-Manjaro-Systeme möchten als Typ-Angabe ein nfs4 (ausprobieren)

Das ist jetzt alles ein Minimum, das noch mächtig verfeinert werden könnte. Aber für den Anfang reicht es hoffentlich, zumal ich das nur theoretisch aus meinen Aufzeichnungen schreibe und nicht praktisch übeprüfen kann. Aber Du wirst dich schon bei Fehlern melden  :)

Viele Grüße gosia
"funktioniert nicht" ist keine brauchbare Fehlermeldung
Folgende Mitglieder bedankten sich: Gerschon

Offline Gerschon

  • Vollwertiges Mitglied
  • ***
  • Beiträge: 101
  • Desktop: Verschiedene bei Anderen Distris bei Manjaro xfce-Desktop
  • Grafikkarte: Verschiedene in den Pcs und Notebooks
  • Prozessor: 32-Bit Rechner und 64-Bit Rechner
  • Skill: Anfänger
  • Zweig: stable
Re: NFS Verbindung NFS-Server zu NFS-Klient...
« Antwort #2 am: 20. Oktober 2015, 18:22:04 »

mount -t nfs 192.168.0.10:/home /mnt/nfs

Also Serverseitig läuft das nfs anscheinend:
Allerdings habe ich nicht /srv/ home genommen sondern nur /home (Also das Heimverzeichnis des jeweiligen Users auf Datei-Server).
Das andere "NFSD_OPTS="-N 2 -N 3" braucht man anscheinend nicht den dann "meckert" nfs-Dämon rum...

  GNU nano 2.4.2              Datei: exports                                   

# /etc/exports - exports(5) - directories exported to NFS clients
#
# Example for NFSv2 and NFSv3:
#  /srv/home        hostname1(rw,sync) hostname2(ro,sync)
# Example for NFSv4:
#  /srv/nfs4        hostname1(rw,sync,fsid=0)
#  /srv/nfs4/home   hostname1(rw,sync,nohide)
# Using Kerberos and integrity checking:
#  /srv/nfs4        *(rw,sync,sec=krb5i,fsid=0)
#  /srv/nfs4/home   *(rw,sync,sec=krb5i,nohide)
#
# Use `exportfs -arv` to reload.
  /home        192.168.XXX.0/24(rw,sync,fsid=0)
#   NFSD_OPTS="-N 2 -N 3"





                             [ 15 Zeilen gelesen ]
^G Hilfe     ^O Speichern ^W Wo ist    ^K Ausschneid^J Ausrichten^C Cursor
^X Beenden   ^R Datei öffn^\ Ersetzen  ^U Ausschn. r^T Rechtschr.^_ Zu Zeile

systemctl status nfs-server.service -l
● nfs-server.service - NFS server and services
   Loaded: loaded (/usr/lib/systemd/system/nfs-server.service; enabled; vendor preset: disabled)
   Active: active (exited) since Di 2015-10-20 13:31:28 CEST; 4h 24min ago
 Main PID: 557 (code=exited, status=0/SUCCESS)
   CGroup: /system.slice/nfs-server.service

Okt 20 13:31:28 merkur.XXXXX.XXXXX systemd[1]: Starting NFS server and services...
Okt 20 13:31:28 merkur.XXXXX.XXXXX systemd[1]: Started NFS server and services.
Okt 20 13:31:28 merkur.XXXXX.XXXXX exportfs[556]: exportfs: /etc/exports [1]: Neither 'subtree_check' or 'no_subtree_check' specified for export "192.168.XXX.0/24:/home".
Okt 20 13:31:28 merkur.XXXXX.XXXXX exportfs[556]: Assuming default behaviour ('no_subtree_check').
Okt 20 13:31:28 merkur.XXXXX.XXXXX  exportfs[556]: NOTE: this default has changed since nfs-utils version 1.0.x

(Die Individuellen Einträge zu Server merkur habe ich mit XXXXX ausge -X -t.)

Bevor ich das in die Fstab einhänge sollte das auch alles richtig durch manuelles Einhängen funktionieren.

Auf der Klientseite geht das Einhängen mit:

mount -t nfs merkur:/home /home

Aber auf dem Klient werden dann die lokalen Verzeichnisse /home des Benutzers einfach überschrieben oder ausgeblendet...jedenfalls sind sie (die lokalen /home Verzeichnisse des Benutzers) nicht da :-(
Stattdessen sind die /home Verzeichnisse des Servers da. soweit so gut, ist aber nicht ganz so gewollt.
Auch ein vorheriges Anlegen im lokalen Homeverzeichnis des Klients als /nfshome ind damit:

mount -t nfs merkur:/home /nfshome 

geht wiederum nicht zu mounten.. er (der Rechner) sollte das /home Verzeichnis auf Server /home über export in das neu angelegte Verzeichnis /nfshome (auf dem Klient) exportieren.
Ferner haut das überhaupt nicht hin mit dem manuellen umount also z.B.
umount -t nfs merkur:/home /home (Nur Neustart hilft da.)

Irgendwo wird dann angegeben dass zuerst der nfs-Server gestartet sein sollte bevor der nfs Klient-Rechner gestartet wird.
Meist ist es doch aber so im Heimnetz, dass die überwiegende Zeit lokal mit dem Klient gearbeitet wird und nur zur Datensicherung, Datenausgleich der Server mit einbezogen wird. Sprich.. der Server läuft nicht dauernd.

Was ist da nicht richtig???




Meine Lebenskraft ist unverkäuflich und Du kannst nur etwas freiwillig geschenkt bekommen davon, wenn ich als lebender  Mann und souveränes und mündiges, einmaliges, göttlich beseeltes Individuum respektvoll wertgeschätzt werde.

Offline gosia

  • Held Mitglied
  • *****
  • Beiträge: 1530
  • Dankeschön: 293 mal
  • Desktop: Openbox + xfce
  • Grafikkarte: Intel HD 4000
  • Grafikkartentreiber: i915 (free)
  • Kernel: 4.19 Artix
  • Prozessor: Intel Core i5-3210M
  • Skill: Durchschnitt
  • Zweig: stable
Re: NFS Verbindung NFS-Server zu NFS-Klient...
« Antwort #3 am: 20. Oktober 2015, 22:32:11 »
Hallo Gerschon,
# /etc/exports - exports(5) - directories exported to NFS clients
# Use `exportfs -arv` to reload.
/home        192.168.XXX.0/24(rw,sync,fsid=0)
#   NFSD_OPTS="-N 2 -N 3"
Auf der Klientseite geht das Einhängen mit:
mount -t nfs merkur:/home /home

Aber auf dem Klient werden dann die lokalen Verzeichnisse /home des Benutzers einfach überschrieben oder ausgeblendet...jedenfalls sind sie (die lokalen /home Verzeichnisse des Benutzers) nicht da :-(
Stattdessen sind die /home Verzeichnisse des Servers da. soweit so gut, ist aber nicht ganz so gewollt.
Naja, auf /home zu mounten ist ja auch eine schlechte Idee, da solltest Du schon einen anderen mount point benutzen, gibt ja genug unter /mnt/nfs z.B. Von mir aus auch extra /nfshome einrichten. Ist etwas unorthodox, aber sollte auch gehen.
Auch ein vorheriges Anlegen im lokalen Homeverzeichnis des Klients als /nfshome ind damit:
mount -t nfs merkur:/home /nfshome 
geht wiederum nicht zu mounten..
"Geht nicht" ist immer eine ungünstige Beschreibung, damit kann man schlecht was anfangen. Gibt es eine Fehlermeldung?
Aber bis Du die hier postest, ein Versuch: Füge mal in deine /etc/exports die Option no_root_squash ein:
/home        192.168.XXX.0/24(rw,no_root_squash,sync)Überprüfe auch die Rechte von /nfshome, die sollten 755 (rwxr-xr-x) sein. Vielleicht hilft auch das schon.
Ferner haut das überhaupt nicht hin mit dem manuellen umount also z.B.
umount -t nfs merkur:/home /home (Nur Neustart hilft da.)
Das umounten passiert ja auch ganz normal auf dem Client, also
umount /nfshomeIMHO muss der Typ -t nicht angegeben werden. Und /home willst Du ja wohl nicht aushängen. Aber auch hier hat es doch bestimmt eine Meldung gegeben.
Irgendwo wird dann angegeben dass zuerst der nfs-Server gestartet sein sollte bevor der nfs Klient-Rechner gestartet wird.
Meist ist es doch aber so im Heimnetz, dass die überwiegende Zeit lokal mit dem Klient gearbeitet wird und nur zur Datensicherung, Datenausgleich der Server mit einbezogen wird. Sprich.. der Server läuft nicht dauernd.
Was so ein ordentlicher Server ist, der läuft immer  :) Aber im Heimnetz ist das schon richtig, da kann der Server schon mal (oder überwiegend) unten sein. Deshalb solltest Du am Anfang erstmal alles von Hand einhängen, schon um Fehlerquellen auszuschliessen. Um die Automatik kann man sich später kümmern, wenn alles läuft.
Es gibt aber kleine Skripte, die überprüfen, ob der Server läuft und dann mounten. In dem Ubuntu-Link https://wiki.ubuntuusers.de/NFS gibt es unten bei "Probleme mit nfs4, Kerberos und LDAP" so ein Beispiel. Aber mit solchen Sachen würde ich mich erst abgeben, wenn alles von Hand läuft.

Viele Grüße gosia
"funktioniert nicht" ist keine brauchbare Fehlermeldung

Offline Gerschon

  • Vollwertiges Mitglied
  • ***
  • Beiträge: 101
  • Desktop: Verschiedene bei Anderen Distris bei Manjaro xfce-Desktop
  • Grafikkarte: Verschiedene in den Pcs und Notebooks
  • Prozessor: 32-Bit Rechner und 64-Bit Rechner
  • Skill: Anfänger
  • Zweig: stable
Re: NFS Verbindung NFS-Server zu NFS-Klient...
« Antwort #4 am: 26. Oktober 2015, 21:55:34 »
Hallo Gerschon,Naja, auf /home zu mounten ist ja auch eine schlechte Idee,

Server: nfs-Serverdienst läuft...

Klient:
root:#mount -t /nfshome

nfshome wurde über chmod -R 755 nfshome mit den entsprechenden Rechten versehen.

root:#mount -t nfs merkur:/home /nfshome
mount.nfs: mount point /nfshome does not exist

Der Mountpoint ist doch da auf dem Klient


Das verstehe ich immer noch nicht warum das nicht geht.
Meine Lebenskraft ist unverkäuflich und Du kannst nur etwas freiwillig geschenkt bekommen davon, wenn ich als lebender  Mann und souveränes und mündiges, einmaliges, göttlich beseeltes Individuum respektvoll wertgeschätzt werde.

Offline Gerschon

  • Vollwertiges Mitglied
  • ***
  • Beiträge: 101
  • Desktop: Verschiedene bei Anderen Distris bei Manjaro xfce-Desktop
  • Grafikkarte: Verschiedene in den Pcs und Notebooks
  • Prozessor: 32-Bit Rechner und 64-Bit Rechner
  • Skill: Anfänger
  • Zweig: stable
Re: NFS Verbindung NFS-Server zu NFS-Klient...
« Antwort #5 am: 27. Oktober 2015, 18:41:36 »
Server: nfs-Serverdienst läuft...

Klient:
root:#mount -t /nfshome

nfshome wurde über chmod -R 755 nfshome mit den entsprechenden Rechten versehen.

root:#mount -t nfs merkur:/home /nfshome
mount.nfs: mount point /nfshome does not exist

Der Mountpoint ist doch da auf dem Klient


Das verstehe ich immer noch nicht warum das nicht geht.

Ich probiere mal etwas anderes...
Meine Lebenskraft ist unverkäuflich und Du kannst nur etwas freiwillig geschenkt bekommen davon, wenn ich als lebender  Mann und souveränes und mündiges, einmaliges, göttlich beseeltes Individuum respektvoll wertgeschätzt werde.

Offline gosia

  • Held Mitglied
  • *****
  • Beiträge: 1530
  • Dankeschön: 293 mal
  • Desktop: Openbox + xfce
  • Grafikkarte: Intel HD 4000
  • Grafikkartentreiber: i915 (free)
  • Kernel: 4.19 Artix
  • Prozessor: Intel Core i5-3210M
  • Skill: Durchschnitt
  • Zweig: stable
Re: NFS Verbindung NFS-Server zu NFS-Klient...
« Antwort #6 am: 27. Oktober 2015, 20:52:26 »
Hallo Gerschon,
Klient:
root:#mount -t /nfshome
???
root:#mount -t nfs merkur:/home /nfshome
mount.nfs: mount point /nfshome does not exist
Der Mountpoint ist doch da auf dem Klient
Das ist für mich ein kleines Dilemma. Ich glaube dir ja gern, daß Du ein Verzeichnis nfshome angelegt hast, aber ich sehe auch keinen Grund, an der Fehlermeldung zu zweifeln.
Menschen können irren, bzw. Fehler machen, bei Computern ist das eher selten  ;) Vielleicht ein kleiner Tipp-Fehler, Buchstabendreher, statt nfshome nsfhome z.B., was weiß ich. Da müsste man wirklich direkt vor dem Computer sitzen.
Aber da Du eh was anderes probieren willst, ein (oder zwei) Vorschläge zur Güte: Du siehst nochmal genau nach, ob auf dem Client im Wurzelverzeichnis ein Verzeichnis nfshome existiert und als zweites führst Du ebenfalls auf dem Client einen einfachen Befehl aus, der nichts mit NFS zu tun hat, bei dem es also völlig egal ist, ob NFS richtig läuft, oder der Rechner überhaupt im Netz hängt:
sudo touch /nfshome/foound postest anschliessend, ob und was der Rechner dazu meint.

Viele Grüße gosia
"funktioniert nicht" ist keine brauchbare Fehlermeldung

Offline Gerschon

  • Vollwertiges Mitglied
  • ***
  • Beiträge: 101
  • Desktop: Verschiedene bei Anderen Distris bei Manjaro xfce-Desktop
  • Grafikkarte: Verschiedene in den Pcs und Notebooks
  • Prozessor: 32-Bit Rechner und 64-Bit Rechner
  • Skill: Anfänger
  • Zweig: stable
Re: NFS Verbindung NFS-Server zu NFS-Klient...
« Antwort #7 am: 28. Oktober 2015, 20:18:13 »
Hallo Gerschon,???Das ist für mich ein kleines Dilemma. Ich glaube dir ja gern, daß Du ein Verzeichnis nfshome angelegt hast, aber ich sehe auch keinen Grund, an der Fehlermeldung zu zweifeln.
Menschen können irren, bzw. Fehler machen, bei Computern ist das eher selten  ;) Vielleicht ein kleiner Tipp-Fehler, Buchstabendreher, statt nfshome nsfhome z.B., was weiß ich. Da müsste man wirklich direkt vor dem Computer sitzen.
Aber da Du eh was anderes probieren willst, ein (oder zwei) Vorschläge zur Güte: Du siehst nochmal genau nach, ob auf dem Client im Wurzelverzeichnis ein Verzeichnis nfshome existiert und als zweites führst Du ebenfalls auf dem Client einen einfachen Befehl aus, der nichts mit NFS zu tun hat, bei dem es also völlig egal ist, ob NFS richtig läuft, oder der Rechner überhaupt im Netz hängt:
sudo touch /nfshome/foound postest anschliessend, ob und was der Rechner dazu meint.

Viele Grüße gosia

Wie gewünscht:
touch /nfshome/foo
touch: „/nfshome/foo“ kann nicht berührt werden: Datei oder Verzeichnis nicht gefunden


Meine Lebenskraft ist unverkäuflich und Du kannst nur etwas freiwillig geschenkt bekommen davon, wenn ich als lebender  Mann und souveränes und mündiges, einmaliges, göttlich beseeltes Individuum respektvoll wertgeschätzt werde.

Offline gosia

  • Held Mitglied
  • *****
  • Beiträge: 1530
  • Dankeschön: 293 mal
  • Desktop: Openbox + xfce
  • Grafikkarte: Intel HD 4000
  • Grafikkartentreiber: i915 (free)
  • Kernel: 4.19 Artix
  • Prozessor: Intel Core i5-3210M
  • Skill: Durchschnitt
  • Zweig: stable
Re: NFS Verbindung NFS-Server zu NFS-Klient...
« Antwort #8 am: 28. Oktober 2015, 21:10:39 »
Hallo Gerschon,
touch /nfshome/foo
touch: „/nfshome/foo“ kann nicht berührt werden: Datei oder Verzeichnis nicht gefunden
Ok, zwei verschiedene Befehle sagen, daß /nfshome nicht existiert (warum auch immer), also lege es bitte an:
sudo mkdir /nfshome
sudo chmod 755 /nfshome
Du scheinst gern als root unterwegs zu sein (was ich nicht empfehle), in dem Fall ohne sudo (wenn Du root bist).
Dann kannst Du nochmals versuchen, das Verzeichnis zu mounten:
sudo mount -t nfs merkur:/home /nfshome Auch hier, wenn Du das als root machst, ohne sudo. sudo sollte allerdings die bevorzugte Methode sein.

Viele Grüße gosia
"funktioniert nicht" ist keine brauchbare Fehlermeldung
Folgende Mitglieder bedankten sich: Gerschon

Offline Gerschon

  • Vollwertiges Mitglied
  • ***
  • Beiträge: 101
  • Desktop: Verschiedene bei Anderen Distris bei Manjaro xfce-Desktop
  • Grafikkarte: Verschiedene in den Pcs und Notebooks
  • Prozessor: 32-Bit Rechner und 64-Bit Rechner
  • Skill: Anfänger
  • Zweig: stable
Re: NFS Verbindung NFS-Server zu NFS-Klient...
« Antwort #9 am: 28. Oktober 2015, 22:56:43 »
Hallo Gerschon,Ok, zwei verschiedene Befehle sagen, daß /nfshome nicht existiert (warum auch immer), also lege es bitte an:
sudo mkdir /nfshome
sudo chmod 755 /nfshome
Du scheinst gern als root unterwegs zu sein (was ich nicht empfehle), in dem Fall ohne sudo (wenn Du root bist).
Dann kannst Du nochmals versuchen, das Verzeichnis zu mounten:
sudo mount -t nfs merkur:/home /nfshome Auch hier, wenn Du das als root machst, ohne sudo. sudo sollte allerdings die bevorzugte Methode sein.

Viele Grüße gosia

Habe alles so gemacht hier das Ergebnis:

mount -t nfs 192.168.XXX.XXX:/home/roland  /home/roland/nfshome
mount.nfs: Connection timed out
Habe auch chown auf den Ordner nfshome angewendet.

Gosia ich benutze ja mehrere Linuxdistributionen und ich lege gerne z.B. bei Ubuntu noch einen Nutzer an der dann nicht in der sudoer Liste ist. Beim Installieren mit dem bei der ersten Installation angelegten Benutzer (der ist dann in der Sudoer Liste) mache ich das dann schon so wie Du sagst mit Verwendung von sudo. Die meisten anderen Linuxdistributionen haben zwei Benutzer, einer mit root Rechten und der andere ist der "normale" Benutzer den man üblicherweise nimmt.
Hätte nie gedacht dass dieses nfs so Probleme macht.
Vielleicht klappt es ja mal, aber ich habe auch nicht geschlafen und habe in der Zwischenzeit zwei Webserver (für die zwei Vereine) aufgesetzt mit CMS Joomla, was dann mit Inhalten gefüllt werden muss. Ein klein wenig "Härtung" fällt noch, aber sie laufen...

Meine Lebenskraft ist unverkäuflich und Du kannst nur etwas freiwillig geschenkt bekommen davon, wenn ich als lebender  Mann und souveränes und mündiges, einmaliges, göttlich beseeltes Individuum respektvoll wertgeschätzt werde.

Offline gosia

  • Held Mitglied
  • *****
  • Beiträge: 1530
  • Dankeschön: 293 mal
  • Desktop: Openbox + xfce
  • Grafikkarte: Intel HD 4000
  • Grafikkartentreiber: i915 (free)
  • Kernel: 4.19 Artix
  • Prozessor: Intel Core i5-3210M
  • Skill: Durchschnitt
  • Zweig: stable
Re: NFS Verbindung NFS-Server zu NFS-Klient...
« Antwort #10 am: 28. Oktober 2015, 23:50:02 »
Hallo Gerschon,
Habe alles so gemacht hier das Ergebnis:

mount -t nfs 192.168.XXX.XXX:/home/roland  /home/roland/nfshome
mount.nfs: Connection timed out
Irgendwie müssen wir uns schon einigen wo dein nfshome hin soll, sonst wird es etwas schwierig mit der Fehlersuche. /home/roland/nfshome ist etwas anderes als /nfshome von dem Du vorher gesprochen hast.
Gosia ich benutze ja mehrere Linuxdistributionen und ich lege gerne z.B. bei Ubuntu noch einen Nutzer an der dann nicht in der sudoer Liste ist.
Ist ja schon gut, sudo ist ja nur eine Empfehlung. Wenn Du aus irgendwelchen Gründen root benutzen willst/musst, dann mach es und lass sudo weg (auch wenn ich es hier hinschreibe).
Hätte nie gedacht dass dieses nfs so Probleme macht.

Das Timeout könnte von der Firewall kommen. Mit rpcinfo -p kannst Du nachsehen, welche Ports geöffnet sein sollten. Auf jeden Fall alles mit nfs (klar), die von portmapper u. mountd. Bei mir sind das die ports 2049 (nfs*), 111 (portmapper) u. 20048 (mountd).
Wenn Du es einfacher haben willst dann schalte die Firewall einfach erstmal ab.
Probiere auch mal auf dem Client showmount -e 192.168.XXX.XXX
Viele Grüße gosia
"funktioniert nicht" ist keine brauchbare Fehlermeldung

Offline Gerschon

  • Vollwertiges Mitglied
  • ***
  • Beiträge: 101
  • Desktop: Verschiedene bei Anderen Distris bei Manjaro xfce-Desktop
  • Grafikkarte: Verschiedene in den Pcs und Notebooks
  • Prozessor: 32-Bit Rechner und 64-Bit Rechner
  • Skill: Anfänger
  • Zweig: stable
Re: NFS Verbindung NFS-Server zu NFS-Klient...
« Antwort #11 am: 29. Oktober 2015, 12:59:03 »
Hallo Gerschon,Irgendwie müssen wir uns schon einigen wo dein nfshome hin soll, sonst wird es etwas schwierig mit der Fehlersuche. sollten.

Auf jeden Fall alles mit nfs (klar), die von portmapper u. mountd. Bei mir sind das die ports 2049 (nfs*), 111 (portmapper) u. 20048 (mountd).
Wenn Du es einfacher haben willst dann schalte die Firewall einfach erstmal ab.
Probiere auch mal auf dem Client showmount -e 192.168.XXX.XXX
Viele Grüße gosia

Kein Wunder dass nfs kaum Anklang findet, hört sich einfach an und dann...

Also nochmal es soll nicht das root Verzeichnis geholt werden auf dem Server sondern zu dem Benutzer dessen /home quasi auf den Klient (gleicher Benutzer) in das dortige /home Verzeichnis aber in den neu erstellten Ordner /nfshome exportiert werden. Damit sind Dateimanipulationen sehr einfach, weil von einem Ordner in den anderen Ordner.
Hier vom Server: Ist wohl in Ordnung, da gleich wie bei Dir.
rpcinfo -p
   program vers proto   port  service
    100000    4   tcp    111  portmapper
    100000    3   tcp    111  portmapper
    100000    2   tcp    111  portmapper
    100000    4   udp    111  portmapper
    100000    3   udp    111  portmapper
    100000    2   udp    111  portmapper
    100024    1   udp  50352  status
    100024    1   tcp  44245  status
    100005    1   udp  20048  mountd
    100005    1   tcp  20048  mountd
    100005    2   udp  20048  mountd
    100005    2   tcp  20048  mountd
    100005    3   udp  20048  mountd
    100005    3   tcp  20048  mountd
    100003    3   tcp   2049  nfs
    100003    4   tcp   2049  nfs
    100227    3   tcp   2049  nfs_acl
    100003    3   udp   2049  nfs
    100003    4   udp   2049  nfs
    100227    3   udp   2049  nfs_acl
    100021    1   udp  49077  nlockmgr
    100021    3   udp  49077  nlockmgr
    100021    4   udp  49077  nlockmgr
    100021    1   tcp  54918  nlockmgr
    100021    3   tcp  54918  nlockmgr
    100021    4   tcp  54918  nlockmgr

exportfs -arv
exportfs: /etc/exports [1]: Neither 'subtree_check' or 'no_subtree_check' specified for export "192.168.XXX.*/24:/home/robert".
  Assuming default behaviour ('no_subtree_check').
  NOTE: this default has changed since nfs-utils version 1.0.x

exporting 192.168.XXX.*/24:/home/roland

Ich denke mal ich gebe das nochmal viel genauer an also vom Server /home/roland nach Klient /home/roland/nfshome exportieren.

Serverseitig scheint alles in Ordnung zu sein.

Klient:
Report der Ports auf Klient:

rpcinfo -p
   program vers proto   port  service
    100000    4   tcp    111  portmapper
    100000    3   tcp    111  portmapper
    100000    2   tcp    111  portmapper
    100000    4   udp    111  portmapper
    100000    3   udp    111  portmapper
    100000    2   udp    111  portmapper
    100024    1   udp  40800  status
    100024    1   tcp  43216  status

Keine nfs Ports, Firewall ist aber nicht extra konfiguriert. Ping geht ja auch...

showmount -e 192.168.XXX.XXXExport list for 192.168.XXX.XXX:
/home/roland 192.168.XXX.*/24

Scheint in Ordnung zu sein.

mount -t nfs 192.168.XXX.XXX:/home/roland home/roland/nfshome
mount.nfs: mount point home/roland/nfshome does not exist

Hier weiss ich dann nicht mehr weiter...diesen Ordner gibt es im /home Verzeichnis und Rechte und Eigentümer von root auf Benutzer sind gesetzt...






« Letzte Änderung: 29. Oktober 2015, 13:09:35 von Gerschon »
Meine Lebenskraft ist unverkäuflich und Du kannst nur etwas freiwillig geschenkt bekommen davon, wenn ich als lebender  Mann und souveränes und mündiges, einmaliges, göttlich beseeltes Individuum respektvoll wertgeschätzt werde.

GypsyWolve

  • Gast
Re: NFS Verbindung NFS-Server zu NFS-Klient...
« Antwort #12 am: 29. Oktober 2015, 15:07:04 »

mount -t nfs 192.168.XXX.XXX:/home/roland home/roland/nfshome
mount.nfs: mount point home/roland/nfshome does not exist

Er sagt dir hier das der mount.point nicht existiert.

Zuma anderen, wenn bsp UFW installiert und aktiv ist kann es heir auch zu Stoerungen kommen

https://wiki.archlinux.org/index.php/Nfs


https://wiki.archlinux.org/index.php/NFS_Troubleshooting




Viel Glueck


GW
Folgende Mitglieder bedankten sich: Gerschon

Offline gosia

  • Held Mitglied
  • *****
  • Beiträge: 1530
  • Dankeschön: 293 mal
  • Desktop: Openbox + xfce
  • Grafikkarte: Intel HD 4000
  • Grafikkartentreiber: i915 (free)
  • Kernel: 4.19 Artix
  • Prozessor: Intel Core i5-3210M
  • Skill: Durchschnitt
  • Zweig: stable
Re: NFS Verbindung NFS-Server zu NFS-Klient...
« Antwort #13 am: 29. Oktober 2015, 19:10:05 »
Hallo Gerschon,
Also nochmal es soll nicht das root Verzeichnis geholt werden auf dem Server sondern zu dem Benutzer dessen /home quasi auf den Klient (gleicher Benutzer) in das dortige /home Verzeichnis aber in den neu erstellten Ordner /nfshome exportiert werden.
Gut, das ist doch eine klare Ansage.
Hier vom Server: Ist wohl in Ordnung, da gleich wie bei Dir.
Heisst aber nur, daß NFS läuft.

Klient:
mount -t nfs 192.168.XXX.XXX:/home/roland home/roland/nfshome
mount.nfs: mount point home/roland/nfshome does not exist
Hier weiss ich dann nicht mehr weiter...diesen Ordner gibt es im /home Verzeichnis und Rechte und Eigentümer von root auf Benutzer sind gesetzt...
NEIN, es gibt keinen Ordner home/roland/nfshome, es gibt nur (hoffentlich) einen Ordner /home/roland/nfshome
So klein ein Schrägstrich auch ist, so wichtig ist er auch bei Pfadangaben  ;)

Und bitte, beachte auch das, was GypsyWolve geschrieben hat. ping und NFS sind zwei verschiedene Dinge. Glaube oder denke nicht, sondern kontrolliere die Firewall auf dem Server. Du kannst entweder ufw nehmen (sehr empfehlenswert, weil einfach zu handhaben), oder dich mit iptables rumschlagen (eigentlich auch nicht so kompliziert, aber auf jeden Fall komplizierter als NFS).

Es reicht ein sudo ufw disable um die Firewall als Störungsmöglichkeit auszuschliessen. Wenn es dann immer noch nicht läuft, ja dann ziehe ich meine Vermutung erstmal zurück. Aber ich bin optimistisch  :) Anschliessend könntest Du dann z.B. auf dem Server mit
sudo ufw enable
sudo ufw allow NFS
ausdrücklich zulassen. Aber bitte erst das eine und dann später das andere.

Viele Grüße gosia

PS. Habe ich was verpasst oder bilde ich mir nur ein, daß ein "gelöst-Häkchen" an dem Thread steht?
"funktioniert nicht" ist keine brauchbare Fehlermeldung
Folgende Mitglieder bedankten sich: Gerschon

Offline Gerschon

  • Vollwertiges Mitglied
  • ***
  • Beiträge: 101
  • Desktop: Verschiedene bei Anderen Distris bei Manjaro xfce-Desktop
  • Grafikkarte: Verschiedene in den Pcs und Notebooks
  • Prozessor: 32-Bit Rechner und 64-Bit Rechner
  • Skill: Anfänger
  • Zweig: stable
Re: NFS Verbindung NFS-Server zu NFS-Klient...
« Antwort #14 am: 01. November 2015, 19:17:29 »
[quote author=gosia link=topic=3954.msg32881#msg32881 date=1446142205]
Hallo Gerschon,Gut, das ist doch eine klare Ansage.Heisst aber nur, daß NFS läuft.
NEIN, es gibt keinen Ordner home/roland/nfshome, es gibt nur (hoffentlich) einen Ordner [b]/[/b]home/roland/nfshome
So klein ein Schrägstrich auch ist, so wichtig ist er auch bei Pfadangaben  ;)



PS. Habe ich was verpasst oder bilde ich mir nur ein, daß ein "gelöst-Häkchen" an dem Thread steht?
[/quote]

Jetzt geht es aber wirklich!!!:-)
Und zwar gab es noch den Fehler in exports mit 192.168.XXX.* (Also der Stern!!) und das mit der falschen Angabe von Home ohne "Schräger".
An Firewalleinstellungen musste ich nix einstellen. Es ist aber da sehr gut beschrieben was man tun kann wenn es doch zu Problemen führt über die beiden Weblinks von GypsyWolve.

Wenn ich also den nfs-Server komplett mit der richtigen IP-Adresse nehme funktioniert auch das exportieren in das angelegte  Verzeichnis auf dem Klient (Heimverzeichnis des Benutzers).
Jetzt kann ich sehr bequem Dateimanipulationen vom Klient aus ausführen.
Das gemountete Verzeichnis kann auch wieder sehr leicht gelöst werden mit:
umount /home/roland/nfshome

Allerdings müssen da alle Dateien in nfs geschlossen sein.

Nochmals vielen Dank für Deine Hilfe und auch an GypsyWolve.


« Letzte Änderung: 01. November 2015, 19:19:40 von Gerschon »
Meine Lebenskraft ist unverkäuflich und Du kannst nur etwas freiwillig geschenkt bekommen davon, wenn ich als lebender  Mann und souveränes und mündiges, einmaliges, göttlich beseeltes Individuum respektvoll wertgeschätzt werde.