Autor Thema: Crash: ManjaroVG-ManjaroRoot "voll", dann X-Server Crash  (Gelesen 3841 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

LuMI

  • Gast
Re: Crash: ManjaroVG-ManjaroRoot "voll", dann X-Server Crash
« Antwort #30 am: 03. November 2015, 14:48:18 »
sudo mhwd -f -i pci nvidia
damit erzwingst Reinstalation

sudo pacman -S mdm
damit niemand mehr meckert ;)

dann durfte dein System wieder O.K. sein

MfG
« Letzte Änderung: 03. November 2015, 14:50:24 von LuMI »

Offline AyKay

  • Neuling
  • *
  • Beiträge: 25
  • Dankeschön: 1 mal
  • Desktop: Xfce
  • Grafikkarte: GeForce GTX 560
  • Kernel: 4.4.30-1 x86_64
  • Prozessor: i5
  • Skill: Anfänger
  • Zweig: stable
Re: Crash: ManjaroVG-ManjaroRoot "voll", dann X-Server Crash
« Antwort #31 am: 03. November 2015, 15:07:49 »
Glaube, das ist zumindest ein Schritt weiter. Folgende Info:

sudo mhwd -f -i pci nvidia
Error:   config 'nvidia' does not exist!

A-ha. Sollte es vielleicht eine Config namens nvidia geben, die jetzt futsch ist?
(Noch nicht aktualisiert habe ich: pacman -S mdm)

Die Fehlermeldung am Anfang sagt weiterhin, dass der X-Server falsch konfiguriert sei. Hab nach all den Schritten bisher jetzt mal wieder in /var/log/Xorg.0.log reingeschaut. Ergebnis: Ist (fast) völlig identisch mit der Log-Datei gleich nach dem "Crash". (Ausnahme sind Prozess-Ids; = irrelevant.) Da hat sich also nichts getan.


LuMI

  • Gast
Re: Crash: ManjaroVG-ManjaroRoot "voll", dann X-Server Crash
« Antwort #32 am: 03. November 2015, 15:13:32 »
Zitat
A-ha. Sollte es vielleicht eine Config namens nvidia geben, die jetzt futsch ist?
sudo mhwd -f -i pci video-nvidia
hab video unterschlagen

Sorry,

MfG
« Letzte Änderung: 03. November 2015, 15:15:16 von LuMI »

Offline AyKay

  • Neuling
  • *
  • Beiträge: 25
  • Dankeschön: 1 mal
  • Desktop: Xfce
  • Grafikkarte: GeForce GTX 560
  • Kernel: 4.4.30-1 x86_64
  • Prozessor: i5
  • Skill: Anfänger
  • Zweig: stable
Re: Crash: ManjaroVG-ManjaroRoot "voll", dann X-Server Crash
« Antwort #33 am: 03. November 2015, 15:24:18 »
Sie, Sir, müssen niemals "Sorry" zu mir sagen. Ich muß euch eigentlich am Ende was überweisen.

Okay, leider ist das Ding immer noch hartnäckig: mhwd -f -i pci video-nvidia

Installing video-nvidia...
Using default
   Has lib32 support: true
   Sourcing /var/lib/mhwd/db/pci/graphic_drivers/nvidia/MHWDCONFIG
   Processing classid: 0300
   Sourcing /var/lib/mhwd/scripts/include/0300
   Processing classid: 0302
   :: Synchronisiere Paketdatenbanken...
    core ist aktuell
    extra ist aktuell
    community ist aktuell
    multilib ist aktuell
   Löse Abhängigkeiten auf...
   Suche nach in Konflikt stehenden Paketen...
   
   Pakete (3) lib32-nvidia-utils-1:352.55-1  linux310-nvidia-1:352.55-2  nvidia-utils-1:352.55-1
   
   Gesamtgröße der zu installierenden Pakete:  213,52 MiB
   
   :: Installation fortsetzen? [J/n]
   Prüfe Schlüsselring...
   Prüfe Paketintegrität...
   Lade Paket-Dateien...
   Prüfe auf Dateikonflikte...
   Fehler: Konnte den Vorgang nicht durchführen (In Konflikt stehende Dateien)
   nvidia-utils: /usr/bin/nvidia-bug-report.sh existiert im Dateisystem
   nvidia-utils: /usr/bin/nvidia-cuda-mps-server existiert im Dateisystem
   nvidia-utils: /usr/bin/nvidia-debugdump existiert im Dateisystem
   nvidia-utils: /usr/bin/nvidia-modprobe existiert im Dateisystem
   nvidia-utils: /usr/bin/nvidia-settings existiert im Dateisystem
   nvidia-utils: /usr/bin/nvidia-smi existiert im Dateisystem
   nvidia-utils: /usr/bin/nvidia-xconfig existiert im Dateisystem
   nvidia-utils: /usr/lib/libcuda.so existiert im Dateisystem
   nvidia-utils: /usr/lib/libcuda.so.1 existiert im Dateisystem
   nvidia-utils: /usr/lib/libcuda.so.352.55 existiert im Dateisystem
   nvidia-utils: /usr/lib/libnvcuvid.so existiert im Dateisystem
   nvidia-utils: /usr/lib/libnvcuvid.so.1 existiert im Dateisystem
   nvidia-utils: /usr/lib/libnvcuvid.so.352.55 existiert im Dateisystem
   nvidia-utils: /usr/lib/libnvidia-cfg.so existiert im Dateisystem
   nvidia-utils: /usr/lib/libnvidia-cfg.so.1 existiert im Dateisystem
   nvidia-utils: /usr/lib/libnvidia-cfg.so.352.55 existiert im Dateisystem
   nvidia-utils: /usr/lib/libnvidia-eglcore.so existiert im Dateisystem
   nvidia-utils: /usr/lib/libnvidia-eglcore.so.352.55 existiert im Dateisystem
   nvidia-utils: /usr/lib/libnvidia-encode.so existiert im Dateisystem
   nvidia-utils: /usr/lib/libnvidia-encode.so.1 existiert im Dateisystem
   nvidia-utils: /usr/lib/libnvidia-encode.so.352.55 existiert im Dateisystem
   nvidia-utils: /usr/lib/libnvidia-fbc.so existiert im Dateisystem
   nvidia-utils: /usr/lib/libnvidia-fbc.so.1 existiert im Dateisystem
   nvidia-utils: /usr/lib/libnvidia-fbc.so.352.55 existiert im Dateisystem
   nvidia-utils: /usr/lib/libnvidia-glcore.so existiert im Dateisystem
   nvidia-utils: /usr/lib/libnvidia-glcore.so.352.55 existiert im Dateisystem
   nvidia-utils: /usr/lib/libnvidia-glsi.so existiert im Dateisystem
   nvidia-utils: /usr/lib/libnvidia-glsi.so.352.55 existiert im Dateisystem
   nvidia-utils: /usr/lib/libnvidia-gtk2.so existiert im Dateisystem
   nvidia-utils: /usr/lib/libnvidia-gtk2.so.352.55 existiert im Dateisystem
   nvidia-utils: /usr/lib/libnvidia-gtk3.so existiert im Dateisystem
   nvidia-utils: /usr/lib/libnvidia-gtk3.so.352.55 existiert im Dateisystem
   nvidia-utils: /usr/lib/libnvidia-ifr.so existiert im Dateisystem
   nvidia-utils: /usr/lib/libnvidia-ifr.so.1 existiert im Dateisystem
   nvidia-utils: /usr/lib/libnvidia-ifr.so.352.55 existiert im Dateisystem
   nvidia-utils: /usr/lib/libnvidia-ml.so existiert im Dateisystem
   nvidia-utils: /usr/lib/libnvidia-ml.so.1 existiert im Dateisystem
   nvidia-utils: /usr/lib/libnvidia-ml.so.352.55 existiert im Dateisystem
   nvidia-utils: /usr/lib/libnvidia-tls.so existiert im Dateisystem
   nvidia-utils: /usr/lib/libnvidia-tls.so.352.55 existiert im Dateisystem
   nvidia-utils: /usr/lib/nvidia/libEGL.so existiert im Dateisystem
   nvidia-utils: /usr/lib/nvidia/libEGL.so.1 existiert im Dateisystem
   nvidia-utils: /usr/lib/nvidia/libEGL.so.352.55 existiert im Dateisystem
   nvidia-utils: /usr/lib/nvidia/libGL.so existiert im Dateisystem
   nvidia-utils: /usr/lib/nvidia/libGL.so.1 existiert im Dateisystem
   nvidia-utils: /usr/lib/nvidia/libGL.so.352.55 existiert im Dateisystem
   nvidia-utils: /usr/lib/nvidia/libGLESv1_CM.so existiert im Dateisystem
   nvidia-utils: /usr/lib/nvidia/libGLESv1_CM.so.1 existiert im Dateisystem
   nvidia-utils: /usr/lib/nvidia/libGLESv1_CM.so.352.55 existiert im Dateisystem
   nvidia-utils: /usr/lib/nvidia/libGLESv2.so existiert im Dateisystem
   nvidia-utils: /usr/lib/nvidia/libGLESv2.so.2 existiert im Dateisystem
   nvidia-utils: /usr/lib/nvidia/libGLESv2.so.352.55 existiert im Dateisystem
   nvidia-utils: /usr/lib/nvidia/xorg/modules/extensions/libglx.so existiert im Dateisystem
   nvidia-utils: /usr/lib/nvidia/xorg/modules/extensions/libglx.so.352.55 existiert im Dateisystem
   nvidia-utils: /usr/lib/vdpau/libvdpau_nvidia.so existiert im Dateisystem
   nvidia-utils: /usr/lib/vdpau/libvdpau_nvidia.so.1 existiert im Dateisystem
   nvidia-utils: /usr/lib/vdpau/libvdpau_nvidia.so.352.55 existiert im Dateisystem
   nvidia-utils: /usr/lib/xorg/modules/drivers/nvidia_drv.so existiert im Dateisystem
   nvidia-utils: /usr/share/applications/nvidia-settings.desktop existiert im Dateisystem
   nvidia-utils: /usr/share/doc/nvidia-utils existiert im Dateisystem
   nvidia-utils: /usr/share/doc/nvidia/NVIDIA_Changelog existiert im Dateisystem
   nvidia-utils: /usr/share/doc/nvidia/README existiert im Dateisystem
   nvidia-utils: /usr/share/licenses/nvidia-utils existiert im Dateisystem
   nvidia-utils: /usr/share/licenses/nvidia/LICENSE existiert im Dateisystem
   nvidia-utils: /usr/share/man/man1/nvidia-cuda-mps-control.1.gz existiert im Dateisystem
   nvidia-utils: /usr/share/man/man1/nvidia-settings.1.gz existiert im Dateisystem
   nvidia-utils: /usr/share/man/man1/nvidia-smi.1.gz existiert im Dateisystem
   nvidia-utils: /usr/share/man/man1/nvidia-xconfig.1.gz existiert im Dateisystem
   nvidia-utils: /usr/share/nvidia/nvidia-application-profiles-352.55-key-documentation existiert im Dateisystem
   nvidia-utils: /usr/share/nvidia/nvidia-application-profiles-352.55-rc existiert im Dateisystem
   nvidia-utils: /usr/share/pixmaps/nvidia-settings.png existiert im Dateisystem
   Fehler sind aufgetreten, keine Pakete wurden aktualisiert.
   Error: pacman failed!
Error: script failed!

Sollte jetzt nach Log-Dateien mit mehr Aussagekraft dazu forschen, aber mir geht gerade die Puste aus; mach mir erstmal 'ne Schnitte, sonst fall ich um.

GypsyWolve

  • Gast
Re: Crash: ManjaroVG-ManjaroRoot "voll", dann X-Server Crash
« Antwort #34 am: 03. November 2015, 15:26:42 »
Wenn es danach noch nicht, dann ggf noch

mhwd und mhwd-nvidia installieren

Und noichmals probieren nvidia mit -f



GW

PS Holzhammer?

Bevor nvidia

pacman -S nvidia-utils --force

dann nvidia Installation wie von LuMi vorgegeben.


GW
Folgende Mitglieder bedankten sich: AyKay

LuMI

  • Gast
Re: Crash: ManjaroVG-ManjaroRoot "voll", dann X-Server Crash
« Antwort #35 am: 03. November 2015, 15:41:54 »
Zitat
leider ist das Ding immer noch hartnäckig:

sudo pacman -Rs  nvidia-utils
Dann müsste

sudo mhwd -f -i pci video-nvidia
gehen

MfG
Folgende Mitglieder bedankten sich: AyKay

Offline AyKay

  • Neuling
  • *
  • Beiträge: 25
  • Dankeschön: 1 mal
  • Desktop: Xfce
  • Grafikkarte: GeForce GTX 560
  • Kernel: 4.4.30-1 x86_64
  • Prozessor: i5
  • Skill: Anfänger
  • Zweig: stable
Re: Crash: ManjaroVG-ManjaroRoot "voll", dann X-Server Crash
« Antwort #36 am: 03. November 2015, 16:08:56 »
Wollte das gerade umsetzen und switche auf Linux, da startet Xfce (ohne, dass ich noch etwas weiteres gemacht habe). Fonts sind komplett zerschossen und werden fehlerhaft dargestellt. Ich starte ein Terminal:

sudo pacman -Rs  nvidia-utils
Fehler: Ziel nicht gefunden: nvidia-utils

Das Nvidia-Zeugs muß also weiterhin sauber installiert werden und weigert sich noch. Aber Xfce startet schonmal, wenn auch mit argen Darstellungsmacken - ein Riesenschritt.

PS: Das Ergebnis von mhwd -f -i pci video-nvidia ist ebenfalls weiterhin das gleiche.

LuMI

  • Gast
Re: Crash: ManjaroVG-ManjaroRoot "voll", dann X-Server Crash
« Antwort #37 am: 03. November 2015, 16:38:24 »
Zitat
Fehler: Ziel nicht gefunden: nvidia-utils

hmm, es bleibt also nichts anderes übrig als all die Dateien manuell  zu löschen.

MfG
« Letzte Änderung: 03. November 2015, 16:41:06 von LuMI »
Folgende Mitglieder bedankten sich: AyKay

Offline AyKay

  • Neuling
  • *
  • Beiträge: 25
  • Dankeschön: 1 mal
  • Desktop: Xfce
  • Grafikkarte: GeForce GTX 560
  • Kernel: 4.4.30-1 x86_64
  • Prozessor: i5
  • Skill: Anfänger
  • Zweig: stable
Re: Crash: ManjaroVG-ManjaroRoot "voll", dann X-Server Crash
« Antwort #38 am: 03. November 2015, 19:10:46 »
Was für ein Ritt. Aber er hat sich gelohnt, und war auch spannend. Es läuft!!! Geil, geil, geil....! Ich schreibe diese Zeilen hier endlich wieder vom Linux. Alle E-Mails der letzten Tage trudeln brav in den Client.

Ich hänge diese Woche hier nochmal eine Zusammenfassung an, so dass sich dieser Thread auch für alle Manjaro-User lohnt. In diese Falle könnten auch andere tappen. Vorab schonmal einen Riesendank insbesondere an GypsyWolve und LuMI, aber auch an klesk und virtual-dev. Leute..... GANZ GROSS. *Verneig!* Ich hätt da noch ewig dran gepuzzelt.

LuMI

  • Gast
Re: Crash: ManjaroVG-ManjaroRoot "voll", dann X-Server Crash
« Antwort #39 am: 03. November 2015, 19:33:22 »
Zitat
Ich hänge diese Woche hier nochmal eine Zusammenfassung an, so dass sich dieser Thread auch für alle Manjaro-User lohnt
Als Ergänzung, wie man die knapp 70 Dateien an der Konsole los wird:

sudo rm /usr/bin/*nvidia*
sudo rm /usr/lib/*libcuda*
sudo rm /usr/lib/*libnvcuvid*
sudo rm /usr/lib/*libnvidia*
sudo rm/usr/lib/nvidia/*
sudo rm /usr/lib/nvidia/xorg/modules/extensions/*libglx*
sudo rm /usr/lib/vdpau/*nvidia*
sudo rm /usr/lib/xorg/modules/drivers/*nvidia_drv*
sudo rm /usr/share/applications/nvidia-settings.desktop
sudo rm /usr/share/doc/nvidia/*
sudo rm /usr/share/licenses/nvidia/*
sudo rm /usr/share/man/man1/*nvidia*
sudo rm /usr/share/nvidia/*nvidia*
sudo rm /usr/share/pixmaps/nvidia-settings.png

Zitat
Ich hätt da noch ewig dran gepuzzelt.

Ich wußte daß du nicht neu installieren musst. ;)

MfG
« Letzte Änderung: 03. November 2015, 19:37:28 von LuMI »