Autor Thema: Immer noch CUPS  (Gelesen 2359 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Offline kochstudio

  • Neuling
  • *
  • Beiträge: 36
  • Desktop: Xfce netbook
  • Grafikkartentreiber: free
  • Kernel: 4.4.25-1-netbook
  • Prozessor: Atom N270
  • Skill: Anfänger
Immer noch CUPS
« am: 17. November 2015, 13:41:49 »
Folgende Fehler sind im CUPS Log und sehe keine Drucker:

E [11/Sep/2015:21:34:39 +0200] [CGI] CUPS-Get-Devices request failed with status 401: Verboten
E [06/Nov/2015:12:16:06 +0100] [Client 982] pam_authenticate() returned 10 (User not known to the underlying authentication module)
E [06/Nov/2015:12:16:13 +0100] [Client 1058] Empty Basic username.
E [06/Nov/2015:12:16:35 +0100] [Client 1256] pam_authenticate() returned 10 (User not known to the underlying authentication module)

Wie kann ich das beheben?

Offline Pig of Destiny

  • Held Mitglied
  • *****
  • Beiträge: 1383
  • Dankeschön: 125 mal
  • Desktop: Xfce
  • Grafikkarte: Intel Graphics
  • Grafikkartentreiber: free
  • Kernel: 4.16
  • Prozessor: Intel Celeron N3350
  • Skill: Durchschnitt
  • Zweig: Arch Linux
Re: Immer noch CUPS
« Antwort #1 am: 17. November 2015, 13:47:24 »
Wie hast du denn die Drucker hinzugefügt. Du musst dich im Webinterface als root anmelden um die Drucker hinzuzufügen.
Folgende Mitglieder bedankten sich: kochstudio

Offline kochstudio

  • Neuling
  • *
  • Beiträge: 36
  • Desktop: Xfce netbook
  • Grafikkartentreiber: free
  • Kernel: 4.4.25-1-netbook
  • Prozessor: Atom N270
  • Skill: Anfänger
Re: Immer noch CUPS
« Antwort #2 am: 17. November 2015, 16:20:32 »
Wie hast du denn die Drucker hinzugefügt. Du musst dich im Webinterface als root anmelden um die Drucker hinzuzufügen.

Hmm, Ich bekomme immer nur "verboten" als Antwort.
Ich habe jetzt einmal den Browser als root gestartet - selbe Ergebnis.
Es ist so komisch, da der Netzwerkdrucker schon einmal gefunden wurde und ich auch drucken konnte.

OlliFri

  • Gast
Re: Immer noch CUPS
« Antwort #3 am: 17. November 2015, 16:28:55 »
Hallo
Ich hatte auch große Probleme meinen an USB angeschlossen Drucker installieren!
Wenn du im Browser das Web Interface von Cups öffnest und auf Drucker hinzufügen klickst, kommt doch ein Dialog Fenster. Dort musst du den Benutzernamen auf root ändern und dein Passwort eingeben.
Wird dein Drucker nicht erkannt probiere mal folgendes - Habe ich aus dem Arch Wiki kopiert.

CUPS erkennt den Drucker nicht

Viele USB-Drucker werden von CUPS (v1.5) nach wie vor als parallele Geräte angesprochen. Sobald der Drucker beim Einstecken und Anschalten in /dev/usb/ eine Datei lp0 , lp1, oder usw. anlegt genügt ein Link direkt in /dev/

Speichern Sie dazu folgende udev-rule unter bspw. diesem Namen /etc/udev/rules.d/10-cups_device_link.rules ab.

KERNEL=="lp[0-9]", SYMLINK+="%k", GROUP="lp"

Beim neuen einstecken des USB-Kabels wird die neue Regel angewendet, und CUPS dürfte den Drucker (als parallel) im Web-Interface erkennen.
Folgende Mitglieder bedankten sich: kochstudio

Offline kochstudio

  • Neuling
  • *
  • Beiträge: 36
  • Desktop: Xfce netbook
  • Grafikkartentreiber: free
  • Kernel: 4.4.25-1-netbook
  • Prozessor: Atom N270
  • Skill: Anfänger
Re: Immer noch CUPS
« Antwort #4 am: 18. November 2015, 14:17:29 »
Hallo
Ich hatte auch große Probleme meinen an USB angeschlossen Drucker installieren!
Wenn du im Browser das Web Interface von Cups öffnest und auf Drucker hinzufügen klickst, kommt doch ein Dialog Fenster. Dort musst du den Benutzernamen auf root ändern und dein Passwort eingeben.
Wird dein Drucker nicht erkannt probiere mal folgendes - Habe ich aus dem Arch Wiki kopiert.

CUPS erkennt den Drucker nicht

Viele USB-Drucker werden von CUPS (v1.5) nach wie vor als parallele Geräte angesprochen. Sobald der Drucker beim Einstecken und Anschalten in /dev/usb/ eine Datei lp0 , lp1, oder usw. anlegt genügt ein Link direkt in /dev/

Speichern Sie dazu folgende udev-rule unter bspw. diesem Namen /etc/udev/rules.d/10-cups_device_link.rules ab.

KERNEL=="lp[0-9]", SYMLINK+="%k", GROUP="lp"

Beim neuen einstecken des USB-Kabels wird die neue Regel angewendet, und CUPS dürfte den Drucker (als parallel) im Web-Interface erkennen.

Danke, tatsächlich bin  ich nicht darauf gekommen "root" im Anmeldefenster mit meinem Passwort zu verwenden.
Der Drucker wurde sofort gefunden, allerdings druckt er in Ermangelung der Treiber nicht.
Diese gibt es von Epson als .deb und .rpm, habe sie aber noch nicht am laufen.

Offline kochstudio

  • Neuling
  • *
  • Beiträge: 36
  • Desktop: Xfce netbook
  • Grafikkartentreiber: free
  • Kernel: 4.4.25-1-netbook
  • Prozessor: Atom N270
  • Skill: Anfänger
Re: Immer noch CUPS
« Antwort #5 am: 18. November 2015, 14:40:35 »
Stellte gerade fest, dass die Treiber auch im AUR sind.
Daher war die Installation kein Problem - der Drucker druckt!
Ohne den entsprechenden Hinweis mit root, hätte ich es wohl immer noch nicht am laufen.
Daher nochmal ein Danke ;D

OlliFri

  • Gast
Re: Immer noch CUPS
« Antwort #6 am: 18. November 2015, 14:48:06 »
Hi, Kochstudio
Habe mich erst am Sonntag das erste mal in meinem Leben in einem Forum zu Wort gemeldet.
Genau aus diesem Grund! - Auch mal anderen zu helfen und nicht immer nur von Foren zu profitieren.
Habe nämlich viel Zeit zum rumfummeln, bin auf Grund meiner Sehbehinderung EU Rentner.
Also viel Spaß weiterhin bei Manjaro
Gruß Olli
Folgende Mitglieder bedankten sich: kochstudio