Autor Thema: Lande immer auf der Konsole  (Gelesen 1566 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Offline Hanisch

  • Held Mitglied
  • *****
  • Beiträge: 738
  • Dankeschön: 2 mal
  • Desktop: Xfce4, KDE-Plasma - 32 Bit/64Bit
  • Grafikkarte: VGA compatible controller: InnoTek Systemberatung GmbH VirtualBox Graphics Adapter, bzw. NVIDIA Optimus
  • Grafikkartentreiber: free, bzw. nonfree
  • Kernel: 4.1.32-1-MANJARO/4.4.55-1-MANJARO/4.9.20-1-MANJARO
  • Prozessor: VirtualBox bzw. Intel Core i7-2630QM
  • Skill: Durchschnitt
  • Zweig: stable
Lande immer auf der Konsole
« am: 24. November 2015, 18:06:14 »
Hallo,
beim Booten des Systems lande ich immer auf der Konsole beim Login:
Dann muß ich Benutzername und Passwort eingeben und kann dann erst mit
$ startxauf die grafische Oberfläche (Xfce) kommen.
Das war nicht immer so. Woran mag das jetzt liegen?
$ sudo systemctl enable lightdm.service
Failed to execute operation: File exists

$ sudo systemctl start lightdm.service
Job for lightdm.service failed because the control process exited with error code. See "systemctl status lightdm.service" and "journalctl -xe" for details.

$ sudo systemctl status lightdm.service
● lightdm.service - Light Display Manager
   Loaded: loaded (/usr/lib/systemd/system/lightdm.service; disabled; vendor preset: disabled)
   Active: failed (Result: start-limit) since Di 2015-11-24 17:56:28 CET; 24s ago
     Docs: man:lightdm(1)
  Process: 2755 ExecStart=/usr/bin/lightdm (code=exited, status=1/FAILURE)
 Main PID: 2755 (code=exited, status=1/FAILURE)

Nov 24 17:56:28 VM-Manjaro systemd[1]: Failed to start Light Display Manager.
Nov 24 17:56:28 VM-Manjaro systemd[1]: lightdm.service: Unit entered failed state.
Nov 24 17:56:28 VM-Manjaro systemd[1]: lightdm.service: Failed with result 'exit-code'.
Nov 24 17:56:28 VM-Manjaro systemd[1]: lightdm.service: Service hold-off time over, scheduling restart.
Nov 24 17:56:28 VM-Manjaro systemd[1]: Stopped Light Display Manager.
Nov 24 17:56:28 VM-Manjaro systemd[1]: lightdm.service: Start request repeated too quickly.
Nov 24 17:56:28 VM-Manjaro systemd[1]: Failed to start Light Display Manager.
Nov 24 17:56:28 VM-Manjaro systemd[1]: lightdm.service: Unit entered failed state.
Nov 24 17:56:28 VM-Manjaro systemd[1]: lightdm.service: Failed with result 'start-limit'.

Oder welcher Display-Manager war standardmäßig bei Manjaro in Betrieb?
Wie aktiviere ich den wieder?

Gruß
Ch. Hanisch

Je mehr man schon weiß, je mehr hat man noch zu lernen. Mit dem Wissen nimmt das Nichtwissen in gleichem Grade zu, oder vielmehr das Wissen des Nichtwissens.(Friedrich Schlegel)

Offline gosia

  • Held Mitglied
  • *****
  • Beiträge: 1523
  • Dankeschön: 292 mal
  • Desktop: Openbox + xfce
  • Grafikkarte: Intel HD 4000
  • Grafikkartentreiber: i915 (free)
  • Kernel: 4.19 Artix
  • Prozessor: Intel Core i5-3210M
  • Skill: Durchschnitt
  • Zweig: stable
Re: Lande immer auf der Konsole
« Antwort #1 am: 24. November 2015, 20:58:24 »
Hallo Hanisch,
Hallo,
beim Booten des Systems lande ich immer auf der Konsole beim Login:
Dann muß ich Benutzername und Passwort eingeben und kann dann erst mit
$ startxauf die grafische Oberfläche (Xfce) kommen.
Das war nicht immer so. Woran mag das jetzt liegen?
Hm, vielleicht liegt es an der Konfiguration. Laut Wiki muss Lightdm konfiguriert werden:
https://wiki.manjaro.org/index.php/Install_Display_Managers#LightDM

Oder welcher Display-Manager war standardmäßig bei Manjaro in Betrieb?
Wie aktiviere ich den wieder?
Im Prinzip hast Du ja freie Wahl  :) Ich habe z.B. LightDM mal runtergeschmissen (weiss ehrlich gesagt, nicht mehr genau warum) und benutze statt dessen LXDM. Der lief relativ gut "out of the Box". Wenn man trotzdem was dran schrauben will (oder muss), ist das außer auf der obigen Seite auch hier sehr gut beschrieben:
https://wiki.archlinux.org/index.php/LXDM

Viele Grüße gosia
"funktioniert nicht" ist keine brauchbare Fehlermeldung
Folgende Mitglieder bedankten sich: Hanisch

Offline Hanisch

  • Held Mitglied
  • *****
  • Beiträge: 738
  • Dankeschön: 2 mal
  • Desktop: Xfce4, KDE-Plasma - 32 Bit/64Bit
  • Grafikkarte: VGA compatible controller: InnoTek Systemberatung GmbH VirtualBox Graphics Adapter, bzw. NVIDIA Optimus
  • Grafikkartentreiber: free, bzw. nonfree
  • Kernel: 4.1.32-1-MANJARO/4.4.55-1-MANJARO/4.9.20-1-MANJARO
  • Prozessor: VirtualBox bzw. Intel Core i7-2630QM
  • Skill: Durchschnitt
  • Zweig: stable
Re: Lande immer auf der Konsole
« Antwort #2 am: 24. November 2015, 21:27:36 »
Hallo,
... vielleicht liegt es an der Konfiguration. Laut Wiki muss Lightdm konfiguriert werden:
https://wiki.manjaro.org/index.php/Install_Display_Managers#LightDM
Wunderbar! Warum finde ich nicht die passenden Wikis?
Jetzt bootet er über lightdm auf die Xfce-Oberfläche.

Aber ein Problem habe ich noch. Neben Xfce habe ich noch KDE-Plasma installiert.
Der Display-Manager bietet mir beim Login keine Auswahl an.

Erst mal herzlichen Dank!

Gruß
Ch. Hanisch

Je mehr man schon weiß, je mehr hat man noch zu lernen. Mit dem Wissen nimmt das Nichtwissen in gleichem Grade zu, oder vielmehr das Wissen des Nichtwissens.(Friedrich Schlegel)

Offline Hanisch

  • Held Mitglied
  • *****
  • Beiträge: 738
  • Dankeschön: 2 mal
  • Desktop: Xfce4, KDE-Plasma - 32 Bit/64Bit
  • Grafikkarte: VGA compatible controller: InnoTek Systemberatung GmbH VirtualBox Graphics Adapter, bzw. NVIDIA Optimus
  • Grafikkartentreiber: free, bzw. nonfree
  • Kernel: 4.1.32-1-MANJARO/4.4.55-1-MANJARO/4.9.20-1-MANJARO
  • Prozessor: VirtualBox bzw. Intel Core i7-2630QM
  • Skill: Durchschnitt
  • Zweig: stable
Re: Lande immer auf der Konsole
« Antwort #3 am: 24. November 2015, 21:55:15 »
Aber ein Problem habe ich noch. Neben Xfce habe ich noch KDE-Plasma installiert.
Der Display-Manager bietet mir beim Login keine Auswahl an.
Durch Zufall habe ich durch Drücken von F1,F2,F3,F4-Tasten am oberen Bdildschirmrand ein Panel hervorgezaubert, von dem aus ich u.a. auch die Oberfläche auswählen kann.
Die ist wohl jetzt permanent da.
Also alles paletti - Danke!

Gruß
Ch. Hanisch
Je mehr man schon weiß, je mehr hat man noch zu lernen. Mit dem Wissen nimmt das Nichtwissen in gleichem Grade zu, oder vielmehr das Wissen des Nichtwissens.(Friedrich Schlegel)

Offline Hanisch

  • Held Mitglied
  • *****
  • Beiträge: 738
  • Dankeschön: 2 mal
  • Desktop: Xfce4, KDE-Plasma - 32 Bit/64Bit
  • Grafikkarte: VGA compatible controller: InnoTek Systemberatung GmbH VirtualBox Graphics Adapter, bzw. NVIDIA Optimus
  • Grafikkartentreiber: free, bzw. nonfree
  • Kernel: 4.1.32-1-MANJARO/4.4.55-1-MANJARO/4.9.20-1-MANJARO
  • Prozessor: VirtualBox bzw. Intel Core i7-2630QM
  • Skill: Durchschnitt
  • Zweig: stable
Re: Lande immer auf der Konsole
« Antwort #4 am: 26. November 2015, 13:52:55 »
Hallo,
stelle gerade fest, daß nach einem Update in meiner Manjaro-Installation in einer VirtualBox auch kein Display-Manager mehr da zu sein scheint.
Auch hier Landung auf de Konsole und dann 'startx'.

Nachdem ich mir auch hier den DM 'lightdm' installiert und konfiguriert habe, läuft es wieder.

Gruß
Ch. Hanisch
Je mehr man schon weiß, je mehr hat man noch zu lernen. Mit dem Wissen nimmt das Nichtwissen in gleichem Grade zu, oder vielmehr das Wissen des Nichtwissens.(Friedrich Schlegel)

Amber

  • Gast
Re: Lande immer auf der Konsole
« Antwort #5 am: 28. November 2015, 20:44:14 »
Moin,

nur zur Info: Plasma will den sddm (der neue Standard im KDE Feld) haben, daher kann es sein das durch Plasma dein lightdm deinstalliert wurde??

peace

Edit:Kannst ja mal schauen ob der installiert ist unter /usr/share/sddm

Offline Hanisch

  • Held Mitglied
  • *****
  • Beiträge: 738
  • Dankeschön: 2 mal
  • Desktop: Xfce4, KDE-Plasma - 32 Bit/64Bit
  • Grafikkarte: VGA compatible controller: InnoTek Systemberatung GmbH VirtualBox Graphics Adapter, bzw. NVIDIA Optimus
  • Grafikkartentreiber: free, bzw. nonfree
  • Kernel: 4.1.32-1-MANJARO/4.4.55-1-MANJARO/4.9.20-1-MANJARO
  • Prozessor: VirtualBox bzw. Intel Core i7-2630QM
  • Skill: Durchschnitt
  • Zweig: stable
Re: Lande immer auf der Konsole
« Antwort #6 am: 28. November 2015, 21:38:33 »
Moin,

nur zur Info: Plasma will den sddm (der neue Standard im KDE Feld) haben, daher kann es sein das durch Plasma dein lightdm deinstalliert wurde??
Ich weiß gar nicht, welcher DM installiert war. Jedenfalls lief mit diesem DM bislang auch KDM-Plasma.
Das hat sich erst mit einem Update geändert, so daß wohl gar kein DM mehr lief.

Zitat
Edit:Kannst ja mal schauen ob der installiert ist unter /usr/share/sddm
Ja,  /usr/share/sddm ist vorhanden.
Aber ich möchte eigentlich jetzt bei lightdm bleiben.

Gruß
Ch. Hanisch
Je mehr man schon weiß, je mehr hat man noch zu lernen. Mit dem Wissen nimmt das Nichtwissen in gleichem Grade zu, oder vielmehr das Wissen des Nichtwissens.(Friedrich Schlegel)

Offline sam

  • Held Mitglied
  • *****
  • Beiträge: 598
  • Dankeschön: 27 mal
  • Desktop: MATE, KDE, Xfce, Openbox, Fluxbox
  • Grafikkarte: Intel Corporation 4 Series Chipset Integrated Graphics Controller (rev 03)
  • Grafikkartentreiber: free
  • Prozessor: Intel® Core™2 Quad CPU @ 4× 2.666GHz
  • Skill: Fortgeschritten
  • Zweig: stable
Re: Lande immer auf der Konsole
« Antwort #7 am: 29. November 2015, 08:42:05 »
SDDM wird von Plasma5 benötigt, muss aber nicht zwingend für den Login verwendet werden. (Habe bei mir SLiM installiert, u.a. auch für Plasma5.) Nur will man nicht unbedingt zwei Login Manager installieren und daher wird SDDM empfohlen.

Mit dem Befehlsudo systemctl -t service | grep -i "dm" bekommt man angezeigt, welche DM installiert und aktiviert bzw. deaktiviert sind.

Wenn einer nicht funktioniert, kann man ihn mit stop beenden und einen Anderen mit start starten, also z.B. sudo systemctl stop sddm
sudo systemctl start lightdm

Es darf nur ein DM aktiviert bzw. gestartet sein.

Wenn dann einer funzt, kann man den einen DM dann aktivieren und alle Anderen deaktivieren, damit das dann auch beim Systemstart klappt.
Z.B.
sudo systemctl disable sddm
sudo systemctl enable lightdm
« Letzte Änderung: 29. November 2015, 08:54:59 von sam »

Offline klesk

  • Held Mitglied
  • *****
  • Beiträge: 1194
  • Dankeschön: 142 mal
  • Desktop: herbstluftwm
  • Grafikkartentreiber: nvidia 3.40xx
  • Kernel: 4.2
  • Prozessor: Intel Core2 Quad Q9550 (-MCP-)
  • Skill: Durchschnitt
  • Zweig: unstable
Re: Lande immer auf der Konsole
« Antwort #8 am: 29. November 2015, 14:58:00 »
Drüber wird folgendes Vorgeschlagen;

Zitat
1. $ sudo rm /etc/systemd/system/display-manager.service

after

2. sudo pacman -S lxdm OR other DM

2. $ sudo systemctl enable lxdm OR other DM.

and ENJOY!  ;)

Natürlich ist LXDM  hier austauschbar gegen den DM des Vertrauens. Falls schon ein DM läuft den natürlich vorher beenden mit

sudo systemctl disable blablabla.service
Hat samtux ja schon gut beschrieben wie das geht.