Autor Thema: Nach Update kein Login mehr möglich  (Gelesen 5574 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Offline hylli

  • Neuling
  • *
  • Beiträge: 16
  • Skill: Durchschnitt
Re: Nach Update kein Login mehr möglich
« Antwort #15 am: 26. November 2015, 08:49:18 »
Ich habe nun versucht SDDM zu installieren. Vermutlich habe ich hier die Befehlsreihenfolge nicht sauber eingehalten bzgl. Deaktivieren von LXDM und Installation/Aktivierung von SDDM.

Fakt ist:
Nach dem Neustart ist bekomme ich statt SDDM nur einen schwarzen Bildschirm zu sehen.

Hierzu benötige ich aktuell noch Hilfe!

Meine Befehle die ich eingegeben habe:
sudo pacman -S sddm
sudo systemctl enable sddm.service -f
sudo pacman -Rs lxdm
sudo systemctl disable lxdm

Ich hätte zwar kein Problem einen anderen Display Manager zu nutzen, aber LXDM ist nun mal der Standard DM für das Community System, und sollte damit auch grundsätzlich laufen.

Von daher gebe ich @sam Recht, dass das Problem nicht behoben ist.

Hylli

Offline sam

  • Held Mitglied
  • *****
  • Beiträge: 598
  • Dankeschön: 27 mal
  • Desktop: MATE, KDE, Xfce, Openbox, Fluxbox
  • Grafikkarte: Intel Corporation 4 Series Chipset Integrated Graphics Controller (rev 03)
  • Grafikkartentreiber: free
  • Prozessor: Intel® Core™2 Quad CPU @ 4× 2.666GHz
  • Skill: Fortgeschritten
  • Zweig: stable
Re: Nach Update kein Login mehr möglich
« Antwort #16 am: 26. November 2015, 10:35:59 »
Du hättest LXDM nicht deinstallieren müssen.
Vermutlich liegt das Problem darin, dass Du LXDM zuerst deinstalliert hast und erst danach disbled.
Disable SDDM, installiere LXDM neu und mache danach disable von LXDM. Danach solltest Du in der Lage sein, SDDM zu starten.

Also:
sudo systemctl disable sddm
sudo pacman -S lxdm
sudo systemctl disable lxdm
sudo systemctl enable sddm
sudo systemctl start sddm

Ansonsten kannst Du mitsudo systemctl -t service | grep -i "dm"schauen, welcher der beiden aktiviert und deaktiviert ist.
« Letzte Änderung: 26. November 2015, 10:39:49 von sam »

Offline hylli

  • Neuling
  • *
  • Beiträge: 16
  • Skill: Durchschnitt
Re: Nach Update kein Login mehr möglich
« Antwort #17 am: 26. November 2015, 10:51:35 »
Das Bild bleibt trotzdem schwarz, wobei der Mauszeiger funktioniert.

Der Befehl
sudo systemctl -t service | grep -i "dm"ergibt, dass
sddm.serviceläuft.


Hylli

Offline sam

  • Held Mitglied
  • *****
  • Beiträge: 598
  • Dankeschön: 27 mal
  • Desktop: MATE, KDE, Xfce, Openbox, Fluxbox
  • Grafikkarte: Intel Corporation 4 Series Chipset Integrated Graphics Controller (rev 03)
  • Grafikkartentreiber: free
  • Prozessor: Intel® Core™2 Quad CPU @ 4× 2.666GHz
  • Skill: Fortgeschritten
  • Zweig: stable
Re: Nach Update kein Login mehr möglich
« Antwort #18 am: 26. November 2015, 11:04:25 »
Probier malsudo systemctl stop sddm
sudo systemctl stop lxdm
sudo systemctl start sddm
Werden Fehlermeldungen angezeigt?

Habe das gerade nochmal in der VM getestet und keine Probleme gehabt.

Offline hylli

  • Neuling
  • *
  • Beiträge: 16
  • Skill: Durchschnitt
Re: Nach Update kein Login mehr möglich
« Antwort #19 am: 26. November 2015, 11:21:59 »
Wenn ich vom schwarzen Bildschirm auf eine Konsole wechsel, und den ersten Befehl eingebe. So läuft bei mir so einiges durch.

Anfänglich meine obligatorischen Intel i915 Fehler, die ich mittlerweile bzw. schon lange gewöhnt bin.

Weiterhin steht zu lesen:
Zitat
[Failed]Failed to start daily man-db cache update.
See 'systemctl status man-db.timer' for details.
....
dann noch diverse OK-Meldungen, am Ende:
Zitat
[OK] Started TLP system startup/shutdown
[OK]Reached target graphical interface
An der Stelle bleibt es hängen, mit STRG+Alt+F2 komme ich dann wieder in eine Konsole.

Wenn ich dann die beiden anderen Befehle eingeben, erscheinen keine Fehler!

Nach einem Reboot bleibt der Bildschirm wieder schwarz, nur der Mauszeiger ist zu sehen/kann bewegt werden.

Hylli


Offline sam

  • Held Mitglied
  • *****
  • Beiträge: 598
  • Dankeschön: 27 mal
  • Desktop: MATE, KDE, Xfce, Openbox, Fluxbox
  • Grafikkarte: Intel Corporation 4 Series Chipset Integrated Graphics Controller (rev 03)
  • Grafikkartentreiber: free
  • Prozessor: Intel® Core™2 Quad CPU @ 4× 2.666GHz
  • Skill: Fortgeschritten
  • Zweig: stable
Re: Nach Update kein Login mehr möglich
« Antwort #20 am: 26. November 2015, 12:07:15 »
Als weiteren Loginmanager habe ich SLiM getestet, mit dem der Login auch funzt.

sudo pacman -S slim
sudo systemctl stop sddm
sudo systemctl disable sddm
sudo systemctl start slim
sudo systemctl enable slim

Allerdings musste ich in meiner .xinitrc den Eintrag ck-launch-session aus den die Befehlszeilen löschen, sonst klappte der Login auch nicht.

Also
DEFAULT_SESSION=startlxde
case $1 in
  LXDE) exec ck-launch-session dbus-launch startlxde ;;
  *) exec ck-launch-session dbus-launch  $DEFAULT_SESSION ;;
esac

geändert in
DEFAULT_SESSION=startlxde
case $1 in
  LXDE) exec dbus-launch startlxde ;;
  *) exec dbus-launch $DEFAULT_SESSION ;;
esac

Und wenn LXDM die einzige Desktopumgebung ist, kann man auch den ganzen Block durch eine Zeile ersetzen:exec dbus-launch startlxde
« Letzte Änderung: 26. November 2015, 12:10:55 von sam »

Offline hylli

  • Neuling
  • *
  • Beiträge: 16
  • Skill: Durchschnitt
Re: Nach Update kein Login mehr möglich
« Antwort #21 am: 26. November 2015, 14:06:21 »
Hi,

vielen Dank!!!

Mit Slim als DM funktioniert es nun wie gewünscht.

Ist zwar nicht die eigentliche Lösung (Warum funktioniert LXDM nicht mehr richtig?), aber damit kann ich nun leben.

Muss nur mal schauen, wie ich dieses rosa Hintergrundbild durch ein angenehmeres Bild ersetze.

Hylli

Offline sam

  • Held Mitglied
  • *****
  • Beiträge: 598
  • Dankeschön: 27 mal
  • Desktop: MATE, KDE, Xfce, Openbox, Fluxbox
  • Grafikkarte: Intel Corporation 4 Series Chipset Integrated Graphics Controller (rev 03)
  • Grafikkartentreiber: free
  • Prozessor: Intel® Core™2 Quad CPU @ 4× 2.666GHz
  • Skill: Fortgeschritten
  • Zweig: stable
Re: Nach Update kein Login mehr möglich
« Antwort #22 am: 26. November 2015, 14:45:34 »
Muss nur mal schauen, wie ich dieses rosa Hintergrundbild durch ein angenehmeres Bild ersetze.
Dazu gibt es einen Manjaro-Wiki-Eintrag.

LuMI

  • Gast
Re: Nach Update kein Login mehr möglich
« Antwort #23 am: 27. November 2015, 01:52:11 »
Zitat
Ist zwar nicht die eigentliche Lösung (Warum funktioniert LXDM nicht mehr richtig?), aber damit kann ich nun leben.

Man soll die

/etc/lxdm/Xsession
vor und nach Update betrachten.
Abhilfe schafft die neue /etc/lxdm/Xsession mit der alten /etc/lxdm/Xsession zu überschreiben. ;)

MfG
Folgende Mitglieder bedankten sich: sam

Offline sam

  • Held Mitglied
  • *****
  • Beiträge: 598
  • Dankeschön: 27 mal
  • Desktop: MATE, KDE, Xfce, Openbox, Fluxbox
  • Grafikkarte: Intel Corporation 4 Series Chipset Integrated Graphics Controller (rev 03)
  • Grafikkartentreiber: free
  • Prozessor: Intel® Core™2 Quad CPU @ 4× 2.666GHz
  • Skill: Fortgeschritten
  • Zweig: stable
Re: Nach Update kein Login mehr möglich
« Antwort #24 am: 27. November 2015, 11:18:22 »
Danke, LuMI!

Habe mir das Script angeschaut und auch die Scripts, die in der /etc/lxdm/Xsession aufgerufen werden und habe feestgestellt, dass es ausreicht nur folgende Änderung in der $HOME/.xprofile zu machen:
Die letzte Zeile, also
. .initde 2>/dev/nullauskommentieren oder so ändern:
[ -f .initde ] && . .initde
Bei mir existiert die Datei .initde nicht und daher scheinbar der Fehler.

Es ist also nicht nötig an der systemweiten Konfiguration etwas zu ändern.
« Letzte Änderung: 27. November 2015, 11:34:07 von sam »
Folgende Mitglieder bedankten sich: oldmcsam

LuMI

  • Gast
Re: Nach Update kein Login mehr möglich
« Antwort #25 am: 27. November 2015, 12:31:47 »
Immer gerne :)

Naja, das ist schon bisschen Frustrierend für Leute die LXDE installieren wollen.

Bei mir existiert die Datei $HOME/.xprofile nicht.

MfG

Offline sdoubleyou

  • Held Mitglied
  • *****
  • Beiträge: 1050
  • Dankeschön: 148 mal
  • Desktop: Gentoo + spectrwm
  • Grafikkarte: intel
  • Kernel: Longterm 4.4
  • Skill: Durchschnitt
  • Zweig: unstable
Re: Nach Update kein Login mehr möglich
« Antwort #26 am: 27. November 2015, 12:40:02 »
Hierzu kann auch im engl. Forum nachgelesen werden
https://forum.manjaro.org/index.php?topic=28543.msg238900#msg238900

Offline oldmcsam

  • Sr. Mitglied
  • ****
  • Beiträge: 435
  • Dankeschön: 16 mal
  • Desktop: XFCE, Mate
  • Grafikkarte: Ati Radeon HD 6670, Intel 3000
  • Grafikkartentreiber: free
  • Kernel: 4.14.48
  • Prozessor: Dual Core 3.0; i5 2,5
  • Skill: Durchschnitt
  • Zweig: stable
Re: Nach Update kein Login mehr möglich
« Antwort #27 am: 28. November 2015, 16:23:10 »
Hello sam,

das war ein hilfreicher Tip, in /.xprofile die letzte Zeile auskommentieren!
Hatte heute mal die neue Manjaro Lxde installiert und nach dem ersten Backup kein Reinkommen.
Passwort neu gemacht  -  alles dicht!

Und dann mal ins Forum geschaut und sofort fündig geworden.
Dank an alle bisherigen und zukünftigen Ratgeber!
Nicht der ist dumm, der nichts weiß,
sondern der, der glaubt schon alles zu wissen.