Autor Thema: Grub Bootloader Probleme (Uefi)  (Gelesen 1075 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Offline timi042

  • Neuling
  • *
  • Beiträge: 2
  • Grafikkarte: GTX 750ti
  • Prozessor: AMD A8 Quad-core
  • Skill: Anfänger
Grub Bootloader Probleme (Uefi)
« am: 09. Januar 2016, 21:05:46 »
Hallo liebe manjaro Community,
ich wende mich an euch da ich gerne von Windows auf Linux umsteigen wollte.
Ich wollte meinen Computer so einrichten das ich Windows 10 und manjaro Linux als Dualboot nutzen kann.

Erstmal Daten zu meinem PC:
- Prozessor: AMD A8-6500 Quad-Core 3,6Ghz Turbo 4,1Ghz.
- RAM: 8 Gb (2x4Gb) 1600Mhz DDR3 DIMM CL11 von Dragon.
- Grafikkarte: Nvidea GTX 750ti 2Gb Grafikspeicher 128bit Speicheranbindung (für mehr Daten bitte googeln)
- Mainboard: MS-7857 von Medion Chipset (K15IMC)
  Für weitere Fragen stehe ich euch gerne zur Verfügung.

Mein Problem:

Ich wollte mir Linux manjaro als zweites Betriebssystem auf meinem Windows 10 Rechner einrichten.
Dafür habe ich mir extra eine 500GB HDD gekauft auf die nur Linux Daten sollen (damit Win10 und Linux physisch getrennt sind).
Und zwar ist das Problem das ich nicht beide Betriebssysteme starten kann. Wenn ich in den Bootprioritäten die Linux Festplatte an erste stelle setze komme ich in Grub und in manjaro aber nicht in Windows 10 rein. Wenn ich die Windows 10 Festplatte an erste stelle setze komme ich nicht mal in Grub sondern mein Rechner startet sofort Windows. Ab und zu bekomme ich auch beim starten den Grub rescue mode.
Der Secureboot wurde davor natürlich disabled.

Ich habe die ganze Installation und Partitionierung mit einem Freund durchgeführt der viel Wissen über Linux besitzt. Wir haben viel an den Uefi Partitionen gearbeitet (da wir dort den Fehler vermuten) diese verschoben, verknüpft und so weiter aber wir kommen nicht voran wir schaffen es einfach nicht das wir vom Bootmenü aus beide Betriebssysteme starten können. Wir haben auch versucht die Win10 und Linux Partition zusammen zu bringen, hat alles nichts genützt. Nach Tagelangem suchen was der Fehler sein konnten haben wir den Fehler immer noch nicht gefunden und wenden uns hoffnungsvoll an euch liebe Community.
Vielleicht hatte schon mal jemand ein ähnliches Problem wie ich und kann uns die Lösung verraten.
Wenn ihr weitere Informationen benötigt, fragt mich bitte. Teamview wäre ebenfalls vorhanden so wie Skype.

Edit: Ich habe noch das Bild mit der Fehlermeldung hinzugefügt.
« Letzte Änderung: 09. Januar 2016, 21:18:26 von timi042 »

Offline timi042

  • Neuling
  • *
  • Beiträge: 2
  • Grafikkarte: GTX 750ti
  • Prozessor: AMD A8 Quad-core
  • Skill: Anfänger
Re: Grub Bootloader Probleme (Uefi)
« Antwort #1 am: 09. Januar 2016, 21:49:03 »
Noch etwas. Nach jedem Neustart kommt diese Fehlermeldung. Egal ob ich davor in Linux oder Windows war.

Grub Bootloader

error: no such device:7f9a3fb3-c7a3.....
error: unknown filesystem.
Entering rescue mode...
grub rescue>

Trotz der Fehlermeldung existiert die Platte mit der UUID 7f9a3fb3-c7a3.....

LuMI

  • Gast
Re: Grub Bootloader Probleme (Uefi)
« Antwort #2 am: 10. Januar 2016, 09:28:18 »
Die Lösung ist doch einfach.
Vermeiden lässt sich die Komplikation mit GRUB, wenn man den BIOS / UEFI BootManager benutzt.

Als erstes Boot Timeout hoch setzen:
Entwerder im BIOS / UEFI unter Boot; Timeout

oder auf der Konsole
sudo efibootmgr -t 15
Nach dem Neustart hat man  genug Zeit für BootManager Taste. (F11 oder F12)

MfG

 

Offline Demon.Spawn

  • Neuling
  • *
  • Beiträge: 12
  • Desktop: cinnamon
  • Grafikkarte: Radeon R9 280
  • Grafikkartentreiber: catalyst
  • Kernel: 4.2
  • Prozessor: i5 4650
  • Skill: Durchschnitt
  • Zweig: stable
Re: Grub Bootloader Probleme (Uefi)
« Antwort #3 am: 11. Januar 2016, 20:54:25 »
Ich verwende auch Windows 10 und manjaro auf zwei verschiedenen Festplatten (Windows 10 auf der SSD und manjaro auf seiner komplett eigenen). Ich führe den Start auch wie oben beschrieben mit F12 (schnelles drücken sobald der Einschalter betätigt wurde) aus (bei mir das bootmenu) und wähle dann die Platte für Linux aus.
Auf diese habe ich Grub gelegt, und kann auch nur Linux damit starten.

Ich habe einmal den Versuch gestartet Windows 8.1 und ein Linux auf der gleichen Platte nebeneinander existieren zu lassen, aber das ging nicht. Grub hat das Windows nicht erkennen wollen.
Die damalige Recherche (~6-9 Monate her) hat ergeben, dass es wohl nicht möglich ist, da die damaligen Linux das Windows noch nicht erkennen konnten.
Weiterhin habe ich gelesen, dass ab Windows 8, bei (jedem) Update der Bootsektor mit dem windowseigenen Bootloader überschrieben wird, was zu Komplikationen führen könnte.