Autor Thema: setup.py nicht gefunden  (Gelesen 785 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Offline m-bostaurus

  • Sr. Mitglied
  • ****
  • Beiträge: 366
  • Dankeschön: 5 mal
  • Desktop: KDE, XFCE, LXQt, Mate
  • Grafikkarte: Desktop: GTX 1070Ti; Laptop: Nvidia
  • Grafikkartentreiber: unfree; unfree
  • Kernel: 419/420 64bit auf beiden Rechnern
  • Prozessor: i5-6500; i5
  • Skill: Durchschnitt
  • Zweig: stable
setup.py nicht gefunden
« am: 19. Februar 2016, 16:34:58 »
Im Zusammenhang mit dem onedrive muss ich etwas von Python installieren.
sudo python3 setup.py install
sudo pip3 install --upgrade setuptools
Requirement already up-to-date: setuptools in /usr/lib/python3.5/site-packages
[blabla@blub ~]$ sudo python3 setup.py install
python3: can't open file 'setup.py': [Errno 2] No such file or directory
Ich habe darauf den ganzen Rechner durchsuchen lassen:
find: "setup.py": Datei oder Verzeichnis nicht gefundenIch bin ziemlich ratlos, zumal auf zwei anderen Rechnern die Installation problemlos durchgelaufen ist. Hat jemand eine Idee, was ich tun könnte?

sdoubleyou

  • Gast
Re: setup.py nicht gefunden
« Antwort #1 am: 19. Februar 2016, 16:47:01 »
bist du schon wieder mit der onedrive im Gange?  ;)

Du musst doch nur in den Ordner wechseln
git clone https://github.com/xybu/onedrive-d-old.git
cd onedrive-d-old

# Register package
sudo python3 setup.py install
https://de.manjaro.org/index.php?topic=5177.msg38969#msg38969
Folgende Mitglieder bedankten sich: m-bostaurus

Offline m-bostaurus

  • Sr. Mitglied
  • ****
  • Beiträge: 366
  • Dankeschön: 5 mal
  • Desktop: KDE, XFCE, LXQt, Mate
  • Grafikkarte: Desktop: GTX 1070Ti; Laptop: Nvidia
  • Grafikkartentreiber: unfree; unfree
  • Kernel: 419/420 64bit auf beiden Rechnern
  • Prozessor: i5-6500; i5
  • Skill: Durchschnitt
  • Zweig: stable
Re: setup.py nicht gefunden
« Antwort #2 am: 19. Februar 2016, 17:22:39 »
Asche auf mein Haupt ... Ich habe beim Kopieren den Befehl übersehen. Nach Deinem Hinweis habe ich das Ganze noch mal gemacht und es hatfunktioniert. Danke!