Autor Thema: ffdiaporama 2.x unter Manjaro?  (Gelesen 2830 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Offline EgLe

  • Vollwertiges Mitglied
  • ***
  • Beiträge: 172
  • Dankeschön: 6 mal
  • Desktop: KDE 5.x / Plasma 5.x
  • Grafikkarte: Radeon RX Vega M GH
  • Grafikkartentreiber: amdgpu
  • Kernel: 4.19.0-1-MANJARO x86_64
  • Prozessor: Intel Core i7-8809G @ 8x 4.2GHz
  • Skill: Anfänger
  • Zweig: stable
ffdiaporama 2.x unter Manjaro?
« am: 13. März 2016, 09:45:18 »
Hallo zusammen,

bin neu unter Manjaro (netruner), und bin noch am lernen gegenüber meiner alten Distribution Kubuntu 14.04.

Was mir im Moment noch schmerzlich fehlt ist das Programm ffdiaporama, welches ich (und vor allem mein Frauchen)
nutze um aus unseren Urlaubsbilder (oft über Tausend Bilder) eine Diashow mit Ton zu machen.

mein System ist folgendes:
OS:  Netrunner Rolling (x86_64)
Kernel:  Linux 4.4.5-1-MANJARO x86_64
Qt:   5.5.1
Plasma:  5.5.5
KDE Frameworks:   5.19.0
KDE Applications:  15.12.2

in meinem Repository finde ich es leider nicht:
[egle@i7-core-4770 ~]$ uname -a
Linux i7-core-4770 4.4.5-1-MANJARO #1 SMP PREEMPT Thu Mar 10 20:58:34 UTC 2016 x86_64 GNU/Linux
[egle@i7-core-4770 ~]$ sudo pacman -Syyu
[sudo] Passwort für egle:
:: Synchronisiere Paketdatenbanken...
 netrunner                                  13,8 KiB  3,37M/s 00:00 [#####################################] 100%
 core                                      134,3 KiB  2,62M/s 00:00 [#####################################] 100%
 extra                                    1862,5 KiB  6,74M/s 00:00 [#####################################] 100%
 community                                   3,5 MiB  6,60M/s 00:01 [#####################################] 100%
 multilib                                  183,0 KiB  10,5M/s 00:00 [#####################################] 100%
:: Starte vollständige Systemaktualisierung...
 Es gibt nichts zu tun
[egle@i7-core-4770 ~]$ pacman -Ss ffdiaporama
[egle@i7-core-4770 ~]$

Also habe ich mich auf die suche gemacht da es angeblich laut der Website:

http://ffdiaporama.tuxfamily.org/?page_id=10472

auch für ArchLinux/Manjaro Linux geben soll...

Dabei stoße ich jedoch auf das Arch User Repository welches wie ich gelsen habe nur mit Bedacht benutz werden sollte...


So wie ich es gelesen und verstanden habe benutzt man ja yaourt um vom Arch User Repository was zu installieren.

Also habe ich wie hier beschrieben, mein yaourt aktualisiert:
https://de.manjaro.org/index.php?topic=2589.msg21471#msg21471

und dann mittels yaourt auch schon Google Chrome und jdownloader2 erfolgreich installiert.

Leider gelingt mir das installieren von "fdiaporama" nicht:

[egle@i7-core-4770 ~]$ yaourt ffdiaporama
1 aur/ffdiaporama 2.1-3 (33) (0,44)
    Movie creator from photos and video clips
2 aur/ffdiaporama-openclipart 0.18-1 (4) (0,22)
    Extension for ffDiaporama to use the openclipart-library
3 aur/ffdiaporama-rsc 2.1-2 [installed] (13) (0,87)
    Recource-files for ffDiaporama
4 aur/ffdiaporama-texturemate 1.0-5 (8) (0,22)
    Additional background-images for ffDiaporama from texturemate.com
==> Geben Sie die Nummern der zu installierenden Pakete an (z.B. 1 2 3 oder 1-3)
==> ----------------------------------------------------------------------------
==> 1-4

bekomme ich erst diese Meldung:

==> Lade PKGBUILD von ffdiaporama aus dem AUR herunter...
x .SRCINFO
x EncodeVideo2.cpp.patch
x PKGBUILD
x cDeviceModelDef.patch
x ffdiaporama.install
 
I'm using manjaro, same problem.

 
To make this compiles I had to comment out lines 129 and 131 in file /usr/include/libswresample/swresample.h to make the #define unconditional.  This is probably due to a bug in libswresample which is installed by ffmpeg.
Cheers

 
Isn't compatible with ffmpeg 2.6 and 2.6.1. then you can't compile it.
You can use my patchs and resolve the problem:
http://www.4shared.com/file/TeGoa3xEba/parches.html

 
I can't download the patches. Please post them on http://pastebin.com/ or email them. Thanks

 
great! Thanks for the patches. Finally it compiles again!

ffdiaporama 2.1-3  (2015-07-07 15:11)
(Nicht unterstütztes Paket: Potenziell gefährlich!)
==> PKGBUILD bearbeiten? [J/n] („A“ zum Abbrechen)
==> ----------------------------------------------
==>

und wenn ich es ausführe bricht er leider etwas später mit der folgenden Meldung ab:

In file included from ./engine/cApplicationConfig.h:42:0,
                 from ./engine/_Transition.h:80,
                 from ./engine/_Diaporama.h:26,
                 from MainWindow/cCustomSlideTable.h:26,
                 from MainWindow/cCustomSlideTable.cpp:21:
./engine/cDeviceModelDef.h:56:36: schwerwiegender Fehler: libavutil/audioconvert.h: Datei oder Verzeichnis nicht gefunden
Kompilierung beendet.
Makefile:3394: die Regel für Ziel „cCustomSlideTable.o“ scheiterte
make[1]: *** [cCustomSlideTable.o] Fehler 1
make[1]: Verzeichnis „/tmp/yaourt-tmp-egle/aur-ffdiaporama/src/ffDiaporama/src/ffDiaporama“ wird verlassen
Makefile:68: die Regel für Ziel „sub-src-ffDiaporama-make_first“ scheiterte
make: *** [sub-src-ffDiaporama-make_first] Fehler 2
==> FEHLER: Ein Fehler geschah in build().
    Breche ab...
==> FEHLER:Makepkg konnte ffdiaporama nicht erstellen.
==> Erstellen von ffdiaporama neu starten?[j/N]
==> -------------------------------------------
==>

..

So habe mir nun den oben genannten Patch gedownloadet, ist im Anhang.

Doch habe ich noch nicht begriffen wie ich diesen einsetzten muss um mir das "ffdiaporama" nun mit diesem patch und dem "yaourt" zu installieren?



Wenn ich das ganze richtig verstanden habe, würde ja wenn ich es mittels "yaourt" mir installiere dann auch zusätzlich das Programm in das AUR mit aufgenommen und andere könnten es dann direkt mittles "yaourt" sich dann installieren???



MfG EgLe

Offline artoo

  • OpenRC Team
  • *****
  • Beiträge: 102
  • Dankeschön: 21 mal
  • Desktop: kde/lxqt
  • Skill: Fortgeschritten
  • Zweig: unstable
Re: ffdiaporama 2.x unter Manjaro?
« Antwort #1 am: 13. März 2016, 09:56:44 »
Ich mache mir jetzt bestimmt keine Freunde, aber laßt das yaourt sein.

Nehmt makepkg.

Also, hole dir den PKGBUILD vom AUR.
Dafür kannst Du gern yaourt nutzen.

Terminal:

yaourt -G <mein_paket>
Danach gehst du in den Paketorder deines Paketes.

cd <mein_paket>
So, und nun musst du den Patch einbauen.

Der Patch wird in den Paketordner kopiert, da wo auch der PKGBUILD liegt.

Öffne den PKGBUILD mit einem Texteditor deiner Wahl

kate PKGBUILD
So, jetzt brauchst du eine Funktion um zum Patchen:

prepare(){
    patch -Np1 -i $srcdir/<mein_patch.patch>
}

Dann bindest du die Patchquelle in "source" ein.

source=("irgend_ein_paket.tar.gz"
        'mein_patch.patch')

Im terminal:

updpkgsums
und dann

makepkg -sri
und Daumen drücken, daß dein Patch funktioniert.

« Letzte Änderung: 13. März 2016, 10:02:42 von artoo »

Offline EgLe

  • Vollwertiges Mitglied
  • ***
  • Beiträge: 172
  • Dankeschön: 6 mal
  • Desktop: KDE 5.x / Plasma 5.x
  • Grafikkarte: Radeon RX Vega M GH
  • Grafikkartentreiber: amdgpu
  • Kernel: 4.19.0-1-MANJARO x86_64
  • Prozessor: Intel Core i7-8809G @ 8x 4.2GHz
  • Skill: Anfänger
  • Zweig: stable
Re: ffdiaporama 2.x unter Manjaro?
« Antwort #2 am: 13. März 2016, 11:06:06 »
Hallo,

hmm, was muss ich den da installieren???

[egle@i7-core-4770 ~]$ yaourt PKGBUILD
1 community/emacs-pkgbuild-mode 0.14-1
    A major mode for creating packages with emacs
2 community/pkgbuild-introspection 8-1
    Tools for generating .AURINFO files and PKGBUILD data extraction
3 aur/aur-updater-git r6.dde4350-1 (2) (0,18)
    Easy tool to update your PKGBUILDS and update the AUR database automatically
4 aur/auto-07p 0.9.1-46 (3) (0,00)
    Software for continuation and bifurcation problems in ordinary differential equations. Release 07P.
    Environment variables controlling build (default to 'no', see PKGBUILD): _BUILD_DOC, _WITH_PLAUT04,
    _PLAUT04_WITH_QT, AUTO_DEBUG, _WITH_OPENMP, _WITH_MPI.
5 aur/chirp-daily 20151201-1 (3) (0,92)
    Daily build for GUI tool for programming ham radios; this pkgbuild is never out of date
6 aur/customizepkg-git 51.6cf63cb-1 (99) (8,35)
    A tool to modify automatically PKGBUILD
7 aur/customizepkg-patching 20-1 (5) (0,34)
    A tool to automate modification of PKGBUILDs using patch
8 aur/customizepkg-scripting 0.4.1-1 (8) (0,05)
    A tool to modify automatically PKGBUILDs - modified to just run scripts
9 aur/devpkgcheck 1.2-1 (1) (0,33)
    Tool that builds and tests pkgbuilds with vcs sources from the AUR
10 aur/emacs-pkgbuild-mode-git 0.14.1.6.geef2803-1 (11) (0,00)
    A major mode for creating packages with emacs
11 aur/gem2arch 0.11-1 (51) (0,73)
    Create PKGBUILD from Ruby Gem Package
12 aur/go-makepkg-git autogenerated-1 (0) (0,00)
    Generate PKGBUILD for Golang programs
13 aur/gutaur 1.0.3-1 (2) (0,06)
    An AUR helper. PKGBUILD at https://github.com/gutenye/gutaur/tree/master/misc/aur
14 aur/gutbackup 3.0.2-1 (1) (0,00)
    The simplest rsync wrapper for backup Linux system. PKGBUILD at
    https://github.com/gutenye/gutbackup/tree/master/misc/aur
15 aur/gututils 1.0.2-1 (1) (0,00)
    Guten's cmdline utils. PKGBUILD at https://github.com/gutenye/gututils/tree/master/misc/aur
16 aur/heretic2 1.06c-1 (1) (0,28)
    Heretic 2 from Raven Software, Linux version by Loki. Update PKGBUILD with path to CD for the data files.
17 aur/jwasm-git latest-1 (2) (0,21)
    JWasm fork (git) PKGBUILD file.
18 aur/keepass-plugin-favicon 1.9.0-1 (7) (1,47)
    A KeePass plugin that downloads and stores favicons. PKGBUILD source code at
    https://github.com/GutenYe/aur/tree/master/keepass-plugin-favicon
19 aur/lightspark-local 20120810-1 (0) (0,00)
    My modified version of the lightspark-git PKGBUILD; Enhancements: choose between devel and normal
    buildtype, save changes local even if you use yaourt
20 aur/linux-w110er 4.4.5-1 (1) (0,00)
    Linux 4.4.5 kernel and modules optimized for Mountain F11 Netbook (Clevo W110ER). See PKGBUILD
21 aur/mcabber-crew-modules 40-1 (0) (0,00)
    All modules from MCabber repository. PKGBUILD for crew edition.
22 aur/nodejs-npm2arch 0.1.19-1 (42) (1,27)
    Convert NPM package to a PKGBUILD for ArchLinux
23 aur/nwn-diamond 1.69-8 (11) (0,17)
    Neverwinter Nights RPG from Bioware. Requires the Diamond Collection DVD. Update PKGBUILD with path to
    your DVD.
24 aur/opennebula 4.14.2-2 (2) (1,51)
    Virtual management infrastructure as a service (IaaS) toolkit for cloud computing (NOTE: Read the
    PKGBUILD!)
25 aur/pacbuild-git 8-1 (0) (0,00)
    A simple abs wrapper to download single PKGBUILDs
26 aur/pbget 2016.2-1 (48) (1,91)
    Retrieve PKGBUILDs and local source files from Git, ABS and the AUR for makepkg.
27 aur/perl-gnupg 0.19-1 (3) (0,00)
    Perl module interface to the GNU Privacy Guard (v1.x.x series) Note: Tests fail if GnuPG is not correctly
    setup. See comments inside PKGBUILD if you have it set up correctly.
28 aur/pip2pkgbuild 0.1.5-1 (3) (0,45)
    Generate PKGBUILD file for a Python module from PyPi
29 aur/pipman-git 0.7.1.r0.g1de56ee-1 (3) (0,04)
    Generate PKGBUILD from pip packages
30 aur/pkgbuild-introspection-git 6.4.ga135f86-1 (27) (0,31)
    Tools for generating .SRCINFO files and PKGBUILD data extraction (mkaurball)
31 aur/pkgbuild-watch 20120622-1 (12) (0,10)
    Monitor upstream for updates.
32 aur/pkgbuilder 4.2.5-1 (26) (1,24)
    A Python AUR helper/library.
33 aur/pkgbuilder-git 4.2.5.r1.g33c40b1-1 (2) (0,00)
    A Python AUR helper/library. (git version)
34 aur/pkgbuildup-git 20131218-1 (0) (0,00)
    A helper tool for AUR package maintainer to automatic update PKGBUILD files - Git version
35 aur/pkgman r188-1 (41) (0,00)
    A script providing centralized local package and PKGBUILD management
36 aur/python-parched-git 0.1.r25.4c3ec3f-3 (3) (0,00)
    A Pacman package and PKGBUILD parser module for Python
37 aur/python-pkgbuild-git r3.aeca84e-1 (1) (0,73)
    Python library to parse pacman's .SRCINFO file
38 aur/python2-pip2pkgbuild 0.1.5-1 (3) (0,45)
    Generate PKGBUILD file for a Python module from PyPi
39 aur/reform 0.2.2-1 (2) (0,01)
    a PKGBUILD management suite
40 aur/repo-make 1.2.0-3 (1) (0,06)
    Tool to autobuild a set of PKGBUILDs into a working repository
41 aur/rezound-svn latest-2 (6) (0,65)
    A graphical audio file editor, not bloated, simple to use. Supports LADSPA-plugins. (NOTE: The package's
    dependencies can be minimised by changing the PKGBUILD's ./configure-script.)
42 aur/rhythmbox-tray-icon 0.2_1-4 (2) (0,60)
    Restores the tray icon functionality from the 0.x series. Please report PKGBUILD bugs at
    https://github.com/ystein/archlinux-aur-packages.
43 aur/rhythmbox-tray-icon-git 159f882-2 (1) (0,08)
    Restores the tray icon functionality from the 0.x series. Please report PKGBUILD bugs at
    https://github.com/ystein/archlinux-aur-packages.
44 aur/tetra-codec 1:20151213_3-1 (0) (0,00)
    installer script for TETRA codecs , based on https://github.com/sq5bpf/install-tetra-codec/. This PKGBUILD
    does not contain source code or binaries from ETSI, it merely downloads and compiles them
45 aur/vmware-vcli 5.5.0.2043780-1 (Out of Date) (8) (0,32)
    The vCLI utilities make it possible to manage VMWare ESX servers (with the possibility of using vCenter).
    For make package, place VMware-vSphere-CLI-5.5.0-1549297.{your_arch}.tar.gz to PKGBUILD directory.
46 aur/vmware-vsphere-web-client-plugin 5.5.0.1896274-2 (Out of Date) (11) (0,00)
    Firefox and Chromium plugin, to access virtual machines console from vSphere Web Client. For make package,
    place VMware-ClientIntegrationPlugin-5.5.0.{your_arch}.bundle to PKGBUILD directory.
47 aur/yaaw-git r124.a5d2d30-1 (9) (0,06)
    Yet Another Aria2 Web Frontend in pure HTML/CSS/Javascirpt. PKGBUILD source code at
    https://github.com/gutenye/aurs/tree/master/yaaw-git
==> Geben Sie die Nummern der zu installierenden Pakete an (z.B. 1 2 3 oder 1-3)
==> ----------------------------------------------------------------------------
==>
MfG EgLe

Offline EgLe

  • Vollwertiges Mitglied
  • ***
  • Beiträge: 172
  • Dankeschön: 6 mal
  • Desktop: KDE 5.x / Plasma 5.x
  • Grafikkarte: Radeon RX Vega M GH
  • Grafikkartentreiber: amdgpu
  • Kernel: 4.19.0-1-MANJARO x86_64
  • Prozessor: Intel Core i7-8809G @ 8x 4.2GHz
  • Skill: Anfänger
  • Zweig: stable
Re: ffdiaporama 2.x unter Manjaro?
« Antwort #3 am: 13. März 2016, 11:57:47 »
Hallo,

so habe es erstmal auf die alte weise Probiert...

sourcen gezogen und entpackt, patches hinereinkopiert und dann gings los:

[egle@i7-core-4770 ffDiaporama]$ patch -p0 < cDeviceModelDef.patch
patching file src/ffDiaporama/engine/cDeviceModelDef.h

[egle@i7-core-4770 ffDiaporama]$ patch -p0 < EncodeVideo2.cpp.patch
patching file src/ffDiaporama/engine/_EncodeVideo.cpp

[egle@i7-core-4770 ffDiaporama]$ qmake
Project MESSAGE: Install to : /usr

[egle@i7-core-4770 ffDiaporama]$ make
cd src/ffDiaporama_lib/ && ( test -e Makefile || /usr/lib/qt/bin/qmake /home/egle/ffdiaporama2.1/ffDiaporama/src/ffDiaporama_lib/ffDiaporama_lib.pro -o Makefile ) && make -f Makefile
make[1]: Verzeichnis „/home/egle/ffdiaporama2.1/ffDiaporama/src/ffDiaporama_lib“ wird betreten

... snip

In file included from ./engine/cApplicationConfig.h:42:0,
                 from ./engine/_Transition.h:80,
                 from ./engine/_Diaporama.h:26,
                 from MainWindow/cCustomSlideTable.h:26,
                 from MainWindow/cCustomSlideTable.cpp:21:
./engine/cDeviceModelDef.h:56:36: schwerwiegender Fehler: libavutil/audioconvert.h: Datei oder Verzeichnis nicht gefunden
Kompilierung beendet.
Makefile:3394: die Regel für Ziel „cCustomSlideTable.o“ scheiterte
make[1]: *** [cCustomSlideTable.o] Fehler 1
make[1]: Verzeichnis „/home/egle/ffdiaporama2.1/ffDiaporama/src/ffDiaporama“ wird verlassen
Makefile:68: die Regel für Ziel „sub-src-ffDiaporama-make_first“ scheiterte
make: *** [sub-src-ffDiaporama-make_first] Fehler 2
[egle@i7-core-4770 ffDiaporama]$


Dann habe ich nach weitere Googlen ja noch das hier gefunden:

https://sourceforge.net/p/ffdiaporamadevel22patch/wiki/Home/

aber auch mit ffdiaporama 2.2 unstable und diesem Patch (in dem Link oben drüber) klappt das nicht mehr :-(



PS: also mit Google findet man ja auch was im Französichem Manjaro forum auch was darüber.
Nur verstehe ich da noch weniger aber wenn ich mir so die Smilies anschaue scheinen die das hinzu bekommen?

http://www.manjaro.fr/forum/viewtopic.php?f=28&t=5243




« Letzte Änderung: 13. März 2016, 12:07:04 von EgLe1 »
MfG EgLe

Offline Pig of Destiny

  • Held Mitglied
  • *****
  • Beiträge: 1383
  • Dankeschön: 125 mal
  • Desktop: Xfce
  • Grafikkarte: Intel Graphics
  • Grafikkartentreiber: free
  • Kernel: 4.16
  • Prozessor: Intel Celeron N3350
  • Skill: Durchschnitt
  • Zweig: Arch Linux
Re: ffdiaporama 2.x unter Manjaro?
« Antwort #4 am: 13. März 2016, 12:14:49 »
Das Problem liegt hier nicht bei den Patches. Ich hab mir gerade mal das PKGBUILD angesehen, dort sind die Patches schon eingearbeitet. Du musst vor dem bauen aus der Header-File /tmp/yaourt-tmp-BENUTZERNAME/aur-ffdiaporama/src/ffDiaporama/src/ffDiaporama/engine/cDeviceModelDef.h die Zeile#include <libavutil/audioconvert.h>entfernen, audioconvert.h wird wohl nicht benötigt.
« Letzte Änderung: 13. März 2016, 12:23:37 von Pig of Destiny »

Offline artoo

  • OpenRC Team
  • *****
  • Beiträge: 102
  • Dankeschön: 21 mal
  • Desktop: kde/lxqt
  • Skill: Fortgeschritten
  • Zweig: unstable
Re: ffdiaporama 2.x unter Manjaro?
« Antwort #5 am: 13. März 2016, 13:07:55 »
Das Problem liegt hier nicht bei den Patches. Ich hab mir gerade mal das PKGBUILD angesehen, dort sind die Patches schon eingearbeitet. Du musst vor dem bauen aus der Header-File /tmp/yaourt-tmp-BENUTZERNAME/aur-ffdiaporama/src/ffDiaporama/src/ffDiaporama/engine/cDeviceModelDef.h die Zeile#include <libavutil/audioconvert.h>entfernen, audioconvert.h wird wohl nicht benötigt.

Also sind die Patches dann wohl nicht so ganz komplett.
Sowas sollte eigentlich ein Patch machen.

Übrigens, wieder eine Bestätigung, daß AUR Pakete nix auf dem installierbaren Medium zu suchen haben, was immer wieder angefragt wird.

Offline Pig of Destiny

  • Held Mitglied
  • *****
  • Beiträge: 1383
  • Dankeschön: 125 mal
  • Desktop: Xfce
  • Grafikkarte: Intel Graphics
  • Grafikkartentreiber: free
  • Kernel: 4.16
  • Prozessor: Intel Celeron N3350
  • Skill: Durchschnitt
  • Zweig: Arch Linux
Re: ffdiaporama 2.x unter Manjaro?
« Antwort #6 am: 13. März 2016, 13:22:38 »
Also sind die Patches dann wohl nicht so ganz komplett.
Sowas sollte eigentlich ein Patch machen.
Da muss ich dir zustimmen!
Wollte es gerade mal testweise installieren, da liegt noch einiges im Argen mit dem Paket... Ich frickel mal noch ein bisschen. Mal sehen obs schlussendlich hinhaut.


Offline EgLe

  • Vollwertiges Mitglied
  • ***
  • Beiträge: 172
  • Dankeschön: 6 mal
  • Desktop: KDE 5.x / Plasma 5.x
  • Grafikkarte: Radeon RX Vega M GH
  • Grafikkartentreiber: amdgpu
  • Kernel: 4.19.0-1-MANJARO x86_64
  • Prozessor: Intel Core i7-8809G @ 8x 4.2GHz
  • Skill: Anfänger
  • Zweig: stable
Re: ffdiaporama 2.x unter Manjaro?
« Antwort #7 am: 13. März 2016, 13:35:00 »
Hallo habe das auch mal mit dem

//#include <libavutil/audioconvert.h>

auskommentiert, doch leider bingt es mir so nichts, da
mir "yaourt ffdiaporama" immer die sourcen neu runterlädt bei jedem versuch.

Aber ich habe noch was in englisch gefunden, was einem erfahrenen weiterhilft?

Die patches scheinen wohl nur bis ffmpeg 2.8.6 zu funktionieren und der folgende Thread handel sich um ffmpeg 3.0

http://ffdiaporama.tuxfamily.org/Forum/viewtopic.php?id=1212

Hatte da angefangen mal zu ändern was gerd1028 so geschrieben hatte.

doch leider werde ich aus dem letzten Posting nicht ganz schlau, da es recht kurz gehalten ist..
MfG EgLe

Offline Pig of Destiny

  • Held Mitglied
  • *****
  • Beiträge: 1383
  • Dankeschön: 125 mal
  • Desktop: Xfce
  • Grafikkarte: Intel Graphics
  • Grafikkartentreiber: free
  • Kernel: 4.16
  • Prozessor: Intel Celeron N3350
  • Skill: Durchschnitt
  • Zweig: Arch Linux
Re: ffdiaporama 2.x unter Manjaro?
« Antwort #8 am: 13. März 2016, 13:39:03 »
Wenn du die Zeile auskommentiert und gespeichert hast darfst du das Paket nicht versuchen via yaourt zu installieren, da sonst der Download erneut startet. Du musst dann in das Verzeichnis /tmp/yaourt-tmp-BENUTZERNAME/aur-ffdiaporama/src/ffDiaporama/src/ffDiaporama wechseln und mit makedas Paket bauen.
Aber es gibt da noch Probleme, weil die Patches, wie du schon geschrieben hast, nicht auf die aktuelle Version ffmpeg passen. Da bedarf es einer Überarbeitung. Wenn du möchtest kannst du ja mal den Maintainer des AUR-Paketes kontaktieren.

Offline EgLe

  • Vollwertiges Mitglied
  • ***
  • Beiträge: 172
  • Dankeschön: 6 mal
  • Desktop: KDE 5.x / Plasma 5.x
  • Grafikkarte: Radeon RX Vega M GH
  • Grafikkartentreiber: amdgpu
  • Kernel: 4.19.0-1-MANJARO x86_64
  • Prozessor: Intel Core i7-8809G @ 8x 4.2GHz
  • Skill: Anfänger
  • Zweig: stable
Re: ffdiaporama 2.x unter Manjaro?
« Antwort #9 am: 13. März 2016, 14:18:11 »
Hallo,

habe mich mal im AUR registriert und dort im Wiki unter ffdiaporama ein Kommentar hinterlassen.
mal sehen was daraus wird?
MfG EgLe
Folgende Mitglieder bedankten sich: Pig of Destiny

Offline Pig of Destiny

  • Held Mitglied
  • *****
  • Beiträge: 1383
  • Dankeschön: 125 mal
  • Desktop: Xfce
  • Grafikkarte: Intel Graphics
  • Grafikkartentreiber: free
  • Kernel: 4.16
  • Prozessor: Intel Celeron N3350
  • Skill: Durchschnitt
  • Zweig: Arch Linux
Re: ffdiaporama 2.x unter Manjaro?
« Antwort #10 am: 13. März 2016, 15:09:10 »
Super, danke.

Ich hab jetzt mal versucht es hinzufrickeln und gebe auf. Es stimmen ziemlich viele Pfade zu den Headern nicht. Ich hatte jetzt mal manuell recht viele Pfade korrigiert, aber es nimmt kein Ende...

Offline EgLe

  • Vollwertiges Mitglied
  • ***
  • Beiträge: 172
  • Dankeschön: 6 mal
  • Desktop: KDE 5.x / Plasma 5.x
  • Grafikkarte: Radeon RX Vega M GH
  • Grafikkartentreiber: amdgpu
  • Kernel: 4.19.0-1-MANJARO x86_64
  • Prozessor: Intel Core i7-8809G @ 8x 4.2GHz
  • Skill: Anfänger
  • Zweig: stable
Re: ffdiaporama 2.x unter Manjaro?
« Antwort #11 am: 21. März 2016, 11:26:30 »
Hallo,

also ich habe jetzt eine weile darüber nachgedacht, und bin zum Entschluss gekommen
dieses Thema für mich als erledigt anzusehen.

1. wird das Programm selbst wohl nicht mehr weiterentwickelt
denn selbst die Devel-version von 2.2 ist zuletzt vom 20140701  :(

2. wenn nun bei der alten Version bei jedem ffmpeg-update damit zu rechnen ist
das es wieder nur Probleme gibt wird das ganze wohl keinen Wert mehr haben...


Bin also auf der Suche nach alternativen die evtl. auch für Windows verfügbar sind,
da mein Frauchen sich leider nicht von Ihrem Windows trennen will/kann und slebst auch als mit den Diashows arbeitet.

« Letzte Änderung: 21. März 2016, 11:28:22 von EgLe »
MfG EgLe

sarrejam

  • Gast
Re: ffdiaporama 2.x unter Manjaro?
« Antwort #12 am: 21. März 2016, 12:19:05 »
Bin also auf der Suche nach alternativen die evtl. auch für Windows verfügbar sind,
da mein Frauchen sich leider nicht von Ihrem Windows trennen will/kann und slebst auch als mit den Diashows arbeitet.

Hallo EgLe,

könnte das nicht eine Alternative (auch für Win) sein:

4K Slideshow Maker

offizielleWebsite

oder (Linux)

Imagination

offizielle Website

ausführliche Beschreibung bei Linux-User

Gruß

sarrejam
Folgende Mitglieder bedankten sich: EgLe

Offline EgLe

  • Vollwertiges Mitglied
  • ***
  • Beiträge: 172
  • Dankeschön: 6 mal
  • Desktop: KDE 5.x / Plasma 5.x
  • Grafikkarte: Radeon RX Vega M GH
  • Grafikkartentreiber: amdgpu
  • Kernel: 4.19.0-1-MANJARO x86_64
  • Prozessor: Intel Core i7-8809G @ 8x 4.2GHz
  • Skill: Anfänger
  • Zweig: stable
Re: ffdiaporama 2.x unter Manjaro?
« Antwort #13 am: 21. März 2016, 12:46:17 »
Hallo,

Hatte auch schon recht viel gegoogelt  ;)

Hallo EgLe,

könnte das nicht eine Alternative (auch für Win) sein:

4K Slideshow Maker

offizielleWebsite


Das hatte ich auch gesehen, gibt es nicht nur für Windows , sondern auch für Linux, aber leider nur fertige debfiles für Ubuntu  :-\
Vor allem weil es ja auch 4K kann also schon zukunftsorientiert ist für UHD-TV :)

PS: Ahh habe erst jetzt gesehen das du da ja einen Link zum ARCH gesetzt hast, hatte ich gar nicht gefunden...
Besten Dank, das Probiere ich mal zu installieren....



oder (Linux)

Imagination

Habe ich installiert ist auch nicht schlecht und einfach zu bedienen, leider nur für Linux und FreeBSD  ;)


Als Alternattive habe ich auch noch was anderes gefunden, doch das gibts es leider nicht per pacman &yaourt

und habe wegen der Installation zum testen einen eigenen Thread begonnen..

https://de.manjaro.org/index.php?topic=5440.0


« Letzte Änderung: 21. März 2016, 13:00:17 von EgLe »
MfG EgLe

Offline EgLe

  • Vollwertiges Mitglied
  • ***
  • Beiträge: 172
  • Dankeschön: 6 mal
  • Desktop: KDE 5.x / Plasma 5.x
  • Grafikkarte: Radeon RX Vega M GH
  • Grafikkartentreiber: amdgpu
  • Kernel: 4.19.0-1-MANJARO x86_64
  • Prozessor: Intel Core i7-8809G @ 8x 4.2GHz
  • Skill: Anfänger
  • Zweig: stable
Re: ffdiaporama 2.x unter Manjaro?
« Antwort #14 am: 21. März 2016, 13:13:17 »
Sorry,

Dies paket ist im AUR auch veraltete und wird wohl nicht mehr weiter Unterstütz?

https://aur.archlinux.org/packages/4kslideshowmaker/

Zmindest steht da im ANhang ne Lange Latte mit Warnigs in Englisch die ich nicht verstehe...

Und wenn ich es Trotzdem installieren will, will er mir viele veraltete Pakete ffmpeg 2,x usw. installieren und irgendwann bricht er doch dann ab :-(

=> Prüfe Buildtime-Abhängigkeiten...
==> Empfange Quellen...
  -> Lade jpegsrc.v09b.tar.gz herunter...
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0
curl: (22) The requested URL returned error: 404 Not Found
==> FEHLER: Fehler beim Download von http://www.infai.org/jpeg/files?get=jpegsrc.v09b.tar.gz
    Breche ab...
==> FEHLER:Makepkg konnte libjpeg9 nicht erstellen.
==> Erstellen von libjpeg9 neu starten?[j/N]
==> ----------------------------------------
==>
==> WARNUNG:Vor dem Fehlschlag wurden Abhängigkeiten installiert
Prüfe Abhängigkeiten...
:: vlc benötigt optional portaudio: for portaudio support

Pakete (3) libavutil-52-2.3.4-1  ffmpeg-compat-55-2.3.4-4  portaudio-19_20140130-3

Gesamtgröße der entfernten Pakete:  11,84 MiB

:: Möchten Sie diese Pakete entfernen? [J/n]
MfG EgLe