Autor Thema: Thunar zeigt Laufwerk nicht mehr an  (Gelesen 651 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Offline suska

  • Sr. Mitglied
  • ****
  • Beiträge: 371
  • Dankeschön: 31 mal
  • Desktop: openbox
  • Grafikkarte: Intel
  • Grafikkartentreiber: free
  • Kernel: 4.9
  • Prozessor: i5
  • Skill: Durchschnitt
  • Zweig: #
Thunar zeigt Laufwerk nicht mehr an
« am: 14. April 2016, 12:46:54 »
Ob es mit meiner Updateorgie zusammenhängt kann ich nicht sagen. Habe jedenfalls weder hier noch im englischen Forum Hinweise dazu finden können. Thunar zeigt mir seit gestern meine 2. interne Festplatte und auch ein DVD-Laufwerk in diesem Schacht nicht mehr an.

In der netzlosen Zeit hab ich das Laufwerk des öfteren aus dem Schacht gezogen und ein DVD-Laufwerk eingesteckt. Da gabs keinerlei Probleme. Nach jedem Wechsel wurde das gerade eingeschobene Laufwerk von Thunar angezeigt. Egal ob ichs bei ausgeschaltetem Gerät, während einem Suspend oder hot geswappt habe.

Die Platte ist verschlüsselt, in der fstab, crypttab und rc.local eingetragen. Bisher wurde sie in Thunar unter Geräte als "750 GB verschlüsselt" schattiert angezeigt. Nach einem Klick drauf wurde das unter /etc/cryptkey_sdb1 abgelegte Passwort abgefragt und das Laufwerk anschliessend geöffnet.

Auch wenn ich das DVD-Laufwerk einschiebe und eine DVD einlege wird nix mehr angezeigt obwohl ich die DVD mit VLC einwandfrei abspielen kann.

Bin momentan ratlos. Hat jemand eine Idee woran es liegen könnte?

EDIT: Per Live-USB funktioniert es. Aber im laufenden System via USB angeschlossen geht nix. Auch keine USB-Sticks.
« Letzte Änderung: 14. April 2016, 12:51:40 von suska »
.:. Artix Linux .:. FreeBSD .:. Salix OS .:.

LuMI

  • Gast
Re: Thunar zeigt Laufwerk nicht mehr an
« Antwort #1 am: 14. April 2016, 16:16:54 »
Ob es mit meiner Updateorgie zusammenhängt kann ich nicht sagen. Habe jedenfalls weder hier noch im englischen Forum Hinweise dazu finden können. Thunar zeigt mir seit gestern meine 2. interne Festplatte und auch ein DVD-Laufwerk in diesem Schacht nicht mehr an.

In der netzlosen Zeit hab ich das Laufwerk des öfteren aus dem Schacht gezogen und ein DVD-Laufwerk eingesteckt. Da gabs keinerlei Probleme. Nach jedem Wechsel wurde das gerade eingeschobene Laufwerk von Thunar angezeigt. Egal ob ichs bei ausgeschaltetem Gerät, während einem Suspend oder hot geswappt habe.

Die Platte ist verschlüsselt, in der fstab, crypttab und rc.local eingetragen. Bisher wurde sie in Thunar unter Geräte als "750 GB verschlüsselt" schattiert angezeigt. Nach einem Klick drauf wurde das unter /etc/cryptkey_sdb1 abgelegte Passwort abgefragt und das Laufwerk anschliessend geöffnet.

Auch wenn ich das DVD-Laufwerk einschiebe und eine DVD einlege wird nix mehr angezeigt obwohl ich die DVD mit VLC einwandfrei abspielen kann.

Bin momentan ratlos. Hat jemand eine Idee woran es liegen könnte?

EDIT: Per Live-USB funktioniert es. Aber im laufenden System via USB angeschlossen geht nix. Auch keine USB-Sticks.

Dieses Verhalten betrifft scheinbar nur Openbox.
In der LXDE und und XFCE Sitzung zeigt sowohl Thunar als auch Pcmanfm alles nach Wunsch.

Für Pcmanfm unter Openbox schafft folgendes Abhilfe:

dbus-launch pcmanfm -d &
MfG

Offline suska

  • Sr. Mitglied
  • ****
  • Beiträge: 371
  • Dankeschön: 31 mal
  • Desktop: openbox
  • Grafikkarte: Intel
  • Grafikkartentreiber: free
  • Kernel: 4.9
  • Prozessor: i5
  • Skill: Durchschnitt
  • Zweig: #
Re: Thunar zeigt Laufwerk nicht mehr an
« Antwort #2 am: 14. April 2016, 16:28:39 »
Hi LuMI,

erstmal vielen Dank an dich für den Tipp. Es funktioniert sowohl mit Pcmanfm als auch mit Thunar (dann ohne Option -d).

Allerdings erzweugen beide Befehle eine Warnmeldung. Vielleicht kannst ja was damit anfangen.

Zitat
(pcmanfm:7496): WARNING **: Couldn't register with accessibility bus: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.

Grüße
« Letzte Änderung: 14. April 2016, 16:31:18 von suska »
.:. Artix Linux .:. FreeBSD .:. Salix OS .:.

LuMI

  • Gast
Re: Thunar zeigt Laufwerk nicht mehr an
« Antwort #3 am: 14. April 2016, 17:16:16 »
Die Warnung gibt es wegen der Verschlüsselten Festplatte.

Man kann in die ~/.config/openbox/autostart eintragen:

dbus-launch pcmanfm -d &dbus-launch thunar &
So wird die Warnung "ausgeblendet"  ;)

MfG

Offline suska

  • Sr. Mitglied
  • ****
  • Beiträge: 371
  • Dankeschön: 31 mal
  • Desktop: openbox
  • Grafikkarte: Intel
  • Grafikkartentreiber: free
  • Kernel: 4.9
  • Prozessor: i5
  • Skill: Durchschnitt
  • Zweig: #
Re: Thunar zeigt Laufwerk nicht mehr an
« Antwort #4 am: 14. April 2016, 19:38:35 »
So wird die Warnung "ausgeblendet"  ;)

Auch ne Möglichkeit Warnungen zu "umschiffen"  ;D

Interessieren würde mich die Ursache was den ursprünglichen Fehler angeht, dass Thunar die Laufwerke nimmer anzeigt. Schade, hab vorm Update nur ein Backup von /home gemacht. Wird aber wohl mit dbus zu tun haben oder bin ich da auf dem Holzweg?
.:. Artix Linux .:. FreeBSD .:. Salix OS .:.

LuMI

  • Gast
Re: Thunar zeigt Laufwerk nicht mehr an
« Antwort #5 am: 14. April 2016, 21:13:41 »
Auch ne Möglichkeit Warnungen zu "umschiffen"  ;D

Interessieren würde mich die Ursache was den ursprünglichen Fehler angeht, dass Thunar die Laufwerke nimmer anzeigt. Schade, hab vorm Update nur ein Backup von /home gemacht. Wird aber wohl mit dbus zu tun haben oder bin ich da auf dem Holzweg?

Bei Google gibt dbus-launch pcmanfm 4.080 Treffer aus.

Neu ist das nicht, ich habe den Eintrag vorbeugend in ~/.config/openbox/autostart seit 2 Jahren.

http://bbs.archbang.org/viewtopic.php?id=3704

MfG

Offline suska

  • Sr. Mitglied
  • ****
  • Beiträge: 371
  • Dankeschön: 31 mal
  • Desktop: openbox
  • Grafikkarte: Intel
  • Grafikkartentreiber: free
  • Kernel: 4.9
  • Prozessor: i5
  • Skill: Durchschnitt
  • Zweig: #
Re: Thunar zeigt Laufwerk nicht mehr an
« Antwort #6 am: 16. April 2016, 17:59:48 »
Neu ist das nicht, ich habe den Eintrag vorbeugend in ~/.config/openbox/autostart seit 2 Jahren.

Hatte das Problem bisher nie gehabt und natürlich nix mit dbus in die Suchmaschine eingegeben, weil ich das Verhalten einzig Thunar zugeschrieben hatte.
Aus dem Autostart hab ichs aber wieder rausgenommen und stattdessen die Befehle für Thunar im Menü von Openbox entsprechend angepasst.

Danke nochmals für die Lösung.
.:. Artix Linux .:. FreeBSD .:. Salix OS .:.