Autor Thema: 2016-08-06 - Plasma 5.7.3, LibreOffice, Firefox, Thunderbird (Testing Update)  (Gelesen 918 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Offline suska

  • Sr. Mitglied
  • ****
  • Beiträge: 382
  • Dankeschön: 32 mal
  • Desktop: openbox
  • Grafikkarte: Intel
  • Grafikkartentreiber: free
  • Kernel: 4.19
  • Prozessor: i5
  • Skill: Durchschnitt
  • Zweig: #
Almost a week passed for this testing branch update-pack. It took us a little longer to sync our Firefox and Thunderbird packages with upstream. Rob worked on his Netbook optimized kernel, our kernel team on the real-time kernels and I on the Nvidia drivers. Let see if 367.36.02 is fixing some issues we have in 367 series of the proprietary driver.

We also have Libreoffice in both branches. Fresh is now at v5.2 series and Still adopted v5.1 series. We have an updated tool-chain featuring the latest glibc 2.24 which let to rebuilds of python, haskel and a new version of eric. KDE fans will be happy about the Plasma 5.7.3 update.

Archlinux upstream fixes are now from: Sat Aug 06 16:37 CEST 2016.

Please report any issues you may have with this update. Also read our troubleshoots to avoid known issues. Additional it would be good to test one of our preview install medias to check these changes on a fresh install. Package details can be found here.

Kind regards,
Philip Müller and the Manjaro Development Team


Troubleshoots

GTK3

With this we updated Gnome and GTK to 3.20. This will break most of the themes, which will be fixed if and when their developers decide to update them. Some GTK 3.20-compliant themes are ready now - see further down this post.

The new default Manjaro GTK theme, which is GTK 3.20 compatible, is Vertex-Maia

You can install it with:

Code: sudo pacman -Sy vertex-maia-themes vertex-maia-icon-theme xcursor-maia

KDE users should default to Maia theme:

Code: sudo pacman -Sy maia-icon-theme gtk-theme-maia plasma5-themes-maia xcursor-maia


QT apps style with GTK - only needed for non-KDE desktop environments!

With QT 5.7 you need to install qt5-styleplugins and qt5ct and configure your system to have an unified look again.


ufw

If you have issues with ufw not working anymore, you have to copy your custom rules to a different folder. Do it like this:

Code: sudo cp -v /usr/lib/ufw/user.rules.pacsave /etc/ufw/user.rules
sudo cp -v /usr/lib/ufw/user6.rules.pacsave /etc/ufw/user6.rules

steam

Steam might not work due incompatiblity of libgpg. You my try followed command to "fix" it:

Code: find ~/.steam/root/ \( -name "libgcc_s.so*" -o -name "libstdc++.so*" -o -name "libxcb.so*" -o -name "libgpg-error.so*" \) -print -delete

Code: find ~/.local/share/Steam/ \( -name "libgcc_s.so*" -o -name "libstdc++.so*" -o -name "libxcb.so*" -o -name "libgpg-error.so*" \) -print -delete

Reference: Archlinux wiki


Current supported kernels
Linux310 3.10.102
Linux312 3.12.62
Linux314 3.14.74
Linux316 3.16.36
Linux318 3.18.37
Linux319 3.19.8.23 [EOL]
Linux41 4.1.28
Linux42 4.2.8.13 [EOL]
Linux44 4.4.16
Linux45 4.5.7 [EOL]
Linux46 4.6.5
Linux47 4.7.0
Linux-RT-LTS 4.4.15-rt23
Linux-RT 4.6.5-rt9

Upstream package changes:
testing community i686: 446 new and 441 removed package(s)
testing core x86_64: 22 new and 22 removed package(s)
testing core i686: 22 new and 22 removed package(s)
testing multilib x86_64: 25 new and 25 removed package(s)
testing extra i686: 502 new and 501 removed package(s)
testing extra x86_64: 502 new and 501 removed package(s)
testing community x86_64: 449 new and 444 removed package(s)

Overlay package changes:
testing community i686: 103 new and 98 removed package(s)
testing core x86_64: 3 new and 2 removed package(s)
testing core i686: 3 new and 2 removed package(s)
testing multilib x86_64: 2 new and 4 removed package(s)
testing extra i686: 20 new and 21 removed package(s)
testing extra x86_64: 20 new and 19 removed package(s)
testing community x86_64: 132 new and 98 removed package(s)

Quelle
Void Linux .:. FreeBSD

Offline suska

  • Sr. Mitglied
  • ****
  • Beiträge: 382
  • Dankeschön: 32 mal
  • Desktop: openbox
  • Grafikkarte: Intel
  • Grafikkartentreiber: free
  • Kernel: 4.19
  • Prozessor: i5
  • Skill: Durchschnitt
  • Zweig: #
Hab ein Problem mit libvpx.

/usr/lib/inox/inox: error while loading shared libraries: libvpx.so.3: cannot open shared object file: No such file or directory
Ein Downgrade von libvpx brachte keine Lösung. Hat wer ne Idee?
Void Linux .:. FreeBSD

Offline linuxkumpel

  • Held Mitglied
  • *****
  • Beiträge: 866
  • Dankeschön: 72 mal
  • "Sei klug und stell Dich dumm!"
  • Desktop: Xfce 4.13.2 | Budgie
  • Grafikkarte: Intel HD Graphics 4400
  • Grafikkartentreiber: nonfree
  • Kernel: 4.20 / 4.19
  • Prozessor: Intel Core i3-4010U
  • Skill: Durchschnitt
  • Zweig: testing
Im Gegensatz zu suska hatte ich keine Probleme bei der Installation und der Aktualisierung.   :)
Lenovo M 30-70 Manjaro 18.0.3 Xfce | Packard Bell Easynote TK 85 - Manjaro Budgie | Netbook Packard Bell Dot's - elementary OS 5.0 | ThinkPad T420s Pop!_OS 18.10| Dell Inspiron 11-3162 PeppermintOS 9 | Asus EeePC 701 4 G - Peppermint OS | Dell Latitude E7240 - Windows 10   "Lieber mit Linux üben, als Microsoft eine Chance." EDV, Ende der Vernunft!