Autor Thema: [Testing Update] 2016-08-19 - Calamares, Nvidia, Virtualbox, Kernels  (Gelesen 679 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Online Linu74

  • Administrator
  • ******
  • Beiträge: 1970
  • Dankeschön: 141 mal
  • Desktop: XFCE/i3gaps x86_64
  • Grafikkarte: Intel/Nvidia
  • Grafikkartentreiber: free/nonfree
  • Kernel: 4.1, 4.4
  • Prozessor: Core2Duo + Intel® Core™ i5-2520M
  • Skill: Durchschnitt
  • Zweig: testing
Testing Updates

Zitat
Hi community,

this might be a fast-track update. We renewed our kernels (most of the EOL tagged kernels are now removed), updated nvidia drivers to 370-series (which fixes the black screen bug) and released VirtualBox 5.1.4. Most work went into Calamares, which is now at version v2.4-rc1. These are the changes:

* Fixed an issue in the users module which could cause failed installs when entering and then deleting a name (validation kicks in correctly now).
* Fixed Portage dependency management in the packages module (contribution by V3n3RiX).
* Configuration defaults fixes (contribution by Philip Müller).
* Internet connection status is now written into GlobalStorage so it's available to all modules (the key is "hasInternet").
* Added support for GeoIP in the locale module, this relies on freegeoip which is open source, and can be used both as a service (freegeoip.net) as well as self-hosted. Geolocation is used to pre-select the timezone (same as Ubiquity). While this feature only performs a single HTTP GET and sends no user data, it has potential privacy implications. We have enabled this feature by default on Manjaro. Maintainer may want to disable it. Simply comment the line in locale.conf.

Archlinux upstream fixes are now from: Fri Aug 19 08:07 CEST 2016.

Please report any issues you may have with this update. Also read our **troubleshoots** to avoid known issues. Additional it would be good to test one of our [preview install medias](https://manjaro.org/manjaro-preview-releases/) to check these changes on a fresh install.

Kind regards,
Philip Müller and the Manjaro Development Team

---

**Troubleshoots**

**Issues with updating MATE**

Some users have **mate-menu** installed from AUR. Please remove this package if you use the **GTK2** version of MATE before trying to update. If you have a different issue with updating, please post.

**LibreOffice and GTK3**

LibreOffice might be broken on gtk-based Desktop Environments. Workaround would be to force a look to Libreoffice by editing `/etc/profile.d/libreoffice*sh`. We recommend to uncomment `SAL_USE_VCLPLUGIN=gtk`. Our KDE edition isn't affected by this issue.

**GTK3**

With this we updated Gnome and GTK to 3.20. This will break most of the themes, which will be fixed if and when their developers decide to update them. Some GTK 3.20-compliant themes are ready now - see further down this post.

The new default Manjaro GTK theme, which is GTK 3.20 compatible, is Vertex-Maia

You can install it with:
```
sudo pacman -Sy vertex-maia-themes vertex-maia-icon-theme xcursor-maia
```

KDE users should default to Maia theme:
```
sudo pacman -Sy maia-icon-theme gtk-theme-maia plasma5-themes-maia xcursor-maia
```

**QT apps style with GTK** - only needed for non-KDE desktop environments!

With **QT 5.7** you need to install **qt5-styleplugins** and **qt5ct** and [configure](https://wiki.manjaro.org/index.php?title=Set_all_Qt_app%27s_to_use_GTK%2B_font_%26_theme_settings) your system to have an unified look again.

**ufw**

If you have issues with ufw not working anymore, you have to copy your custom rules to a different folder. Do it like this:
```
sudo cp -v /usr/lib/ufw/user.rules.pacsave /etc/ufw/user.rules
sudo cp -v /usr/lib/ufw/user6.rules.pacsave /etc/ufw/user6.rules
```

**steam**

Steam might not work due incompatiblity of **libgpg**. You my try followed command to "fix" it:
```
find ~/.steam/root/ \( -name "libgcc_s.so*" -o -name "libstdc++.so*" -o -name "libxcb.so*" -o -name "libgpg-error.so*" \) -print -delete
```

```
find ~/.local/share/Steam/ \( -name "libgcc_s.so*" -o -name "libstdc++.so*" -o -name "libxcb.so*" -o -name "libgpg-error.so*" \) -print -delete
```

Reference: [Archlinux wiki](https://wiki.archlinux.org/index.php/Steam/Troubleshooting#Steam_runtime_issues)


-------------------------------------------------------------------------------

**Current supported kernels**

- Linux310  3.10.102
- Linux312  3.12.62
- Linux314  3.14.76
- Linux316  3.16.36
- Linux318  3.18.39
- Linux41   4.1.30
- Linux44   4.4.17
- Linux46   4.6.7 [EOL]
- Linux47   4.7.1
- Linux-RT-LTS 4.4.17_rt25
- Linux-RT 4.6.5-rt10

-------------------------------------------------------------------------------

**Package changes**

 - testing community i686:  147 new and 126 removed package(s)
 - testing community x86_64:  174 new and 151 removed package(s)
 - testing core i686:  23 new and 28 removed package(s)
 - testing core x86_64:  24 new and 29 removed package(s)
 - testing extra i686:  134 new and 187 removed package(s)
 - testing extra x86_64:  134 new and 187 removed package(s)
 - testing multilib x86_64:  7 new and 4 removed package(s)

```

https://forum.manjaro.org/t/testing-update-2016-08-19-calamares-nvidia-virtualbox-kernels/7650

Linu74
« Letzte Änderung: 19. August 2016, 09:35:17 von Linu74 »
Manjaro XFCE/i3gaps x86_64bit auf ThinkPad X200, T400, T520
Deutscher Manjaro IRC Channel auf Freenode #manjaro-de