Autor Thema: openRC mit Plasma 5 - Probleme mit Netzwerkverbindung  (Gelesen 1864 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Offline Ahnungsloser

  • Held Mitglied
  • *****
  • Beiträge: 888
  • Dankeschön: 39 mal
  • Desktop: KDE Plasma 5.14.4 - OpenRC
  • Grafikkarte: Intel 3rd Gen Core processor Graphics Controller | NVIDIA GK208M [GeForce GT 720M]
  • Grafikkartentreiber: free
  • Kernel: 4.19.6-artix1-1-ARTIX
  • Prozessor: Intel Core i3-3217U
  • Skill: Durchschnitt
  • Zweig: stable
openRC mit Plasma 5 - Probleme mit Netzwerkverbindung
« am: 16. Oktober 2016, 19:36:13 »
Ich habe heute openRC-NET 16.08 auf einem Notebook frisch installiert und dann anhand der folgenden Anleitung KDE Plasma 5 als DE installiert.

https://de.manjaro.org/index.php?topic=5412.0

Die Installation hat perfekt geklappt aber es gibt noch das ein oder andere Wehwehchen  8).
Ich habe z. B. das Problem, dass die W-Lan Verbindung beim Systemstart nicht automatisch aktiviert ist.
Der Netzwerkmanager networkmanager-openrc ist installiert und auch in Runlevel: default eingebunden, scheint aber nicht korrekt gestartet zu sein. Außerdem steht netmount auf scheduled.

Runlevel: default
 dbus                                                                                                                            [  started  ]
 syslog-ng                                                                                                                       [  started  ]
 acpid                                                                                                                           [  started  ]
 cronie                                                                                                                          [  started  ]
 sshd                                                                                                                            [  started  ]
 consolekit                                                                                                                      [  started  ]
 NetworkManager                                                                                                                  [ inactive  ]
 netmount                                                                                                                        [ scheduled ]
 xdm                                                                                                                             [  started  ]
 cgmanager                                                                                                                       [  started  ]
 cupsd                                                                                                                           [  started  ]
 alsasound                                                                                                                       [  started  ]
 saned                                                                                                                           [  started  ]
 ntpd                                                                                                                            [  started  ]
 local                                                                                                                           [  started  ]


Im Moment habe ich keinen blassen Schlimmer, was ich noch machen muss  :-[
Im neuen Forum unter dem Nick "Roberto" :)

Online gosia

  • Held Mitglied
  • *****
  • Beiträge: 1432
  • Dankeschön: 274 mal
  • Desktop: Openbox + xfce
  • Grafikkarte: Intel HD 4000
  • Grafikkartentreiber: i915 (free)
  • Kernel: 4.19 Artix
  • Prozessor: Intel Core i5-3210M
  • Skill: Durchschnitt
  • Zweig: stable
Re: openRC mit Plasma 5 - Probleme mit Netzwerkverbindung
« Antwort #1 am: 16. Oktober 2016, 20:58:34 »
Hallo Ahnungsloser,
probiere doch mal den networkmanager von Hand zu starten:
sudo rc-service NetworkManager startWird doch dann hoffentlich eine mehr oder weniger aussagekräftige Fehlermeldung ausspucken.

Viele Grüße gosia
"funktioniert nicht" ist keine brauchbare Fehlermeldung

Offline Ahnungsloser

  • Held Mitglied
  • *****
  • Beiträge: 888
  • Dankeschön: 39 mal
  • Desktop: KDE Plasma 5.14.4 - OpenRC
  • Grafikkarte: Intel 3rd Gen Core processor Graphics Controller | NVIDIA GK208M [GeForce GT 720M]
  • Grafikkartentreiber: free
  • Kernel: 4.19.6-artix1-1-ARTIX
  • Prozessor: Intel Core i3-3217U
  • Skill: Durchschnitt
  • Zweig: stable
Re: openRC mit Plasma 5 - Probleme mit Netzwerkverbindung
« Antwort #2 am: 17. Oktober 2016, 13:25:46 »
Hallo Gosia,

ich bin heute und morgen beruflich unterwegs.
Ich teste das morgen Abend und schreibe dann hier das Ergebnis.

Vielen Dank schon mal für deine Hilfe.

Viele Grüße
Ahnungsloser
Im neuen Forum unter dem Nick "Roberto" :)

Offline Ahnungsloser

  • Held Mitglied
  • *****
  • Beiträge: 888
  • Dankeschön: 39 mal
  • Desktop: KDE Plasma 5.14.4 - OpenRC
  • Grafikkarte: Intel 3rd Gen Core processor Graphics Controller | NVIDIA GK208M [GeForce GT 720M]
  • Grafikkartentreiber: free
  • Kernel: 4.19.6-artix1-1-ARTIX
  • Prozessor: Intel Core i3-3217U
  • Skill: Durchschnitt
  • Zweig: stable
Re: openRC mit Plasma 5 - Probleme mit Netzwerkverbindung
« Antwort #3 am: 18. Oktober 2016, 20:21:43 »
Hallo Gosia,

ich habe den Befehl ausgeführt.

sudo rc-service NetworkManager start
Das kam dabei heraus:

* WARNING: NetworkManager has already started, but is inactive
Im neuen Forum unter dem Nick "Roberto" :)

Online gosia

  • Held Mitglied
  • *****
  • Beiträge: 1432
  • Dankeschön: 274 mal
  • Desktop: Openbox + xfce
  • Grafikkarte: Intel HD 4000
  • Grafikkartentreiber: i915 (free)
  • Kernel: 4.19 Artix
  • Prozessor: Intel Core i5-3210M
  • Skill: Durchschnitt
  • Zweig: stable
Re: openRC mit Plasma 5 - Probleme mit Netzwerkverbindung
« Antwort #4 am: 19. Oktober 2016, 15:06:13 »
Hallo Ahnungsloser,
leider noch keine Lösung, sondern nur eine Einkreisung bzw. Verschiebung des Problems.
* WARNING: NetworkManager has already started, but is inactive
Das ist nicht sehr aufschlußreich, aber eben nur eine Warnung, kein Fehler. Ich habe mal in den Logdateien nachgesehen, und da wird es schon interessanter. In der /var/log/rc.log steht
Starting NetworkManager
Connecting..........         0sConnecting...........
Marking NetworkManager as inactive. It will automatically be marked as started after a network connection has been established.
WARNING: NetworkManager has started, but is inactive
Checking your configfile (/etc/syslog-ng/syslog-ng.conf)
Wichtig war da die Bemerkung "It will automatically be marked as started after a network connection has been established."
Und tatsächlich, wenn ich mein WLAN per Hand durch Anklicken starte erhalte ich sofort "status: started" und kann ins Internet.
Es ist also nicht das Problem, daß der Networkmanager als "inactiv" angezeigt wird, sondern daß die WLAN-Verbindung nicht automatisch startet, obwohl in den Eigenschaften der Haken bei "Automatisch verbinden, wenn verfügbar" gesetzt ist.
Tja, warum dem so ist, ich weiss es noch nicht. Aber ich bleibe dran. Vielleicht hat ja noch jemand eine Idee.

Viele Grüße gosia
"funktioniert nicht" ist keine brauchbare Fehlermeldung
Folgende Mitglieder bedankten sich: Ahnungsloser

Online gosia

  • Held Mitglied
  • *****
  • Beiträge: 1432
  • Dankeschön: 274 mal
  • Desktop: Openbox + xfce
  • Grafikkarte: Intel HD 4000
  • Grafikkartentreiber: i915 (free)
  • Kernel: 4.19 Artix
  • Prozessor: Intel Core i5-3210M
  • Skill: Durchschnitt
  • Zweig: stable
Re: openRC mit Plasma 5 - Probleme mit Netzwerkverbindung
« Antwort #5 am: 19. Oktober 2016, 18:46:53 »
Hallo Ahnungsloser,
bei mir hat sich das relativ simpel gelöst. Bei "Netzwerkvebindungen bearbeiten" -> "Allgemein" hat nur das Häkchen bei der Option "Alle Benutzer dürfen dieses Netzwerk benutzen" gefehlt. Dies gesetzt und schon startet WLAN ganz automatisch :) und die Dienste Netzwerkmanager und netmount haben den Status "gestartet".

Viele Grüße gosia
"funktioniert nicht" ist keine brauchbare Fehlermeldung
Folgende Mitglieder bedankten sich: Ahnungsloser

Offline Ahnungsloser

  • Held Mitglied
  • *****
  • Beiträge: 888
  • Dankeschön: 39 mal
  • Desktop: KDE Plasma 5.14.4 - OpenRC
  • Grafikkarte: Intel 3rd Gen Core processor Graphics Controller | NVIDIA GK208M [GeForce GT 720M]
  • Grafikkartentreiber: free
  • Kernel: 4.19.6-artix1-1-ARTIX
  • Prozessor: Intel Core i3-3217U
  • Skill: Durchschnitt
  • Zweig: stable
Re: openRC mit Plasma 5 - Probleme mit Netzwerkverbindung
« Antwort #6 am: 19. Oktober 2016, 21:28:39 »
Hi Gosia,

in meiner rc-log steht folgendes:

* Starting NetworkManager ...
 [ ok ]
Connecting............       0sConnecting.............      0sConnecting..............     0sConnecting...............    0sConnecting...............    0s
 * Marking NetworkManager as inactive. It will automatically be marked
 * as started after a network connection has been established.
 * WARNING: NetworkManager has started, but is inactive
 * Checking your configfile (/etc/syslog-ng/syslog-ng.conf) ...
 [ ok ]
 * Starting syslog-ng ...
 [ ok ]
 * Starting acpid ...
 [ ok ]
 * Starting consolekit ...
 [ ok ]
 * WARNING: netmount will start when NetworkManager has started

Ich werde dieses Häkchen jetzt auch mal setzen und dann neu starten.
Ich bin gespannt  ;)

Viele Grüße
Ahnungsloser
Im neuen Forum unter dem Nick "Roberto" :)

Offline Ahnungsloser

  • Held Mitglied
  • *****
  • Beiträge: 888
  • Dankeschön: 39 mal
  • Desktop: KDE Plasma 5.14.4 - OpenRC
  • Grafikkarte: Intel 3rd Gen Core processor Graphics Controller | NVIDIA GK208M [GeForce GT 720M]
  • Grafikkartentreiber: free
  • Kernel: 4.19.6-artix1-1-ARTIX
  • Prozessor: Intel Core i3-3217U
  • Skill: Durchschnitt
  • Zweig: stable
Re: openRC mit Plasma 5 - Probleme mit Netzwerkverbindung
« Antwort #7 am: 19. Oktober 2016, 21:33:00 »
Hi Gosia,

ich habe den Haken gesetzt und das System neu gestartet und siehe da ... die Netzwerkverbindung wurde automatisch gestartet  :D

Ich danke dir vielmals für deine Hilfe  :)
Im neuen Forum unter dem Nick "Roberto" :)