Autor Thema: Lock des Bildschirms de(aktivieren)  (Gelesen 1021 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Offline leesrott

  • Sr. Mitglied
  • ****
  • Beiträge: 326
  • Dankeschön: 8 mal
  • Desktop: i3
  • Grafikkarte: Intel 3rd Gen Core processor Graphics Controller
  • Grafikkartentreiber: free
  • Kernel: Linux 4.4
  • Prozessor: intel core i5
  • Skill: Durchschnitt
  • Zweig: stable
Lock des Bildschirms de(aktivieren)
« am: 25. Oktober 2016, 00:09:17 »
Hallo Zusammen. Ich hätte mal eine Frage zu i3. Wie kann ich es einstellen, dass sich der Bildschirm nicht nach einigen Minuten automatisch sperrt? Bei längeren Filmen etc. ist das etwas nervig. Gehe ich recht in der Annahme, dass dieses Verhalten über die Zeile
exec --no-startup-id xautolock -time 10 -locker blurlock
in der .i3/config gesteuert wird? Ich habe es im Terminal mit
xautolock -disable
versucht, aber da bekomme ich nur die Antwort
No process with PID 12860, or the process is owned by another user.
Kann mir da jemand einen Tipp geben? Danke!
Folgende Mitglieder bedankten sich: SteffenX

Offline direwolf

  • Neuling
  • *
  • Beiträge: 5
  • Desktop: XFCE
  • Skill: Anfänger
Re: Lock des Bildschirms de(aktivieren)
« Antwort #1 am: 25. Oktober 2016, 22:16:36 »
Ich kenn mich mit i3 nicht aus, aber laut archwiki hast du recht mit deiner Vermutung

https://wiki.archlinux.org/index.php/I3 -> Screensaver and power management

probiers einfach aus und wenns nicht klappt, musst du halt wissen was du geändert hast, mach ich mit xfce auch ständig.

Offline catalunya

  • Neuling
  • *
  • Beiträge: 9
  • Desktop: Xfce und LXDE
  • Grafikkarte: Intel&NVIDIA " krieg die NVIDIAaber nicht zum laufen" / Intel / AMD Athlon
  • Grafikkartentreiber: nonfree / free
  • Kernel: 4.4.
  • Prozessor: Quad core Intel Core i7 / Intel dualcore Toshiba / AMD DualCore Asus
  • Skill: Anfänger
  • Zweig: stable
Re: Lock des Bildschirms de(aktivieren)
« Antwort #2 am: 22. Dezember 2016, 14:04:04 »
Ich setze da immer ein Haken beim Präsentationsmodus, in der Leiste obe bei den Schnelleinstellungen (Energieoptionen)
Aber mich würde es auch interessieren ob ich für den vlc player und für youtube videos im webbrowser den Modus automatisch setzen kann, vielleicht weiss jemand wie man das macht.
Caffeine ng habe ich schon probiert, hat aber nicht funktioniert, bzw. nur auf dem Adminaccount.
Wer Bäume setzt, obwohl er weiß, daß er nie in ihrem Schatten sitzen wird, hat zumindest angefangen, den Sinn des Lebens zu begreifen.

Rabindranath Tagore

Offline leesrott

  • Sr. Mitglied
  • ****
  • Beiträge: 326
  • Dankeschön: 8 mal
  • Desktop: i3
  • Grafikkarte: Intel 3rd Gen Core processor Graphics Controller
  • Grafikkartentreiber: free
  • Kernel: Linux 4.4
  • Prozessor: intel core i5
  • Skill: Durchschnitt
  • Zweig: stable
Re: Lock des Bildschirms de(aktivieren)
« Antwort #3 am: 29. Oktober 2017, 15:33:16 »
Nach all der Zeit hat sich das Problem noch immer nicht gelöst. Bin eben wieder drauf gestoßen. Führe ich im Terminal den Befehl:
xautolock -disable
aus, bekomme ich die Reaktion
Could not locate a running xautolock.
Laut htop läuft der Prozess aber. Also was läuft da falsch?

Offline SteffenX

  • Neuling
  • *
  • Beiträge: 14
  • Desktop: i3
  • Grafikkarte: GeForce GTX 960
  • Grafikkartentreiber: nonfree
  • Kernel: 414
  • Prozessor: core i5
  • Skill: Anfänger
  • Zweig: stable
Re: Lock des Bildschirms de(aktivieren)
« Antwort #4 am: 29. Oktober 2017, 16:34:07 »
Hi,

versuche mal mit einem Editor deine i3config (~/.i3/config) zu öffnen und setze vor:
exec --no-startup-id xautolock -time 10 -locker blurlock
eine # und ein leerzeichen.
Also so:
# exec --no-startup-id xautolock -time 10 -locker blurlock
(Bei mir in Zeile 286)
Dann müsste es eigentlich aus sein.
Zumindest hat es bei mir so nach verlassen von i3 (mod+shift+e) und erneutem anmelden geklappt.
Oder setze  die 10 oder was auch immer bei dir steht auf eine Zeit deiner Wahl.
Soweit ich weiß ist es auch aus wenn du diese Zeit auf 0 bzw 00 setzt.

MfG Steffen

Offline SteffenX

  • Neuling
  • *
  • Beiträge: 14
  • Desktop: i3
  • Grafikkarte: GeForce GTX 960
  • Grafikkartentreiber: nonfree
  • Kernel: 414
  • Prozessor: core i5
  • Skill: Anfänger
  • Zweig: stable
Re: Lock des Bildschirms de(aktivieren)
« Antwort #5 am: 30. Oktober 2017, 06:10:29 »
Und danke, du hast mich daran erinnert, dass ich das auch noch machen wollte.
Du kannst übrigens wenn du die Zeile mit "# " auskommentiert hast immernoch manuell mit (mod+9) die Bildschirmsperre aktivieren.
Ich hoffe ich konnte deine Frage beantworten.

Offline leesrott

  • Sr. Mitglied
  • ****
  • Beiträge: 326
  • Dankeschön: 8 mal
  • Desktop: i3
  • Grafikkarte: Intel 3rd Gen Core processor Graphics Controller
  • Grafikkartentreiber: free
  • Kernel: Linux 4.4
  • Prozessor: intel core i5
  • Skill: Durchschnitt
  • Zweig: stable
Re: Lock des Bildschirms de(aktivieren)
« Antwort #6 am: 30. Oktober 2017, 12:41:20 »
Danke für die Antworten. Ich hab ein paar nette Optionen und damit eine recht komfortable Lösung des Problems gefunden wie mir scheint. Man kann in .i3/conf den Aufruf folgendermaßen erweitern.
exec --no-startup-id xautolock -time 10 -locker blurlock -corners 000- -cornersize 50
"-corners 000-" und "-cornersize 50" definieren die untere rechte Ecke, wobei 50 den Radius in Pixel angibt. Befindet sich der Mauszeiger in diesem Bereich, ist der Autolockmechanismus temporär deaktiviert. Befindet sich der Zeiger außerhalb des Bereichs, funktioniert xautolock wie gehabt. Ich hab das eben mal ausprobiert und es scheint genau so zu funktionieren.

Offline SteffenX

  • Neuling
  • *
  • Beiträge: 14
  • Desktop: i3
  • Grafikkarte: GeForce GTX 960
  • Grafikkartentreiber: nonfree
  • Kernel: 414
  • Prozessor: core i5
  • Skill: Anfänger
  • Zweig: stable
Re: Lock des Bildschirms de(aktivieren)
« Antwort #7 am: 30. Oktober 2017, 18:02:13 »
Mir persönlich reicht es so, wie ich es gemacht habe, da hier normalerweise niemand an meinen Rechner geht und falls doch kann ich ja immernoch manuell sperren.
Aber die Idee an sich find ich super.  8)