Autor Thema: Intel Grafik - "Tearing"  (Gelesen 1488 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Offline Emko

  • Neuling
  • *
  • Beiträge: 2
  • Skill: Anfänger
Intel Grafik - "Tearing"
« am: 01. November 2016, 19:57:31 »
Hallo zusammen!

Ich nutze seit einiger Zeit Manjaro und davor habe ich Xubuntu genutzt. Ich würde mich noch als Anfänger einschätzten, kann aber die Linux Grundlagen (denke ich jedenfall :D).
Unter Xubuntu hatte ich irgendwie ständig Probleme - vor allem hat mich gestört, dass der Ton von Youtube Videos usw. ständig "abgehackt" war. Außerdem hatte ich Probleme mit der Grafik. Wie im Titel auch beschrieben war ich vom "Tearing" betroffen (deutsch: reißen?) wenn Compiz eingeschaltet war. Vor allem beim Scrollen war das ziemlich nervig.
Unter Manjaro funktioniert der Ton super, aber das Grafikproblem ist geblieben.

Im Arch Wiki habe ich folgendes gefunden:
https://wiki.archlinux.org/index.php/Intel_graphics#Tear-free_video

d.h. ich muss in der 20-intel.conf folgende Zeile einfügen: Option      "TearFree"    "true"
Jedoch habe ich nicht so eine conf-Datei. Im Ordner "org.conf.d" befindet sich stattdessen "90-mhwd.conf" mit diesem Inhalt:
##
## Generated by mhwd - Manjaro Hardware Detection
##
 
 
Section "Device"
Identifier  "Device0"
Driver      "intel"
EndSection
 
 
Section "DRI"
        Group  "video"
        Mode   0666
EndSection
 
 
Section "Extensions"
Option "Composite" "Enable"
Option "RENDER"    "Enable"
EndSection
 
 
Section "InputClass"
Identifier          "Keyboard Defaults"
MatchIsKeyboard     "yes"
Option              "XkbOptions" "terminate:ctrl_alt_bksp"
EndSection
 

Soll ich nun hier die TearFree-Option einfügen oder soll ich 20-intel.conf erstellen und es dort einfügen?

Und wenn ich sudo mhwd-gpu --status
ausführe kommt folgendes:
Using default
Default lib32 support: true
:: status
  lib32-libGl: '/usr/lib32/mesa/libGL.so.1.2.0'
  lib32-libGLESv1: '/usr/lib32/mesa/libGLESv1_CM.so.1.1.0'
  lib32-libGLESv2: '/usr/lib32/mesa/libGLESv2.so.2.0.0'
  lib32-libEGL: '/usr/lib32/mesa/libEGL.so.1.0.0'
  libGl: '/usr/lib/mesa/libGL.so.1.2.0'
  libGLESv1: '/usr/lib/mesa/libGLESv1_CM.so.1.1.0'
  libGLESv2: '/usr/lib/mesa/libGLESv2.so.2.0.0'
  libEGL: '/usr/lib/mesa/libEGL.so.1.0.0'
  libglx: '/usr/lib/xorg/modules/extensions/libglx.xorg'
  xorg configuration file: ''

Unter "xorg configuration file" steht nichts. Soll das so sein?


Noch paar Infos zur Grafikarte (Hybrid):

lspci -nnk | grep -i VGA -A2lspci: Unable to load libkmod resources: error -12
00:02.0 VGA compatible controller [0300]: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller [8086:0116] (rev 09)
Subsystem: Hewlett-Packard Company Device [103c:1651]
Kernel driver in use: i915
--
01:00.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] Seymour [Radeon HD 6400M/7400M Series] [1002:6760] (rev ff)
Kernel driver in use: radeon
09:00.0 Network controller [0280]: Realtek Semiconductor Co., Ltd. RTL8188CE 802.11b/g/n WiFi Adapter [10ec:8176] (rev 01)

Hoffe jemand kann mir weiterhelfen :)
Danke im Voraus!

Gruß
Emko
« Letzte Änderung: 01. November 2016, 20:08:27 von Emko »

Offline Emko

  • Neuling
  • *
  • Beiträge: 2
  • Skill: Anfänger
Re: Intel Grafik - "Tearing"
« Antwort #1 am: 01. November 2016, 20:45:08 »
Leider hilft das auch nicht :(

Offline Ahnungsloser

  • Held Mitglied
  • *****
  • Beiträge: 922
  • Dankeschön: 46 mal
  • Desktop: KDE Plasma 5.16.4
  • Grafikkarte: Intel 3rd Gen Core processor Graphics Controller | NVIDIA GK208M [GeForce GT 720M]
  • Grafikkartentreiber: free
  • Kernel: 5.2.10-artix1-1-ARTIX x86_64
  • Prozessor: Intel Core i3-3217U
  • Skill: Anfänger
  • Zweig: stable
Re: Intel Grafik - "Tearing"
« Antwort #2 am: 01. November 2016, 20:49:58 »
Bei mir hat es geholfen, die Zeile

Option      "AccelMethod" "sna"
auf "uxa" zu ändern.
Im neuen Forum unter dem Nick "Roberto" :)

Offline KoboldDresden

  • Neuling
  • *
  • Beiträge: 1
  • Desktop: Xfce
  • Grafikkarte: Intel
  • Grafikkartentreiber: free
  • Skill: Durchschnitt
  • Zweig: stable
Re: Intel Grafik - "Tearing"
« Antwort #3 am: 09. März 2017, 08:20:28 »
Im Terminal:sudo mkdir /etc/X11/xorg.conf.d
sudo nano /etc/X11/xorg.conf.d/20-intel.conf
Inhalt der Datei:Section "Device"
    Identifier "Intel Graphics"
    Driver "intel"
    Option "TearFree" "true"
    Option "SwapbuffersWait" "true"
    Option "AccelMethod" "sna"
EndSection
Nach einem Neustart funktioniert dann wie gewünscht.

Offline gosia

  • Held Mitglied
  • *****
  • Beiträge: 1642
  • Dankeschön: 314 mal
  • Desktop: Openbox + xfce
  • Grafikkarte: Intel HD 4000
  • Grafikkartentreiber: i915 (free)
  • Kernel: 4.19 Artix
  • Prozessor: Intel Core i5-3210M
  • Skill: Durchschnitt
  • Zweig: stable
Re: Intel Grafik - "Tearing"
« Antwort #4 am: 09. März 2017, 13:30:48 »
Hallo KoboldDresden,
die Lösung wird hoffentlich funktionieren, trotzdem halte ich es für einen unglücklichen Weg, eine schon vorhandene Datei sozusagen "zu verdoppeln". Es gibt ja schon die 90-mhwd.conf, oder genauer gesagt die /etc/X11/mhwd.d/intel.conf.
/etc/X11/xorg.conf.d/90-mhwd.conf ist ja nur ein Link auf /etc/X11/mhwd.d/intel.conf
ls -l /etc/X11/xorg.conf.d/90-mhwd.conf
lrwxrwxrwx 1 root root  26 28.09.2016 19:32 90-mhwd.conf -> /etc/X11/mhwd.d/intel.conf
Da kann man die Optionen auch dorthin schreiben, wo sie hingehören. Spätestens bei der nächsten Frage kann es zu Unklarheiten kommen, wenn dann gefragt wird "was steht denn in deiner intel.conf?" und man sich nicht an die etwas unorthodoxe Datei /etc/X11/xorg.conf.d/20-intel.conf erinnert.

Viele Grüße gosia

PS. Wie ich dummerweise erst jetzt bemerke (ich sollte besser aufpassen), war die Frage ja vom 01. November 2016 :( Emko ist also entweder schon längst "TearFree" oder hat das Handtuch geworfen. Zumindest war sein letzter Besuch hier genau am 01. November 2016.
Ist also alles mehr eine akademische Fragestellung...
« Letzte Änderung: 09. März 2017, 13:37:02 von gosia »
"funktioniert nicht" ist keine brauchbare Fehlermeldung

Offline DerNeue

  • Neuling
  • *
  • Beiträge: 2
  • Skill: Anfänger
Re: Intel Grafik - "Tearing"
« Antwort #5 am: 23. März 2017, 21:42:06 »
Hatte gerade das gleiche Problem und habe in der intel.conf Option "TearFree" "true" eingefügt. Tearing ist weg  :)