Autor Thema: TeamDrive will nicht autostarten  (Gelesen 108 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Offline silmaril

  • Neuling
  • *
  • Beiträge: 15
  • Skill: Durchschnitt
TeamDrive will nicht autostarten
« am: 09. Januar 2017, 21:58:17 »
Hallo,
ich habe das aktuelle Manjaro in der KDE-Edition installiert und verwende auch teamdrive aus dem AUR.
Das funktioniert an sich auch bestens, nur der automatische Start des Programms will nicht klappen.
In den TeamDrive-Einstellungen habe ich "Autostart" aktiviert und "Verzögerung nach dem Autostart" steht auf 1 Minute.
Das erstellt offenbar einen Eintrag in der Liste, die auch unter Systemeinstellungen >> Starten und Beenden >> Autostart erscheint mit folgendem Befehl:
"/opt/teamdrive/TeamDrive" "autostart"
Wenn ich diesen Befehl im Terminal ausführe, startet TeamDrive brav, aber im Autostart mag das nicht so recht klappen. Der Autostart-Mechanismus an sich funktioniert offenbar. Der Owncloud-Client wird auf die gleiche Weise erfolgreich gestartet.

Hat jemand eine Idee, woran das liegen könnte?


Offline silmaril

  • Neuling
  • *
  • Beiträge: 15
  • Skill: Durchschnitt
Re: TeamDrive will nicht autostarten
« Antwort #1 am: 10. Januar 2017, 20:00:19 »
Das sieht interessant aus :)
Nur leider geht es da um den TeamDrive-Server.

Alles was ich möchte, ist die Client-Anwendung zu starten, die dann ein Symbol im Infobereich der KDE-Taskleiste anlegt und leider auch ihr Fenster öffnet (letzteres könnte sie sich von mir aus auch gerne sparen). Das Ganze soll bei der Anmeldung des Nutzers erfolgen. Systemd würde ja vermutlich bereits beim Systemstart aktiviert und könnte dann garnicht im richtigen User-Kontext laufen, oder verstehe ich das falsch?